プロジェクトを作成すると、Anypoint Code Builder によりプロジェクトはデフォルトでホームディレクトリに保存されます。プロジェクトの他のフォルダーを IDE に作成できます。
別のプロジェクトディレクトリ内にプロジェクトを作成しないでください。
クラウド IDE にプロジェクトフォルダーを作成する
Mule プロジェクトを保存するフォルダーをホームディレクトリの下に作成する手順は、次のとおりです。
-
コマンドパレットを開きます。
手順を表示
-
キーボードショートカットを使用する。
-
Mac: Cmd+Shift+p
-
Windows: Ctrl+Shift+p
-
-
デスクトップ IDE で、[View (表示)] > [Command Palette (コマンドパレット)] を選択する。
-
クラウド IDE で、
(メニュー) アイコンをクリックし、[View (表示)] > [Command Palette (コマンドパレット)] を選択する。
-
-
次のコマンドを選択します。
File: Open Folder...
-
Anypoint Code Builder ホームディレクトリを選択します。
確認を促されたら、ディレクトリ内のファイルの作成者を信頼します。
-
Anypoint Code Builder にホームディレクトリが読み込まれたら、[Explorer] ビューを右クリックして、[New Folder (新規フォルダー)] を選択します。
-
新しいディレクトリに名前を付けて、Enter キーを押す。
-
(メニュー) アイコンをクリックし、[File (ファイル)] > [Close Folder (フォルダーを閉じる)] を選択して、ホームディレクトリを閉じます。
デスクトップ IDE にプロジェクトフォルダーを作成する
デスクトップ IDE からプロジェクトのローカルフォルダーを作成する手順は、次のとおりです。
-
コマンドパレットを開きます。
手順を表示
-
キーボードショートカットを使用する。
-
Mac: Cmd+Shift+p
-
Windows: Ctrl+Shift+p
-
-
デスクトップ IDE で、[View (表示)] > [Command Palette (コマンドパレット)] を選択する。
-
クラウド IDE で、
(メニュー) アイコンをクリックし、[View (表示)] > [Command Palette (コマンドパレット)] を選択する。
-
-
次のコマンドを選択します。
File: Open Folder...
-
ローカルディレクトリを使用して新しいフォルダーを作成します。
デスクトップ IDE またはクラウド IDE からプロジェクトフォルダーを作成する
IDE のターミナルを使用してフォルダーを作成します。
-
開いているプロジェクトがないことを確認します。
-
IDE から、コンソールのターミナルウィンドウを開きます。
-
デスクトップ IDE で、[View (表示)] > [Terminal (ターミナル)] を選択する。
-
クラウド IDE で、
(メニュー) アイコンをクリックし、[Terminal (ターミナル)] > [New Terminal (新規ターミナル)] を選択する。 -
いずれかの IDE で、Ctrl キーを押してからバッククォートキー (`) を押す。
-
-
次のコマンドを入力してフォルダーを作成します。
mkdir <name-of-your-folder><name-of-your-folder> をディレクトリの任意の名前に置き換えます。