---
schema_version: "1"
id: 3368620e7c858156a4cb8ceb43f2a6b8b02e0bfd18a3dcfae7b38497e883206b
title: 為工具提示建立檢視（工具提示內部視覺效果）
collection: tableau
version: next
locale: zh-tw
portal_url: https://docs.salesforce.com/tableau/next/zh-tw/public/desktop/viz_in_tooltip.md
canonical_url: https://help.tableau.com/v0.0/public/desktop/zh-tw/viz_in_tooltip.htm
source_site: help.tableau.com
content_type: documentation
content_hash: 9f2b8a2e987ec4009e95493dccdddb618e368e27fdf239e91a139c7fc095db9a
description: Embed a visualization within a tooltip using Viz in Tooltip.
---
[跳至主要內容](#main-content)

# 在工具提示中建立檢視（工具提示內部視覺效果）

當您製作檢視並尋找方法向受眾展示有關資料的更多詳細資訊時，您可以在工具提示中內嵌視覺效果（又稱為「工具提示內部視覺效果」）。

![滑鼠暫留在橫條圖中的標記上時，工具提示視覺效果會顯示一個資料表。](/tableau/next/zh-tw/public/desktop/zh-tw/Img/ViT-basic.png)

當使用者將游標暫留在標記上時，工具提示將透過另一個視覺效果顯示針對該標記篩選的相關資料和詳細資訊。

您可以在工具提示中顯示相關視覺效果，說明您的受眾從不同層次或更深入地瞭解資料，同時可使他們保留在當前上下文中，並可最大限度地提高當前檢視的可用空間。

**觀看影片**：如需進階提示，請觀看[全新的工具提示視覺效果](https://youtu.be/0V6PvROxv3s)，這是一個時長 55 分鐘的免費影片展示。  
  
有關如何編輯常規工具提示的資訊，請參閱[設定工具提示的格式](https://help.tableau.com/v0.0/public/desktop/zh-tw/formatting_specific_titlecaption.htm#Format_tooltips)。

## 建立工具提示內部視覺效果的一般步驟

1. 在 Tableau 內的_來源_工作表中建立視覺效果。
2. 在_目標_工作表中建立視覺效果以充當工具提示內部視覺效果。為工作表指定一個可幫助您將其標識為工具提示內部視覺效果的名稱。
3. 在來源工作表中，按一下「標記」卡片中的「工具提示」。在工具提示編輯器中，插入對工具提示內部視覺效果目標工作表的引用。有關詳情，請參閱[設定工具提示內部視覺效果](#ConfigureViT)。
4. **可選**：為工具提示內部視覺效果隱藏目標工作表。有關詳情，請參閱[在工具提示中建立檢視（工具提示內部視覺效果）](#hidesheet).
5. 透過將游標暫留在源工作表檢視中的不同標記上來測試生成的工具提示內部視覺效果。如果工具提示內部視覺效果對於工具提示視窗而言太大，請調整目標工作表視覺效果的高度和寬度。您可能還要考慮簡化目標視覺效果中的結構和詳細資訊。有關詳情，請參閱[變更工具提示內部視覺效果的大小](#Size)。

**附註**：

預設情況下，工具提示內部視覺效果的篩選層級是_所有欄位。_透過在_所選欄位_上定義篩選條件來變更工具提示內部視覺效果的詳細層級。有關詳情，請參閱[變更工具提示內部視覺效果的篩選條件](#Filters)。

在 Tableau 版本 2023.3 及更高版本中，工具提示中的視覺效果不適用於總計和總和。

**附註：**預設情況下，工具提示內部視覺效果的篩選層級是_所有欄位。_透過在_所選欄位_上定義篩選條件來變更工具提示內部視覺效果的詳細層級。有關詳情，請參閱[變更工具提示內部視覺效果的篩選條件](#Filters)。  
  
在 Tableau 版本 2023.3 及更高版本中，工具提示中的視覺效果不適用於總計和總和。

## 設定工具提示內部視覺效果

您將需要_來源_工作表視覺效果和_目標_工作表視覺效果，以建立工具提示內部視覺效果。

這些步驟使用的範例源檢視是一個按州/省/市/自治區顯示銷售利潤的地圖，使用的範例目標工作表具有一個按產品子類別顯示利潤的圖表。

### 在工作表中建立源和目標視覺效果

1. 在 Tableau Desktop 中，確定要用作來源視覺效果的工作表。或者在新工作表上構建一個新視覺效果。這將是您的源檢視。
2. 建立一個新工作表來充當目標視覺效果。
    
    使目標檢視中使用的篩選條件數保持最少。
3. 為目標檢視命名，以便您將能夠在其他工作表的列表中將其識別出來。

### 在源工作表工具提示中插入對目標工作表的引用

1. 在來源工作表中，按一下「標記」卡片中的「工具提示」按鈕以開啟工具提示編輯器。
    
    ![工具提示編輯器視窗。](/tableau/next/zh-tw/public/desktop/zh-tw/Img/vit-tooltipeditor-novit.png)
2. 在工具提示編輯器中，按一下「插入」功能表。在「插入」功能表中，選取「工作表」，然後選取目標工作表。
    
    例如：
    
    ![插入功能表，顯示選取目標工作表的工作表選項。](/tableau/next/zh-tw/public/desktop/zh-tw/Img/vit-insert-targetsheet.png)
    
    系統會自動新增工具提示內部視覺效果的標記。（在此範例中，原始標記欄位已被刪除。）
    
    ![工具提示視覺效果的標記。](/tableau/next/zh-tw/public/desktop/zh-tw/Img/vit-targetsheetmarkup-default.png)
    
    _為工具提示內部視覺效果自動生成的標記範例_
    
    這是此範例的結果標記：
    
    `<Sheet name="Tooltip: Profit by Sub-Category" maxwidth="300" maxheight="300" filter="<All Fields>">`
    
    預設情況下，會在所有欄位上篩選工具提示內部視覺效果（在所有可能的欄位上並且在最具體的詳細資訊層級進行篩選）。
    
    按一下「確定」。
3. 返回到源工作表並測試工具提示內部視覺效果。將游標暫留在其他標記上以查看所生成的工具提示內部視覺效果。根據需要對目標檢視進行調整以改善工具提示內部視覺效果。
    
    ![調整大小之前的工具提示視覺效果。](/tableau/next/zh-tw/public/desktop/zh-tw/Img/vit-sourcesheet-test.png)
    
    此範例中的工具提示內部視覺效果會顯示一條消息，以指明目標檢視中的某些資料未顯示。如果看到此消息，您可以在工具提示內部視覺效果的參數中調整高度和寬度設定，從而增大檢視大小。

## 變更工具提示內部視覺效果的大小

您可以手動變更 `maxwidth` 和 `maxheight` 值來調整工具提示內部視覺效果的大小。預設大小為 300 x 300 圖元。要變更大小，請用另一個值手動替換 `"300"`。如果您需要設定大於 600 圖元的值，則可能需要重新考慮目標檢視是否非常適合工具提示內部視覺效果。

1. 在來源工作表中，按一下「標記」卡片中的「工具提示」按鈕以開啟工具提示編輯器。
2. 為 `maxwidth` 和 `maxheight` 選取數位值，然後鍵入不同的值來替換此值。例如：
    
    `<Sheet name="Tooltip: Profit by Sub-Category" maxwidth="500" maxheight="500" filter="<All Fields>">`
3. 按一下「確定」
    
    ![調整大小後的工具提示視覺效果。](/tableau/next/zh-tw/public/desktop/zh-tw/Img/vit-resized.png)
    
    寬度和高度均設定為 500 圖元的工具提示內部視覺效果的範例。作者還為目標工作表檢視中的標題文本建立了更多空間。

## 變更工具提示內部視覺效果的篩選條件

預設情況下，工具提示內部視覺效果的篩選層級是_所有欄位。_這意味著，檢視將以最具體的詳細資料層級，在目前檢視（不包括篩選條件架上的欄位）的所有維度上進行篩選。

您可以透過在所選欄位上定義篩選條件（類似在篩選動作中的所選欄位上進行篩選）來變更工具提示內部視覺效果的詳細資訊層級。

1. 在來源工作表中，按一下「標記」卡片中的「工具提示」按鈕以開啟工具提示編輯器。
2. 將游標放在篩選條件值 (`filter="<_place cursor here_>"`) 中，然後按一下「插入」功能表以選取可用欄位。或者，用檢視中的欄位名稱手動替換 <_All Fields_\> 值。例如：
    
    `<Sheet name="Tooltip: Profit by Sub-Category" maxwidth="300" maxheight="500" filter="<State>">`
    
    您也可以透過用逗號分隔欄位名稱來篩選多個所選欄位。例如：
    
    `<Sheet name="Tooltip: Profit by Sub-Category" maxwidth="300" maxheight="500" filter="<Country>,<State>">`
    
    若要依日期層級篩選，您需要在欄位名稱中包含指定日期層級的字串。例如：
    
    `<Sheet name="Tooltip: Profit by Month" maxwidth="300" maxheight="300" filter="<MONTH(Order Date)>">`
    
    **附註：**工具提示指令碼中視覺效果中的日期篩選條件必須與檢視中欄位的日期層級完全相符。

## 隱藏或顯示工具提示內部視覺效果工作表

您可以在工具提示中隱藏和顯示用於視覺效果的工作表，其選項類似於儀表板和本文的選項。

### 隱藏工具提示內部視覺效果工作表

**附註：**如果源工作表對於儀表板窗格處於隱藏狀態，則您首先需要從其儀表板窗格中取消隱藏該工作表，以便能夠存取。有關詳情，請參閱[管理儀表板窗格和本文中的工作表](https://help.tableau.com/v0.0/public/desktop/zh-tw/environ_workbooksandsheets_sheets_hideshow.htm)。

若要隱藏工具提示內部視覺效果工作表，請從作為工具提示內部視覺效果之目標工作表的索引標籤選取「隱藏」。

![隱藏工作表。](/tableau/next/zh-tw/public/desktop/zh-tw/Img/hide-vit-sheet.gif)

### 顯示工具提示工作表中的視覺效果

若要顯示工具提示內部視覺效果工作表，請從來源工作表的索引標籤選取「取消隱藏所有工作表」。

![取消隱藏工作表。](/tableau/next/zh-tw/public/desktop/zh-tw/Img/show-vit-sheet.gif)

## 工具提示內部視覺效果的範例

當您建立工具提示內部視覺效果時，使用者可以將游標暫留在標記上，以在原始檢視的上下文中以檢查按需隨選的詳細資訊。工具提示內部視覺效果是另一個檢視中與當前檢視中的標記相關的靜態資料影像。如果將游標暫留在標記上或者選取標記，則會在其工具提示中顯示針對該標記篩選的另一個工作表中的資料。

**觀看視訊**：若要檢視更多範例和相關概念，請參閱[工具提示中全新的視覺效果](https://youtu.be/0V6PvROxv3s)，這是長度 55 分鐘的免費視訊簡報。  

使用工具提示內部視覺效果可以顯示：

- 另一個詳細資訊層級的資料
    
    ![滑鼠暫留在橫條圖中的標記上時，工具提示視覺效果會顯示一個資料表。](/tableau/next/zh-tw/public/desktop/zh-tw/Img/ViT-basic.png)
- 不同但相關的資料
    
    ![滑鼠暫留在橫條圖中的標記上時，工具提示視覺效果會顯示一個不同的圖表。](/tableau/next/zh-tw/public/desktop/zh-tw/Img/vit-contextfilter.png)
- 標記值隨時間變化情況
    
    ![滑鼠暫留在橫條圖中的標記上時，工具提示視覺效果會顯示一個折線圖，以顯示隨時間推移的變更。](/tableau/next/zh-tw/public/desktop/zh-tw/Img/vit-currentperiodtrendovertime.png)
- 一個工具提示中的多個視覺效果
    
    ![滑鼠暫留在橫條圖上的標記上時，工具提示視覺效果會顯示一個折線圖和橫條圖。](/tableau/next/zh-tw/public/desktop/zh-tw/Img/vit-multipleviewsintooltip.png)
- 主檢視的圖例
    
    ![工具提示視覺效果顯示主要檢視的圖例。](/tableau/next/zh-tw/public/desktop/zh-tw/Img/vit-legend.png)

當您在工具提示中顯示相關檢視時，可以幫助您的受眾更深入地瞭解資料，同時可最大限度地提高目前檢視的可用空間。

## 關於使用和設定工具提示內部視覺效果的提示和注意事項

- 您可以使用工作表來建立工具提示內部視覺效果，但不能使用儀表板窗格或故事來建立工具提示內部視覺效果。
- 工具提示內部視覺效果是目標檢視的靜態影像，而不是互動式工作表。工具提示內部視覺效果不能具有其自己的工具提示內部視覺效果。
- 您將需要_來源_工作表視覺效果和_目標_工作表視覺效果，以建立工具提示內部視覺效果。您將需要建立一個目標檢視，以使其在工具提示編輯器中可用。
- 對於您計畫在工具提示中顯示的目標工作表，請使用標準命名方案，例如「工具提示：_檢視名稱_」。使用標準命名方案將幫助您跟蹤您正在工具提示中使用的檢視。
- 對於目標檢視，請考慮檢視資料的大小以及檢視在工具提示中的外觀。您可以在設定工具提示內部視覺效果時指定其大小，但是在發佈之前，您將需要查看其顯示方式，並且可能需要對檢視進行調整。
    
    請記住，目標檢視顯示在源檢視的上下文中。使目標視覺效果保持簡單可幫助提高性能和減輕認知負荷。
- 如果在來源工作表中按一下「智慧顯示」並且其變更檢視結構，則包括工具提示內部視覺效果引用在內的所有工具提示編輯都將重置。您將需要重新設定工具提示內部視覺效果。
- 一個工具提示內部視覺效果一次可引用一個目標工作表，因為篩選條件直接應用於引用的工作表。當工具提示中已經使用工作表作為目標工作表時，無法在工具提示編輯器中選取工作表。
- 預設情況下，系統會在_所有欄位_上篩選工具提示內部視覺效果，這會在標識匹配記錄時（在最具體的詳細資訊層級）考慮檢視中的所有欄位。您可以透過在_所選欄位_上定義篩選條件（類似在篩選動作中的**所選欄位**上進行篩選）來變更工具提示內部視覺效果的詳細資訊層級。有關相關詳細資訊，請參閱[建立進階反白顯示動作](https://help.tableau.com/v0.0/public/desktop/zh-tw/actions_highlight_advanced.htm)。
    
    針對_所選欄位_篩選的操作無法跨不同資料來源工作。如果源檢視和目標檢視使用不同的資料來源，則針對_所有欄位_篩選的操作會自動檢測共有欄位（如果它們具有相同的別名），並針對這些欄位進行篩選。但是，針對_所選欄位_篩選的操作將不起作用。