---
schema_version: "1"
id: 9305451335a52ee5fbf5a3c0950c413e811ce124e1c9d6b196049fcdc7ea8e8e
title: 架和卡參考
collection: tableau
version: next
locale: zh-tw
portal_url: https://docs.salesforce.com/tableau/next/zh-tw/pro/desktop/buildmanual_shelves.md
canonical_url: https://help.tableau.com/v0.0/pro/desktop/zh-tw/buildmanual_shelves.htm
source_site: help.tableau.com
content_type: documentation
content_hash: 7a9db5d1a43f4bd0f299075cb2a7d9e1d46127dc03a030f2a36fb0168497b184
description: Reference of Tableau worksheet shelves and cards-Columns, Rows, Marks, Filters, Pages-and their roles.
---
[跳至主要內容](#main-content)

# 架和卡參考

Tableau 中的每個工作表都包含架和卡，例如 \[欄\] 、 \[列\] 、 \[標記\] 、 \[篩選器\] 、 \[頁面\] 、 \[圖例\] 等等。

透過將欄位放在架或卡上，您可以執行以下操作：

- 組建視覺化項的結構。
- 透過包括或排除資料來提高詳細資料層級以及控制檢視中的標記數。
- 透過使用色彩、大小、形狀、文字和詳細資料對標記進行編碼來為視覺化項新增上下文。

嘗試將欄位放置在不同架和卡上，以找到查看資料的最佳方式。

## 用於啟動檢視的選項

如果不確定要將欄位放在何處，您可以讓 Tableau 說明您確定顯示資料的最佳方式。

- 可以將欄位從 \[資料\] 窗格拖放到屬於每個 Tableau 工作表的卡和架上。
- 可以在 \[資料\] 窗格中按兩下一個或多個欄位。
- 您可以在 \[資料\] 窗格中選取一個或多個欄位，然後從 \[顯示\] 中選取一種圖表類型，後者可確定適合於您所選的欄位的圖表類型。有關詳情，請參閱[使用 \[顯示\] 啟動檢視](buildauto_showme.htm)。
- 您可以將欄位放在 \[在此處放置欄位\] 網格上，開始以表格方式建立檢視。
    
    ![含三個標記為「將欄位拖曳至此處」位置的資料表。](/tableau/next/zh-tw/pro/desktop/zh-tw/Img/dropFieldHere.png)

## \[欄\] 和 \[列\] 架

從 \[資料\] 窗格拖動欄位以建立視覺化項結構。

\[欄\] 架用於建立表列，而 \[列\] 架用於建立表列。可以將任意數量的欄位放置在這些架上。

將維度置於 \[列\] 或 \[欄\] 架上時，將為該維度的成員建立標題。將度量置於 \[列\] 或 \[欄\] 架上時，將建立該度量的定量軸。向檢視新增更多欄位時，表中會包含更多標題和軸，您對資料的瞭解也會更加詳細。

在下面顯示的檢視中， \[Segment\] （細分市場）維度的成員將顯示為列標題，而 \[Profit\] （利潤）度量將顯示為垂直軸。

![描述檢視中定量軸 和欄標題的圖形。](/tableau/next/zh-tw/pro/desktop/zh-tw/Img/wwd_shelf_cr1.png)

Tableau 使用標記顯示資料，其中每個標記對應於資料來源中的一列（或一組列）。 \[列\] 和 \[欄\] 架上的內層欄位決定預設標記類型。例如，如果內層欄位為度量和維度，則預設標記類型為橫條圖。可以使用 \[標記\] 卡下拉式功能表手動選取其他標記類型。有關詳情，請參閱[變更檢視中標記的類型](https://help.tableau.com/v0.0/pro/desktop/zh-tw/viewparts_marks_marktypes.htm)。

向 \[列\] 和 \[欄\] 架新增更多欄位時，表中也會新增更多的列、欄和區。

![描述檢視中定量軸 和欄標題的圖形。](/tableau/next/zh-tw/pro/desktop/zh-tw/Img/wwd_shelf_cr2.png)

## 隱藏列和欄

通常，您會新增維度和度量來建立表列和欄，並將包含所有資料或透過新增篩選器顯示資料子集。但是，在篩選資料時，這些資料也從常規計算以及對表的匯總資料執行的其他計算中排除。您可以不篩選資料，而是隱藏列或欄，使其不顯示在檢視中，但仍包含在計算中。

> [!TIP]
> 
> **提示**: 在使用對前後日期值進行比較的表計算時，隱藏列特別有用。在這種情況下，始終有一個列或欄由於沒有資料要比較而不顯示資料。隱藏空白欄以保持表計算的完整性。有關表計算的詳情，請參閱[表計算類型](https://help.tableau.com/v0.0/pro/desktop/zh-tw/calculations_tablecalculations_definebasic_runningtotal.htm)。

例如，在計算年同比增長時，第一年沒有可以比較的前一年，因此該列保留為空白。篩選第一年會將其從檢視中移除，但它也會從計算中移除（第二年現在就沒有可以比較的前一年，從而保留為空白）。不要篩選，而是改為隱藏空白欄來保持計算的完整性。

**隱藏列或欄：**

以右鍵按一下（在 Mac 上按住 Control 按一下）要隱藏的列或欄，然後選取 **\[隱藏\]** 。

![從標頭隱藏視覺效果上的欄。](/tableau/next/zh-tw/pro/desktop/zh-tw/Img/hide_columns1.gif)

**顯示隱藏的資料：**

對包含隱藏列或欄的欄位開啟其欄位功能表，然後選取 **\[顯示隱藏資料\]** 。

![從欄架隱藏視覺效果上的欄。](/tableau/next/zh-tw/pro/desktop/zh-tw/Img/hide_columns2.gif)

## \[標記\] 卡

\[標記\] 卡是 Tableau 視覺分析的關鍵元素。將欄位拖到 \[標記\] 卡中的不同屬性時，您可以將上下文和詳細資料新增至檢視中的標記。

使用 \[標記\] 卡設定標記類型（請參閱[變更檢視中標記的類型](https://help.tableau.com/v0.0/pro/desktop/zh-tw/viewparts_marks_marktypes.htm)），並使用色彩、大小、形狀、文字和詳細資料對資料進行編碼。若要變更標記設定，請參閱[控制檢視中標記的外觀](https://help.tableau.com/v0.0/pro/desktop/zh-tw/viewparts_marks_markproperties.htm)。

![標記卡，包含「細分市場」、「區域」和「總和」（數量）架。](/tableau/next/zh-tw/pro/desktop/zh-tw/Img/build_manual_shelves_marks1.png)

在此範例中，三個不同的欄位被拖放到 \[標記\] 卡中的不同屬性。\[Segment\] （細分市場）位於 \[色彩\] 上， \[Region\] （區域）位於 \[形狀\] 上， \[Quantity\] （數量）位於 \[大小\] 上。

將欄位新增到 \[標記\] 卡後，可以按一下該欄位旁的圖示以變更它所使用的屬性。您還可以按一下 \[標記\] 卡中的屬性按鈕來變更這些設定。

![標記卡，包含「細分市場」、「區域」和「總和」（數量）架。對於總和（數量）度量，內容功能表顯示色彩、標籤、圖形、詳細資料和工具提示選項。](/tableau/next/zh-tw/pro/desktop/zh-tw/Img/build_manual_shelves_marks2.png)

很多屬性都可以有多個欄位。例如，您可以向 \[標籤\] 、 \[詳情\] 、 \[工具提示\] 和 \[色彩\] 新增多個欄位。\[大小\] 和 \[形狀\] 一次只能有一個欄位。有關詳情，請參閱[控制檢視中標記的外觀](https://help.tableau.com/v0.0/pro/desktop/zh-tw/viewparts_marks_markproperties.htm)。

**附註：** 預設情況下，將一個新欄位拖到 \[色彩\] 會替換現有欄位。若要將新欄位新增到色彩而不替換現有欄位，請在將新欄位拖到 \[標記\] 卡的 \[色彩\] 上時按住鍵盤上的 SHIFT 鍵。

## \[篩選器\] 架

使用 \[篩選器\] 架可以指定要包含和排除的資料。例如，您可能希望對每個客戶分區的利潤進行分析，但希望只限於特定的裝運容器和交貨時間。透過將欄位放在 \[篩選器\] 架上，即可建立這樣的檢視。

**附註：** 本節簡要介紹篩選功能。有關篩選的詳情，請參閱[篩選檢視中的資料](https://help.tableau.com/v0.0/pro/desktop/zh-tw/filtering.htm)。

可以使用度量、維度或同時使用這兩者來篩選資料。此外，還可以根據構成表欄和表列的欄位來篩選資料。這稱為內部篩選。也可以使用不屬於表的標題或軸的欄位來篩選資料。這稱為外部篩選。所有經過篩選的欄位都顯示在 \[篩選器\] 架上。

為闡釋篩選的基本概念，請考慮以下檢視。

![細分市場維度放在欄架上，利潤度量放在列架上。](/tableau/next/zh-tw/pro/desktop/zh-tw/Img/wwd_shelf_cr1.png)

假設您對 \[Home Office\] （家庭辦公室）資料不感興趣。您可以透過篩選 \[Segment\] （細分市場）維度從檢視中移除此欄。為此，請在欄位功能表上選取 \[篩選器\] 或將 \[Segment\] （細分市場）維度拖到 \[篩選器\] 架。此時會開啟 \[篩選器\] 對話方塊。預設情況下，所有成員都處於選中狀態。清除 \[Home Office\] （家庭辦公室）的核取方塊以將其從檢視中排除。所有選定成員都將包含在檢視中。

![描述篩選條件對話方塊的圖形。](/tableau/next/zh-tw/pro/desktop/zh-tw/Img/filter_shelf2.png)

如下所示，檢視將會更新，並移除 \[Home Office\] （家庭辦公室）欄。該篩選器由 \[篩選器\] 架上的 \[Segment\] （細分市場）欄位來指示。

![描述應用於「市場區段」欄位的篩選器的圖形。](/tableau/next/zh-tw/pro/desktop/zh-tw/Img/filter_shelf3.png)

假設您只想查看某一類產品的利潤。即使 \[列\] 和 \[欄\] 架或 \[標記\] 卡上沒有使用 \[Category\] （類別）欄位，您仍可以新增篩選器。將 \[Category\] （類別）維度拖到 \[篩選器\] 架。這是外部篩選器的範例，因為 \[Category\] （類別）未包含在檢視中。

此時會自動開啟 \[篩選器\] 對話方塊。預設情況下不選中任何成員。選取要保留在檢視中的成員。所有清除的成員都被排除。在本例中，選取了 \[Office Supplies\] （辦公耗材）。

下面顯示了經過修改的資料檢視。標記標籤顯示 \[Consumer\] （消費者）細分市場的利潤總額已降至 $56,330。此數位是透過對資料來源中與 \[Corporate\] （企業）市場關聯並屬於 \[Office Supplies\] （辦公耗材）類別的所有列求和而得到的。

![描述使用「市場區段」和「出貨容器」 欄位篩選器的長條圖的圖形。](/tableau/next/zh-tw/pro/desktop/zh-tw/Img/filter_shelf5.png)

由於篩選器是獨立的，因此在 \[篩選器\] 架上放置欄位的順序不會影響資料檢視。換言之，先按客戶細分然後按容器進行篩選的結果與先按容器然後按客戶細分篩選的結果相同。有關操作篩選順序的詳情，請參閱[篩選檢視中的資料](https://help.tableau.com/v0.0/pro/desktop/zh-tw/filtering.htm)。

## \[頁面\] 架

使用 \[頁面\] 架可以將檢視劃分為一系列頁面，使您可以更好地分析特定欄位對檢視中其他資料的影響。將某個維度放置到 \[頁面\] 架上時，將為該維度的每個成員新增一個新列。將某個度量放置到 \[頁面\] 架上時，Tableau 會自動將該度量轉換為離散度量。

\[頁面\] 架會建立一組頁面，每個頁面上都有不同的檢視。每個檢視都基於您放置在 \[頁面\] 架上的欄位。使用將欄位移到 \[頁面\] 架時新增到檢視中的控制項，您可以輕鬆地翻閱檢視並在一個公共軸上比較它們。例如，以下的檢視按 \[Region\] （區域）顯示整個月中每一天的 \[Profit\] （利潤）與 \[Sales\] （銷售額）。下圖顯示第 1、2、3 和 4 天的資料。您必須捲動才能查看這個月中的其他各天。

![散佈圖，視覺化不同區域的利潤和銷售額之間的關聯性。](/tableau/next/zh-tw/pro/desktop/zh-tw/Img/pages_shelf1.png)

為了使該檢視更方便查看，可將 \[DAY(Order Date)\] 移到 \[頁面\] 架，並使用關聯的控制項翻閱頁面（一天一個頁面）。可以快速發現隱藏的細節。在此範例中，就西部地區的銷售額和利潤而言，19 號是一個大喜之日，這十分有趣。

![將 DAY（訂單日期）移至頁面架，並使用關聯控制項翻閱頁面。](/tableau/next/zh-tw/pro/desktop/zh-tw/Img/pages6.gif)

向 \[頁面\] 架中新增欄位時，會自動向檢視的右側新增頁面控制項。

使用此控制項可在頁面之間巡覽。有三種方法可在檢視中的頁面之間巡覽：

- 跳轉到特定頁面
- 手動翻閱頁面
- 自動翻閱頁面

### 跳轉到特定頁面

從下拉清單中選取要查看的成員或值以顯示特定頁面。

![跳轉到特定頁面。](/tableau/next/zh-tw/pro/desktop/zh-tw/Img/pages_shelf7.gif)

### 手動翻閱頁面

透過執行以下任意操作，可以手動翻閱頁面序列：

- 使用下拉清單任意一側的向前和向後按鈕，一次瀏覽一個頁面。
- 使用 \[頁面滑塊\] 快速在頁面序列中向前和向後滾動。
- 使用以下任意鍵盤快速鍵在頁面序列中向前和向後捲動。
    
    <table style="mc-table-style: url('Resources/TableStyles/Basic-Border.css');margin-left: 0;margin-right: auto;" class="TableStyle-Basic-Border" cellspacing="0"><colgroup><col class="TableStyle-Basic-Border-Column-Column1"><col class="TableStyle-Basic-Border-Column-Column1"></colgroup><tbody><tr class="TableStyle-Basic-Border-Body-Body1"><td class="TableStyle-Basic-Border-BodyE-Column1-Body1">F4</td><td class="TableStyle-Basic-Border-BodyD-Column1-Body1">開始和停止向前播放</td></tr><tr class="TableStyle-Basic-Border-Body-Body1"><td class="TableStyle-Basic-Border-BodyE-Column1-Body1">SHIFT + F4</td><td class="TableStyle-Basic-Border-BodyD-Column1-Body1">開始和停止向後播放</td></tr><tr class="TableStyle-Basic-Border-Body-Body1"><td class="TableStyle-Basic-Border-BodyE-Column1-Body1">Ctrl + .</td><td class="TableStyle-Basic-Border-BodyD-Column1-Body1">向前跳一頁</td></tr><tr class="TableStyle-Basic-Border-Body-Body1"><td class="TableStyle-Basic-Border-BodyB-Column1-Body1">Ctrl + ,</td><td class="TableStyle-Basic-Border-BodyA-Column1-Body1">向後跳一頁</td></tr></tbody></table>
    
    在 Mac 上，這些是等效的鍵盤快速鍵。
    
    <table style="mc-table-style: url('Resources/TableStyles/Basic-Border.css');margin-left: 0;margin-right: auto;" class="TableStyle-Basic-Border" cellspacing="0"><colgroup><col class="TableStyle-Basic-Border-Column-Column1"><col class="TableStyle-Basic-Border-Column-Column1"></colgroup><tbody><tr class="TableStyle-Basic-Border-Body-Body1"><td class="TableStyle-Basic-Border-BodyE-Column1-Body1">F4</td><td class="TableStyle-Basic-Border-BodyD-Column1-Body1">開始和停止向前播放</td></tr><tr class="TableStyle-Basic-Border-Body-Body1"><td class="TableStyle-Basic-Border-BodyE-Column1-Body1">Shift-F4</td><td class="TableStyle-Basic-Border-BodyD-Column1-Body1">開始和停止向後播放</td></tr><tr class="TableStyle-Basic-Border-Body-Body1"><td class="TableStyle-Basic-Border-BodyE-Column1-Body1">Command-句號鍵</td><td class="TableStyle-Basic-Border-BodyD-Column1-Body1">向前跳一頁</td></tr><tr class="TableStyle-Basic-Border-Body-Body1"><td class="TableStyle-Basic-Border-BodyB-Column1-Body1">Command-逗號鍵</td><td class="TableStyle-Basic-Border-BodyA-Column1-Body1">向後跳一頁</td></tr></tbody></table>

### 自動翻閱頁面

使用播放控制項可以觀看檢視中頁面的投影片放映。可以前進或後退，並且可以隨時停止播放。可以使用控制項右下角的速度控制項來控制播放速度。最小的條指示播放速度最慢。

![帶有按鈕的滑桿，可瀏覽和檢視視覺效果上的訂單資料。](/tableau/next/zh-tw/pro/desktop/zh-tw/Img/pages_shelf8.png)

### 顯示頁面歷程記錄

使用 \[顯示歷程記錄\] 核取方塊顯示頁面歷程記錄。對於頁面歷程記錄，前面頁面上的標記將顯示在當前頁面上。

_僅在 Tableau Desktop 中_：開啟歷程記錄的下拉控制項可以指定顯示哪些標記以及何時顯示這些標記。

![具有顯示資料歷程記錄選項的表單，包括長度、類型和格式。](/tableau/next/zh-tw/pro/desktop/zh-tw/Img/pages7.png)

歷程記錄下拉控制項包含以下選項：

- 標記以顯示以下內容的歷程記錄 ― 選取是僅為選定的標記、突出顯示的標記、已手動選取顯示其歷程記錄的標記顯示歷程記錄，還是為所有標記顯示歷程記錄。若要手動顯示標記的歷程記錄，方法是在檢視中以右鍵按一下（在 Mac 上按住 Control 按一下）標記，然後在 \[頁面歷程記錄\] 功能表中選取一個選項。
- 長度 ― 選取要顯示在歷程記錄中的頁面數量。
- 顯示 ― 指定是顯示歷史標記、穿過以前值的跟蹤線（軌跡），還是兩者都顯示。
- 標記 ― 為歷史標記設定格式，包括色彩、淡化程度；如果已將色彩設定為自動，則標記將使用 \[色彩\] 架上的預設標記色彩或色彩編碼。
- 軌跡 ― 為穿過歷史標記繪製的線設定格式。僅當在 \[顯示\] 選項中選取 \[軌跡\] 時，此選項才可用。

如果頁面上的每個色彩有多個標記，則不會顯示頁面軌跡。確保檢視的詳情層級小於或等於 \[頁面\] 架和 \[色彩\] 目標上的詳情層級。此外，僅對於離散標記類型（例如正方形、圓形或形狀）才支援軌跡。在標記類型為 \[自動\] 時，不支援軌跡。

### 儀表板上的頁面（僅限 Tableau Desktop）

當儀表板包含使用 \[頁面\] 架上的同一欄位的多個檢視時，可以透過選取 \[同步\] 選項，利用一個頁面控制項控制所有這些檢視。此選項只適用於儀表板上顯示的頁面控制項。

![透過選取同步選項，使用單一頁面控制項來控制所有檢視。](/tableau/next/zh-tw/pro/desktop/zh-tw/Img/pages9.gif)

## 附加架、圖例、卡和控制項

某些架、圖例、卡或控制項僅在您使用檢視時執行操作後才會顯示。例如，僅在 \[色彩\] 上有欄位時，才會顯示 \[色彩\] 圖例。

![圖例顯示帶有相應色彩的運輸模式。](/tableau/next/zh-tw/pro/desktop/zh-tw/Img/color1.png)

Tableau 提供了用於移動或以其他方式自訂檢視的這些元素的控制項。

以下清單描述了上述每種架、圖例、卡或控制項。

- 度量值架 -「度量值」是一個特殊欄位，它總是出現在「資料」窗格中，並且包含收集到單一欄位中的所有資料度量。當多個度量共用相同軸時，Tableau 會將 \[度量值\] 自動新增到檢視中。當 \[度量值\] 在檢視中時，Tableau 會顯示 \[度量值\] 架，此架顯示正在被納入的度量。您可以在此卡中新增或刪除度量。有關詳情，請參閱[度量值與度量名稱](https://help.tableau.com/v0.0/pro/desktop/zh-tw/datafields_understanddatawindow_meavalues.htm)。
- 色彩圖例 – 在 \[色彩\] 上有欄位時顯示分配色彩的方法。有關詳情，請參閱[為標記指派色彩](https://help.tableau.com/v0.0/pro/desktop/zh-tw/viewparts_marks_markproperties.htm#ColorProp)。
- 形狀圖例 – 在 \[形狀\] 上有欄位時顯示分配形狀的方法。有關詳情，請參閱[變更標記的形狀](https://help.tableau.com/v0.0/pro/desktop/zh-tw/viewparts_marks_markproperties.htm#ShapeProp)。
- 大小圖例 – 在 \[大小\] 上有欄位時顯示分配大小的方法。有關詳情，請參閱[變更標記的大小](https://help.tableau.com/v0.0/pro/desktop/zh-tw/viewparts_marks_markproperties.htm#SizeProp)。
- 地圖圖例 – 在地圖上顯示符號和圖案的圖例。不是所有地圖提供程式都可使用地圖圖例。
- 參數控制項 - 單獨的參數控制項可用於工作簿中的每個參數。有關詳情，請參閱[建立參數](https://help.tableau.com/v0.0/pro/desktop/zh-tw/parameters_create.htm)。
- 標題 – 預設情況下會顯示每個檢視的標題。預設標題是工作表名稱。按兩下（在 Mac 上，Control + 按一下）標題以編輯標題。有關詳情，請參閱[設定檢視各別部分的格式](https://help.tableau.com/v0.0/pro/desktop/zh-tw/formatting_specific_titlecaption.htm)。
- 說明 - 從 \[工作表\] 功能表中選取 \[顯示說明\] 以顯示檢視的說明。
- 摘要卡 - 從 \[工作表\] 功能表中選取 \[顯示摘要\] 以顯示檢視的摘要卡。有關詳情，請參閱[摘要卡](https://help.tableau.com/v0.0/pro/desktop/zh-tw/inspectdata_summary.htm)。
- 頁面控制項 – 當 \[頁面\] 架上有欄位時，提供用於在頁面中巡覽的選項。有關詳情，請參閱[\[頁面\] 架](#Pages)。