---
schema_version: "1"
id: f4caa960da55532d8cbbd0a6f6e0ca728365b0809653b1240eb1565ff1114f96
title: 创建参数
collection: tableau
version: next
locale: zh-cn
portal_url: https://docs.salesforce.com/tableau/next/zh-cn/public/desktop/parameters_create.md
canonical_url: https://help.tableau.com/v0.0/public/desktop/zh-cn/parameters_create.htm
source_site: help.tableau.com
content_type: documentation
content_hash: 283db51b122c47ccad7c58ea150b4121a54c9d8eba868d16764344c567a58c69
description: Create, edit, and use parameters in calculations, filters, and reference lines.
---
[跳转到主要内容](#main-content)

# 创建参数

参数是工作簿变量，例如数字、日期或字符串，可以替换计算、筛选器或参考行中的常量值。

例如，您可能会创建一个在销售额大于 $500,000 时返回“True”否则返回“False”的计算字段。可以在公式中使用参数来替换常量值“500000”。然后，可使用参数控件来动态更改计算中的阈值。

若要使用参数，您必须：

1. 设置初始参数。
2. 在计算、筛选器或参考线等元素中使用参数。
3. 通过以下方式调整参数值：
    - 显示参数控件
    - 使用参数动作
    - 设置动态参数以自动更新

## 创建参数

若要通过“数据”窗格创建参数，请执行以下操作：

1. 在“数据”窗格中，单击右上角中的下拉箭头，并选择“创建参数”。
    
    ![上下文菜单，包含用于分组、排序、隐藏和扩展数据的选项。突出显示了“创建参数”选项，以及“按数据源表分组”选项和“按名称排序”选项。](/tableau/next/zh-cn/public/desktop/zh-cn/Img/DPVcreate-parameter-contextmenu.png)
2. 在“创建参数”对话框中，为字段指定一个名称。
    
    ![“创建参数”窗口，其中包含名称、数据类型、当前值、允许值和显示格式的字段。](/tableau/next/zh-cn/public/desktop/zh-cn/Img/DPVname-parameter.png)
3. 指定参数将接受的值的数据类型：
    
    ![用于自定义数据类型的属性窗口，其中展开了“数据类型”下拉菜单并选择了整数选项。](/tableau/next/zh-cn/public/desktop/zh-cn/Img/DPVspecify-datatype.png)
4. _可选：_指定当前值。这是参数的默认值。
5. _可选：_在工作簿打开时指定值。
6. 指定要在参数控件中使用的显示格式（仅限 Tableau Desktop）。
    
    ![用于自定义数字数据显示格式的属性窗口。](/tableau/next/zh-cn/public/desktop/zh-cn/Img/DPVdisplayformat.png)
7. 指定参数接受值的方式。可从以下选项中选择：
    
    - 全部：参数控件是一个简单的文本字段。
    - 列表：参数控件提供可供选择的可能值的列表。
        - 如果选择“列表”，则必须指定值列表。在左边的列中单击以键入值列表，或者可以通过选择“添加值来源”来添加字段的成员或从剪贴板粘贴。
            
            ![带有用于添加值的选项的窗口。](/tableau/next/zh-cn/public/desktop/zh-cn/Img/DPV-Addvaluesfrom-FIXED.png)
    - 范围：参数控件可用于选择指定范围中的值。
        - 如果选择“范围”，则必须指定最小值、最大值和步长。步长控制值之间的跳跃，例如让您选择每个数字（5、6、7...）或从 5 到 10 到 15。
    
    这些选项的可用性由数据类型确定。例如，字符串参数不支持“范围”。
    
    若要在工作簿打开时刷新参数的值列表（或域），请选择“列表”或“范围”，然后选择 “工作簿打开时”。请注意，某些选项显示为灰色，因为工作簿正在动态地从数据源中拉取值。
8. 完成后，单击“确定”。

参数现在列在“数据”窗格底部的“参数”部分中。

![数据窗格的参数部分。](/tableau/next/zh-cn/public/desktop/zh-cn/Img/DPV-parameter-in-datapane.png)

## 编辑参数

可通过“数据”窗格或参数控件来编辑参数。编辑用于更改允许范围或数据类型等操作。若只是更改值或参数，请使用参数控件。请参见[在可视化项中显示参数控件](#Show)。

若要编辑参数，请执行以下操作：

1. 执行以下操作之一：
    - 在“数据”窗格中右键单击参数，并选择“编辑”。
    - 在参数控件菜单中选择“编辑参数”。
2. 在“编辑参数”对话框中，进行相应更改。
3. 单击“确定”。参数会随使用它的任何元素一起更新。

### 删除参数

若要删除参数，请在“数据”窗格中右键单击该参数并选择“删除”。使用已删除参数的任何计算字段都变为无效。

## 使用参数

参数在绑定到可视化项中的元素之前不会执行任何操作。可以在计算、筛选器和参考线中引用参数。参数在工作簿中为全局参数，可在任何工作表中使用。

元素引用参数后，请确保[在可视化项中显示参数控件](#Show)（或设置参数动作或动态参数）。如果无法更改参数的值，那么一开始就设置它没有任何好处。

### 在计算中使用参数

您可通过参数来动态修改计算中的值。您可以使用参数而不是手动编辑计算（以及所有依赖计算）。然后在要更改值时，可打开参数控件并更改值；使用该参数的所有计算都会更新。

若要在计算中使用参数，请键入参数的名称，它会出现在建议的选项中，就像键入字段名称一样。您还可以将参数从“数据”窗格拖放到计算编辑器中。

![带有 IF 语句的计算字段框，其中包含计算中的参数。](/tableau/next/zh-cn/public/desktop/zh-cn/Img/parameter_in_calculation.png)

### 在筛选器中使用参数

您可通过参数来动态修改“前 N 个”筛选器中的值。您可以使用参数而不是在筛选器中手动设置要显示的值数。“筛选器”对话框“前”选项卡上的下拉列表中有一个参数列表。选择要在筛选器中使用的参数。

![带有按字段或参数进行筛选的选项的筛选器菜单。](/tableau/next/zh-cn/public/desktop/zh-cn/Img/parameters_filters1.png)

### 在参考线中使用参数

您可通过参数来动态修改参考线、参考区间或框。例如，您可以参考一个参数而不是在轴上的一个固定位置显示一条参考线。然后就可以使用参数控件移动参考线。

“添加参考线、参考区间或框”对话框的**“值”**下拉列表中有一个参数列表。选择要使用的参数。参考线在参数指定的“当前值”处绘制。

![“编辑参考线、参考区间或参考箱”对话框，其中包含用于在值中插入参数的选项。](/tableau/next/zh-cn/public/desktop/zh-cn/Img/parameters_referencelines1.png)

## 在可视化项中显示参数控件

参数控件是可用来修改参数值的工作表卡。参数控件与筛选器卡相似，因为它们都包含修改视图的控件。您可以在工作表和仪表板上打开参数控件，在保存到 Web 或发布到 Tableau Server 时会包括这些参数控件。

若要打开参数控件，请在“数据”窗格中右键单击（按住 Control 单击）参数并选择“显示参数”。

![“显示参数”下拉菜单选项。](/tableau/next/zh-cn/public/desktop/zh-cn/Img/example_parameters13.png)

像其他卡一样，参数控件具有一个菜单，您可以使用卡右上角中的下拉箭头打开此菜单。使用此菜单，可自定义控件的显示。例如，可以将值列表显示为单选按钮、精简列表、滑块或字段中的类型。

此菜单中可用的选项取决于参数的数据类型以及该参数是接受所有值、值列表还是值范围。

![“编辑参数”对话框，其中包含“显示标题”和“选择参数类型”选项；已选择滑块。](/tableau/next/zh-cn/public/desktop/zh-cn/Img/parameters13.png)

## 生成动态参数

### 参数动作

可通过在[参数动作](https://help.tableau.com/v0.0/public/desktop/zh-cn/actions_parameters.htm)中使用参数来使参数更加动态并更具交互性。参数动作可让受众通过直接与可视化项交互（例如单击或选择标记）来更改参数值。

### 动态当前值

您可以创建一个参数，该参数可以根据计算结果、值列表（基于字段）或值范围来刷新其当前值。每次打开工作簿或从数据源的上下文菜单中选择“刷新”时，都会发生此刷新。

**使用计算作为参数的当前值**

如果当前值是计算结果，则它必须是单值、与视图无关的计算。如果计算结果可能有多个值，则工作簿无法选择默认值。计算还必须与视图无关，以便值不会随着可视化项的变化而变化。

为此，可以使用不依赖于可视化项的结构的 FIXED 详细级别 (LOD) 表达式。计算的所有部分都必须位于 FIXED LOD 表达式内。如果使用 FIXED LOD 表达式作为默认值，并且使用上下文筛选器，则动态参数不会反映任何上下文筛选器。

有关 LOD 表达式的详细信息，请参见[在 Tableau 中创建详细级别表达式](https://help.tableau.com/v0.0/public/desktop/zh-cn/calculations_calculatedfields_lod.htm)。

注意：我们不建议在数据提取筛选器中使用动态参数，因为它会影响性能。如果您对数据提取筛选器使用动态参数，Tableau 需要首先处理所有数据以确定参数的值，从而确定要筛选的数据。例如，如果您使用动态参数筛选器返回最近 30 天的数据，Tableau 会评估整个数据源以查找最近 30 天的数据，然后对其进行筛选。这会导致性能下降和加载时间更长。

## 排除参数故障

此处是一些默认参数值或可刷新参数值列表（域）不会按预期更新的情况：

- 默认字段返回其数据与参数的数据类型不兼容的值。
- 参数当前值的默认字段不返回单个值。
- 默认字段返回 null。
- 默认字段位于未连接的数据源中。
- 默认字段位于未混合的数据源中。
- 默认字段已删除。
- 在 Tableau 尝试连接时，用户将取消对数据源的查询。

在 Tableau Desktop 中，当打开工作簿并且 Tableau 首次连接到字段的数据源时，将对这些查询进行初始评估。还可以通过刷新数据源来评估查询。为此，请按 F5，或打开数据源的上下文菜单并选择“刷新”。在 Tableau Server 和 Tableau Cloud 上，可以通过单击工具栏中的“数据源刷新”按钮来刷新数据源。但是，在这种情况下，请记住返回的值取决于服务器的缓存策略。

如果默认字段无法返回值，则参数的行为将如下所示：

- 当前值将保留最新的有效值。
- 值列表将为空，因为 Tableau 不会序列化从工作簿中的查询返回的值。

当前值必须位于值列表中才能将其分配给参数。如果值列表为空，则将依据数据类型（1 表示整数，1.0 表示浮点，"” 表示字符串，以及当前日期表示日期和日期时间）为参数分配回退值。

## 此部分中的其他文章