---
schema_version: "1"
id: 3d415d411b7c80686a53ed88a6e9c7cc369dd5e424892fc5fac91359fbe26f8d
title: 查找背景图像坐标
collection: tableau
version: next
locale: zh-cn
portal_url: https://docs.salesforce.com/tableau/next/zh-cn/public/desktop/bkimages_coordinates.md
canonical_url: https://help.tableau.com/v0.0/public/desktop/zh-cn/bkimages_coordinates.htm
source_site: help.tableau.com
content_type: documentation
content_hash: b2e39917e13d8ed4636aec1d85133fcb1ce340307f13e43ee686156db93570ed
description: Plot data points on a background image by creating an X/Y coordinate table and joining it to your data.
---
[跳转到主要内容](#main-content)

# 查找背景图像坐标

在许多情况下，您可能希望将数据映射到背景图像（而不是 Tableau 地图）上。本文介绍如何在背景图像上绘制数据点。

此过程有若干步骤：

1. 在数据源中为 X 和 Y 坐标创建一个表。
2. 在 Tableau Desktop 中连接到您的数据源，并将坐标表与其余数据联接。
3. 导入背景图像并构建视图。
4. 为背景图像上的点添加注释。
5. 向数据源中的坐标表中添加坐标。
6. 在 Tableau 中刷新您的数据源。

## 步骤 1：创建坐标表

在数据源中创建一个表，该表包含用于标识唯一标记的列。此示例中有三个列：

- 第一列容纳每个标记的唯一标识符。
- 其他两列表示 X 和 Y 坐标。

创建列之后，将新的坐标表联接到原始数据源。联接基于原始数据源和坐标表中都使用的唯一标识符（表示单一标记的标识符）进行。

1. 选择一个适合于背景图像的标度。如果图像的宽度大于高度，请使用 X：0-100 和 Y：0-50。
2. 对于此示例，在 Excel 中打开 Tableau 存储库中的“Sample Superstore”Excel 文件，并选择一个新工作表标签。
3. 在新标签上的表中放置一行，该行包含其中一个唯一标识符，以及您为两个标度选择的 X 和 Y 端点。
    
    在本例中，**“Product Sub-category”（产品子类）**是“Sample Superstore”中的一列，它的其中一个成员是**“Tables”（表）**。**X** 端点为 **100**，**Y** 端点为 **50**，因为这是背景图像的标度。
    
    ![表格显示产品子类的信息。](/tableau/next/zh-cn/public/desktop/zh-cn/Img/BackgroundImage1_1.png)
4. 将标签名称更改为**“Coords”**并保存文件。

## 步骤 2：连接到坐标表

1. 在新 Tableau 工作簿中，选择**“连接到数据”**。
2. 在**“连接到数据”**对话框中，选择**“Microsoft Excel”**，然后单击**“下一步”**。
3. 在数据源页面上，执行下列操作：

- 将“Orders”（订单）工作表拖到“联接”区域。
- 将“Coords”（坐标）工作表拖到“联接”区域。
- 单击联接图标可修改现有联接。
- 在打开的“联接”对话框中，选择**“左侧”**，然后为**“Data Source”（数据源）**列选择**“Product Sub-Category”（产品子类）**，并为**“Coords”（坐标）**列选择**“Product Name (Coords)”（产品名称 (坐标)）** 。
    
    ![在“Product Sub-Category”（产品子类）和“Product Name (Coords)”（产品名称（坐标））上具有左联接的联接表。](/tableau/next/zh-cn/public/desktop/zh-cn/Img/BackgroundImage13_1.png)

5. 关闭“联接”对话框，然后选择工作表标签以转到工作表。

## 步骤 3：导入背景图像

1. 在新工作表中，选择**“地图”**\>**“背景图像”**、**示例 - 超市**。这将打开“背景图像”对话框。
2. 在**“背景图像”**对话框中，单击**“添加图像”**。
3. 在**“添加背景图像”**对话框中，浏览到文件并将其选中。
4. 对于**“X 字段”**，在列表中选择**“X”**。
    
    **注意：**如果在列表中未看到 X 字段，则意味着您需要将 X 字段更改为连续数字。  
      
    若要将字段更改为数字，请在“数据”窗格中右键单击**“X”**字段，并选择**“更改数据类型”**\>**“数字(整数)”**。若要将字段更改为连续，请在“数据”窗格中右键单击**“X”**字段，并选择**“转换为连续”**。  
      
    为**“Y”**字段重复这些步骤。
5. 在**“右侧”**文本框中，键入**“100”**（100 是您在坐标表中使用的数字）。
6. 对于**“Y 字段”**，在列表中选择**“Y”**。
7. 在**“顶部”**文本框中，键入**“50”**（50 是您在坐标表中使用的数字）。确保在正确的文本框中键入内容。
    
    ![“添加背景图像”对话框。](/tableau/next/zh-cn/public/desktop/zh-cn/Img/BackgroundImage3_1.png)
8. 单击**“确定”**，然后在**“背景图像”**对话框中单击**“确定”**。（忽略**“背景图像”**对话框中的**“有效”**设置**“否”**。）

## 步骤 4：查找坐标

1. 从“数据”窗格中，将**“X”**拖到**“列”**功能区，并将**“Y”**拖到**“行”**功能区。
2. 在**“列”**功能区上，右键单击**“X”**，并选择**“维度”**。
3. 在**“行”**功能区上，右键单击**“Y”**，并选择**“维度”**。
    
    **注意：**只有在“X”和“Y”字段是以度量的形式引入 Tableau 的情况下，才必须执行此步骤。
    
    背景图像将出现在视图中。
    
    ![带有背景图像的仪表板。](/tableau/next/zh-cn/public/desktop/zh-cn/Img/BackgroundImage4_1.png)
4. 右键单击 X 轴，并选择**“编辑轴”**。
    
    ![下拉菜单上的“编辑轴”选项。](/tableau/next/zh-cn/public/desktop/zh-cn/Img/BackgroundImage5_0_0.png)
5. 在**“编辑轴”**对话框中，选择**“固定”**，然后在**“起始”**文本框中键入**“0”**，并在**“结束”**文本框中键入**“100”**。
6. 单击**“确定”**。
7. 右键单击 Y 轴，并选择**“编辑轴”**。
8. 在**“编辑轴”**对话框中，选择**“固定”**，然后在**“起始”**文本框中键入**“0”**，并在**“结束”**文本框中键入**“50”**。
9. 单击**“确定”**。
    
    现在轴将以 0 为起点。
    
    ![平面图的背景图像。](/tableau/next/zh-cn/public/desktop/zh-cn/Img/BackgroundImage7_1.png)
10. 右键单击要在其中查找坐标的图像上的任何位置，并选择**“添加注释”**\>**“点”**。
    
    有关为视图中的标记或点添加注释的详细信息，请参见 Tableau 帮助中的[添加注释](https://help.tableau.com/v0.0/public/desktop/zh-cn/annotations_annotations_add.htm)主题。
    
    ![带有注释点或区域的选项的下拉菜单。](/tableau/next/zh-cn/public/desktop/zh-cn/Img/BackgroundImage8_1.png)
11. 在**“编辑注释”**对话框中，单击**“确定”**。
12. 为要添加注释的每个点重复步骤 10 和 11。
    
    坐标将以标注的形式显示在背景图像上。您可以将标注移到显示效果更好的位置；只需单击并拖动标注即可。也可通过单击大小控柄之一来调整标注的大小。可通过单击并拖动箭头将坐标点移到新位置；标注中的坐标将更改以反映新位置。
    
    ![红色矩形突出显示平面图上的坐标。](/tableau/next/zh-cn/public/desktop/zh-cn/Img/BackgroundImage10_1.png)
13. 将这些坐标添加至示例 - 超市Excel 文件中的“Coords”工作表，并保存更改。
    
    ![该表显示产品子类及其各自的 X 和 Y 值。](/tableau/next/zh-cn/public/desktop/zh-cn/Img/BackgroundImage11_1.png)
14. 在 Tableau 中，选择**“数据”**\>**示例 - 超市**\>**“刷新”**。
    
    刷新的视图将在坐标位置显示标记。
    
    如果不想继续显示标注，您可以在背景图像上选择这些标注并将其移除。
    
    ![平面图上有四个标有坐标的蓝点。](/tableau/next/zh-cn/public/desktop/zh-cn/Img/BackgroundImage12_1.png)

## 其他提议

尝试将另一个度量放在“大小”功能区上，并将维度或度量放在“标记”卡的“颜色”上。添加您自己的自定义形状。通过在此视图和您的其他分析之间创建动作来开发功能强大而独一无二的分析。

如果要隐藏 X 和 Y 标度，请在“列”或“行”功能区上右键单击各自的字段，并清除**“显示标题”**。

## 另请参见

- [在您的视图中使用背景图像](https://help.tableau.com/v0.0/public/desktop/zh-cn/bkimages.htm)
- [Tableau 中的地图和地理数据分析](https://help.tableau.com/v0.0/public/desktop/zh-cn/maps.htm)