---
schema_version: "1"
id: 2006b8aee3062739bf6f8032aab955502a25abffc3d0a68d5c686bf042baf4bf
title: Web 制作入门指南
collection: tableau
version: next
locale: zh-cn
portal_url: https://docs.salesforce.com/tableau/next/zh-cn/pro/desktop/getstarted_web_authoring.md
canonical_url: https://help.tableau.com/v0.0/pro/desktop/zh-cn/getstarted_web_authoring.htm
source_site: help.tableau.com
content_type: documentation
content_hash: 1a426f6a29af4cddc7e8fee0b73310284734965d65a186c55733e2558e050ae4
description: "Get started with web authoring as a Creator: connect to data and build views on the web."
---
[跳转到主要内容](#main-content)

# Creator：Web 制作入门指南

您可以在 Web 上使用 Tableau 执行很多操作。作为 Creator，您可以直接连接到数据来增强您的分析、创建绝妙的数据可视化项，以及与其他人共享见解。在本指南中，我们将讨论 Tableau Cloud 环境、连接到数据并准备要分析的数据、创建工作簿以及与其他人共享见解。

**不确定自己的用户级别是哪种？**若要进行检查，请选择站点右上角带有您的姓名首字母缩写或个人资料图像的图标，并选择“**我的帐户设置**”。**“站点角色”**指明您是 Creator、Explorer 还是 Viewer（查看者）。

[步骤 1：登录和浏览项目](#Step6)

[步骤 2：创建新工作簿并连接到数据](#Step7)

[步骤 3：准备数据](#Step)

[步骤 4：制作视图](#Step2)

[步骤 5：展示您的工作](#Step3)

[步骤 6：保存您的工作](#Step4)

[步骤 7：协作和共享您的发现](#Step5)

## 步骤 1：登录和浏览项目

若要开始操作，请输入您的用户名和密码以登录到您的 Tableau 站点。然后，从导航窗格中，单击“浏览”查看整个站点中您有权访问的所有内容。

一开始，您将看到顶层项目。您可以浏览这些项目，或者选择其他内容类型。

![内容类型选择](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/explore_content_type.png)

工作簿、数据源、数据角色和流程可以保存到称为项目的位置。项目还可以包含嵌套项目。与桌面的文件夹很像，可以通过项目对站点中的内容进行排序和管理。如果您曾经被邀请访问过某个现有站点，您可能会看到您的队友创建的项目。

除了项目之外，您还可以将工作簿以私有方式保存到名为“个人空间”的位置。您可以使用个人空间来创建或浏览工作簿，并在您准备好与他人共享时将它们移动到项目中。有关详细信息，请参见[在个人空间中创建和编辑私有内容](https://help.tableau.com/v0.0/pro/desktop/zh-cn/personal_space.htm)。

如果其他项目对您不可用，则个人空间和默认项目都是供您用于探索的地方。

从 2019.3 开始，Tableau Catalog 随 Tableau Server 和 Tableau Cloud 中的 Data Management 一起提供。在环境中启用了 Tableau Catalog 后，除了通过“浏览”导航和连接到数据外，您还可以通过“外部资产”导航和连接到更多种类的数据，如数据库和表。有关 Tableau Catalog 的详细信息，请参见 [Tableau Server](https://help.tableau.com/current/server/zh-cn/dm_catalog_overview.htm) 或 [Tableau Cloud](https://help.tableau.com/current/online/zh-cn/dm_catalog_overview.htm) 帮助中的“关于 Tableau Catalog”。

## 步骤 2：创建新工作簿并连接到数据

在某种程度上，您将需要连接到数据，以便对其进行分析并构建工作簿。作为 Creator，Tableau 允许您直接连接到 Web 上的数据源，或者可以连接到[通过 Tableau Desktop 发布到 Tableau Cloud 的数据源](https://help.tableau.com/current/online/zh-cn/to_publish.htm)。

若要开始，请单击“新建”按钮，并选择“工作簿”。

![“创建工作簿”按钮](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/online_new_workbook.png)

“连接到数据”对话框显示常见混合内容的可滚动列表。如果有 Data Management 许可证，您可以使用虚拟连接来连接到数据，如果有启用了 Tableau Catalog 的 Data Management，您还可以连接到外部资产，比如数据库、文件和表。

响应式搜索字段显示建议列表，该列表会在您输入文本时更新。按数据类型、认证状态或其他取决于所选数据类型的筛选器来筛选结果。例如，某些类型的数据可能允许您根据标记、连接类型、数据质量警告或其他条件进行筛选。旧版本的对话框和功能略有不同，但整体功能相似。

![“连接到数据”窗口](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/connect_to_data.png)

您可以通过若干方式连接到可增强您的工作簿的数据：

- 通过“此站点上”选项卡连接到发布的数据源。
    
    如果有 Data Management 许可证，您可以使用虚拟连接来连接到数据，如果有启用了 Tableau Catalog 的 Data Management，您还可以连接到外部资产，比如数据库、文件和表。
- 通过“文件”选项卡上载 Excel 数据源或基于文本的数据源。
- 通过“连接器”选项卡连接到服务器或云数据源。

- 在 Tableau Cloud 上，通过“**仪表板起始模板**”选项卡快速制作并对来自 LinkedIn Sales Navigator、Oracle Eloqua、Salesforce、ServiceNow ITSM 和  Marketo 的数据进行分析。

若要了解有关连接到 Web 上的数据的详细信息，请参见 [Creator：连接到 Web 上的数据](https://help.tableau.com/current/pro/desktop/zh-cn/creator_connect.htm)。

### Tableau Catalog 用户通过外部资产创建工作簿

如果有启用了 Tableau Catalog 的 Data Management，您可以在从“外部资产”页创建支持 Catalog 的连接时创建新的工作簿：

![数据库和表页面上的“新建工作簿”按钮](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/db_table_new_wkbk.png)

通过数据库和表页面：

![“外部资产”选项卡上的“新建工作簿”按钮](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/external_assets_new_wkbk.png)

如果 Catalog 不支持连接，**“新建工作簿”**将不会出现。

## 步骤 3：准备数据

连接到数据之后，使用数据源页面来准备要分析的数据。

### 数据源页面的各个部分

![“数据源”页面](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/online_datasource.png)

数据源页面有四个部分： 

1. **左侧窗格**：显示有关数据的详细信息。对于基于文件的数据，左侧窗格可能显示文件名和文件中的工作表。对于关系数据，左侧窗格可能会显示服务器、数据库或架构以及数据库中的表。
2. **画布**：连接到多数关系数据和基于文件的数据时，您可以将一个或多个表拖到画布区域来设置要分析的 Tableau 数据源。
3. **数据网格**：您可以使用数据网格查看字段以及 Tableau 数据源中所包含的前 1,000 行数据。
4. **元数据网格**：单击该按钮将转到元数据网格，该网格将数据源中的字段显示为行，以便您能够查看其结构。

可通过以下方式在数据源页面中准备要分析的数据： 

- 重命名数据源
- 使用数据解释器清理数据
- 设置文本文件选项
- 关联数据
- 编辑数据列

若要了解有关在 Web 上准备要分析的数据的详细信息，请参见 [Creator：在 Web 上准备数据](https://help.tableau.com/current/pro/desktop/zh-cn/creator_data_prep.htm)。

数据准备就绪可进行分析后，单击屏幕底部的**“工作表 1**”转到 Tableau 工作区以构建视图。

## 步骤 4：制作视图

您已连接到数据，并设置了要分析的数据，现在即可创建数据的可视分析。Tableau 将此称为**视图**。如果之前使用过 Tableau Desktop，工作区区域非常相似。

### 工作区区域

这是 Tableau 工作区的布局：

![Tableau Cloud 工作表，带有视图不同部分的各种标注。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/online_workspace.png)

1. **工作簿名称**。工作簿包含工作表，后者可以是工作表、仪表板或故事。有关详细信息，请参见[工作簿和工作表](https://help.tableau.com/current/pro/desktop/zh-cn/environ_workbooksandsheets.htm)。
2. “**页面”功能区、“筛选器”功能区、“标记”卡** - 将字段拖到工作区中的卡和功能区，以将数据添加到您的视图中。有关详细信息，请参见[功能区和卡](https://help.tableau.com/current/pro/desktop/zh-cn/buildmanual_shelves.htm)。
3. **“列”和“行”功能区** - 将字段拖到工作区中的卡和功能区，以将数据添加到您的视图中。有关详细信息，请参见[功能区和卡](https://help.tableau.com/current/pro/desktop/zh-cn/buildmanual_shelves.htm)。
4. **工具栏** - 使用工具栏访问命令以及分析和导航工具。请参见 [Tableau 工具栏按钮参考](https://help.tableau.com/current/pro/desktop/zh-cn/environment_workspace.htm#ToolbarButtons)。
5. **视图** - 这是您在其中创建数据可视化项的工作区。
6. **侧栏** - 在工作表中，侧栏区域包含“数据”窗格和“分析”窗格。
7. 转到**数据源**页面。有关详细信息，请参见 [Creator：在 Web 上准备数据](https://help.tableau.com/v0.0/pro/desktop/zh-cn/creator_data_prep.htm)。
8. **工作表标签** - 标签表示工作簿中的每个工作表。这可能包括工作表、仪表板和故事。

**从 Tableau 2020.2 开始**：对于“数据”窗格中的每个表或文件夹，一条灰线将维度（线上方）和度量（线下方）分隔开来。“数据”窗格中不再使用**“维度”**和**“度量”**标签。

### 开始构建视图的不同方式

每次将字段拖到视图中或功能区上时，都会提出一个有关该数据的问题。问题将因您将各个字段拖到何处、字段的类型以及将字段拖到视图中所采用的顺序而异。

对于您提出的每个问题，视图将发生变化，使用标记（形状、文本、分层结构、表结构、轴、颜色）以直观方式呈现答案。

在工作表中，数据源中的列显示为“数据”窗格中左侧的字段。“数据”窗格包含各种不同类型的字段，按表加以组织。

![包含维度和度量列表的“数据”窗格。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/schema3.png)

在构建视图时，您通过“数据”窗格添加字段。可通过不同方式来达到此目的。例如：

- 将字段从“数据”窗格拖放到属于每个 Tableau 工作表的卡和功能区上。
    
    ![将胶囊从“数据”窗格拖到“列”功能区。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/online_drag_pill.gif)
- 以在“数据”窗格中双击一个或多个字段。
    
    ![双击区域将其放置在“列”功能区上。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/online_double_click.gif)
- 在“数据”窗格中选择一个或多个字段，然后从“智能显示”中选择一种图表类型，后者可确定适合于您所选的字段的图表类型。有关详细信息，请参见[智能显示](https://help.tableau.com/current/pro/desktop/zh-cn/buildauto_showme.htm)。
    
    ![Tableau Cloud 上的“智能显示”功能。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/online_show_me.gif)

### 筛选数据

您可能需要筛选数据以便只在视图中显示一定数量的数据。可通过多种方式来筛选数据，其中包括：

当您向“筛选器”功能区添加字段时，视图中将出现一个交互式筛选器。然后，您可以选择要在视图中包括或排除的项。

- 若要在 Web 上通过 Tableau 创建筛选器，请将维度、度量或日期字段拖到“筛选器”功能区。
    
    当您向“筛选器”功能区添加字段时，视图中将出现一个交互式筛选器。您可以选择要在视图中包括或排队的项，或者选择一个值范围。
    
    ![类别复选框列表，其中包含已选中的全部、家具、办公用品和技术选项。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/filter_web_dimension.png)
- 您也可以通过选择单一标记（数据点）与发布的视图交互，或者在视图中单击并拖动以选择若干标记。在出现的工具提示上，您可以选择“只保留”以仅在视图中保留所选标记，或者选择“排除”以从视图中移除所选标记。
    
    ![选择标记以将其排除。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/exclude1.gif)

有关 Tableau 中的筛选的详细信息，包括 Tableau 的操作顺序，请参见[筛选视图中的数据](https://help.tableau.com/current/pro/desktop/zh-cn/filtering.htm)。

### 使用“标记”卡

您可以使用“标记”卡将上下文和详细信息添加至视图中的标记。使用“标记”卡设置标记类型，并使用颜色、大小、形状、文本和详细信息对数据进行编码。

![“标记”卡，带有“细分”、“区域”和“总数（数量）”功能区。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/build_manual_shelves_marks1.png)

将字段添加到“标记”卡后，可以单击该字段旁的图标以更改它所使用的属性。您还可以单击“标记”卡中的属性按钮来更改这些设置。

![“标记”卡，带有“细分”、“区域”和“总数（数量）”功能区。对于“总和（数量）”度量，上下文菜单显示“颜色”、“标签”、“形状”、“详细信息”和“工具提示”选项。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/build_manual_shelves_marks2.png)

很多属性都可以有多个字段。例如，您可以向“标签”、“详细信息”、“工具提示”和“颜色”添加多个字段。“大小”和“形状”一次只能有一个字段。有关详细信息，请参见[标记属性参考](https://help.tableau.com/current/pro/desktop/zh-cn/viewparts_marks_markproperties.htm)。

### 撤消您的工作

Tableau 非常灵活，也极为宽容。在构建视图时，如果采用了未回答您的问题的路径，您始终可以撤消至探究过程中的上一个点。

- 若要撤消或重做，请单击工具栏上的“撤消”![指向左边的箭头。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/undo.png)或“重做”![重做图标。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/redo.png)。

您可以一直撤消至上次打开工作簿的时间。您可以撤消或重做无限次。

### 在 Web 上构建和编辑视图

可通过多种方式在 Tableau 中探索数据。有关在 Web 上构建特定图表类型的说明，请参见[在 Web 上编辑 Tableau 视图](https://help.tableau.com/v0.0/pro/desktop/zh-cn/web_author_build_view.htm)，或者，若要了解可帮助您在 Tableau 中构建可视化项的更多功能，请参见[构建和浏览数据视图](https://help.tableau.com/current/pro/desktop/zh-cn/building_overview.htm)。

## 步骤 5：展示您的工作

可通过多种方式，用您在视图中找到的数据见解来讲述故事或说服他人。

### 设置工作内容的格式

您可以为在工作簿上看到的几乎任何内容（包括视图的各个部分、工作簿的字体和图形线条）设置格式。

- [了解可视化最佳做法](https://help.tableau.com/current/pro/desktop/zh-cn/visual_best_practices.htm)
- [设置视图部件的格式](https://help.tableau.com/current/pro/desktop/zh-cn/formatting_specific.htm)
- [创建自定义调色板](https://help.tableau.com/current/pro/desktop/zh-cn/formatting_create_custom_colors.htm)
- [设置文本和数字的格式](https://help.tableau.com/current/pro/desktop/zh-cn/formatting_specific.htm)
- [在工作簿级别设置格式](https://help.tableau.com/current/pro/desktop/zh-cn/formatting_workbook.htm)

### 仪表板

**仪表板**是显示在单一位置的多个工作表和支持信息的集合，它便于您同时比较和监视不同数据。

若要打开新仪表板工作表并开始创建仪表板，请单击工作簿底部的“新建仪表板”图标：

![“新建仪表板”图标。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/web_author_new_dashboard_icon.png)

“仪表板”区域会出现在左侧，并且会列出您的工作簿中的工作表。您可以向仪表板中添加一个或多个视图、添加像网页、空白空间和布局容器这样的对象，或者添加交互性以关联工作表上的不同视图。

![具有三种可视化项的 Tableau Cloud 仪表板。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/online_dashboard.png)

- [详细了解仪表板](https://help.tableau.com/v0.0/pro/desktop/zh-cn/dashboards.htm)
- [向仪表板专家学习要诀和技巧](https://www.tableau.com/zh-cn/about/blog/2017/10/7-tips-and-tricks-dashboard-experts-76821)

### 故事

**故事**是一个包含一系列共同作用以传达信息的工作表和仪表板的工作表。您可以使用故事揭示各种事实之间的关系以及决策与结果的关系，从而使用数据创建一个极具吸引力的案例。

[创建故事](https://help.tableau.com/current/pro/desktop/zh-cn/story_create.htm)或[详细了解故事](https://help.tableau.com/current/pro/desktop/zh-cn/stories.htm)。

![Tableau 故事。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/story_intro.png)

## 步骤 6：保存您的工作

您可以随时通过选择“**文件”>“另存为**”来保存工作簿。工作簿将保存到在其中创建工作簿的文件夹中。

您也可以保存数据源以稍后创建另一个工作簿，或者使您的团队成员能够使用该数据进行自己的分析。

若要保存数据源，请将光标悬停在工作区内“数据”选项卡中的数据源名称上，直至出现一个箭头。选择该箭头，并选择“**保存**”。

![带有编辑、刷新、重命名、关闭和保存数据源选项的菜单。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/online_datasource_save.png)

**注意**：在 Web 上保存数据源时，它将在**“连接到数据”**窗口以及**“数据源”**部分中显示为发布的数据源。

完成后，选择“**文件”>“关闭**”退出工作区。

## 步骤 7：协作和共享您的发现

可通过多种方式共享您的工作和保持更新。

### 协作

组织中的其他 Creator 或 Explorer 可以编辑或更新您的工作簿和视图，前提是已为他们授予了工作簿所在项目的访问权限。访问由站点的管理员加以控制，后者可以设置项目权限、在项目之间移动内容以及更改用户的角色。如果保存了数据源，则这些用户可以连接到您的数据并使用它来创建新工作簿。

### 共享视图和见解

每个保存到站点的视图或工作簿都可以通过电子邮件中的链接和其他应用程序来共享，或者直接嵌入到网页、wikis 和 Web 应用程序中。

若要查看视图，用户必须在 Tableau Server 或 Tableau Cloud 中具有访问共享视图的权限。

了解如何：

- [共享 Web 视图](https://help.tableau.com/current/pro/desktop/zh-cn/shareworkbooks.htm)（指向视图的链接或嵌入视图）。
- [订阅视图](https://help.tableau.com/current/pro/desktop/zh-cn/subscribe_user.htm)以定期通过电子邮件接收视图的快照。
- 创建[](https://help.tableau.com/current/pro/desktop/zh-cn/data_alerts.htm)[数据驱动型通知](https://help.tableau.com/v0.0/pro/desktop/zh-cn/data_alerts.htm)以在数据达到重要的阈值时收到电子邮件通知。
- [](https://help.tableau.com/current/pro/desktop/zh-cn/comment.htm)[向视图添加注释](https://help.tableau.com/v0.0/pro/desktop/zh-cn/comment.htm)以与其他用户进行讨论。
- 在网页中[嵌入视图和仪表板](https://help.tableau.com/current/pro/desktop/zh-cn/embed_landing.htm)。
- [下载视图或工作簿](https://help.tableau.com/current/pro/desktop/zh-cn/export.htm)。