---
schema_version: "1"
id: de77c69285fa7f741c680f2ce635cb30371f23fbbcfa74f1214a9d8e319ae0e1
title: 通过使用 Tableau Server 或 Tableau Cloud 连接到数据
collection: tableau
version: next
locale: zh-cn
portal_url: https://docs.salesforce.com/tableau/next/zh-cn/pro/desktop/examples_tableauserver.md
canonical_url: https://help.tableau.com/v0.0/pro/desktop/zh-cn/examples_tableauserver.htm
source_site: help.tableau.com
content_type: documentation
content_hash: 4703feea08e93d72c4c7caadc291c28efa9f8527822410c34deac73640cc9613
description: Connect to published data sources by signing in to Tableau Server or Tableau Cloud.
---
[跳转到主要内容](#main-content)

# 通过使用 Tableau Server 或 Tableau Cloud 连接到数据

在您的环境中启用 Tableau Catalog 后，还有其他连接选项。有关详细信息，请参见 [Tableau Server](https://help.tableau.com/current/server/zh-cn/dm_catalog_overview.htm) 或 [Tableau Cloud](https://help.tableau.com/current/online/zh-cn/dm_catalog_overview.htm) 帮助中的“关于 Tableau Catalog”、[Tableau Server](https://help.tableau.com/current/server/zh-cn/dm_vconn_overview.htm) 或 [Tableau Cloud](https://help.tableau.com/current/online/zh-cn/dm_vconn_overview.htm) 帮助中的“关于虚拟连接和数据策略”，以及 Tableau Prep Builder 帮助中[连接到已发布数据源](https://help.tableau.com/current/prep/zh-cn/prep_connect.htm#published_datasource)。

## 通过 Tableau Desktop 连接

1. 启动 Tableau Desktop，并在“连接”窗格上的“搜索数据”下选择“Tableau Server”。
2. 若要连接到 Tableau Server，请输入服务器的名称，然后选择“连接”。
    
    若要连接到 Tableau Cloud，请在“快速连接”下选择“Tableau Cloud”。
    
    ![Tableau Server 登录对话框](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/examples_tableau_server_sign_in.png)
    
    **提示：**如果您未注销，Tableau Desktop 将保存您的服务器连接，因此可以跳过步骤 3。如果在 Tableau Server 上启用了 Kerberos，并且您的计算机具有有效的凭据，您也可以跳过该步骤。有关详细信息，请参见[使 Tableau Desktop 自动保持连接到 Tableau Cloud 或 Tableau Server](https://help.tableau.com/v0.0/pro/desktop/zh-cn/sign_in_server.htm#Automati)。
3. 若要登录：
    - 对于 Tableau Server，输入您的用户名和密码。
    - 对于 Tableau Cloud，输入您的电子邮件地址和密码。
4. 选择要连接的数据。“搜索数据”对话框显示常见混合内容的可滚动列表。如果有 Data Management 许可证，您可以使用虚拟连接来连接到数据，如果有启用了 Tableau Catalog 的 Data Management，您还可以连接到外部资产，比如数据库、文件和表。
    
    响应式搜索字段显示建议列表，该列表会在您输入文本时更新。按数据类型、认证状态或其他取决于所选数据类型的筛选器来筛选结果。例如，某些类型的数据可能允许您根据标记、连接类型、数据质量警告或其他条件进行筛选。旧版本的对话框和功能略有不同，但整体功能相似。
    
    ![“搜索数据”页面](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/search_for_data_desktop.png)
    
    注意：
    
    - 您没有“连接”权限的数据不可用（灰色）。
    - 外部资产（数据库、文件和表）在 Catalog 完成摄取它们之前不可用（灰色）。
    - 如果选择多维数据集（多维）数据源，则“创建本地副本”对话框将出现，您必须创建数据的本地副本，然后才能开始分析。
    - 在 Web 制作中，您可以与 Tableau Desktop支 持的数据连接器的子集建立连接。如果数据源、数据库、文件或表呈灰色显示，则无法从 Tableau Server 或 Tableau Cloud 中连接。不过，如果有正确的权限，您可以通过 Tableau Desktop 的“连接”窗格进行连接。
5. 选择要连接的数据后，单击“连接”。
6. 选择工作表标签以开始分析。

发布到 Tableau Server 或 Tableau Cloud 的数据源在“数据”窗格中以 Tableau 图标显示。

![Tableau 图标的示例](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/examples_tableau_server_icon.png)

举例来说，您可能想要下载数据源的本地副本以便能够脱机工作，或在不修改原稿的情况下对数据源进行更改。若下载本地副本，请在“数据”菜单中选择数据源，然后选择“创建本地副本”。数据源的一个副本将添加至“数据”窗格。

## 登录到 Mac

如果在 Mac 上使用 Tableau Desktop，则在输入服务器名称进行连接时，请使用完全限定的域名（例如 mydb.test.ourdomain.lan）而不是相对域名（例如 mydb 或 mydb.test）。

或者，可以将域添加到 Mac 计算机的“搜索域”的列表中，以便在您连接时，只需要提供服务器名称。若要更新“搜索域”的列表，请转到“系统首选项”\>“网络”\>“高级”，然后打开“DNS”选项卡。

## 在进行 Web 制作时连接到发布的数据源

创建和自定义数据连接供 Tableau 使用的 Tableau Desktop 用户可以将自己的数据源发布到 Tableau Server 或 Tableau Cloud。通过发布可以在同事之间共享数据；包括在那些不使用 Tableau Desktop 但有权在 Web 编辑环境中编辑工作簿的同事之间共享。

如果您有权在浏览器中编辑工作簿，请按照以下步骤在登录到 Tableau Server 或 Tableau Cloud 时连接到发布的数据源。有关详细信息，请参见[在 Web 上编辑 Tableau 视图](https://help.tableau.com/current/pro/desktop/zh-cn/web_author_build_view.htm)和[在 Web 上使用 Tableau](https://help.tableau.com/current/pro/desktop/zh-cn/web_author_home.htm)。

**注意：**若要连接到数据，您需要创建和编辑视图的权限。

### 向现有视图添加更多数据

1. 在 Tableau Server 或 Tableau Cloud 站点上，选择一个要编辑的视图。
2. 在编辑模式下，单击“新建数据源”图标 ![新数据源图标。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/datasource_using1.png)。
3. 在“连接到数据”页面中，您可以看到和选择的选项取决于您的权限：
    - 此站点上。从列表中选择一个已发布数据源，然后选择“添加数据源”。
        
        如果在环境中启用了 Tableau Catalog，您可以从“内容类型”下拉列表中选择“数据源”、“数据库和文件”或“表和对象”。然后选择要连接到的数据，并单击“连接”。
    - 文件。拖放文件或从计算机上载一个文件。
    - 连接器。使用列出的连接器之一连接到数据。

### 创建包含已发布数据源的工作簿

您也可以在创建新工作簿时连接到发布的数据源：

1. 在 Tableau Server 或 Tableau Cloud 站点上，导航到“浏览”页面，并从下拉列表中选择“所有数据源”。
2. 在列表中，选中要使用的数据旁边的复选框。
3. 在页面顶部，从“操作”下拉菜单中选择“新建工作簿”。

有关在 Web 上制作时连接到数据的详细信息，请参见 [Creator：连接到 Web 上的数据](https://help.tableau.com/current/pro/desktop/zh-cn/creator_connect.htm)。