---
schema_version: "1"
id: aba462724cddc473f6fffe779fb907c8705e29c1138e7f963bbeddb088b586d9
title: 创建仪表板
collection: tableau
version: next
locale: zh-cn
portal_url: https://docs.salesforce.com/tableau/next/zh-cn/pro/desktop/dashboards_create.md
canonical_url: https://help.tableau.com/v0.0/pro/desktop/zh-cn/dashboards_create.htm
source_site: help.tableau.com
content_type: documentation
content_hash: a287fef80219b58554f6c09d810d6537011d0693d801dd71479df8db76774607
description: Create a dashboard by combining sheets, adding objects, and setting interactivity.
---
[跳转到主要内容](#main-content)

# 创建仪表板

创建了一个或多个工作表后，您可以在仪表板中合并它们、添加交互性等等。有关此过程的分步演示，请观看[在 Tableau Desktop 中构建仪表板](https://www.tableau.com/zh-cn/node/106947?playlist=509089)培训视频（4 分钟）。

**提示：**若要快速启动并运行，请参见[使用加速器快速可视化数据](https://help.tableau.com/v0.0/pro/desktop/zh-cn/accelerators.htm)。

有关相关资源和视频，请参见[在 Tableau Desktop 中构建仪表板](https://www.tableau.com/zh-cn/node/106947?playlist=509089)。

## 创建仪表板并添加或替换工作表

仪表板的创建方式与新工作表的创建方式大致相同。

1. 在工作簿的底部，单击“新建仪表板” 图标：
    
    ![“新建仪表板”图标。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/web_author_new_dashboard_icon.png)
2. 从左侧的“工作表”列表中，将视图拖到右侧的仪表板。
    
    ![突出显示“Forecast”（预测）工作表的可视化项，箭头表示可以将其拖入视图。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/dashboard_create.png)
3. 若要替换工作表，请在右侧的仪表板中选择该工作表。在左侧的“工作表”列表中，将鼠标光标悬停在替换工作表上，并单击“交换工作表”按钮。
    
    ![在 Tableau 仪表板中交换工作表的选项。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/dashboard_swap_sheets.png)
    
    **注意：**在替换工作表时，Tableau 会保留任何填充、边框或背景颜色。但是，如果内容明显不同，您可能需要调整工作表大小。您可能还需要删除特定于以前的工作表的仪表板项（例如筛选器），这些项将变为空白。

## 添加交互功能  

您可以向仪表板中添加交互功能来增强用户的数据洞察力。尝试以下方法：

- 在工作表的上角，启用“用作筛选器”选项以使用工作表中的标记作为仪表板中其他工作表的筛选器。
    
    ![Tableau Cloud 中的美国东北部地图，其中各州以蓝色和橙色进行颜色编码，带有使用筛选器的选项。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/action_dashboards4_web.png)
- 在 Tableau Desktop 中制作时，添加动作以使用多个工作表作为筛选器，从一个工作表导航到另一个工作表，显示网页，等等。有关详细信息，请参见[动作和仪表板](https://help.tableau.com/v0.0/pro/desktop/zh-cn/actions_dashboards.htm)。

## 添加仪表板对象并设置其选项  

除了工作表外，您还可以添加用于增加视觉吸引力和交互性的仪表板对象。下面是有关每种类型的指引：

- 水平和垂直对象提供[布局容器](https://help.tableau.com/v0.0/pro/desktop/zh-cn/dashboards_refine.htm#Use_a_layout_container)，这些容器使您能将相关对象分组在一起，并微调用户与对象交互时仪表板调整大小的方式。
- 文本对象可提供标题、解释和其他信息。
    
    **注意：**仅在 Web 上才支持在文本框中支持实时超链接的 RTF 格式。
- 图像对象添加到仪表板的视觉风味，您可以将它们链接到特定目标 URL。（虽然网页对象也可以用于图像，但它们对于完整的网页效果更好。图像对象提供特定于图像的拟合、链接和替代文本选项。）
- 网页对象在仪表板的上下文中显示目标页面。确保查看[这些 Web 安全性选项](#Be_security-savvy)，并且要注意，某些网页不允许嵌入自身 — Google 就是这样。
    
    **注意**：出于安全原因，Tableau 管理员可能会阻止网页对象和图像对象显示目标 URL。
- 空白对象可帮助您调整仪表板项之间的间距。
- 导航对象可让您的受众从一个仪表板导航到另一个仪表板，或者导航到其他工作表或故事。可以显示文本或图像，以向用户指示按钮的目标，指定自定义边框和背景颜色，并提供信息工具提示。
- 下载对象可让您的受众快速创建整个仪表板或选定工作表的交叉表的 PDF 文件、PowerPoint 幻灯片或 PNG 图像。格式设置选项与导航对象类似。
    
    **注意：**只有在发布到 Tableau Cloud 或 Tableau Server 后，才能下载交叉表。
- [扩展程序](https://help.tableau.com/v0.0/pro/desktop/zh-cn/dashboard_extensions.htm)对象使您能向仪表板中添加独特的功能，或将它们与 Tableau 外部的应用程序集成。
- [Pulse 指标](https://help.tableau.com/current/online/zh-cn/pulse_create_metrics.htm#dashboard-object)对象让您可以将现有的指标卡嵌入到仪表板中。您可以添加的指标与工作簿使用的相同已发布数据源相连接。

### 添加对象

从左侧的“对象”部分，将项目拖到右侧的仪表板：

![显示如何将网页添加到仪表板的箭头。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/dashboard_object_drag1.png)

### 复制对象

您可以在当前仪表板内或从其他工作表和文件中的仪表板复制和粘贴对象。您甚至可以在 Tableau Desktop 和 Web 浏览器中的 Tableau 之间复制对象。

但是，您不能复制以下内容：

- 仪表板中的工作表
- 依赖于特定工作表的项，例如筛选器、参数和图例
- 其中包含您无法复制的内容（如工作表或筛选器）的布局容器
- 设备布局上的对象
- 仪表板标题

**提示：**除了下面描述的菜单命令外，您还可以使用标准键盘快捷键在操作系统上进行复制和粘贴。

1. 选择一个仪表板对象，然后从对象菜单中选择“复制仪表板项”。或者从主菜单中，选择“仪表板”\>“复制所选仪表板项”。
    
    ![展开的仪表板对象上下文菜单，其中已选中“复制仪表板项”选项。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/dashboard_copy_object.png)
2. 转到要在其中粘贴对象的仪表板。然后在仪表板的左上角选择要粘贴的任何内容，或选择要粘贴到旁边的现有项。
3. 在 Tableau Desktop 中，选择“文件”\>“粘贴”。在浏览器中，选择“编辑”\>“粘贴”或使用键盘快捷键进行粘贴。
4. 该对象粘贴在仪表板或所选对象左上角下方和右侧 10 个像素处。若要移动粘贴的对象，请拖动顶部的手柄。
    
    ![复制或移动仪表板中突出显示的栏。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/dashboard_copy_move.png)

**注意：**复制的“显示/隐藏”按钮可能针对原始对象或被禁用。有关如何修复此问题的说明，请参见[通过单击按钮显示和隐藏对象](#Show)。

### 设置对象选项

单击对象将其选中。然后单击上方的箭头打开快捷菜单。（菜单选项因对象而异。）

![仪表板上的可视化项上下文菜单。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/ds-editobject.gif)

### 图像对象的详细选项

使用图像工具，您可以将图像文件插入仪表板，也可以链接到发布在 Web 上的图像。在任何一种情况下，您都可以指定单击图像时打开的 URL，从而增加了与仪表板的交互性。

**注意：**基于 Web 的图像的 URL 需要 HTTPS 前缀以提高安全性。对于带有其他前缀的图像 URL，请使用网页对象。  
出于安全原因，Tableau 会阻止加载包含脚本的 SVG 文件。如果图像对象包含脚本，请从 SVG 文件中移除该脚本，或将图像保存为其他格式，例如 .png 或 .jpeg。

1. 从左侧的“对象”部分，将图像对象拖到右侧的仪表板。或者，在仪表板中的现有图像对象上，单击右上角的弹出菜单，然后选择“编辑图像”。
2. 单击“插入图像文件”以将图像文件嵌入到工作簿中，或单击“链接到图像”以链接到基于 Web 的图像。
    
    在以下情况下，请考虑链接到基于 Web 的图像：
    
    - 图像非常大，您的仪表板受众将在浏览器中查看它。（与基于 Web 的图像不同，插入的图像在每次打开工作表时都必须下载，从而会降低性能。）
    - 图像是 GIF 动画文件。（插入的图像不支持动画 GIF。）

![“编辑图像对象”对话框。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/dashboard_web_image.png)

4. 如果要插入图像，请单击“选择”以选择文件。如果要链接到图像，请输入其 Web URL。
5. 设置其余的图像拟合、URL 链接和替代文本选项。（替换文本在屏幕阅读应用程序中对图像进行描述，以改善辅助功能。）

### 导航和下载对象的详细选项

导航和下载对象有几个独特的选项，可帮助您直观地指明导航目标或文件格式。

![仪表板文本按钮的示例，它与美国地图重叠，并带有以下文本：打开航班延误可视化项。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/dashboard_button_text.png)

为按钮样式使用文本的导航按钮

1. 在对象的上角，单击对象菜单，并选择“编辑按钮”。
    
    ![按钮菜单展开并且选择了“编辑按钮”选项。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/dashboard_button_edit.png)
2. 执行以下操作之一：
    - 从“导航到”菜单中，选择当前仪表板外部的一个工作表。
    - 从 “导出到”菜单中，选择文件格式。
3. 为“按钮样式”选择图像或文本，指定要显示的图像或文本，然后设置相关格式设置选项。
4. 对于“工具提示文本”，添加在查看者将鼠标光标悬停在按钮上时出现的说明性文本。此文本是可选的，通常最好与图像按钮一起使用。（例如，您可以输入“打开销售额可视化项”来阐明显示为一个微型销售额图表的导航按钮的目标。）

**注意：**在查看发布的仪表板时，只需单击按钮便可进行导航或导出操作。但是，在制作仪表板时，则需要按住 Alt 并单击 (Windows) 或按住 Option 并单击 (macOS)。

### 通过单击按钮显示和隐藏对象

“显示/隐藏”按钮使仪表板查看者能够切换仪表板对象的可见性，从而仅在必要时显示这些对象。

#### 隐藏对象如何影响布局

隐藏浮动对象后，它只会显示其下方的任何对象。如果您要临时隐藏一组浮动筛选器以显示更多可视化项，则“显示/隐藏”按钮特别有用。

![隐藏浮动仪表板容器以显示更多可视化内容。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/dashboard_showhide.png)

隐藏平铺对象时，结果取决于布局分层结构中对象的级别。

- 在大多数情况下，您希望将计划隐藏的对象放置在“水平”或“垂直”布局容器中，因为隐藏的对象的空间将由容器中的其他对象填充。
- 相比之下，在布局分层结构最顶部的“平铺”布局容器中，隐藏的对象在后面留有空白空间。

#### 添加并配置“显示/隐藏”按钮

1. 选择一个仪表板对象。
2. 从对象上角的弹出菜单中，选择“添加显示/隐藏按钮”。
    
    ![仪表板容器上下文菜单，带有“添加显示/隐藏按钮”选项。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/dashboard_showhide_add.png)
3. 从按钮菜单中，选择“编辑按钮”。
    
    ![带有“编辑按钮”选项的上下文菜单。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/dashboard_showhide_edit.png)
4. 设置以下选项：

- “要显示/隐藏的仪表板项”指定目标对象。（一个对象一次只能是一个“显示/隐藏”按钮的目标。如果要将对象作为另一个“显示/隐藏”按钮的目标，请选择“无”。）
- “按钮样式”指定是否为按钮显示图像或文本。
- “按钮外观”指定项处于显示和隐藏状态时的按钮外观。单击“显示的项”和“隐藏的项”为每种状态选择不同的图像或文本。
- “工具提示文本”提供当查看者将鼠标光标悬停在按钮时出现的说明性文本。（例如，可以为带有筛选器菜单的容器输入“显示或隐藏筛选器”。）

6. 如有必要，将按钮拖到其他位置或调整其大小以更好地适应布局。

**注意：**在查看发布的仪表板时，只需单击“显示/隐藏”按钮便可切换对象可见性。但是，在制作仪表板时，则需要按住 Alt 并单击 (Windows) 或按住 Option 并单击 (macOS)。

### 关闭网页对象的安全性

如果在仪表板中包含网页对象，可以通过执行以下操作来优化安全性。

#### 尽可能使用 HTTPS 协议

作为一种最佳做法，请在 URL 中使用 HTTPS (https://)。这将确保对您的仪表板到网页的连接进行加密。另外，如果 Tableau Server 运行的是 HTTPS，并且您在 URL 中使用 HTTP，则用户的浏览器将无法显示 URL 指向的网页。如果未指定协议，则使用 HTTP。

#### 网页对象的安全性选项（仅限 Tableau Desktop）

选择“帮助”\>“设置和性能”\>“设置仪表板 Web 视图安全性”，并设置下面的选项。（在某些组织中，这些选项由 Tableau 管理员在所有计算机上控制。）

注意：您对于这些安全性选项所做的任何更改都适用于现有和新建的网页对象。

- **启用 JavaScrip**：在 Web 视图中启用 JavaScript 支持。清除此选项可能会导致某些需要 JavaScript 的网页在仪表板中工作不正常。
- **启用插件**：启用网页使用的任何插件，例如 Adobe Flash 或 QuickTime 播放器。
- **阻止弹出窗口**：如果选择此选项，则会阻止弹出窗口。
- **启用 URL 悬停动作**：允许 URL 悬停动作。有关详细信息，请参见[URL 动作](https://help.tableau.com/v0.0/pro/desktop/zh-cn/actions_url.htm)。
- “**启用网页对象和 Web 图像**”允许在网页对象和图像对象中显示目标 URL。如果取消选择此选项，则链接到 Web 的网页对象和图像对象将保留在仪表板中，但不显示任何内容。