---
schema_version: "1"
id: 62ea3030a288d33de013d6df13ba06b1d987b396d8716f4fd9b61d44f0fd02f4
title: 功能区和卡参考
collection: tableau
version: next
locale: zh-cn
portal_url: https://docs.salesforce.com/tableau/next/zh-cn/pro/desktop/buildmanual_shelves.md
canonical_url: https://help.tableau.com/v0.0/pro/desktop/zh-cn/buildmanual_shelves.htm
source_site: help.tableau.com
content_type: documentation
content_hash: 13d40f1a2cab414134f889a7ce89f43f0fe9f0674ea41a869c0e4f5cb76cbf70
description: Reference of Tableau worksheet shelves and cards-Columns, Rows, Marks, Filters, Pages-and their roles.
---
[跳转到主要内容](#main-content)

# 功能区和卡参考

Tableau 中的每个工作表都包含功能区和卡，例如“列”、“行”、“标记”、“筛选器”、“页面”、“图例”等等。

通过将字段放在功能区或卡上，您可以执行以下操作：

- 构建可视化项的结构。
- 通过包括或排除数据来提高详细级别以及控制视图中的标记数。
- 通过使用颜色、大小、形状、文本和详细信息对标记进行编码来为可视化项添加上下文。

尝试将字段放置在不同功能区和卡上，以找到查看数据的最佳方式。

## 用于启动视图的选项

如果不确定要将字段放在何处，您可以让 Tableau 帮助您确定显示数据的最佳方式。

- 可以将字段从“数据”窗格拖放到属于每个 Tableau 工作表的卡和功能区上。
- 可以在“数据”窗格中双击一个或多个字段。
- 您可以在“数据”窗格中选择一个或多个字段，然后从“智能显示”中选择一种图表类型，后者可确定适合于您所选的字段的图表类型。有关详细信息，请参见[使用“智能显示”启动视图](https://help.tableau.com/v0.0/pro/desktop/zh-cn/buildauto_showme.htm)。
- 您可以将字段放在“在此处放置字段”网格上，开始以表格方式创建视图。
    
    ![一个包含三个位置的表，标记为“在此处放置字段”。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/dropFieldHere.png)

## “列”和“行”功能区

从“数据”窗格拖动字段以创建可视化项结构。

“列”功能区用于创建表列，而“行”功能区用于创建表行。可以将任意数量的字段放置在这些功能区上。

将维度置于“行”或“列”功能区上时，将为该维度的成员创建标题。将度量置于“行”或“列”功能区上时，将创建该度量的定量轴。向视图添加更多字段时，表中会包含更多标题和轴，您对数据的了解也会更加详细。

在下面显示的视图中，“Segment”（细分市场）维度的成员将显示为列标题，而“Profit”（利润）度量将显示为垂直轴。

![描绘视图中的定量轴和列标题的图形。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/wwd_shelf_cr1.png)

Tableau 使用标记显示数据，其中每个标记对应于数据源中的一行（或一组行）。“行”和“列”功能区上的内层字段决定默认标记类型。例如，如果内层字段为度量和维度，则默认标记类型为条形图。可以使用“标记”卡下拉菜单手动选择其他标记类型。有关详细信息，请参见[更改视图中标记的类型](https://help.tableau.com/v0.0/pro/desktop/zh-cn/viewparts_marks_marktypes.htm)。

向“行”和“列”功能区添加更多字段时，表中也会添加更多的行、列和区。

![描绘视图中的定量轴和列标题的图形。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/wwd_shelf_cr2.png)

## 隐藏行和列

通常，您会添加维度和度量来创建表行和表列，并将包含所有数据或通过添加筛选器显示数据子集。但是，在筛选数据时，这些数据也从常规计算以及对表的汇总数据执行的其他计算中排除。您可以不筛选数据，而是隐藏行或列，使其不显示在视图中，但仍包含在计算中。

> [!TIP]
> 
> **提示**：在使用对前后日期值进行比较的表计算时，隐藏列特别有用。在这种情况下，将会有行或列由于没有要比较的数据而不显示数据。隐藏空列，使表计算保持不变。有关表计算的详细信息，请参见[表计算类型](https://help.tableau.com/v0.0/pro/desktop/zh-cn/calculations_tablecalculations_definebasic_runningtotal.htm)。

例如，在计算年同比增长时，第一年没有可以比较的前一年，因此该列保留为空白。筛选第一年会将其从视图中移除，但它也会从计算中移除（第二年随后没有了可以比较的前一年，并保留为空白）。隐藏空白列（而不是筛选）会使计算保持不变。

**隐藏行或列：**

右键单击（在 Mac 上按住 Control 单击）要隐藏的行或列，然后选择**“隐藏”**。

![从标题中隐藏可视化项上的列。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/hide_columns1.gif)

**显示隐藏的数据：**

对包含隐藏列或行的字段打开其字段菜单，然后选择**“显示隐藏数据”**。

![从“列”功能区中隐藏可视化项上的列。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/hide_columns2.gif)

## “标记”卡

“标记”卡是 Tableau 视觉分析的关键元素。将字段拖到“标记”卡中的不同属性时，您可以将上下文和详细信息添加至视图中的标记。

使用“标记”卡设置标记类型（请参见[更改视图中标记的类型](https://help.tableau.com/v0.0/pro/desktop/zh-cn/viewparts_marks_marktypes.htm)），并使用颜色、大小、形状、文本和详细信息对数据进行编码。若要更改标记设置，请参见[控制视图中标记的外观](https://help.tableau.com/v0.0/pro/desktop/zh-cn/viewparts_marks_markproperties.htm)。

![“标记”卡，带有“细分”、“区域”和“总数（数量）”功能区。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/build_manual_shelves_marks1.png)

在此示例中，三个不同的字段被拖放到“标记”卡中的不同属性。“Segment”（细分市场）位于“颜色”上，“Region”（区域）位于“形状”上，“Quantity”（数量）位于“大小”上。

将字段添加到“标记”卡后，可以单击该字段旁的图标以更改它所使用的属性。您还可以单击“标记”卡中的属性按钮来更改这些设置。

![“标记”卡，带有“细分”、“区域”和“总数（数量）”功能区。对于“总和（数量）”度量，上下文菜单显示“颜色”、“标签”、“形状”、“详细信息”和“工具提示”选项。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/build_manual_shelves_marks2.png)

很多属性都可以有多个字段。例如，您可以向“标签”、“详细信息”、“工具提示”和“颜色”添加多个字段。“大小”和“形状”一次只能有一个字段。有关详细信息，请参见[控制视图中标记的外观](https://help.tableau.com/v0.0/pro/desktop/zh-cn/viewparts_marks_markproperties.htm)。

**注意：** 默认情况下，将一个新字段拖到“颜色”会替换现有字段。若要将新字段添加到颜色而不替换现有字段，请在将新字段拖到“标记”卡的“颜色”上时按住键盘上的 SHIFT 键。

## “筛选器”功能区

使用“筛选器”功能区可以指定要包含和排除的数据。例如，您可能希望对每个客户分区的利润进行分析，但希望只限于特定的装运容器和交货时间。通过将字段放在“筛选器”功能区上，即可创建这样的视图。

**注意：** 本节简要介绍筛选功能。有关筛选的详细信息，请参见[筛选视图中的数据](https://help.tableau.com/v0.0/pro/desktop/zh-cn/filtering.htm)。

可以使用度量、维度或同时使用这两者来筛选数据。此外，还可以根据构成表列和表行的字段来筛选数据。这称为内部筛选。也可以使用不属于表的标题或轴的字段来筛选数据。这称为外部筛选。所有经过筛选的字段都显示在“筛选器”功能区上。

为阐释筛选的基本概念，请考虑以下视图。

![细分市场维度放在了“列”功能区上，利润度量放在了“行”功能区上。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/wwd_shelf_cr1.png)

假设您对“Home Office”（家庭办公室）数据不感兴趣。您可以通过筛选“Segment”（细分市场）维度从视图中移除此列。为此，请在字段菜单上选择“筛选器”或将“Segment”（细分市场）维度拖到“筛选器”功能区。此时会打开“筛选器”对话框。默认情况下，所有成员都处于选中状态。清除“Home Office”（家庭办公室）的复选框以将其从视图中排除。所有选定成员都将包含在视图中。

![描绘筛选器对话框的图形。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/filter_shelf2.png)

如下所示，视图将会更新，并移除“Home Office”（家庭办公室）列。该筛选器由“筛选器”功能区上的“Segment”（细分市场）字段来指示。

![描绘了应用于“市场细分”字段的筛选器的图形。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/filter_shelf3.png)

假设您只想查看某一类产品的利润。即使“行”和“列”功能区或“标记”卡上没有使用“Category”（类别）字段，您仍可以添加筛选器。将“Category”（类别）维度拖到“筛选器”功能区。这是外部筛选器的示例，因为“Category”（类别）未包含在视图中。

此时会自动打开“筛选器”对话框。默认情况下不选中任何成员。选择要保留在视图中的成员。所有清除的成员都被排除。在本例中，选择了“Office Supplies”（办公耗材）。

下面显示了经过修改的数据视图。标记标签显示“Consumer”（消费者）细分市场的利润总额已降至 $56,330。此数字是通过对数据源中与“Corporate”（企业）市场关联并属于“Office Supplies”（办公耗材）类别的所有行求和而得到的。

![描绘对“市场细分”和“货柜”字段使用筛选器的条形图的图形。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/filter_shelf5.png)

由于筛选器是独立的，因此在“筛选器”功能区上放置字段的顺序不会影响数据视图。换言之，先按客户细分然后按容器进行筛选的结果与先按容器然后按客户细分筛选的结果相同。有关操作筛选顺序的详细信息，请参见[筛选视图中的数据](https://help.tableau.com/v0.0/pro/desktop/zh-cn/filtering.htm)。

## “页面”功能区

使用“页面”功能区可以将视图划分为一系列页面，使您可以更好地分析特定字段对视图中其他数据的影响。将某个维度放置到“页面”功能区上时，将为该维度的每个成员添加一个新行。将某个度量放置到“页面”功能区上时，Tableau 会自动将该度量转换为离散度量。

“页面”功能区会创建一组页面，每个页面上都有不同的视图。每个视图都基于您放置在“页面”功能区上的字段。使用将字段移到“页面”功能区时添加到视图中的控件，您可以轻松地翻阅视图并在一个公共轴上比较它们。例如，下面的视图按“Region”（区域）显示整个月中每一天的“Profit”（利润）与“Sales”（销售额）。下图显示第 1、2、3 和 4 天的数据。您必须滚动才能查看这个月中的其他各天。

![直观展示不同地区的利润和销售额之间的相关性的散点图。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/pages_shelf1.png)

为了使该视图更方便查看，可将“DAY(Order Date)”移到“页面”功能区，并使用关联的控件翻阅页面（一天一个页面）。可以快速发现隐藏的细节。在此示例中，就西部地区的销售额和利润而言，19 号是一个大喜之日，这十分有趣。

![将“DAY(Order Date)”移至“页面”功能区并使用相关控件翻阅页面。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/pages6.gif)

向“页面”功能区中添加字段时，会自动向视图的右侧添加页面控件。

使用此控件可在页面之间导航。有三种方法可在视图中的页面之间导航：

- 跳转到特定页面
- 手动翻阅页面
- 自动翻阅页面

### 跳转到特定页面

从下拉列表中选择要查看的成员或值以显示特定页面。

![跳转到特定页面。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/pages_shelf7.gif)

### 手动翻阅页面

通过执行以下任意操作，可以手动翻阅页面序列：

- 使用下拉列表任意一侧的向前和向后按钮，一次浏览一个页面。
- 使用“页面滑块”快速在页面序列中向前和向后滚动。
- 使用以下任意键盘快捷键在页面序列中向前和向后滚动。
    
    <table style="mc-table-style: url('Resources/TableStyles/Basic-Border.css');margin-left: 0;margin-right: auto;" class="TableStyle-Basic-Border" cellspacing="0"><colgroup><col class="TableStyle-Basic-Border-Column-Column1"><col class="TableStyle-Basic-Border-Column-Column1"></colgroup><tbody><tr class="TableStyle-Basic-Border-Body-Body1"><td class="TableStyle-Basic-Border-BodyE-Column1-Body1">F4</td><td class="TableStyle-Basic-Border-BodyD-Column1-Body1">开始和停止向前播放</td></tr><tr class="TableStyle-Basic-Border-Body-Body1"><td class="TableStyle-Basic-Border-BodyE-Column1-Body1">SHIFT + F4</td><td class="TableStyle-Basic-Border-BodyD-Column1-Body1">开始和停止向后播放</td></tr><tr class="TableStyle-Basic-Border-Body-Body1"><td class="TableStyle-Basic-Border-BodyE-Column1-Body1">Ctrl + .</td><td class="TableStyle-Basic-Border-BodyD-Column1-Body1">向前跳一页</td></tr><tr class="TableStyle-Basic-Border-Body-Body1"><td class="TableStyle-Basic-Border-BodyB-Column1-Body1">Ctrl + ,</td><td class="TableStyle-Basic-Border-BodyA-Column1-Body1">向后跳一页</td></tr></tbody></table>
    
    在 Mac 上，这些是等效的键盘快捷方式。
    
    <table style="mc-table-style: url('Resources/TableStyles/Basic-Border.css');margin-left: 0;margin-right: auto;" class="TableStyle-Basic-Border" cellspacing="0"><colgroup><col class="TableStyle-Basic-Border-Column-Column1"><col class="TableStyle-Basic-Border-Column-Column1"></colgroup><tbody><tr class="TableStyle-Basic-Border-Body-Body1"><td class="TableStyle-Basic-Border-BodyE-Column1-Body1">F4</td><td class="TableStyle-Basic-Border-BodyD-Column1-Body1">开始和停止向前播放</td></tr><tr class="TableStyle-Basic-Border-Body-Body1"><td class="TableStyle-Basic-Border-BodyE-Column1-Body1">Shift-F4</td><td class="TableStyle-Basic-Border-BodyD-Column1-Body1">开始和停止向后播放</td></tr><tr class="TableStyle-Basic-Border-Body-Body1"><td class="TableStyle-Basic-Border-BodyE-Column1-Body1">Command-句号键</td><td class="TableStyle-Basic-Border-BodyD-Column1-Body1">向前跳一页</td></tr><tr class="TableStyle-Basic-Border-Body-Body1"><td class="TableStyle-Basic-Border-BodyB-Column1-Body1">Command-逗号键</td><td class="TableStyle-Basic-Border-BodyA-Column1-Body1">向后跳一页</td></tr></tbody></table>

### 自动翻阅页面

使用播放控件可以观看视图中页面的幻灯片放映。可以前进或后退，并且可以随时停止播放。可以使用控件右下角的速度控件来控制播放速度。最小的条指示播放速度最慢。

![带有按钮的滑块，用于导航和查看可视化项中的订单数据。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/pages_shelf8.png)

### 显示页面历史记录

使用“显示历史记录”复选框显示页面历史记录。对于页面历史记录，前面页面上的标记将显示在当前页面上。

_仅在 Tableau Desktop 中_：打开历史记录的下拉控件可以指定显示哪些标记以及何时显示这些标记。

![带有显示数据历史记录选项的表单，包括长度、类型和格式。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/pages7.png)

历史记录下拉控件包含以下选项：

- 标记以显示以下内容的历史记录 ― 选择是仅为选定的标记、突出显示的标记、已手动选择显示其历史记录的标记显示历史记录，还是为所有标记显示历史记录。若要手动显示标记的历史记录，方法是在视图中右键单击（在 Mac 上按住 Control 单击）标记，然后在“页面历史记录”菜单中选择一个选项。
- 长度 ― 选择要显示在历史记录中的页面数量。
- 显示 ― 指定是显示历史标记、穿过以前值的跟踪线（轨迹），还是两者都显示。
- 标记 ― 为历史标记设置格式，包括颜色、淡化程度；如果已将颜色设置为自动，则标记将使用“颜色”功能区上的默认标记颜色或颜色编码。
- 轨迹 ― 为穿过历史标记绘制的线设置格式。仅当在“显示”选项中选择“轨迹”时，此选项才可用。

如果页面上的每个颜色有多个标记，则不会显示页面轨迹。确保视图的详细级别小于或等于“页面”功能区和“颜色”目标上的详细级别。此外，仅对于离散标记类型（例如正方形、圆形或形状）才支持轨迹。在标记类型为“自动”时，不支持轨迹。

### 仪表板上的页面（仅限 Tableau Desktop）

当仪表板包含使用“页面”功能区上的同一字段的多个视图时，可以通过选择“同步”选项，利用一个页面控件控制所有这些视图。此选项只适用于仪表板上显示的页面控件。

![通过选择“同步”选项，使用单个页面控件来控制所有视图。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/pages9.gif)

## 附加功能区、图例、卡和控件

某些功能区、图例、卡或控件仅在您使用视图时执行操作后才会显示。例如，仅在“颜色”上有字段时，才会显示“颜色”图例。

![图例显示了装运模式和相应的颜色。](/tableau/next/zh-cn/pro/desktop/zh-cn/Img/color1.png)

Tableau 提供了用于移动或以其他方式自定义视图的这些元素的控件。

以下列表描述了上述每种功能区、图例、卡或控件。

- 度量值功能区 -“度量值”是一个特殊字段，它总是出现在“数据”窗格中，并且包含收集到一个字段中的数据的所有度量。当多个度量共享相同轴时，Tableau 会将“度量值”自动添加到视图中。当“度量值”在视图中时，Tableau 会显示“度量值”功能区，此功能区显示正在被纳入的度量。您可以在此卡中添加或删除度量。有关详细信息，请参见[度量值与度量名称](https://help.tableau.com/v0.0/pro/desktop/zh-cn/datafields_understanddatawindow_meavalues.htm)。
- 颜色图例 – 在“颜色”上有字段时显示分配颜色的方法。有关详细信息，请参见[为标记分配颜色](https://help.tableau.com/v0.0/pro/desktop/zh-cn/viewparts_marks_markproperties.htm#ColorProp)。
- 形状图例 – 在“形状”上有字段时显示分配形状的方法。有关详细信息，请参见[更改标记的形状](https://help.tableau.com/v0.0/pro/desktop/zh-cn/viewparts_marks_markproperties.htm#ShapeProp)。
- 大小图例 – 在“大小”上有字段时显示分配大小的方法。有关详细信息，请参见[更改标记的大小](https://help.tableau.com/v0.0/pro/desktop/zh-cn/viewparts_marks_markproperties.htm#SizeProp)。
- 地图图例 – 在地图上显示符号和图案的图例。不是所有地图提供程序都可使用地图图例。
- 参数控件 - 单独的参数控件可用于工作簿中的每个参数。有关详细信息，请参见[创建参数](https://help.tableau.com/v0.0/pro/desktop/zh-cn/parameters_create.htm)。
- 标题 – 默认情况下会显示每个视图的标题。默认标题是工作表名称。双击（在 Mac 上按住 Control 键单击）标题以编辑标题。有关详细信息，请参见[设置视图的各个部分的格式](https://help.tableau.com/v0.0/pro/desktop/zh-cn/formatting_specific_titlecaption.htm)。
- 说明 - 从“工作表”菜单中选择“显示说明”以显示视图的说明。
- 摘要卡 - 从“工作表”菜单中选择“显示摘要”以显示视图的摘要卡。有关详细信息，请参见[摘要卡](https://help.tableau.com/v0.0/pro/desktop/zh-cn/inspectdata_summary.htm)。
- 页面控件 – 当“页面”功能区上有字段时，提供用于在页面中导航的选项。有关详细信息，请参见[“页面”功能区](#Pages)。