O Internet Explorer 11 no Windows e o modo de compatibilidade para o Internet Explorer não são aceitos.
A partir da versão 2020.4, o Tableau Prep oferece suporte à criação na Web para fluxos. Agora você pode criar fluxos para limpar e preparar seus dados usando Tableau Prep Builder, Tableau Server, ou Tableau Cloud. Você também pode executar fluxos manualmente na Web e o Data Management não é necessário.
Embora a maior parte da mesma funcionalidade do Tableau Prep Builder também seja compatível com a Web, existem algumas diferenças ao criar e trabalhar com os fluxos.
Importante: para criar e editar fluxos na Web, você deve ter uma licença de Creator. O Data Management só será necessário se você quiser executar os fluxos de acordo com a agenda, usando o Tableau Prep Conductor ou via API. Para obter informações sobre como configurar e usar o Tableau Prep Conductor, consulte o Tableau Prep Conductor na ajuda do Tableau Server e Tableau Cloud.
Instalação e implantação
Para permitir que os usuários criem e editem fluxos na Web, você precisará fazer várias configurações no servidor. Para obter mais informações sobre cada uma dessas configurações, consulte Criar e interagir com fluxos na Web.
- Criação na Web: ativada por padrão, esta opção controla se os usuários podem criar e editar fluxos em Tableau Server ou Tableau Cloud
- Executar agora: controla se os usuários ou apenas os administradores podem executar fluxos manualmente, usando a opção Executar agora. O Data Management não é necessário para executar fluxos manualmente na Web.
- Tableau Prep Conductor: se Data Management tiver licença, ative essa opção para permitir que os usuários agendem e rastreiem os fluxos.
- Tableau Prep Extensions (versão 2021.2.0 e posterior): controla se os usuários podem se conectar ao Einstein Discovery para aplicar e executar modelos preditivos em relação aos dados em seu fluxo.
- Salvamento automático: ativado por padrão, esse recurso salva automaticamente o fluxo de trabalho de um usuário em um intervalo de poucos segundos.
Dados de amostra e limites de processamento
Para manter o desempenho enquanto trabalha com fluxos na Web, os limites são aplicados ao volume de dados que você pode incluir em um fluxo.
Aplicam-se os seguintes limites:
- O tamanho máximo do arquivo é de 1GB ao se conectar aos arquivos.
- A opção de amostragem de dados para incluir todos os dados não está disponível. O limite padrão de dados da amostra é de 1 milhão de linhas. O administrador do Tableau Server pode definir o limite de amostra de dados usando TSM. Para obter mais informações, consulte Opções do tsm configuration set. No Tableau Cloud, esse limite é fixo e não pode ser definido pelo administrador.
Para obter mais informações sobre como definir a amostra de dados, consulte Definir o tamanho da amostra de dados na ajuda do Tableau Prep.
Precisa de ajuda para depurar um fluxo lento? Tente ativar Habilitar log de consulta no menu Ajuda>Configurações e desempenho. Para obter mais informações, consulte Habilitar log de consulta.
Recursos disponíveis na Web
Quando você cria e edita fluxos na Web, pode perceber algumas diferenças na navegação e na disponibilidade de determinados recursos. Embora a maioria dos recursos esteja disponível em todas as plataformas, alguns recursos são limitados ou ainda não são compatíveis com o Tableau Server ou o Tableau Cloud. A tabela a seguir identifica os recursos em que as diferenças podem ser aplicadas.
| Área de recursos | Exceções | Tableau Prep Builder | Tableau Server | Tableau Cloud |
|---|---|---|---|---|
| Conectar a dados | Alguns conectores podem não ser compatíveis com a Web. Abra o painel Conectar no servidor para ver os conectores compatíveis. | ![]() | ![]() | ![]() |
| Criar fluxos do Tableau Prep com o Tableau Agent | A partir da versão 2025.2, com suporte no Tableau Cloud (requer Tableau+) e no Tableau Prep Builder quando conectado ao Tableau Cloud com o Tableau Agent ativado. A partir da versão 2025.3, com suporte no Tableau Server e Tableau Prep Builder quando conectado ao Tableau Server com o Tableau Agent ativado. Para obter mais informações, consulte Ativar IA no seu site do Tableau Cloud e Ativar IA no seu site do Tableau Server. | ![]() | ![]() | ![]() |
| Criar e organizar o fluxo | ![]() | ![]() | ![]() | |
| Definir o tamanho da amostra de dados | No Tableau Server, o tamanho dos dados de amostra está sujeito aos limites definidos pelo administrador usando um comando do TSM. No Tableau Cloud, esse limite é fixado em 1.048.576 linhas e não pode ser alterado pelo administrador. | ![]() | ![]() | ![]() |
| Unir linhas de arquivos e tabelas de banco de dada na etapa de entrada | As uniões de linhas de entrada não podem ser editadas ou criadas no Tableau Server ou no Tableau Cloud. Somente no Tableau Prep Builder. | ![]() | ![]() | ![]() |
| Limpar e formatar dados | ![]() | ![]() | ![]() | |
| Copiar valores da grade de dados | Disponível no Tableau Prep Builder e no Tableau Server a partir da versão 2022.3 e no Tableau Cloud a partir de 2022.2 (agosto) | ![]() | ![]() | ![]() |
| Agregar, unir colunas ou linhas de dados | ![]() | ![]() | ![]() | |
| Usar scripts R e Python no fluxo | As etapas de script não podem ser adicionadas ao criar ou editar um fluxo no Tableau Cloud. No momento, esse recurso é compatível somente com o Tableau Prep Builder e com o Tableau Server. | ![]() | ![]() | ![]() |
| Criar etapas de fluxos reutilizáveis | ![]() | ![]() | ![]() | |
| Salvar os fluxos automaticamente na Web | Não aplicável | ![]() | ![]() | |
| Recuperação automática de arquivos | ![]() | Não aplicável | Não aplicável | |
| Habilitar o log de consultas | ![]() | ![]() | ![]() | |
| Exibir saída de fluxo no Tableau Desktop | ![]() | ![]() | ![]() | |
| Criar uma extração para um arquivo | ![]() | ![]() | ![]() | |
| Criar uma extração para uma planilha do Microsoft Excel | ![]() | ![]() | ![]() | |
| Conectar a uma consulta de SQL personalizado | ![]() | ![]() | ![]() | |
| Criar uma fonte de dados publicada | ![]() | ![]() | ![]() | |
| Salvar saída de fluxo em bancos de dados externos | ![]() | ![]() | ![]() | |
| Adicionar previsões do Einstein Discovery ao seu fluxo | ![]() | ![]() | ![]() |
Salvamento automático e como trabalhar com rascunhos
Quando você cria ou edita fluxos no servidor, o trabalho é salvo automaticamente como rascunho em um intervalo de poucos segundos para que você não perca o trabalho, em caso de acidente ou se uma guia for fechada por acidente.
Os rascunhos são salvos no servidor e no projeto em que você está conectado. Você não pode salvar ou publicar um rascunho em outro servidor, mas pode salvar o fluxo em outro projeto desse servidor, usando a opção do menu Arquivo > Publicar como.

Só você pode ver o conteúdo do rascunho até a publicação. Se você publicar alterações e precisar revertê-las, pode usar a caixa de diálogo Histórico de revisões para exibir e reverter para uma versão publicada anteriormente. Para obter mais informações sobre como salvar fluxos na Web, consulte Salvar os fluxos automaticamente na Web.
Fluxos de publicação na Web
Se você criar um fluxo do zero na Web ou editar um fluxo existente, antes de executar o fluxo, é necessário publicá-lo.
- Você só pode publicar fluxos de rascunho no mesmo servidor em que está conectado.
- Você pode publicar um rascunho em um projeto diferente usando o menu Arquivo e selecionando Publicar como.
- Você pode inserir credenciais para as conexões de banco de dados do fluxo, a fim de permitir que o fluxo seja executado sem inserir manualmente as credenciais quando o fluxo for executado. Se você abrir o fluxo para editá-lo, precisará inserir novamente suas credenciais.
Inserir credenciais
As credenciais inseridas só se aplicam à execução de fluxos no servidor. A partir do Tableau Cloud versão 2025.2, os proprietários de fluxo podem editar seu fluxo na criação na Web sem precisar autenticar novamente em todas as conexões de banco de dados, se essas conexões forem inseridas no fluxo ou salvas no perfil do usuário. Se estiver usando o Tableau Server, é necessário inserir as credenciais manualmente ao editar um fluxo conectado a um banco de dados. As credenciais inseridas só podem ser definidas no nível de fluxo e não no nível do servidor ou do site.
Execute um destes procedimentos:
No menu superior, selecione Arquivo > Credenciais de conexão > Inserir no fluxo publicado.

Ao publicar um fluxo, selecione a caixa de seleção Inserir credenciais. Essa opção é mostrada quando você seleciona Publicar como para publicar o fluxo em um novo projeto pela primeira vez ou quando você está editando um fluxo que foi publicado pela última vez por outra pessoa.

Publicar um fluxo
Quando você publica o fluxo, ele se torna a versão atual do fluxo e pode ser executado e visto por outros usuários com acesso ao projeto. Só você pode ver os fluxos que nunca foram publicados ou as alterações de fluxo que você faz em um rascunho, até que você publique o fluxo. Para obter mais informações sobre os status de fluxos na Web, consulte Salvar os fluxos automaticamente na Web.
Para publicar o fluxo, siga um destes procedimentos:
No menu superior, selecione Arquivo > Publicar ou Arquivar > Publicar como

Na barra superior, clique no botão Publicar ou clique na seta suspensa para selecionar Publicar como.

Quem pode fazer isso
- Administrador do servidor, Creator (administrador de site) e Creator (Criador) têm acesso total de conexão e publicação.
- O Creator pode realizar as tarefas de criação na Web.

