---
schema_version: "1"
id: 314b48209ebc4f05277094a4cef31cc8a36ffadefd13089972b456bc3ca11156
title: インストール後のインストール設定の変更
collection: tableau
version: next
locale: ja-jp
portal_url: https://docs.salesforce.com/tableau/next/ja-jp/desktopdeploy/desktop_deploy_setting_changes.md
canonical_url: https://help.tableau.com/v0.0/desktopdeploy/ja-jp/desktop_deploy_setting_changes.htm
source_site: help.tableau.com
content_type: documentation
content_hash: 4ac59ecdfcb66ec5e8bb3d2d2bae666079e38ee3b8f6e7f328cd02d7ba039da3
description: Change Tableau Desktop installation settings after install, like language and repository location.
---
[メイン コンテンツに進む](#main-content)

# インストール後のインストール設定の変更

Tableau Desktop および Tableau Prep Builder をインストールする際、いくつかの機能が既定でオンになります。例えば、Tableau Desktop では、自動製品アップデートや、ユーザー ワークブックを自動的に保存する機能がインストールの一部として含まれています。しかし、クラッシュ ダンプ ファイルおよびログをアップロードする機能など、ユーザーにアクセスしてほしくない一部の機能があるかもしれません。管理者として、これらの機能の一部をオフにすることができます。

Windows の場合、インストール中に、\[詳しく学ぶ\] ペインに表示するカスタム コンテンツを設定したり、既定のアクセラレーター ワークブックをカスタム ワークブックに置き換えたり、一部の機能をオフにしたりすることもできます。これらの機能の一覧については、「コマンド ラインから Tableau Desktop と Tableau Prep Builder をインストールする」の[コマンド ラインからのインストール](https://help.tableau.com/v0.0/desktopdeploy/ja-jp/desktop_deploy_automate.htm#installer_properties)を参照してください。

Mac の場合、インストール後にのみ、\[詳しく学ぶ\] ペインのカスタム コンテンツを設定したり、既定のアクセラレーター ワークブックをカスタム ワークブックに置き換えたり、一部の機能をオフにしたりすることができます。インストール後に、\[詳しく学ぶ\] ペインのカスタム コンテンツを設定したり、サンプル ワークブックをカスタムのサンプルで置き換えたり、設定を変更したりするには (Windows と Mac の両方)、レジストリまたは `.plist` ファイルを変更してから、アプリケーションを再起動して変更を確認します。

リモート コンピューターに変更を適用するには、レジストリ (Windows) または .plist (Mac) ファイルから設定をエクスポートし、オフにする設定を変更します。次に、変更したファイルを使用して自動スクリプトを作成し、Tableau Desktop がインストールされている各コンピューターに更新をプッシュします。

> [!IMPORTANT]
> 
> **重要**: レジストリ ファイルに変更を加える前に、必ずバックアップ ファイルを作成してください。Windows レジストリを誤って編集すると、コンピューターに問題が発生する可能性があります。

## 表示言語の設定 (オプション)

Tableau Desktop または Tableau Prep Builder を初めて実行する際、ユーザーのロケールを使用してユーザーのコンピューターのロケールを認識し、サポートされている場合は対象の言語を使用します。サポートされていない言語を使用している場合、アプリケーションは既定で英語に設定されます。

Tableau Prep Builder では、数値や日付は、アプリケーションをインストールしたマシンのオペレーティング システムで設定されたロケールに基づく形式で表示されます。Tableau Desktop では、ワークブックの日付と番号の書式を設定できます。詳細については Tableau ユーザーヘルプの[「言語とロケール」](https://help.tableau.com/current/pro/desktop/ja-jp/workbook_language.htm)を参照してください。

Tableau Desktop または Tableau Prep Builder を設定して、ユーザー インターフェイス (メニュー、メッセージなど) を別の言語で表示するには、次の手順を実行し、アプリケーションを再起動して変更を適用します。

1. 上部のメニューにある \[ヘルプ\] を選択します。
2. \[言語の選択\] を選択します。
3. リストから言語を選択します。

## マイ Tableau リポジトリの場所の変更 (オプション)

インストールの際、Tableau Desktop および Tableau Prep Builder は、マイ Tableau <application> リポジトリのフォルダー構造をご利用のコンピューターの Documents フォルダーに自動的に作成します。データをローカル マシンではなくネットワーク サーバーに置く必要があるなどの理由でこのリポジトリを別の場所に移動する必要がある場合は、新しい場所を指定し、Tableau Desktop または Tableau Prep Builder で新しいフォルダーをポイントできます。

リポジトリの新しい場所を設定すると、以下のルールが適用されます。

- 新しいフォルダーはディレクトリにする必要がある。
- 新しいフォルダーへの書き込みパーミッションが必要である。
- 新しいフォルダーは、既存のマイ Tableau リポジトリのフォルダー構成の中に置くことはできません。

**注**：リポジトリの場所を変更しても、元のリポジトリ内に格納されているファイルは移動しません。その代わりに、Tableau でファイルを格納できる新しいリポジトリが作成されます。

1. Tableau Desktop または Tableau Prep Builder を開きます。
2. 上のメニューで、 ファイル \>リポジトリの場所を選択します。
3. \[\[リポジトリ フォルダーを選択する\] ダイアログで、新しいリポジトリの場所として機能する新しいフォルダーを選択します。
4. アプリケーションを再起動し、新しいリポジトリを使用します。

## カスタム コンテンツを表示するように \[詳しく学ぶ\] ペインを設定する (Tableau Desktop のみ)

既定では、Tableau はトレーニング、ブログ投稿、パブリック Viz へのリンクなどの情報を Tableau Desktop の \[詳しく学ぶ\] ペインで提供しており、ユーザーは Tableau を使い始める際に役立てることができます。\[詳しく学ぶ\] ペインは起動時に表示されてスタート ページに保持されるので、ユーザーはこれらのリンクや情報をいつでもすぐに利用できます。

![Tableau の検出パネル。](/tableau/next/ja-jp/desktopdeploy/ja-jp/Img/custom_discover_pane1.png)

ただし、\[詳しく学ぶ\] ペインでは、組織に固有のコンテンツを表示することもできます。そのためには、https 対応 URL を使用して提供する、Web サーバーでホストされる独自のコンテンツ用の Web ページを作成します。その後、DiscoverPane キーと DiscoverPaneURL 値を使用して、Tableau が提供するデフォルトのコンテンツをカスタム Web ページのコンテンツに置き換えます。

**注**: 最良の結果を得るには、javascript やリダイレクトを含む Web ページを使用しないでください。

![Tableau の検出パネル。](/tableau/next/ja-jp/desktopdeploy/ja-jp/Img/custom_discover_pane2.png)

すぐに開始できるように、Tableau が提供する \[詳しく学ぶ\] ペインと同じレイアウトをひな形にした[テンプレート](https://github.com/tableau/discover-pane-template)が Tableau Desktop によって提供されています。テンプレートをダウンロードしてリンクをカスタム コンテンツに置き換えるだけで済みます。テンプレートには、指標、レイアウト構造、コンテンツへのリンクのセクションが含まれています。

### Windows

コマンド ラインを使用してインストールする場合に、インストール時にカスタム Web ページをポイントするように \[詳しく学ぶ\] ペインを構成するには、 `DISCOVERPANEURL="<https://YourWebPage.com>"` プロパティをコマンド ラインに追加します。インストール完了後にカスタム コンテンツを使用するように \[詳しく学ぶ\] ペインを構成する場合は、次の手順に従います。変更を確認するにはアプリケーションを再起動します。

1. Tableau がインストールされているコンピューターの管理者として、変更を加える前にレジストリ ファイルのバックアップを作成してください。
2. レジストリ エディターを開きます (`regedit.exe`)。
3. 次のレジストリ パスに移動します。
    
    `Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau <version>`。例: `Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau 2020.1`
4. 使用している Tableau のバージョンを右クリックし、\[新規\] > \[キー\] を選択して、DiscoverPane という名前を付けます。
5. 新しい DiscoverPane キーの右側のペインで、右クリックしてから \[新規\] > \[文字列値\] を選択し、DiscoverPaneURL という名前を付けます。
6. 新しい DiscoverPaneURL 文字列値を右クリックし、\[Modify (変更)\] を選択します。次に、\[Edit String (文字列の編集)\] ダイアログの \[Value data (値データ)\] フィールドに、カスタム Web ページの URL を入力します。コンテンツは、https 対応 URL を使用してホストされている必要があります。http 対応 URL の使用はサポートされていません。
    
     例: `https://help.tableau.com/current/desktopdeploy/en-us/desktop_deploy_user.htm`。
    
    ![Tableau を含むさまざまなソフトウェアのディレクトリと設定を表示するレジストリ エディター。](/tableau/next/ja-jp/desktopdeploy/ja-jp/Img/custom_discover_pane_Regedit.png)
7. \[詳しく学ぶ\] ペインを既定の Tableau Desktop コンテンツに戻すには、DiscoverPaneURL 値を変更し、入力したカスタム Web ページの URL を消去して、\[値データ\] フィールドを空白のままにします。Tableau Desktop を再起動すると、\[詳しく学ぶ\] ペインに Tableau のデフォルトのコンテンツが表示されます。

### Mac

DiscoverPane キーと DiscoverPaneURL 値を追加して、/Users/<local user>/Library/Preferences/com.tableau.Tableau-<version>.plist を変更します。変更を確認するにはアプリケーションを再起動します。

1. ターミナル コマンド プロンプトから次のコマンドを実行して、カスタム URL に値を設定します。大文字小文字を以下のとおりに入力します。
    
    `defaults write com.tableau.Tableau-<version> DiscoverPane.DiscoverPaneURL <https://YourWebPageURL>`
    
    たとえば、Tableau Desktop 2020.1 では、次のコマンドを使用します。
    
    `defaults write com.tableau.Tableau-<version> DiscoverPane.DiscoverPaneURL https://help.tableau.com/current/desktopdeploy/en-us/desktop_deploy_user.htm`
2. \[詳しく学ぶ\] ペインを Tableau Desktop の既定のコンテンツに戻すには、次のコマンドを実行します。
    
    `defaults write com.tableau.Tableau-<version> DiscoverPane.DiscoverPaneURL " "`
    
    Tableau Desktop を再起動すると、\[詳しく学ぶ\] ペインに Tableau のデフォルトのコンテンツが表示されます。

## アクセラレーター ワークブックをカスタム ワークブックに置き換える (Tableau Desktop のみ)

Tableau では既定で、ユーザーが Tableau を探索する際に役立つ 3 つのパッケージ アクセラレーターが提供されています。(バージョン 2022.2 より前は、これらのアクセラレーターはサンプル ワークブックと呼ばれていました。)バージョン 2021.3 以降、特定のユーザーを対象としたパッケージ化されたワークブックを最大 5 つ作成し、スタート ページの \[アクセラレーター\] セクションにある Tableau 提供のアクセラレーターをカスタム ワークブックに置き換えることができます。

**注**: Tableau Server をインストールするときに、既定サイトにサンプル ワークブックを含めることを選択できます。インストールの際に \[サンプルを含める\] オプションをオンにすると、カスタムのサンプル ワークブックを Tableau Desktop からご利用のサーバー上の Tableau Samples プロジェクトにパブリッシュできます。

![接続ページで提供される Tableau アクセラレーター。](/tableau/next/ja-jp/desktopdeploy/ja-jp/Img/desktop_custom_samples.png)

カスタムのサンプル ワークブックは、次の要件を満たす必要があります。

- 一度に含めることができるサンプル ワークブックは、最大 5 つまでです。
- サポートしているファイルは、パッケージ化されたワークブック (.twbx) のみです。
- ワークブックを格納するローカル マシンのディレクトリには、Tableau とユーザーによる読み取りアクセス権がある必要があります。ネットワーク ディレクトリはサポートしていません。
- ワークブックのファイル名に、文字「'」、「"」、「<」、「>」、「&」 を含めることはできません。

**注:** 新しいリリース バージョン (2021.4 など) にアップグレードすると、カスタムのサンプルは保持されません。コマンド ラインでアップグレードをインストールするときにカスタムのサンプル ファイルへのパスを指定するか、アップグレードした後にレジストリ (Windows) または .plist (MacOS) を変更する必要があります。

### はじめる前に

**Windows と Mac**

サンプルが保存されているローカル マシンにディレクトリを作成し、パッケージ化されたサンプル ワークブック (.twbx) を最大 5 ファイルまで追加します。

必要に応じてワークブック ファイルを置き換えることができますが、スタートページに表示できるワークブックの数は最大 5 つまでです。カスタム ワークブックの置き換えについては、[カスタム ワークブックの管理](#manage_custom_samples)を参照してください。

### Windows

**コマンド ラインより**

コマンド ラインからインストールする際は、`CUSTOMSAMPLESDIR="path to directory"` プロパティを追加します。

例: `tableauDesktop-64bit-2021-3-0.exe /quiet /norestart ACCEPTEULA=1 CUSTOMSAMPLESDIR="C:\Users\mkim\Documents\My Tableau Repository\CustomSamples"`

Tableau Desktop を起動すると、\[スタート\] ページにカスタムのサンプルが表示されます。

**レジストリからのインストール後**

インストールの完了後にカスタムのサンプル用のディレクトリを設定するには、以下の手順に従います。変更を確認するにはアプリケーションを再起動します。

1. Tableau がインストールされているコンピューターの管理者として、変更を加える前にレジストリ ファイルのバックアップを作成してください。
2. レジストリ エディターを開きます (`regedit.exe`)。
3. 次のレジストリ パスに移動します。
    
    `Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau <version>`。例: `Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau 2021.3`
4. Samples という名前の新しいフォルダーを作成します。Tableau バージョン フォルダーを右クリックし、\[新規\] > \[キー\] を選択して、新しいフォルダーの名前を変更します。
    
    ![新しいキーを作成するためのオプションを表示する Tableau バージョン メニュー。](/tableau/next/ja-jp/desktopdeploy/ja-jp/Img/desktop_deploy_custom_samples1.png)
5. 作成した Samples フォルダーを右クリックし、 \[新規\] > \[文字列値\] を選択して、CustomSamplesDirという名前を付けます。
    
    ![「新規」、「検索...」、「削除」などのオプションを含むドロップダウン メニュー。](/tableau/next/ja-jp/desktopdeploy/ja-jp/Img/desktop_deploy_custom_samples2.png)
6. 新しい文字列値 CustomSamplesDir を右クリックし、\[修正\] を選択します。次に、 \[文字列の編集\] ダイアログの \[値データ\] フィールドに、前に設定したディレクトリへの完全な Windows ファイル パスを入力します。
    
    ![フォルダーとファイルの階層を表示するレジストリ エディター ウィンドウ。](/tableau/next/ja-jp/desktopdeploy/ja-jp/Img/desktop_deploy_custom_samples3.png)
7. Tableau Desktop を再起動して変更を確認します。このセクションのタイトルは、カスタム ワークブックになりました。
    
    ![カスタム ワークブックを含む Tableau 接続ページ。](/tableau/next/ja-jp/desktopdeploy/ja-jp/Img/desktop_deploy_custom_samples4.png)
8. 既定のコンテンツ Tableau Desktop に戻すには、CustomSamplesDir 値を修正して、入力したディレクトリ パスを消去し、\[値データ\] フィールドを空白のままにします。Tableau Desktop を再起動すると、スタート ページの \[アクセラレーター\] セクションに既定の Tableau コンテンツが表示されます。

### Mac

Samples.CustomSamplesDir キーとサンプルのディレクトリ パスの値を追加して、/Users/<ローカル ユーザー>/Library/Preferences/com.tableau.Tableau-<バージョン>.plist を修正します。変更を確認するにはアプリケーションを再起動します。

1. ターミナルのコマンド プロンプトから次のコマンドを実行して、カスタムのサンプル ディレクトリに値を設定します。大文字小文字を以下のとおりに入力します。
    
    `defaults write com.tableau.Tableau-<version> Samples.CustomSamplesDir <your directory path>`
    
    たとえば、Tableau Desktop 2021.3 では、次のコマンドを使用します。
    
    `defaults write com.tableau.Tableau-2021.3.0 Samples.CustomSamplesDir "/Users/mkim/Documents/My Tableau Repository/CustomSamples"`
2. 既定のコンテンツ Tableau Desktop に戻すには、次のコマンドを実行します。
    
    `defaults write com.tableau.Tableau-<version> Samples.CustomSamplesDir " "`
    
    Tableau Desktop を再起動すると、スタート ページの \[アクセラレーター\] セクションに既定の Tableau コンテンツが表示されます。

### カスタム ワークブックの管理

カスタムのサンプル ワークブックを Tableau Desktop に追加すると、アプリケーションを最初に開いたときに作成したカスタム サンプル フォルダーに、custom.manifest ファイルとワークシートのサムネイル画像が自動的に生成されます。

カスタムのサンプル ワークブックを新しいワークブックに置き換える場合は、custom.manifest ファイルを削除して、新しいファイルを生成できるようにする必要があります。ワークシートのサムネイル画像は削除しなくても構いません。

![ドキュメントや複数の折れ線グラフを含むファイルのリストを表示するウィンドウ。](/tableau/next/ja-jp/desktopdeploy/ja-jp/Img/desktop_deploy_custom_samples5.png)

1. ローカル ディレクトリのカスタム サンプル フォルダーに移動します。
2. custom.mainfest ファイルを削除します。
3. カスタム サンプル フォルダーから、ワークブックと、ワークブックのワークシート サムネイル画像 (オプション) を削除または移動します。
4. 新しいパッケージ (.twbx) ワークブックをカスタム サンプル フォルダーに追加します。
5. アプリケーションを再起動します。

## 製品の更新をオフにする

製品の更新機能がオンの場合、ユーザーが自動的に製品の更新を受け取ったり、メンテナンス更新が利用可能になったときにそれらをチェックしてインストールすることができます。Tableau Desktop のインストール後に製品の更新をオフにするには、Tableau がインストールされている各コンピューターのレジストリ (Windows) または `AutoUpdateAllowed` ファイル (Mac) で、`.plist` キーを更新する必要があります。

### Windows

1. Tableau がインストールされているコンピューターの管理者として、変更を加える前にレジストリ ファイルのバックアップを作成してください。
2. レジストリ エディターを開きます (`regedit.exe`)。
3. `AutoUpdateAllowed` レジストリ キーを `0` に設定します。次の表は、さまざまな製品のキーの場所をリストしています。

<table>
                    <tbody>
                        <tr>
                            <td style="font-weight: bold;">製品</td>
                            <td style="font-weight: bold;">場所 (64 ビットの Tableau および Windows)</td>
                        </tr>
                        <tr>
                            <td>
                                <p><span class="mc-variable Variables.TabsProductDesktop variable">Tableau Desktop</span>
                                </p>
                            </td>
                            <td><code>HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau <i>&lt;version&gt;</i>\AutoUpdate</code>
                            </td>
                        </tr>
                        <tr>
                            <td>
                                <p><span class="mc-variable Variables.TabsProductDesktop variable">Tableau Desktop</span> Public Edition</p>
                            </td>
                            <td><code>HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau Public <i>&lt;version&gt;</i>\AutoUpdate</code>
                            </td>
                        </tr>
                        <tr>
                            <td>
                                <p>Tableau Reader</p>
                            </td>
                            <td><code>HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau Reader <i>&lt;version&gt;</i>\AutoUpdate</code>
                            </td>
                        </tr>
                    </tbody>
                </table>

製品の更新をもう一度オンにするには、同じ手順を使用し、今回はレジストリ キーを `0` ではなく `1` に設定します。

### Mac

ターミナル コマンド プロンプトから次のいずれかのコマンドを実行します。

<table>
                    <thead>
                        <tr>
                            <th>製品</th>
                            <th>コマンド</th>
                        </tr>
                    </thead>
                    <tbody>
                        <tr>
                            <td><span class="mc-variable Variables.TabsProductDesktop variable">Tableau Desktop</span>
                            </td>
                            <td><code>defaults write com.tableau.Tableau-<em>&lt;version&gt;</em> AutoUpdate.AutoUpdateAllowed "0"</code>
                                <p>たとえば、<span class="mc-variable Variables.TabsProductDesktop variable">Tableau Desktop</span> 2019.1 では、次のコマンドを使用します。</p>
                                <p><code>defaults write com.tableau.Tableau-2019.1 AutoUpdate.AutoUpdateAllowed "0"</code>
                                </p>
                            </td>
                        </tr>
                        <tr>
                            <td><span class="mc-variable Variables.TabsProductDesktop variable">Tableau Desktop</span> Public Edition</td>
                            <td><code>defaults write com.tableau.Tableau-Public-<em>&lt;version&gt;</em> AutoUpdate.AutoUpdateAllowed "0"</code>
                            </td>
                        </tr>
                        <tr>
                            <td>Tableau Reader</td>
                            <td><code>defaults write com.tableau.Tableau-Reader-<em>&lt;version&gt;</em> AutoUpdate.AutoUpdateAllowed "0"</code>
                            </td>
                        </tr>
                    </tbody>
                </table>

製品の更新をもう一度有効化するには、同じコマンドを実行しますが、`0` の代わりに `1` を指定します。

## ファイルの復元をオフにする

ファイルの復元機能により、Tableau Desktop および Tableau Prep Builder (バージョン 2020.3.3 以降) でユーザーのワークブックやフロー ファイルが保存されるため、アプリケーションが予期せず終了した場合でも、作業内容が失われることがありません。ユーザーが再度 Tableau を開くと、選択可能な復元されたファイルのリストがダイアログ ボックスに表示されます。ユーザーは、復元されたファイルを開いて中断した場所から作業を続行するか、不要なファイルを削除することができます。ファイルを削除した場合、最後に保存したとき以降に行った変更が破棄されます。

Tableau Desktop のリスト内、または Tableau Prep Builder の\[復元されたフロー\] フォルダーからすべての復元されたファイルを削除すると、復元ファイルが新たに生成されるまで、復旧ダイアログ ボックスは表示されなくなります。

ファイルの復元は既定で有効になっています。これを無効にするには、`AUTOSAVE` プロパティ (Tableau Desktop) または maestro.appSettings.autosave (Tableau Prep Builder) の設定を変更します。ファイルの復元をオフにする手順を表示するには、製品のタブをクリックします。

ファイルの復元機能をオフにすると、ユーザーは \[自動保存の有効化\] メニュー オプションを使用できなくなります。インストール後にこの機能を再び有効にする場合は、Tableau がインストールされている各コンピューターのレジストリ (Mac の場合は .plist) で、`AUTOSAVE` プロパティの設定を更新する必要があります。インストール時にコマンド ラインからこの設定を制御する方法については、[コマンド ラインからのインストール](https://help.tableau.com/v0.0/desktopdeploy/ja-jp/desktop_deploy_automate.htm#installer_properties)を参照してください。

Tableau のインストール後にファイルの復元をオフにするには、Tableau がインストールされている各コンピューターのレジストリ (Windows) または `AutosaveAllowed` ファイル (Mac) で、`.plist` キーを更新する必要があります。

### Windows

1. Tableau Desktop がインストールされているコンピューターの管理者として、変更を加える前にレジストリ ファイルのバックアップを作成してください。
2. レジストリ エディターを開きます (`regedit.exe`)。
3. `AutosaveAllowed` レジストリ キーを `0` に設定します。
    
    レジストリ キーの場所: `HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau _<version>_\Autosave`

ファイルの復元をもう一度有効にするには、同じ手順に従って、今回は`AutosaveAllowed` レジストリ キーを `0` ではなく `1` に設定します。

### Mac

ターミナル コマンド プロンプトから次のコマンドを実行します。

`defaults write com.tableau.Tableau-_<version>_ Autosave.AutosaveAllowed "0"`

たとえば、Tableau Desktop 2020.3 では、次のコマンドを使用します。

`defaults write com.tableau.Tableau-2020.3 Autosave.AutosaveAllowed "0"`

ファイルの復元をもう一度有効にするには、同じコマンドを実行しますが、`"0"` の代わりに `Autosave.AutosaveAllowed "1"` を指定します。

インストール中に、コマンド ライン (Windows) からファイルの復元機能をオフにするか、カスタム インストール セクション (MacOS) の \[インストール タイプ\] で \[Enable crash recovery (クラッシュ復元の有効化)\] チェック ボックスをオフにします。インストール中にファイルの復元機能をオフにする方法については、[はじめる前に](https://help.tableau.com/v0.0/desktopdeploy/ja-jp/desktop_deploy_download_and_install.htm#Install)を参照してください。

Tableau Prep Builder のインストール後にファイル復元機能を有効または無効にするには、Tableau Prep Builder がインストールされている各コンピューターの `maestro.appSettings.autosave` 設定のプロパティを変更する必要があります。

### Windows

1. Tableau Prep Builder がインストールされているコンピューターの管理者として、アプリ フォルダーに移動します。例:
    
    `C:\Program Files\Tableau\Tableau Prep Builder 2020.3\resources\app`
2. アプリ フォルダーで、`application.properties` ファイルを開きます。
3. `maestro.appSettings.autosave=false` に設定します

ファイルの復元をもう一度有効にするには、同じ手順に従いますが、今回は `maestro.appSettings.autosave=true` に設定します。

### Mac

1. `/Library/Application Support/Tableau Prep Builder/` に移動します
2. テキスト エディターで `application.properties` ファイルを開きます。
3. `maestro.appSettings.autosave=true` を `maestro.appSettings.autosave=false` に変更します
4. 変更を保存してファイルを閉じます。

ファイルの復元をもう一度有効にするには、同じ手順に従いますが、今回は `maestro.appSettings.autosave=false` を `maestro.appSettings.autosave=true` に変更します。

## 利用状況レポートをオフにする

Tableau は、データを収集して製品がどのように使用されているかを把握することで、既存の機能の改善や新しい機能の開発に役立てています。すべての使用状況データは、[プライバシー ポリシー](https://www.salesforce.com/company/privacy/)に従って収集および処理されます。このオプションへの参加を希望しない場合、インストール時やインストール後にオプト アウトできます。

収集するデータのタイプについては、[「Tableau 製品の使用状況データ」](https://www.tableau.com/ja-jp/product-usage-data)を参照してください。

このオプションに参加しない場合、インストール時にオプト アウトのチェック ボックスをオンにするか、プロパティ `SENDTELEMETRY="0"` を含むコマンド ラインを追加することでコマンド ライン (Windows) からオフにしてオプト アウトできます。

このオプションのユーザー インターフェイスでの無効化に関する詳細は、[ユーザー インターフェイスからのインストール](https://help.tableau.com/v0.0/desktopdeploy/ja-jp/desktop_deploy_download_and_install.htm)を参照してください。このオプションのコマンド ラインからの無効化に関する詳細は、[コマンド ラインからのインストール](https://help.tableau.com/v0.0/desktopdeploy/ja-jp/desktop_deploy_automate.htm#Installer_options)を参照してください。

製品利用状況データの送信を無効にしても、特定の製品基礎データは Tableau に送信されます。製品基礎データを Tableau に送信したくない場合は、このオプションを無効にすることもできます。詳細については、[製品基礎データ](https://help.tableau.com/v0.0/desktopdeploy/ja-jp/usage_data_basic_product_data.htm)を参照してください。

インストール後にこのオプションをオプト アウトするには、以下のいずれかを実行します。

### 製品から

1. Tableau Desktop を開きます。
2. トップ メニューより、\[ヘルプ\] > \[設定とパフォーマンス\] を選択します。
3. \[製品使用状況データを送信しない\] をクリックします。
    
    ![製品使用状況データの共有をオプトアウトするオプションが表示された「設定とパフォーマンス」サブメニュー。](/tableau/next/ja-jp/desktopdeploy/ja-jp/Img/prep_usage_data_optout.png)

### レジストリから

システム レベルで利用状況レポートをオフにするには、お使いのオペレーティング システムの指示に従ってください。

**Windows**

コマンド プロンプトを開き、次のコマンドを実行します。

`REG ADD "HKLM\Software\Tableau\<Tableau Version>\Telemetry" /v TelemetryEnabled /t REG_DWORD /d 0`

または、以下の手順に従います。

1. Tableau Desktop がインストールされているコンピューターの管理者として、変更を加える前にレジストリ ファイルのバックアップを作成してください。
2. レジストリ エディターを開きます (`regedit.exe`)。
3. `TelemetryEnabled` レジストリ キーを `0` に設定します。
    
    レジストリ キーの場所: `HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau _<version>_\Telemetry`

利用状況レポートをもう一度有効化するには、同じ手順を使用しますが、レジストリ キーを `0` ではなく `1` に設定します。

Mac

ターミナル コマンド プロンプトから次のコマンドを実行します。

`defaults write com.tableau.Tableau-_<version>_ Telemetry.TelemetryEnabled "0"`

たとえば、Tableau Desktop 2019.4 では、次のコマンドを使用します。

`defaults write com.tableau.Tableau-2019.4 Telemetry.TelemetryEnabled "0"`

利用状況レポートをもう一度有効化するには、同じコマンドを実行しますが、`0` ではなく `1` を指定します。

インストール後にこのオプションをオプト アウトするには、以下のいずれかを実行します。

### 製品から

1. 管理者として Tableau Prep Builder を開きます。
    
    - **Windows**: アプリケーションを右クリックし、\[管理者として実行\] を選択します。
    - **MacOS**: ターミナル コマンド プロンプトから、`sudo /Applications/Tableau\ Prep\ Builder\ <version>.app/Contents/MacOS/Tableau\ Prep\ Builder` を実行します。
2. トップ メニューより、\[ヘルプ\] > \[設定とパフォーマンス\] を選択します。
3. \[製品使用状況データを送信しない\] をクリックします。
    
    **注**: バージョン 2019.3.2 以前では、\[使用状況データを共有して Tableau Prep Builder を改善する\] をクリックしてチェック マークを外します。
    
    ![製品使用状況データの共有をオプトアウトするオプションが表示された「設定とパフォーマンス」サブメニュー。](/tableau/next/ja-jp/desktopdeploy/ja-jp/Img/prep_usage_data_optout.png)

#### プロパティ ファイルから

**Windows**

1. Tableau Prep Builder がインストールされているディレクトリにあるアプリ フォルダーに移動します。例: `C:\Program Files\Tableau\Tableau Prep Builder <version>\resources\app`
2. テキスト エディターで telemetryConfig.properties ファイルを開きます。
3. `maestro.telemetry.enabled=true` を `maestro.telemetry.enabled=false` に変更します
4. 変更を保存してファイルを閉じます。

**Mac**

Mac の場合、この設定はユーザーに固有のものです。アプリケーションを再インストールしない限り、この設定はシステム上の他のユーザーに適用されません。

1. `~/Library/Application Support/Tableau Prep Builder/` に移動します
2. テキスト エディターで telemetryConfig.properties ファイルを開きます。
3. `maestro.telemetry.enabled=true` を `maestro.telemetry.enabled=false` に変更します
4. 変更を保存してファイルを閉じます。

## エラー レポートをオフにする

Tableau Desktop または Tableau Prep Builder に問題が起きて想定外のシャットダウンが発生した場合、クラッシュ ダンプ ファイルとログが生成され、My Tableau または My Tableau Prep Builder のリポジトリの \[ログ\] フォルダーに格納されます。このオプションは既定で有効になっています。

これらのファイルのデータはマシン特有の情報、クラッシュ時のメモリ内コンテンツのスナップショット (これにはアプリケーション活動詳細、データ接続情報、ユーザーに実行されたアクションまたは Tableau 上で作業されていたデータが含まれる可能性があります)、および顧客特定可能な情報が含まれます。

データ保護の規制下にある組織の場合、このオプションを無効にできます。このオプションを無効にするには、Tableau Desktop と Tableau Prep Builder で実行する手順が異なります。以下のタブをクリックして、お使いのアプリケーションに関する指示を表示してください。

Tableau Desktop では、ユーザーが次回アプリケーションを開いたときにダイアログ プロンプトが表示され、ユーザーは次のいずれかのアクションを実行できます。

- クラッシュ ファイルをアップロードする。
- クラッシュ ファイルのアップロードを拒否する。
- クラッシュ ファイルのアップロードを永続的にオプト アウトする。

ユーザーがファイルをアップロードすると、それらは 2048 ビット RSA キーで暗号化された zip パッケージにまとめられて、エンジニアがクラッシュの原因となった問題を分析、特定できるように Tableau に送られます。

暗号化されたパッケージには以下が含まれます。

- クラッシュ ダンプ ファイル (.dmp)
- クラッシュに関連するエラー ログ ファイル (.log)
- クラッシュに関連するマニフェスト ファイル (.maifest)

データ保護の規制下にある組織の場合、各デスクトップ パソコンでレジストリを編集 (Windows) するか、スクリプトを実行 (Mac) してこのプロンプトが表示されないようにすることで、ユーザーがクラッシュ ダンプファイルおよびログをアップロードできないようにすることが可能です。

### Windows

1. Tableau がインストールされているコンピューターの管理者として、変更を加える前にレジストリ ファイルのバックアップを作成してください。
2. レジストリ エディターを開きます (`regedit.exe`)。
3. `CrashReportUpload` レジストリ キーを `2` に設定します。
    
    レジストリ キーの場所: `HKEY_CURRENT_USER\Software\Tableau\_<version>_\Prompts`

### Mac

ターミナル コマンド プロンプトから次のコマンドを実行します。

`defaults write com.tableau-<TABLEAU VERSION>.plist Prompts.CrashReportUpload -string 2`

たとえば、Tableau Desktop 2019.1 では、次のコマンドを使用します。

`defaults write com.tableau.Tableau-2019.1.plist Prompts.CrashReportUpload -string 2`

Windows の Tableau Prep Builder では、\[カスタマイズ\] ダイアログで \[エラー レポートの有効化\] チェック ボックスをオフにするか、コマンド ラインでプロパティ `CRASHDUMP="0"` を含めることで、インストール中にエラー レポートのオプションをオフにできます。

インストール後にこのオプションをオフにするには、application.properties ファイルのアプリケーション プロパティ セクションに `maestro.enable_fault_reporting=false` の行を追加します。

このファイルは `C:\Program Files\Tableau\<Tableau Prep Builder version>\resources\app` にあります。

## ダッシュボードの Web Page オブジェクトをオフにする (Tableau Desktop のみ)

Web ページ オブジェクトはダッシュボードのセクションにターゲット URL を表示します。インストール中に [コマンド ラインからのインストール](https://help.tableau.com/v0.0/desktopdeploy/ja-jp/desktop_deploy_automate.htm#installer_properties) を参照して、これらのオブジェクトの URL の表示を無効にします。インストール後、以下の手順を実行します。

### Windows

1. Tableau がインストールされているコンピューターの管理者として、変更を加える前にレジストリ ファイルのバックアップを作成してください。
2. レジストリ エディターを開きます (`regedit.exe`)。
3. `WebViewToggleWebZonesEnabled` レジストリ キーを `0` に設定します。
    
    レジストリ キーの場所: `HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\_<version>_\Settings`

### Mac

ターミナル コマンド プロンプトから次のコマンドを実行します。

`defaults write /Library/Preferences/com.tableau.Tableau-<version>.plist Settings.WebViewToggleWebZonesEnabled -integer 0`

たとえば、Tableau Desktop 2020.4 では、次のコマンドを使用します。

`defaults write /Library/Preferences/com.tableau.Tableau-2020.4.plist Settings.WebViewToggleWebZonesEnabled -integer 0`

Web ページ オブジェクトをもう一度有効にするには同じコマンドを実行しますが、`-integer 0` の代わりに `-integer 1` を指定します。

## ダッシュボードと Viz 拡張機能を無効にする (Tableau Desktop のみ)

ダッシュボードと Viz 拡張機能を使用すると、Tableau とサードパーティの開発者が作成した Web アプリケーションを使用して、Tableau のダッシュボードとネイティブのビジュアル機能を拡張できます。

Tableau では拡張機能の 2 つの標準形式をサポートしています。1 つは Tableau Web サーバーで実行され、展開前に Tableau が審査を実施する Tableau の信頼できる拡張機能、もう 1 つはサードパーティーの Web サーバーで実行されるネットワーク対応拡張機能です。ネットワーク対応拡張機能は、拡張機能がローカル ネットワーク内で直接ホストされるインスタンスや、ローカル ネットワーク外部で Tableau 以外のサードパーティー サービスによってホストされるインスタンス (パートナーの開発者が提供する本番環境サービスなど) などのシナリオをサポートします。ダッシュボードと Viz の拡張機能の詳細については、「[ダッシュボードの拡張機能の使用](https://help.tableau.com/current/pro/desktop/ja-jp/help.htm#dashboard_extensions.htm)」および「[ワークシートへの Viz 拡張機能の追加](https://help.tableau.com/current/pro/desktop/ja-jp/viz_extensions.htm)」を参照してください。展開オプションの詳細については、「[拡張機能のセキュリティ - 展開に関するベスト プラクティス](https://help.tableau.com/current/server/ja-jp/security_extensions.htm)」を参照してください。

拡張機能は既定で有効になっており、Tableau Desktop で Tableau の信頼できる拡張機能とネットワーク対応拡張機能を使用できます。Tableau の信頼できる拡張機能は自動的に実行されますが、ネットワーク対応拡張機能は実行前にユーザーのパーミッションが必要です。

インストール中に拡張機能を無効にする場合は、次のプロパティを設定します。詳細については、[コマンド ラインからのインストール](https://help.tableau.com/v0.0/desktopdeploy/ja-jp/desktop_deploy_automate.htm#installer_properties)を参照してください。

- `DISABLEEXTENSIONS="1"`: すべての拡張機能タイプを無効にします。
- `DISABLENETWORKEXTENSIONS`\="1": ネットワーク対応拡張機能のみを無効にします。
- `DISABLESANDBOXEXTENSIONS`\="1": Tableau によってホストされるサンドボックス拡張機能のみを無効にします
- `DISABLETABTRUSTEDEXTENSIONS` ="1": Tableau によってホストされ、Tableau が作成した拡張機能のみを無効にします
- `DISABLE3PTRUSTEDEXTENSIONS` ="1": Tableau によってホストされ、Tableau が信頼するパートナーが作成した拡張機能のみを無効にします
    
    これらの構成により、Tableau Desktop のインストールで拡張機能または特定の種類の拡張機能の使用が無効になります。ユーザーにはダッシュボードと Viz の拡張機能を読み込むオプションが表示され、Tableau Exchange に引き続きアクセスできますが、Tableau Desktop は適用された設定に基づいて拡張機能の実行をブロックします。

### インストール後にすべての拡張機能を無効にする

インストール後にすべての拡張機能を無効にするには、次の手順に従って各 Desktop でレジストリを編集するか (Windows)、スクリプトを実行します (MacOS)。

#### Windows

1. Tableau がインストールされているコンピューターの管理者として、変更を加える前にレジストリ ファイルのバックアップを作成してください。
2. レジストリ エディターを開きます (`regedit.exe`)。
3. `DisableExtensions` レジストリ キーを 1 に設定します。
    
    レジストリ キーの場所: `HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau <version>\Settings\Extensions\DisableExtensions`

#### Mac

ターミナル コマンド プロンプトから次のコマンドを実行します。

`defaults write com.tableau.tableau-<TABLEAU VERSION>.plist Settings.Extensions.DisableExtensions "1"`

たとえば、Tableau Desktop 2019.4 では、次のコマンドを使用します。

`defaults write com.tableau.tableau-2019.4.plist Settings.Extensions.DisableExtensions "1"`

### インストール後に特定のタイプの拡張機能を無効にする

Tableau Desktop 2025.3 以降、Desktop 管理者はインストール後に特定の種類の拡張機能を有効または無効にすることができます。次の手順に従って各 Desktop でレジストリを編集するか (Windows)、スクリプトを実行します (MacOS)。

#### Windows

Tableau がインストールされているコンピューターの管理者として、変更を加える前にレジストリ ファイルのバックアップを作成してください。

レジストリ エディター (regedit.exe) を開きます。

次のレジストリ キーのいずれかを 1 に更新して、拡張機能のタイプごとに使用を無効にします。

- `DISABLENETWORKEXTENSIONS`\="1": ネットワーク対応拡張機能のみを無効にします。
- `DISABLESANDBOXEXTENSIONS`\="1": Tableau によってホストされるサンドボックス拡張機能のみを無効にします
- `DISABLETABTRUSTEDEXTENSIONS` \="1": Tableau によってホストされ、Tableau が作成した拡張機能のみを無効にします
- `DISABLE3PTRUSTEDEXTENSIONS` \="1": Tableau によってホストされ、Tableau が信頼するパートナーが作成した拡張機能のみを無効にします

レジストリ キーの場所: `HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau <version>\Settings\Extensions\`

#### Mac

ターミナル コマンド プロンプトから次のいずれかのコマンドを実行します。

- ネットワーク対応拡張機能のみを無効にするには、以下を実行します。
    
    `defaults write com.tableau.tableau-<TABLEAU VERSION>.plist Settings.Extensions.DisableNetworkExtensions` "1"
- Tableau によってホストされるサンドボックス拡張機能のみを無効にするには、以下を実行します。
    
    `defaults write com.tableau.tableau-<TABLEAU VERSION>.plist Settings.Extensions.DisableSandboxExtensions` "1"
- Tableau によってホストされ、Tableau が作成した拡張機能のみを無効にするには、以下を実行します。
    
    `defaults write com.tableau.tableau-<TABLEAU VERSION>.plist Settings.Extensions.DisableTabTrustedExtensions` "1"
- Tableau によってホストされ、Tableau が信頼するパートナーが作成した拡張機能のみを無効にするには、以下を実行します。
    
    `defaults write com.tableau.tableau-<TABLEAU VERSION>.plist Settings.Extensions.Disable3PTrustedExtensions` "1"

たとえば、Mac Tableau Desktop 2025.3 でネットワーク対応拡張機能のみの使用を無効にするには、次のコマンドを使用します。

`defaults write com.tableau.tableau-2025.3.plist Settings.Extensions.DisableNetworkExtensions` "1"

## ログ フォルダーの場所を変更する

Tableau Desktop で既定のログ フォルダーの場所を変更するには、ナレッジ記事[「Tableau Desktop でログ フォルダーの場所を変更する」](https://help.salesforce.com/s/articleView?id=005166930&type=1)を参照してください。