---
schema_version: "1"
id: 15424dfa6427de13bd5eda6a0f445b46ca68a3c6c627be88f2c9a4ad119fc0f5
title: Edit Tableau Views on the Web
collection: tableau
version: next
locale: en-gb
portal_url: https://docs.salesforce.com/tableau/next/en-gb/pro/desktop/web_author_build_view.md
canonical_url: https://help.tableau.com/v0.0/pro/desktop/en-gb/web_author_build_view.htm
source_site: help.tableau.com
content_type: documentation
content_hash: ab7f69af3fbdb372b0a08fb76cb143c631aa5130e993f010c062f5c8f2ad4ddf
description: Edit and create Tableau views on the web.
---
[Skip to main content](#main-content)

# Edit Tableau Views on the Web

If you can see the Edit button when you are looking at a view in Tableau Cloud or Tableau Server, that means you can make changes to it. Depending on your access level and permissions, you can:

- Edit an existing published workbook and add worksheets for views, dashboards, and stories.
- Create and edit a new workbook based on a published data source.
- Edit an existing workbook and add worksheets in the browser, or by opening the workbook in Tableau Desktop.
- Connect to different published data sources while editing. For details, see [Connect to Published Data Sources while Web Editing](https://help.tableau.com/current/pro/desktop/en-gb/examples_tableauserver.htm#Connect).

For more information about how to build different types of charts and views in Tableau, see [Build Charts and Analyse Data](https://help.tableau.com/v0.0/pro/desktop/en-gb/design_and_analyze.htm).

**Note:** Editing a view on a mobile device, either with a mobile web browser or the Tableau Mobile app, is not supported. You must use a desktop web browser.

## Edit a published view

1. Sign in to a site, then either open the workbook that contains the view you want to edit, or show All Views from the Explore page.
2. Open the view.
3. Click Edit in the view toolbar.
    
    ![The view toolbar.](/tableau/next/en-gb/pro/desktop/en-gb/Img/web_author_who1.png)
    
    When you click Edit, the view opens in web authoring mode.
    
    ![The view opened in web authoring mode after selecting Edit from the view toolbar.](/tableau/next/en-gb/pro/desktop/en-gb/Img/web_author_who1b.png)
    
    Now you can edit the view.
    
    **Note:** If you have Tableau Desktop version 2021.2 or later, you can also open the workbook in Tableau Desktop and edit there. Select the Edit in Desktop icon ![A desktop icon.](/tableau/next/en-gb/pro/desktop/en-gb/Img/open_desktop_icon.png) in the authoring toolbar to open, then publish the workbook to the site when you're finished.
    
    To learn how to build a chart or dashboard, see **Step 4** in [Creators: Get Started with Web Authoring](https://help.tableau.com/current/pro/desktop/en-gb/getstarted_web_authoring.htm) and [Explore and Analyse Data in a View](https://help.tableau.com/current/pro/desktop/en-gb/data_explore_analyze_interact.htm).
4. The Save options available to you will vary depending on your permissions set by your Tableau site administrator.
    
    - To close the view without saving your changes, select File > Close.
    - To save your work in the current workbook, select File > Publish.
    - To save your work as a new workbook, select File > Publish As. Creators can select a location to save the workbook, either in a project or to their private Personal Space. Explorers can only save to Personal Space. For more information about Personal Space, see [Create and Edit Private Content in Personal Space](https://help.tableau.com/v0.0/pro/desktop/en-gb/personal_space.htm).
    
    **Note:** If you edited a workbook in Tableau Desktop and want to publish your changes, select Server > Publish Workbook and select Publish. The workbook’s location and name will be populated in the Publish dialog.

## Create a new workbook on the web from a published data source

1. Sign in to a site on Tableau Cloud or Tableau Server.
2. Either open the project that contains the data source you want to use, or show All Data Sources.
3. Click the … next to the data source name to open the actions menu, then click New Workbook.
    
    ![New Workbook button](/tableau/next/en-gb/pro/desktop/en-gb/Img/web_author_workbook.png)
    
    A new, blank workbook opens in the Tableau Server web editing environment.