---
schema_version: "1"
id: 1fb45249a3c93766e1efc4f1f5bd0b69f3b65c979a1517dd7b0433a6f04b48a4
title: 建立參數
collection: tableau
version: current
locale: zh-tw
portal_url: https://docs.salesforce.com/tableau/current/zh-tw/pro/desktop/parameters_create.md
canonical_url: https://help.tableau.com/current/pro/desktop/zh-tw/parameters_create.htm
source_site: help.tableau.com
content_type: documentation
content_hash: a2bcc920cf7ea63e4d82448cc9d71a5e48e1ffaa497e450442d4b041476c6f46
description: Create, edit, and use parameters in calculations, filters, and reference lines.
---
[跳至主要內容](#main-content)

# 建立參數

參數是工作簿預留位置值（像是數字、日期或字串），可以取代計算、篩選器或參考線中的常數值。

例如，您可能會建立一個導出欄位，使其在銷售額大於 $500,000 時傳回 True，若未大於則傳回 False。可以在公式中使用參數來取代常量值 \[500000\] 。接著，您可以使用參數控制項來動態變更計算中的閾值。

要使用參數，必須：

1. 設定初始參數。
2. 在計算、篩選器或參考線等元素中使用參數。
3. 透過以下方式調整參數值：
    - 顯示參數控制項
    - 使用參數動作
    - 設定動態參數以自動更新

## 建立參數

要從「資料」窗格中建立參數：

1. 在「資料」窗格中，按一下右上角的下拉箭頭並選取「建立參數」。
    
    ![含用於分組、排序、隱藏和擴展資料選項的內容功能表。突出顯示「建立參數」選項、「按資料來源資料表分組」選項與「按名稱排序」選項。](/tableau/current/zh-tw/pro/desktop/zh-tw/Img/DPVcreate-parameter-contextmenu.png)
2. 在 \[建立參數\] 對話方塊的 \[名稱\] 欄位中，輸入名稱。
    
    ![含名稱、資料類型、目前值、允許值和顯示格式欄位的「建立參數」視窗。](/tableau/current/zh-tw/pro/desktop/zh-tw/Img/DPVname-parameter.png)
3. 指定參數接受的值的資料類型：
    
    ![用於自訂資料類型的屬性視窗，其中展開了資料類型下拉式功能表，並選取了整數選項。](/tableau/current/zh-tw/pro/desktop/zh-tw/Img/DPVspecify-datatype.png)
4. _可選：_指定目前值。這是參數的預設值。
5. _可選：_在工作簿開啟時指定值。
6. 指定要在參數控制項中使用的顯示格式（僅限 Tableau Desktop）。
    
    ![用於自訂數值資料顯示格式的屬性視窗。](/tableau/current/zh-tw/pro/desktop/zh-tw/Img/DPVdisplayformat.png)
7. 指定參數接受值的方式。可從以下選項中選取：
    
    - 全部：參數控制項是單純的文字欄位。
    - 清單：參數控制項提供可能值的清單供您選取。
        - 如果選取 \[清單\] ，則必須指定值清單。在左欄中按一下以輸入值清單，或者可以透過選取「新增值來源」來新增欄位成員或從剪貼簿貼上。
            
            ![含用於新增值選項的視窗。](/tableau/current/zh-tw/pro/desktop/zh-tw/Img/DPV-Addvaluesfrom-FIXED.png)
    - 範圍：參數控制項可讓您選取指定範圍內的值。
        - 如果選取「範圍」，則必須指定最小值、最大值和級距。級距可控制值之間的間距，例如可讓您選擇每個數字（5、6、7...）或從 5 到 10、到 15。
    
    這些選項的可用性由資料類型確定。例如，字串參數不支援範圍。
    
    要在工作簿開啟時重新整理參數的值（或網域）清單，請選取「清單」或「範圍」，然後選取「工作簿開啟時」。請注意，某些選項會顯示為灰色，因為工作簿正在從資料來源動態提取值。
8. 完成後，按一下「確定」。

參數現在會列於「資料」窗格底部的「參數」區段中。

![資料窗格的參數部分。](/tableau/current/zh-tw/pro/desktop/zh-tw/Img/DPV-parameter-in-datapane.png)

## 編輯參數

可透過 \[資料\] 窗格或參數控制項來編輯參數。編輯可用於變更允許範圍或資料類型等動作。要簡單地變更值或參數，請使用參數控制項。請參閱[在視覺效果中顯示參數控制項](#Show)。

要編輯參數：

1. 執行以下操作之一：
    - 在「資料」窗格中右鍵按一下參數，並選取「編輯」。
    - 在參數控制項功能表上選取「編輯參數」。
2. 在「編輯參數」對話方塊中進行變更。
3. 按一下「OK（確定）」。參數會隨著使用它的任何元素一起更新。

### 刪除參數

若要刪除參數，請在 \[資料\] 窗格中以右鍵按一下該參數並選取 \[刪除\] 。使用已刪除參數的任何計算欄位都將變得無效。

## 使用參數

參數在連結到視覺效果中的元素之前不會執行任何動作。可以在計算、篩選器和參考線中引用參數。參數在工作簿中為全域參數，可在任何工作表中使用。

元素引用參數後，請務必[在視覺效果中顯示參數控制項](#Show)（或設定參數動作或動態參數）。若無法變更參數的值，那麼一開始就設定參數沒有任何益處。

### 在計算中使用參數

您可透過參數來動態修改計算中的值。您可以使用參數而不是手動編輯計算（以及所有依賴計算）。然後，在要變更值時，請開啟參數控制項，變更該值，那麼使用該參數的所有計算都會更新。

要在計算中使用參數，請輸入參數的名稱，然後它會出現在建議的選項中，就像輸入欄位名稱一樣。還可以將參數從「資料」窗格拖放到計算編輯器中。

![含在計算中整合參數的 IF 陳述式的計算欄位方塊。](/tableau/current/zh-tw/pro/desktop/zh-tw/Img/parameter_in_calculation.png)

### 在篩選器中使用參數

您可以透過參數以動態方式修改「前 N 個」篩選器中的值。您可以使用參數而不是在篩選器中手動設定要顯示的值數。「篩選器」對話方塊頂部索引標籤上的下拉式清單中提供了參數清單。選取要在篩選器中使用的參數。

![篩選器功能表，其中包含按欄位或參數篩選的選項。](/tableau/current/zh-tw/pro/desktop/zh-tw/Img/parameters_filters1.png)

### 在輔助線中使用參數

您可透過參數來動態修改輔助線、參考區間或框。例如，您可以參照某個參數，而不是在軸上的固定位置顯示一條參考線。然後就可以使用參數控制項移動輔助線。

「新增參考線、參考區間或參考方塊」對話方塊的**值**下拉式清單中提供了參數清單。選取要使用的參數。輔助線在參數指定的 \[當前值\] 處繪製。

![「編輯參考線、參考帶或參考方塊」對話方塊，其中包含用於在值中插入參數的選項。](/tableau/current/zh-tw/pro/desktop/zh-tw/Img/parameters_referencelines1.png)

## 在視覺效果中顯示參數控制項

參數控制項是可用來修改參數值的工作表卡。參數控制項與篩選器卡類似，它們都包含可修改檢視的控制項。可以在工作表和儀表板上開啟參數控制項，然後在儲存到 Web 或發佈到 Tableau Server 時會包括這些參數控制項。

要開啟參數控制項，請在「資料」窗格中以右鍵按一下（Control + 按一下）參數，然後選取「顯示參數」。

![「顯示參數」的下拉式功能表選項。](/tableau/current/zh-tw/pro/desktop/zh-tw/Img/example_parameters13.png)

與其他卡一樣，參數控制項有一個功能表，您可以使用該卡右上角的下拉箭頭開啟該功能表。使用此功能表，可自訂控制項的顯示。例如，可以將值清單顯示為選項按鈕、精簡清單、滑塊或欄位中的類型。

此功能表上的可用選項取決於參數的資料類型以及參數是否接受所有值、值清單或值範圍。

![含顯示標題和選擇參數類型選項的「編輯參數」對話方塊；已選取「滑桿」。](/tableau/current/zh-tw/pro/desktop/zh-tw/Img/parameters13.png)

## 建立動態參數

### 參數動作

您可以在[參數動作](https://help.tableau.com/current/pro/desktop/zh-tw/actions_parameters.htm)中使用參數，使其更具動態及互動性。參數動作可讓您的對象透過與視覺效果直接互動的方式（例如：按一下或選取標記）來變更參數值。

### 動態目前值

可以建立如下參數：該參數可以將其目前值重新整理為計算結果、值清單（基於欄位）或值範圍。每次開啟工作簿或從資料來源的內容功能表中選取「重新整理」時，都會發生此重新整理。

**使用計算作為參數的目前值**

若目前值為計算結果，則它必須是具有單一值且獨立於檢視的計算。若計算結果可能有多個值，則工作簿無法選擇預設值。計算也必須與檢視無關，值才不會隨著視覺效果變化而變更。

為此，可以使用不依賴於視覺效果結構的 FIXED 詳細資料層級 (LOD) 運算式。計算的所有部分都必須位於 FIXED LOD 運算式內。若使用 FIXED LOD 運算式作為預設值並使用內容篩選器，則動態參數將不會反映任何內容篩選器。

有關 LOD 運算式的詳情，請參閱[在 Tableau 中建立詳細層級運算式](https://help.tableau.com/current/pro/desktop/zh-tw/calculations_calculatedfields_lod.htm)。

附註：不建議在資料擷取篩選器中使用動態參數，因為它會影響效能。如果在資料擷取篩選器中使用動態參數，Tableau 需要先處理所有資料以確定參數的值，從而確定要篩選的資料。例如，如果使用動態參數篩選器傳回最近 30 天的資料，Tableau 會評估整個資料來源以尋找最近 30 天的資料，然後對其進行篩選。這會導致效能下降和載入時間更長。

## 對參數進行疑難排解

以下是預設參數值或可重新整理參數值（網域）清單不會按預期更新的幾種情況：

- 預設欄位所傳回值的資料與參數的資料類型不相容。
- 參數目前值的預設欄位不傳回單一值。
- 預設欄位傳回空值。
- 預設欄位位於未連線的資料來源中。
- 預設欄位位於未混合的資料來源中。
- 預設欄位已被刪除。
- 使用者在 Tableau 嘗試連線時取消對資料來源的查詢。

在 Tableau Desktop 中，在開啟工作簿並且 Tableau 首次連線到欄位的資料來源時，會對這些查詢進行初始評估。您還可以透過重新整理資料來源來評估查詢。為此，請按 F5，或開啟資料來源的內容功能表，然後選取「重新整理」。在 Tableau Server 和 Tableau Cloud 上，可以透過按一下工具列中的「資料來源重新整理」按鈕來重新整理資料來源。但是，在這種情況下，請記住，傳回的值取決於伺服器的快取原則。

若預設欄位無法傳回值，則參數的行為如下：

- 目前值保留最新的有效值。
- 值清單為空白，因為 Tableau 不會序列化從工作簿中的查詢傳回的值。

目前值必須位於值清單中，才能將其指派給參數。如果值清單空白，系統就會根據資料類型（1 表示整數，1.0 表示浮點，"" 表示字串，目前日期則表示日期和日期時間）為參數指派遞補值。

## 此區段的其他文章