---
schema_version: "1"
id: 01be7c170eddcc988b07a9d260dd5acae9d63f47143ba89fa113ea01233fb8d8
title: 在安裝之後變更安裝設定
collection: tableau
version: current
locale: zh-tw
portal_url: https://docs.salesforce.com/tableau/current/zh-tw/desktopdeploy/desktop_deploy_setting_changes.md
canonical_url: https://help.tableau.com/current/desktopdeploy/zh-tw/desktop_deploy_setting_changes.htm
source_site: help.tableau.com
content_type: documentation
content_hash: 9e2bc3d90b3267065743616f2feb55946782fdb28d4f98fc19e8448702967b82
description: Change Tableau Desktop installation settings after install, like language and repository location.
---
[跳至主要內容](#main-content)

# 在安裝之後變更安裝設定

安裝 Tableau Desktop 與 Tableau Prep Builder 時，會預設可其一些功能。例如，使用 Tableau Desktop 時，安裝過程中將會安裝產品自動更新或使用者工作簿自動儲存功能。但您可能有一些不希望使用者存取的功能，例如上載損毀傾印檔案和記錄的功能。作為管理員，您可以關閉其中一些功能。

對於 Windows，也可以在安裝過程中設定要在「探索」窗格中顯示的自訂內容，使用自訂樣本工作簿替換預設的加速器工作簿，並且關閉部分功能。有關這些功能的清單，請參閱《從命令行安裝 Tableau Desktop 與 Tableau Prep Builder》中的[使用命令列安裝](https://help.tableau.com/current/desktopdeploy/zh-tw/desktop_deploy_automate.htm#installer_properties)。

對於 Mac，只能在安裝後才可以設定自訂的探索窗格內容，使用自訂工作簿替換加速器工作簿，或是關閉部分功能。若要在安裝之後為「探索」窗格設定自訂內容、使用自訂樣本替換樣本工作簿，或變更設定（適用於 Windows 和 Mac），可以變更登錄檔或 `.plist` 檔，然後重新啟動應用程式以查看變更。

若要將變更部署到遠端電腦，您可以從登錄檔 (Windows) 或 .plist (Mac) 檔中匯出設定，修改想要關閉的設定，然後使用修改後的檔案建立一個自動化指令碼，將更新推送到已安裝 Tableau Desktop 的每台電腦。

> [!IMPORTANT]
> 
> **重要資訊**：在對登錄檔進行任何變更之前，請一律備份該檔案。不正確地編輯 Windows 登錄檔可能會對電腦造成嚴重影響。

## 設定顯示語言（可選）

首次執行 Tableau Desktop 或 Tableau Prep Builder 時，它會透過使用者地區設定設定識別您的電腦地區設定，並使用適當的語言（若支援）。如果您使用的是不支援的語言，則應用程式預設為英文。

對於 Tableau Prep Builder，數字和日期的顯示格式基於安裝該應用程式的電腦上作業系統的地區設定。對於 Tableau Desktop，可以為工作簿設定日期和數字格式。如需更多資訊，請參閱 Tableau 使用者說明中的[語言和地區設定](https://help.tableau.com/current/pro/desktop/zh-tw/workbook_language.htm)。

若要將 Tableau Desktop 或 Tableau Prep Builder 設定為以不同的語言顯示使用者介面（功能表、訊息等），請執行以下動作，然後重新啟動應用程式以套用變更。

1. 在頂端功能表中選取說明。
2. 選取選擇語言。
3. 從清單中選取語言。

## 變更「我的 Tableau 存放庫」位置（可選）

在安裝過程中，Tableau Desktop 與 Tableau Prep Builder 會在您的電腦的文件資料夾中建立「我的 Tableau <應用程式> 存放庫」資料夾結構。例如，如果因為需要將資料放在網路伺服器（而不是本機電腦）上的原因，您需要將此存放庫轉移到另一個位置，則可以指定一個新位置，並將 Tableau Desktop 或 Tableau Prep Builder 指向該新資料夾。

為存放庫設定新位置時，請遵循以下規則：

- 新資料夾必須為目錄。
- 您必須具有寫入新資料夾的權限。
- 新資料夾不能位於現有「我的 Tableau 存放庫」資料夾結構中。

**附注**：變更存放庫位置不會移動原始存放庫中包含的檔。相反，Tableau 會建立您可以在其中存儲檔案的新存放庫。

1. 開啟 Tableau Desktop 或Tableau Prep Builder。
2. 從頂端功能表中，選取「檔案」\>「存放庫位置」。
3. 在「選取存放庫資料夾」對話方塊中，選取一個將充當新存放庫位置的新資料夾。
4. 重新開機應用程式以使用新存放庫。

## 設定「探索」窗格以顯示自訂內容（僅限 Tableau Desktop）

預設情況下，Tableau 會在 Tableau Desktop 的「探索」窗格中提供如訓練、部落格文章和公開視覺效果等連結的資訊，以協助您的使用者開始使用 Tableau。「探索」窗格會在啟動時顯示，並保留在「開始」頁面上，以便您的使用者隨時取得這些連結和資訊。

![Tableau 探索窗格。](/tableau/current/zh-tw/desktopdeploy/zh-tw/Img/custom_discover_pane1.png)

但是，您可能會想要改為將「探索」窗格用來顯示您組織的特定內容。若要這麼做，對於透過已啟用 https 的 URL 所提供之 Web 伺服器上託管的內容，您可以建立自己的網頁，然後使用 DiscoverPane 金鑰和 DiscoverPaneURL 值，以您自訂網頁中的內容來取代 Tableau 提供的預設內容。

**附註**：為取得最佳結果，請不要使用包含 JavaScript 或重新導向的網頁。

![Tableau 探索窗格。](/tableau/current/zh-tw/desktopdeploy/zh-tw/Img/custom_discover_pane2.png)

為了協助您快速入門，Tableau Desktop 提供的[範本](https://github.com/tableau/discover-pane-template)複製了與 Tableau 提供的「探索」窗格相同的配置。只需下載範本，並將連結取代為自訂內容即可。該範本包括指標部分、配置結構以及內容的連結。

### Windows

使用命令列安裝時，您可以在安裝期間將「探索」窗格設定為指向您的自訂網頁，方法是將屬性 `DISCOVERPANEURL="<https://YourWebPage.com>"` 新增到命令列中。如果要在安裝完成後將「探索」窗格設定為使用您的自訂內容，請遵循下方步驟。重新啟動應用程式以檢視變更。

1. 做為已安裝 Tableau 之電腦上的管理員，請在對登錄檔進行任何變更之前將其備份。
2. 開啟登錄編輯程式 (`regedit.exe`)。
3. 巡覽到以下登錄檔路徑：
    
    `Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau <version>`。例如，`Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau 2020.1`
4. 用滑鼠右鍵按一下您的 Tableau 版本，然後選取「新增」\>「機碼」，並將其命名為 DiscoverPane。
5. 在新 DiscoverPane 機碼的右窗格中，右鍵按一下並選取新建 > 字串值，並將其命名為 DiscoverPaneURL。
6. 用滑鼠右鍵按一下新的 DiscoverPaneURL 字串值，然後選取「修正」。接著，在「編輯字串」對話方塊的「值資料」欄位中，輸入您自訂網頁的 URL。您的內容必須透過已啟用 https 的 URL 託管。不支援使用已啟用 http 的 URL。
    
     例如，`https://help.tableau.com/current/desktopdeploy/en-us/desktop_deploy_user.htm`。
    
    ![登錄編輯器，顯示包括 Tableau 在內的各種軟體的目錄和設定。](/tableau/current/zh-tw/desktopdeploy/zh-tw/Img/custom_discover_pane_Regedit.png)
7. 要將「探索」窗格重設回 Tableau Desktop 預設內容，請修改 DiscoverPaneURL 值並清除輸入的自訂網頁 URL，將「值資料」欄位留空。重新啟動 Tableau Desktop 時，「探索」窗格將顯示預設的 Tableau 內容。

### Mac

透過新增 DiscoverPane 機碼和 DiscoverPaneURL 值來修改 /Users/<local user>/Library/Preferences/com.tableau.Tableau-<version>.plist。重新啟動應用程式以檢視變更。

1. 從終端命令提示字元中執行下列命令，將該值設為您的自訂 URL。使用如下方所示的相同大小寫。
    
    `defaults write com.tableau.Tableau-<version> DiscoverPane.DiscoverPaneURL <https://YourWebPageURL>`
    
    例如，在 Tableau Desktop 2020.1 中，使用此命令：
    
    `defaults write com.tableau.Tableau-<version> DiscoverPane.DiscoverPaneURL https://help.tableau.com/current/desktopdeploy/en-us/desktop_deploy_user.htm`
2. 若要將「探索」窗格重設回 Tableau Desktop 預設內容，請執行此命令：
    
    `defaults write com.tableau.Tableau-<version> DiscoverPane.DiscoverPaneURL " "`
    
    重新啟動 Tableau Desktop 時，「探索」窗格將顯示預設的 Tableau 內容。

## 使用自訂工作簿替換加速器工作簿（僅限 Tableau Desktop）

預設情況下，Tableau 提供三個已封裝加速器幫助使用者探索 Tableau。（在 2022.2 版本之前，這些加速器被稱為樣本工作簿。）從版本 2021.3 開始，最多可以建立 5 個針對特定使用者的已封裝工作簿，並將 Tableau 在「開始」頁面的加速器部分提供的加速器工作簿替換為自訂工作簿。

**注意**：安裝 Tableau Server 時，可以選擇在預設站台中包含範例工作簿。若在安裝時核取包含樣本選項，則可將自訂樣本工作簿 從Tableau Desktop 發佈到您伺服器上的 Tableau 樣本專案。

![連線頁面上提供的 Tableau 加速器。](/tableau/current/zh-tw/desktopdeploy/zh-tw/Img/desktop_custom_samples.png)

自訂樣本工作簿必須符合下列要求：

- 您一次最多可以包含 5 個樣本工作簿。
- 僅支援已封裝工作簿 (.twbx) 檔案。
- 工作簿必須儲存在 Tableau 和使用者具有讀取權限的本機目錄中。不支援網絡目錄。
- 工作簿檔案名稱不能包含 '、"、<、> 或 &字元。

**附註**：升級到新發行版本（例如 2021.4）時，不會保留自訂樣本。在安裝升級時，需透過命令列來為自訂樣本指定檔案路徑，或是在升級後修改註冊檔 (Windows) 或 .plist (MacOS)。

### 開始之前

**Windows 和 Mac**

在儲存樣本的本機上建立一個目錄，並最多新增 5 個樣本封裝工作簿 (.twbx) 檔案。

可以在需要時替換工作簿檔案，但開始頁面上最多只能顯示 5 個工作簿。有關替換自訂工作簿的詳情，請參閱[管理自訂工作簿](#manage_custom_samples)。

### Windows

**從命令列**

從命令列安裝時，新增屬性 `CUSTOMSAMPLESDIR="path to directory"`。

例如：`tableauDesktop-64bit-2021-3-0.exe /quiet /norestart ACCEPTEULA=1 CUSTOMSAMPLESDIR="C:\Users\mkim\Documents\My Tableau Repository\CustomSamples"`

啟動 Tableau Desktop 後，應該會在「開始」頁面上看到自訂樣本。

**從註冊檔安裝後**

要在安裝完成後設定自訂的樣本目錄，請按照以下步驟操作。重新啟動應用程式以檢視變更。

1. 做為已安裝 Tableau 之電腦上的管理員，請在對登錄檔進行任何變更之前將其備份。
2. 開啟登錄編輯程式 (`regedit.exe`)。
3. 巡覽到以下登錄檔路徑：
    
    `Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau <version>`。例如，`Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau 2021.3`
4. 建立一個名為樣本的新文件夾。在 Tableau 版本的文件夾上按一下右鍵，選擇新增\>機碼，然後重新命名新文件夾。
    
    ![Tableau 版本功能表，顯示建立新金鑰的選項。](/tableau/current/zh-tw/desktopdeploy/zh-tw/Img/desktop_deploy_custom_samples1.png)
5. 在剛建立的樣本文件夾按一下右鍵，並選擇新增 > 字串值，並將其命名為CustomSamplesDir 。
    
    ![下拉式功能表，其中包含「新建」、「尋找...」和「刪除」等選項。](/tableau/current/zh-tw/desktopdeploy/zh-tw/Img/desktop_deploy_custom_samples2.png)
6. 在新的 CustomSamplesDir 字串值上按一下右鍵，選取修改。然後在編輯字符串對話框的值資料欄位中，輸入之前所設定目錄的完整 Windows 檔案路徑。
    
    ![登錄編輯器視窗，顯示資料夾和檔案階層。](/tableau/current/zh-tw/desktopdeploy/zh-tw/Img/desktop_deploy_custom_samples3.png)
7. 重新啟動 Tableau Desktop 以檢視變更。該部分現在標題為「您的自訂工作簿」 。
    
    ![Tableau 連線頁面，其中包含自訂工作簿。](/tableau/current/zh-tw/desktopdeploy/zh-tw/Img/desktop_deploy_custom_samples4.png)
8. 要重設回 Tableau Desktop 預設內容，請修改 CustomSamplesDir 值並清除輸入的目錄路徑，將「值資料」欄位留空。當重新啟動 Tableau Desktop 後，「開始」頁面上的 加速器 部分將顯示預設的 Tableau 內容。

### Mac

透過新增 Samples.CustomSamplesDir 機碼和樣本目錄路徑值來修改 /Users/<local user>/Library/Preferences/com.tableau.Tableau-<version>.plist。重新啟動應用程式以檢視變更。

1. 從終端命令提示字元中執行下列命令，將該值設為您的自訂樣本。使用如下方所示的相同大小寫。
    
    `defaults write com.tableau.Tableau-<version> Samples.CustomSamplesDir <your directory path>`
    
    例如，在 Tableau Desktop 2021.3 中，使用此命令：
    
    `defaults write com.tableau.Tableau-2021.3.0 Samples.CustomSamplesDir "/Users/mkim/Documents/My Tableau Repository/CustomSamples"`
2. 要重設回 Tableau Desktop 預設內容，請執行此命令：
    
    `defaults write com.tableau.Tableau-<version> Samples.CustomSamplesDir " "`
    
    當重新啟動 Tableau Desktop 後，「開始」頁面上的 加速器 部分將顯示預設的 Tableau 內容。

### 管理自訂工作簿

將自訂樣本工作簿新增到 Tableau Desktop 後，當首次開啟應用程式，會在您建立的自訂樣本文件夾中自動生成 custom.manifest 檔案和工作表縮圖。

使用新建工作簿替換自訂樣本工作簿時，需要刪除 custom.manifest 檔案，以便可以生成新檔案。刪除工作表縮圖是可選的。

![顯示檔案清單的視窗，包括一個文件和幾個線條圖。](/tableau/current/zh-tw/desktopdeploy/zh-tw/Img/desktop_deploy_custom_samples5.png)

1. 導航到本地目錄中的自訂樣本文件夾。
2. 刪除 custom.mainfest 檔案。
3. 從自訂樣本文件夾中刪除或移動工作簿和這些工作簿的任何工作表縮圖（可選）。
4. 將新封裝 (.twbx) 工作簿新增到自訂樣本文件夾。
5. 重新啟動應用程式。

## 關閉產品更新

「產品更新」功能使使用者可自動接收產品更新，或者在維護更新可用時檢查並安裝相應更新。要在安裝 Tableau Desktop 後關閉產品更新，則必須為安裝了 Tableau 的每台電腦更新登錄檔 (Windows) 或 `.plist` 檔案 (Mac) 中的 `AutoUpdateAllowed` 項。

### Windows

1. 做為已安裝 Tableau 之電腦上的管理員，請在對登錄檔進行任何變更之前將其備份。
2. 開啟登錄編輯程式 (`regedit.exe`)。
3. 將 `AutoUpdateAllowed` 登錄機碼設定為 `0`。下表列出了不同產品的該項所在位置。

<table><tbody><tr><td style="font-weight: bold;">產品</td><td style="font-weight: bold;">位置（64 位元 Tableau 和 Windows）</td></tr><tr><td><p><span class="mc-variable Variables.TabsProductDesktop variable">Tableau Desktop</span></p></td><td><code>HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau <i>&lt;version&gt;</i>\AutoUpdate</code></td></tr><tr><td><p><span class="mc-variable Variables.TabsProductDesktop variable">Tableau Desktop</span> Public Edition</p></td><td><code>HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau Public <i>&lt;version&gt;</i>\AutoUpdate</code></td></tr><tr><td><p>Tableau Reader</p></td><td><code>HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau Reader <i>&lt;version&gt;</i>\AutoUpdate</code></td></tr></tbody></table>

若要再次啟用產品更新，請按照相同的過程進行操作，但將登錄機碼設定為 `1`，而不是 `0`。

### Mac

從終端命令提示字元中執行以下命令之一。

<table><thead><tr><th>產品</th><th>命令</th></tr></thead><tbody><tr><td><span class="mc-variable Variables.TabsProductDesktop variable">Tableau Desktop</span></td><td><code>defaults write com.tableau.Tableau-<em>&lt;version&gt;</em> AutoUpdate.AutoUpdateAllowed "0"</code><p>例如，在 <span class="mc-variable Variables.TabsProductDesktop variable">Tableau Desktop</span> 2019.1 中，使用此命令：</p><p><code>defaults write com.tableau.Tableau-2019.1 AutoUpdate.AutoUpdateAllowed "0"</code></p></td></tr><tr><td><span class="mc-variable Variables.TabsProductDesktop variable">Tableau Desktop</span> Public Edition</td><td><code>defaults write com.tableau.Tableau-Public-<em>&lt;version&gt;</em> AutoUpdate.AutoUpdateAllowed "0"</code></td></tr><tr><td>Tableau Reader</td><td><code>defaults write com.tableau.Tableau-Reader-<em>&lt;version&gt;</em> AutoUpdate.AutoUpdateAllowed "0"</code></td></tr></tbody></table>

若要再次啟用產品更新，請執行相同的命令，但指定 `1`，而不是 `0`。

## 關閉檔案恢復

檔案恢復功能會啟用 Tableau Desktop 與 Tableau Prep Builder（2020.3.3 版本及更新版本）以儲存您的使用者工作簿或流程檔案，若應用程式意外停止時不會遺失工作。當使用者重新開啟 Tableau 時，將顯示一個對話方塊，其中包含可從中進行選取已恢復檔案的清單。使用者可以開啟已恢復檔案並從其中斷的位置繼續，或者可以刪除不需要的任何檔案。如果使用者刪除檔案，則會丟棄自上次儲存以來他們所做的任何變更。

如果使用者刪除 Tableau Desktop 清單中的所有已恢復檔案或從 Tableau Prep Builder 的已恢復流程資料夾中刪除，則在產生新的已恢復檔案之前，恢復對話方塊將不再顯示。

預設情況下已啟用檔案恢復功能。要停用，可以變更 `AUTOSAVE` 屬性的設定 (Tableau Desktop) 或 maestro.appSettings.autosave 設定 (Tableau prep Builder)。按一下標籤頁，可以檢視您的產品關閉檔案恢復的步驟。

關閉檔案恢復功能時，啟動自動儲存功能表選項不會提供給使用者。如果要在安裝後重新啟用此功能，可以部署登錄檔（或 Mac 的 .plist）更新，以為安裝了 Tableau 的每台電腦變更 `AUTOSAVE` 屬性設定。有關如何在安裝期間透過命令列控制此設定的詳細資訊，請參閱[使用命令列安裝](https://help.tableau.com/current/desktopdeploy/zh-tw/desktop_deploy_automate.htm#installer_properties)。

要在安裝 Tableau Desktop 後關閉檔案，則必須為安裝了 Tableau 的每台電腦更新登錄檔 (Windows) 或 `.plist` 檔案 (Mac) 中的 `AutosaveAllowed` 項。

### Windows

1. 作為已安裝 Tableau Desktop 電腦的管理員，請在對登錄檔進行任何變更前將其備份。
2. 開啟登錄編輯程式 (`regedit.exe`)。
3. 將 `AutosaveAllowed` 登錄機碼設定為 `0`。
    
    登錄機碼位置：`HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau _<version>_\Autosave`

要再次啟用檔案恢復，請按照相同的過程進行操作，但將登錄機碼 `AutosaveAllowed` 設定為 `1`，而不是 `0`。

### Mac

從終端命令提示字元中執行以下命令。

`defaults write com.tableau.Tableau-_<version>_ Autosave.AutosaveAllowed "0"`

例如，在 Tableau Desktop 2020.3 中，使用此命令：

`defaults write com.tableau.Tableau-2020.3 Autosave.AutosaveAllowed "0"`

要再次啟用檔案恢復，請執行相同的命令，但指定 `Autosave.AutosaveAllowed "1"`，而不是 `"0"`。

安裝過程中，可以使用 Windows 命令列或清除自訂安裝區段 (MacOS) 上安裝類型的啟用損毀恢復核取方塊這兩種方式，關閉您的檔案恢復功能。有關如何在安裝期間關閉檔案恢復的資訊，請參閱[開始之前](https://help.tableau.com/current/desktopdeploy/zh-tw/desktop_deploy_download_and_install.htm#Install)。

若在安裝 Tableau Prep Builder 後啟用或關閉檔案恢復功能，必須變更安裝 Tableau Prep Builder 的每台電腦的 `maestro.appSettings.autosave` 的設定屬性。

### Windows

1. 作為安裝 Tableau Prep Builder 的電腦上的管理員，導航到 app 資料夾。例如：
    
    `C:\Program Files\Tableau\Tableau Prep Builder 2020.3\resources\app`
2. 在 app 資料夾中開啟 `application.properties` 檔案。
3. 設定 `maestro.appSettings.autosave=false`

若要再次啟用檔案恢復，請遵循相同的程序但設定 `maestro.appSettings.autosave=true`。

### Mac

1. 巡覽到 `/Library/Application Support/Tableau Prep Builder/`
2. 在文字編輯器中開啟 `application.properties` 檔案。
3. 將 `maestro.appSettings.autosave=true` 變更為 `maestro.appSettings.autosave=false`
4. 儲存變更並關閉該檔案。

要再次啟用檔案恢復，請遵循相同的程序，但將 `maestro.appSettings.autosave=false` 變更為 `maestro.appSettings.autosave=true`。

## 關閉使用情況報告

Tableau 會收集有助於我們瞭解產品使用情況的資料，以便我們可以改進現有功能並開發新功能。所有使用情況資料都是根據 [隱私權原則](https://www.salesforce.com/company/privacy/)收集並處理。如果您不想參與此選項，可在安裝過程中或安裝後選擇退出。

有關我們收集的資料類型的資訊，請參閱 [Tableau 產品使用情況資料](https://www.tableau.com/zh-tw/product-usage-data)。

如果您不想參與此選項，可以透過在安裝過程中選取退出核取方塊，也可以透過新增包含屬性 `SENDTELEMETRY="0"` 的命令列，從命令列 (Windows) 退出。

如需在使用者介面中停用此選項的相關資訊，請參閱[從使用者介面安裝](https://help.tableau.com/current/desktopdeploy/zh-tw/desktop_deploy_download_and_install.htm)。有關透過命令列停用此選項的資訊，請參閱[使用命令列安裝](https://help.tableau.com/current/desktopdeploy/zh-tw/desktop_deploy_automate.htm#Installer_options)。

即使已停用傳送產品使用情況資料，某些基本產品資料也會傳送到 Tableau。若不想將基本產品資料傳送到 Tableau，也可以停用此選項。有關詳情，請參閱[基本產品資料](https://help.tableau.com/current/desktopdeploy/zh-tw/usage_data_basic_product_data.htm)。

若要在安裝之後選取退出此選項，請執行以下操作之一：

### 從產品中

1. 開啟 Tableau Desktop。
2. 從頂端功能表中，選取「說明」\>「設定和效能」。
3. 按一下「不傳送產品使用情況資料」。
    
    ![設定和效能子功能表，顯示選擇不共用產品使用情況資料的選項。](/tableau/current/zh-tw/desktopdeploy/zh-tw/Img/prep_usage_data_optout.png)

### 透過登錄檔

若要在系統層級關閉使用情況報告，請按照適用於您的作業系統的說明進行操作。

**Windows**

開啟命令提示字元並執行以下命令：

`REG ADD "HKLM\Software\Tableau\<Tableau Version>\Telemetry" /v TelemetryEnabled /t REG_DWORD /d 0`

或者，執行以下步驟：

1. 作為已安裝 Tableau Desktop 電腦的管理員，請在對登錄檔進行任何變更前將其備份。
2. 開啟登錄編輯程式 (`regedit.exe`)。
3. 將 `TelemetryEnabled` 登錄機碼設定為 `0`。
    
    登錄機碼位置：`HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau _<version>_\Telemetry`

若要再次啟用使用情況報告，請按照相同的過程進行操作，但將登錄機碼設定為 `1`，而不是 `0`。

Mac

從終端命令提示字元中執行以下命令。

`defaults write com.tableau.Tableau-_<version>_ Telemetry.TelemetryEnabled "0"`

例如，在 Tableau Desktop 2019.4 中，使用此命令：

`defaults write com.tableau.Tableau-2019.4 Telemetry.TelemetryEnabled "0"`

若要再次啟用使用情況報告，請執行相同的命令，但指定 `1`，而不是 `0`。

若要在安裝之後選取退出此選項，請執行以下操作之一：

### 從產品中

1. 以管理員身分開啟 Tableau Prep Builder。
    
    - **Windows** ：右鍵按一下該應用程式，然後選取「以管理員身份執行」 。
    - **MacOS** ：在終端命令提示字元中執行`sudo /Applications/Tableau\ Prep\ Builder\ <version>.app/Contents/MacOS/Tableau\ Prep\ Builder`。
2. 從頂端功能表中，選取「說明」\>「設定和效能」。
3. 按一下「不傳送產品使用情況資料」。
    
    **附註**：在 2019.3.2 版及更早版本中，按一下「共用使用情況資料以改進 Tableau Prep Builder」以清除核取記號
    
    ![設定和效能子功能表，顯示選擇不共用產品使用情況資料的選項。](/tableau/current/zh-tw/desktopdeploy/zh-tw/Img/prep_usage_data_optout.png)

#### 從屬性檔中

**Windows**

1. 巡覽到 Tableau Prep Builder 安裝目錄中的 app 資料夾。例如，`C:\Program Files\Tableau\Tableau Prep Builder <version>\resources\app`
2. 在文字編輯器中開啟 telemetryConfig.properties 檔案。
3. 將 `maestro.telemetry.enabled=true` 變更為 `maestro.telemetry.enabled=false`
4. 儲存變更並關閉該檔案。

**Mac**

對於 Mac，此設定特定於使用者。此設定不適用於系統上的任何其他使用者，除非他們重新安裝應用程式。

1. 巡覽到 `~/Library/Application Support/Tableau Prep Builder/`
2. 在文字編輯器中開啟 telemetryConfig.properties 檔案。
3. 將 `maestro.telemetry.enabled=true` 變更為 `maestro.telemetry.enabled=false`
4. 儲存變更並關閉該檔案。

## 關閉錯誤報告

如果 Tableau Desktop 或 Tableau Prep Builder 出現問題並意外關閉，則會生成損毀傾印檔案和記錄，這些檔案和記錄位於您的 My Tableau 或 My Tableau Prep Builder 存放庫中的記錄資料夾中。預設情況下已啟用此選項。

這些檔案中的資料可能包括特定於電腦的資訊、發生損毀時記憶體內容的快照（其中可能包括應用程式活動詳細資訊、資料連線資訊、使用者執行的操作，或正在 Tableau 中處理的資料），以及可識別客戶的資訊。

如果貴組織遵守資料隱私規範，您可以停用此選項。您將需要完成不同步驟，才能為 Tableau Desktop 與 Tableau Prep Builder 停用此選項。按一下以下標籤，檢視您的應用程式的說明。

如果是 Tableau Desktop，使用者下次開啟此應用程式時，將會開啟一個對話方塊提示，使使用者能夠執行以下操作之一：

- 上載損毀檔案。
- 拒絕上載損毀檔案。
- 永久選取不上載損毀檔。

如果使用者上載檔案，系統會使用 2048 位 RSA 金鑰將檔案一起壓縮為一個加密包並傳送到 Tableau，以便工程師能夠進行分析，並確認導致損毀的問題。

加密包包括：

- 損毀傾印檔案 (.dmp)
- 與損毀相關的錯誤記錄檔 (.log)
- 與損毀相關的清單檔 (.maifest)

如果您的組織須遵守資料隱私法規，您可以透過編輯登錄檔 (Windows) 或在每個桌面上執行指令碼 (Mac) 來停用此提示，使其不再顯示，從而防止使用者上載損毀傾印檔和記錄。

### Windows

1. 做為已安裝 Tableau 之電腦上的管理員，請在對登錄檔進行任何變更之前將其備份。
2. 開啟登錄編輯程式 (`regedit.exe`)
3. 將 `CrashReportUpload` 登錄機碼設定為 `2`。
    
    登錄機碼位置：`HKEY_CURRENT_USER\Software\Tableau\_<version>_\Prompts`

### Mac

從終端命令提示字元中執行以下命令：

`defaults write com.tableau-<TABLEAU VERSION>.plist Prompts.CrashReportUpload -string 2`

例如，在 Tableau Desktop 2019.1 中，使用此命令：

`defaults write com.tableau.Tableau-2019.1.plist Prompts.CrashReportUpload -string 2`

如果是 Windows 上的 Tableau Prep Builder，您可以透過清除自訂對話方塊上的啟用錯誤報告核取方塊，或者透過納入屬性 `CRASHDUMP="0"` 從命令列在安裝期間關閉錯誤報告。

若要在安裝之後關閉此選項，請向 application.properties 檔的「application properties」部分新增 `maestro.enable_fault_reporting=false` 行。

此檔案位於 `C:\Program Files\Tableau\<Tableau Prep Builder version>\resources\app` 中。

## 關閉儀表板的網頁物件（僅適用於 Tableau Desktop）

網頁物件在儀表板的一部分中顯示目標 URL。在安裝過程中，請參閱[使用命令列安裝](https://help.tableau.com/current/desktopdeploy/zh-tw/desktop_deploy_automate.htm#installer_properties)，以停用在這些物件中顯示 URL。安裝後，請完成以下步驟。

### Windows

1. 做為已安裝 Tableau 之電腦上的管理員，請在對登錄檔進行任何變更之前將其備份。
2. 開啟登錄編輯程式 (`regedit.exe`)
3. 將 `WebViewToggleWebZonesEnabled` 登錄機碼設定為 `0`。
    
    登錄機碼位置：`HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\_<version>_\Settings`

### Mac

從終端命令提示字元中執行以下命令。

`defaults write /Library/Preferences/com.tableau.Tableau-<version>.plist Settings.WebViewToggleWebZonesEnabled -integer 0`

例如，在 Tableau Desktop 2020.4 中，使用此命令：

`defaults write /Library/Preferences/com.tableau.Tableau-2020.4.plist Settings.WebViewToggleWebZonesEnabled -integer 0`

若要再次啟用網頁物件，請執行相同的命令，但請指定 `-integer 1`，而不是 `-integer 0`。

## 停用儀表板和視覺效果擴充功能（僅限 Tableau Desktop）

儀表板和視覺效果擴充功能可藉助 Tableau 和協力廠商開發人員建立的 Web 應用程式擴充 Tableau 的儀表板和原生視覺功能。

Tableau 支援兩種擴充功能標準：Tableau 受信任的擴充功能（在 Tableau Web 伺服器上執行並在部署之前經過 Tableau 主導的檢閱）或已啟用網路的擴充功能（在協力廠商 Web 伺服器上執行）。已啟用網路的擴充功能支援以下情境，包括擴充功能直接託管在本機網路內，或由本機網路外的非 Tableau 協力廠商服務（例如合作夥伴開發人員提供的生產服務）託管。有關儀表板和視覺效果擴充功能的詳細資訊，請參閱[使用儀表板擴充功能](https://help.tableau.com/current/pro/desktop/zh-tw/help.htm#dashboard_extensions.htm)和[將視覺效果擴充功能新增到工作表](https://help.tableau.com/current/pro/desktop/zh-tw/viz_extensions.htm)。有關部署選項的更多資訊，請參閱[擴充功能安全性 - 部署的最佳做法](https://help.tableau.com/current/server/zh-tw/security_extensions.htm)。

預設情況下，擴充功能已啟用，允許在 Tableau Desktop 上使用 Tableau 受信任的擴充功能和已啟用網路的擴充功能。Tableau 受信任的擴充功能會自動執行，而已啟用網路的擴充功能需要使用者權限才能執行。

若要在安裝期間停用擴充功能，請設定下列屬性。有關詳情，請參閱[使用命令列安裝](https://help.tableau.com/current/desktopdeploy/zh-tw/desktop_deploy_automate.htm#installer_properties)。

- `DISABLEEXTENSIONS="1"`：停用所有擴充功能類型。
- `DISABLENETWORKEXTENSIONS`\="1": 僅停用已啟用網路的擴充功能。
- `DISABLESANDBOXEXTENSIONS`\="1": 僅停用 Tableau 託管的沙箱化擴充功能
- `DISABLETABTRUSTEDEXTENSIONS` ="1": 僅停用 Tableau 託管的 Tableau 建置的擴充功能
- `DISABLE3PTRUSTEDEXTENSIONS` ="1": 僅停用 Tableau 託管的 Tableau 受信任的合作夥伴建置的擴充功能
    
    這些設定將停用擴充功能或特定類型的擴充功能，使其無法用於 Tableau Desktop 安裝。使用者仍然可以看到載入儀表板和視覺效果擴充功能的選項，並且可以存取 Tableau Exchange，但 Tableau Desktop 將根據套用的設定封鎖擴充功能的使用，讓其無法執行。

### 安裝後停用所有擴充功能

若要在安裝後停用所有擴充功能，請按照下列說明在每個桌面上編輯登錄 (Windows) 或執行指令碼 (MacOS)。

#### Windows

1. 做為已安裝 Tableau 之電腦上的管理員，請在對登錄檔進行任何變更之前將其備份。
2. 開啟登錄編輯程式 (`regedit.exe`)
3. 將 `DisableExtensions` 登錄機碼設定為 1。
    
    登錄機碼位置：`HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau <version>\Settings\Extensions\DisableExtensions`

#### Mac

從終端命令提示字元中執行以下命令：

`defaults write com.tableau.tableau-<TABLEAU VERSION>.plist Settings.Extensions.DisableExtensions "1"`

例如，在 Tableau Desktop 2019.4 中，使用此命令：

`defaults write com.tableau.tableau-2019.4.plist Settings.Extensions.DisableExtensions "1"`

### 安裝後停用特定類型的擴充功能

從 Tableau Desktop 2025.3 開始，桌面管理員可以在安裝後啟用和停用特定類型的擴充功能。請按照下列說明在每個桌面上編輯登錄 (Windows) 或執行指令碼 (MacOS)。

#### Windows

做為已安裝 Tableau 之電腦上的管理員，請在對登錄檔進行任何變更之前將其備份。

開啟登錄編輯程式 (regedit.exe)

將以下任一登錄機碼更新為 1，以停用每種類型的擴充功能：

- `DISABLENETWORKEXTENSIONS`\="1": 僅停用已啟用網路的擴充功能。
- `DISABLESANDBOXEXTENSIONS`\="1": 僅停用 Tableau 託管的沙箱化擴充功能
- `DISABLETABTRUSTEDEXTENSIONS` \="1": 僅停用 Tableau 託管的 Tableau 建置的擴充功能
- `DISABLE3PTRUSTEDEXTENSIONS` \="1": 僅停用 Tableau 託管的 Tableau 受信任的合作夥伴建置的擴充功能

登錄機碼位置：`HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau <version>\Settings\Extensions\`

#### Mac

從終端機命令提示字元執行以下任一命令：

- 若要僅停用已啟用網路的擴充功能：
    
    `defaults write com.tableau.tableau-<TABLEAU VERSION>.plist Settings.Extensions.DisableNetworkExtensions` "1"
- 若要僅停用 Tableau 託管的沙箱化擴充功能：
    
    `defaults write com.tableau.tableau-<TABLEAU VERSION>.plist Settings.Extensions.DisableSandboxExtensions` "1"
- 若要僅停用 Tableau 託管的 Tableau 建置的擴充功能：
    
    `defaults write com.tableau.tableau-<TABLEAU VERSION>.plist Settings.Extensions.DisableTabTrustedExtensions` "1"
- 若要僅停用 Tableau 託管的 Tableau 受信任的合作夥伴建置的擴充功能：
    
    `defaults write com.tableau.tableau-<TABLEAU VERSION>.plist Settings.Extensions.Disable3PTrustedExtensions` "1"

例如，要在 Mac 版 Tableau Desktop 2025.3 中僅停用已啟用網路的擴充功能，請使用下列命令：

`defaults write com.tableau.tableau-2025.3.plist Settings.Extensions.DisableNetworkExtensions` "1"

## 變更記錄檔資料夾位置

若要變更 Tableau Desktop 上的預設記錄檔資料夾位置，請參閱 Knowledge 文章[變更 Tableau Desktop 上的記錄檔資料夾位置](https://help.salesforce.com/s/articleView?id=005166930&type=1)。