# tableau Tableau Reader (reader) - Full Documentation [跳转到主要内容](#main-content) # Reader 布局 当您打开工作簿时,工作簿将在 Reader 窗口中打开,您可以在其中查看数据并与之交互。工作簿可能包含一个工作表或视图。它还可能包括仪表板,仪表板是一个视图,它将若干工作表合并在一个位置,以便您能够同时比较和监视各种数据。 ![](/tableau/current/zh-cn/reader/desktop/zh-cn/Img/layout1.png)\` ## 在工作簿中导航 Tableau 为您提供了用于在工作簿中导航的若干选项。如果工作簿包含多个工作表,则工作簿中显示的每个工作表或仪表板在窗口底部显示为选项卡。 若要在工作表之间切换,请单击一个选项卡。如果工作表太多而不能同时显示所有标签,您可以使用左侧的控件滚动查看各个标签。 ![](/tableau/current/zh-cn/reader/desktop/zh-cn/Img/layout4.png) 若要同时查看一个工作簿中的所有工作表或仪表板,请使用幻灯片或工作表排序程序视图。幻灯片视图将每个工作表显示为工作簿底部的缩略图图像。若要在显示选项卡和显示幻灯片视图之间切换,请单击位于 Reader 窗口右下方的按钮。选择缩略图图像以打开要查看的工作表。 ![](/tableau/current/zh-cn/reader/desktop/zh-cn/Img/layout7.png) 工作表排序程序视图将工作簿中的所有工作表显示为单个窗格中的缩略图图像。若要打开工作表排序程序,请单击位于 Reader 窗口右下方的按钮。选择缩略图图像以打开要查看的工作表。 ![](/tableau/current/zh-cn/reader/desktop/zh-cn/Img/layout9.png) ## 使用工具栏和菜单 使用工具栏和菜单以便与视图进行交互。例如,使用导航工具可以放大视图以及在视图中平移;或者可以单击某个“排序”按钮,对表中的数据快速排序。工具栏包含以下控件(从左到右): ## ![](/tableau/current/zh-cn/reader/desktop/zh-cn/Img/layout3.png) - Tableau 图标: 单击以导航到开始页。 - 撤消 - 单击该按钮以撤消您对工作表或仪表板所做的上一次操作。举例来说,如果您更改了视图上的筛选器,请单击“撤消”按钮将视图重置为它的上一次状态。 - 重做 - 如果单击了“撤消”按钮,单击该按钮可重复您对工作表或仪表板撤消的上一次操作。 - 暂停自动更新 - 单击该按钮以暂停自动更新功能。如果启用此功能,Tableau 将根据您使用筛选器进行的更改自动更新工作表或仪表板。如果不想自动更新视图,您可以单击此按钮来禁用该功能。 - 运行更新 - 单击该按钮以使用暂停自动更新时的最新设置手动更新和刷新视图。 - 升序排序 - 单击该按钮以按升序对数据字段进行排序。 - 降序排序 - 单击该按钮以按降序对数据字段进行排序。 - 匹配度控制 - 选择下拉列表中的选项以调整视图相对于应用程序窗口的大小。 - 固定轴 - 单击该按钮在仅显示特定范围的锁定轴以及基于视图中的最小值和最大值显示值范围的动态轴之间切换。 - 演示模式 - 单击该按钮以仅显示视图,并隐藏工具栏和菜单。按 Esc 或单击屏幕右下角的“演示”按钮返回到标准视图模式。 [跳转到主要内容](#main-content) # Tableau Reader 帮助 使用 Tableau Reader 可打开在 Tableau Desktop 中创建的具有已提取数据源的打包工作簿并与之交互。 打包工作簿包含工作簿引用的数据源的副本,因此您无需具有源数据的访问权限也可查看视图并与之交互。利用 Tableau Reader,您能够: - 打开 Tableau 工作簿并与之交互 - 以幻灯片形式呈现视图 - 导出视图或数据 - 打印视图 - 将视图发布为 PDF 文件 [跳转到主要内容](#main-content) # 与视图交互 工作簿的作者可能已向工作簿中添加了允许您与视图交互的功能。如果工作簿包括这些功能,您可以通过以下方式与视图交互: - 筛选器:使您能够直观地隔离数据的子集。 - 排序:使您能够更改数据在视图中的显示顺序。 - 动作:使您能够选择一个视图中的标记来突出显示另一个视图中的相关数据。 - 页面播放:使您能够翻阅视图中的单独页面。 - 图例:更改应用于视图中的数据的调色板。 ## 此部分中的其他文章 [跳转到主要内容](#main-content) # 使用动作来访问链接的数据 某些视图可能包含_动作_,这些动作将一个视图中的信息与其他视图关联,或链接到外部信息。这些动作可为数据添加上下文并且可以将分析结果连接到网页、文件和其他工作表。例如,一个显示特定街区房屋销售情况的视图可能包含指向以下各项的链接:街区的人口普查数据、房屋的卫星图像,以及显示该区域中类似房屋的其他工作表。 在 Reader 中,您可能会看到三种动作: - 筛选器动作 - 筛选器动作使用一个视图中的选定内容来筛选其他视图中显示的数据。 - 突出显示动作 - 突出显示动作使用一个视图中的选定内容来突出显示其他视图中的相关数据。 - URL 动作。- URL 动作指向网页、文件或其他 Web 资源。 只需将鼠标悬停在标记上方、选择标记或者右键单击标记并选择菜单选项,便可以设置动作以运行。 注意: 超链接不是对每个工作表和标记都始终可见。因为超链接映射到数据源中的特定字段,所以链接只在使用包含必要参数的映射字段和标记的工作表中才可见。 例如,以下视图显示了从 Reader 中的地图视图链接到特定位置的卫星图像的 URL 链接。 ![](/tableau/current/zh-cn/reader/desktop/zh-cn/Img/links3_522x470.png) [跳转到主要内容](#main-content) # 使用图例 Tableau Reader 使用颜色、大小和形状通过附加信息对视图进行编码。例如,标记可以划分为多个颜色(表示不同的区域)和形状(表示不同的产品)。然后可以对相同标记分配不同大小来表示利润率。每种类型的编码都有一个图例。您可以编辑这些图例以使用不同的[颜色](https://help.tableau.com/current/reader/desktop/zh-cn/colors.htm)。 ## 此部分中的其他文章 [跳转到主要内容](#main-content) # 使用演示模式 在与视图交互时,您可能希望使用演示模式与其他人分享您的发现。使用此模式时,Tableau 会隐藏工具栏和菜单,并且仅显示视图,类似于演示幻灯片。 若要打开或关闭演示模式,请单击工具栏上的“演示模式”![显示演示图标。](/tableau/current/zh-cn/reader/desktop/zh-cn/Img/pres_mode.png) 按钮,或者选择“窗口”\>“演示模式”。 **注意:**如果要隐藏个别工作表,请与工作簿作者联系。 下表描述了处于演示模式中时可用的不同控件。这些控件显示在屏幕的右下角。
电影胶片图标。显示缩图 - 在工作区底部将工作表显示为缩略图。
显示标签图标。显示标签 - 在工作区底部显示工作表标签。
左、右箭头三角形。 上一/下一工作表 - 向前或向后浏览工作簿中的工作表。
捕获图标。进入/退出全屏 - 在展开工作簿以占据整个屏幕以及在窗口中显示工作簿之间切换。
显示演示图标。退出演示模式 - 返回到显示整个工作区的工作簿,包括菜单、工具栏和“数据”窗格。
[跳转到主要内容](#main-content) # 使用页面播放 可以将视图划分为一系列页面,这样可以更好地分析特定字段对视图中其他数据的影响。例如,页面通常用于显示随时间的变化情况,每一页表示年、月或其他特定的日期。 使用“页面”卡控件可以自动翻阅页面或跳转到特定页面。 ![](/tableau/current/zh-cn/reader/desktop/zh-cn/Img/rpages_shelf1_159x123.png) #### 若要翻阅页面,请执行以下操作之一: - 若要以幻灯片形式查看页面,请单击“页面”卡底部的“播放”按钮 ![](/tableau/current/zh-cn/reader/desktop/zh-cn/Img/play_65x32.png)。 - 若要手动在页面之间移动,请单击下拉列表任一侧的向前和向后按钮,或者使用滑块。 - 若要跳转到特定页面,请从列表中选择该页面。 若要更改播放速度,请使用“页面”卡右下角的速度控件。 在页面之间移动时,若要留下前一页面的标记,请选择“显示历史记录”。 [跳转到主要内容](#main-content) # 创建 PDF 文件 可以将一个或多个视图打印为 PDF 文档。您无需在计算机上安装 Adobe Acrobat。 #### 发布为 PDF: 1. 如果要指定将哪些元素打印到 PDF 文件并指定这些元素的布局方式,请选择“文件”\>“页面设置”。有关详细信息,请参见[打印工作表](https://help.tableau.com/current/reader/desktop/zh-cn/print.htm)。 2. 选择“文件”\>“打印为 PDF”。 3. 在“打印为 PDF”对话框中,选择打印范围: - 整个工作簿 — 发布工作簿中的所有工作表。 - 当前工作表 — 仅发布工作簿中当前显示的工作表。 - 选定工作表 — 发布选定工作表。 ![](/tableau/current/zh-cn/reader/desktop/zh-cn/Img/rpdf3.png) 4. 选择纸张尺寸和方向。如果选择“未指定”,则纸张尺寸将为在一页上显示整个视图所需的大小。 5. 或者,如果希望在打印完成后自动打开该 PDF 文件,则可选择“打印后查看 PDF 文件”。只有在计算机上安装了 Adobe Acrobat Reader 或 Adobe Acrobat 时,才会提供此选项。 6. (可选)如果希望在 PDF 中包含所选标记和突出显示,请选择“显示选定内容”。 7. 单击“确定”并选择保存 PDF 的位置。然后单击“保存”。 8. (可选)在发布为 PDF 之前,为工作簿中的每个工作表指定[页面设置](https://help.tableau.com/current/reader/desktop/zh-cn/print.htm#psetup)。 [跳转到主要内容](#main-content) # 发布和导出 共享工作簿中的视图和数据,以及将它们包含在演示文稿和文档中。可以打印 PDF、导出到其他应用程序或者打印一个或多个工作表。 ## 此部分中的其他文章 [跳转到主要内容](#main-content) # 恢复工作簿 您可能需要撤消对工作簿所做的所有更改,使它恢复为打开时的内容。您可以将工作簿恢复为已保存的状态,而不必使用“撤消”![指向左边的箭头。](/tableau/current/zh-cn/reader/desktop/zh-cn/Img/undo.png) 按钮一步步操作。 #### 恢复工作簿: 1. 选择“文件”\>“恢复为已保存版本”。 2. 在警告对话框中单击“恢复”。 [跳转到主要内容](#main-content) # 大小图例 大小图例可以是分类图例或定量图例。分类图例表示离散类别(例如区域和订单优先级),而定量图例表示数值范围(例如交货时间或利润)。

分类图例

定量图例

[跳转到主要内容](#main-content) # 对数据进行排序 在 Reader 中,可以根据视图中所用的度量对表中的项进行排序。通过排序可以控制表中所列维度成员的顺序,并且通常可以显示字段之间的关系。 #### 对表中的项进行排序: 1. 选择要排序的项。 2. 单击工具栏上的某个排序按钮 ![](/tableau/current/zh-cn/reader/desktop/zh-cn/Img/quick_sort1_59x27.png)。 **注意:**排序按钮的工具提示显示将对表进行排序的方式。 例如,单击“升序排序”按钮在图表中按最低销售额到最高销售额的顺序对条重新排序,如下所示。 ![](/tableau/current/zh-cn/reader/desktop/zh-cn/Img/rsort2_684x465.png) 还可以通过拖动列中的字段标签来对各项进行排序。在下面的示例中,拖动“Regular Espresso”以将其移到“Mint”下面。黑线指示了新位置。 ![已排序的列。](/tableau/current/zh-cn/reader/desktop/zh-cn/Img/sortcolumn.png) 您也可以使用“图例”对视图中的项进行手动排序。若要对项进行手动排序,请执行以下步骤: 1. 在“图例”,右键单击空白中的任意位置,并从上下文菜单中选择“排序”。 2. 在“排序”对话框内的“手动”部分中,选择想要重新排序的项,然后使用“向上”和“向下”按钮在列表中移动项。 ![选择了“手动排序”选项的“排序”对话框。](/tableau/current/zh-cn/reader/desktop/zh-cn/Img/ManualSort.png) ## 重置排序顺序 可通过单击“撤消”按钮或将工作簿恢复为其已保存状态来重置表的排序方式。有关如何恢复工作簿的详细信息,请参见[恢复工作簿](https://help.tableau.com/current/reader/desktop/zh-cn/revert.htm)。 [跳转到主要内容](#main-content) # 导出数据或视图 您可以将工作簿中的数据或表示视图的图像导出到其他演示文稿和文档应用程序。 ## 导出数据 可以复制从视图中选择的数据以便在其他应用程序中使用,也可以将工作表中的所有数据导出到 Access 数据库。 #### 将数据复制到剪贴板: 1. 在视图中选择要复制的数据。 2. 右键单击(在 Mac 上按住 Control 单击)所选项,并选择“复制”\>“数据”。 3. 打开其他应用程序(例如 MS Word 或 MS Excel),然后选择“编辑”\>“粘贴”。 注意: 还可以按交叉表形式复制数据以便在 Microsoft Excel 中使用。在上下文菜单中选择“复制”\>“交叉表”。 ![](/tableau/current/zh-cn/reader/desktop/zh-cn/Img/data1.png) #### 将数据导出到 Microsoft Access: 1. 选择“工作表”\>“导出”\>“数据”。 ![](/tableau/current/zh-cn/reader/desktop/zh-cn/Img/data2.png) 2. 输入 Access 数据库的位置和名称,然后单击“保存”。 3. 在“将数据导出到 Access”对话框中,指定数据库名称和要导出的数据,然后单击“确定”。 ## 将视图导出为图像 可以复制视图以便在其他应用程序中使用,也可以将视图导出为图像文件。 #### 将视图复制到剪贴板: 1. 选择“工作表”\>“复制”\>“图像”。 2. 在“复制图像”对话框中,选择要包括的内容和图例布局(如果视图包含图例)。 ![](/tableau/current/zh-cn/reader/desktop/zh-cn/Img/image3.png) 3. 单击“复制”。 4. 打开其他应用程序(例如 MS Word 或 MS Excel),然后选择“编辑”\>“粘贴”。 注意: 在某些应用程序中,可以选择“选择性粘贴”并指定图像的格式。 #### 将视图导出为图像文件: 1. 选择“工作表”\>“导出”\>“图像”。 ![](/tableau/current/zh-cn/reader/desktop/zh-cn/Img/image4.png) 2. 在“导出图像”对话框中,选择要包括的内容和图例布局(如果视图包含图例),然后单击“保存”。 3. 完成后,单击“保存”。 4. 在“保存图像”对话框中,导航到要保存图像文件的位置,然后在文本框中键入文件名。在“保存类型”下拉列表中选择文件格式。完成后,单击“保存”。 [跳转到主要内容](#main-content) # 形状图例 形状图例只能表示分类数据,此类数据属于离散类别(例如产品和区域)。标记分为不同的形状。无法通过 Reader 编辑视图中所用的形状。 ![](/tableau/current/zh-cn/reader/desktop/zh-cn/Img/shape1_162x91.png) [跳转到主要内容](#main-content) # 打印工作表 指定页面设置选项并打印一个或多个工作表。 ## 页面设置 页面设置是有关工作表在打印时的外观的选项集合。例如,可以选择是否包含图例以及页面方向。可以为每个工作表分配不同的页面设置选项。选择“文件”\>“页面设置”打开页面设置对话框。 ![](/tableau/current/zh-cn/reader/desktop/zh-cn/Img/print1.png) 逐个浏览以下设置类别:
常规

选择要在打印时显示的工作表部分。此外,指定如何处理标题和分页符。如果视图包含页面,则可以选择是打印当前页还是打印所有页。

布局

指定图例布局、页边距和居中。

打印缩放

将视图调整到特定尺寸和更改页面方向。

## 打印 指定[“页面设置”](#psetup)选项后,可通过选择“文件”\>“打印”进行打印。在“打印”对话框中,选择一台打印机,指定打印范围,并选择要打印的份数。 ![](/tableau/current/zh-cn/reader/desktop/zh-cn/Img/print2.png) [跳转到主要内容](#main-content) # 打开工作簿 在 Tableau Reader 中,可以打开使用 Tableau Desktop 或 Tableau Server 创建的打包工作簿。使用 .twbx 文件扩展名保存的打包工作簿包含工作簿以及任何本地文件数据源和背景图像的副本。该工作簿不再链接到原始数据源和图像。 打包工作簿仅连接到诸如 Excel、Access、数据提取和文本文件之类的本地文件数据源。

若要打开 Tableau Reader 文件,请执行以下操作之一:

  • 在开始页面上单击“浏览文件”,并使用“打开”对话框导航到工作簿的位置。

    Tableau Reader 的主页。

    注意: 只有在窗格中没有其他最近打开的工作簿时,此按钮才会出现。

  • 选择“文件”>“打开”,并使用“打开”对话框导航到打包工作簿的位置。

  • 双击任意打包工作簿文件。

  • 将任意打包工作簿文件拖到 Reader 桌面图标上或拖到运行中的应用程序上。

  • 单击“打开工作簿”链接,并选择要打开的工作簿。

    注意: 只有在您之前已打开至少一个工作簿后,此链接才会出现。

打开工作簿时,工作表和仪表板在窗口底部显示为选项卡。 ![](/tableau/current/zh-cn/reader/desktop/zh-cn/Img/rsheet_navigation.png) 注意: 如果工作簿连接到 Microsoft Office 2007 数据源(Excel 或 Access),您还需要在计算机上安装 Microsoft Office 2007。您还可以咨询工作簿的作者,以将数据源保存为与您的软件兼容的版本。 [跳转到主要内容](#main-content) # 有用的 Tableau 术语 下表描述了 Reader 帮助中使用的一些常用术语。

交叉表

文本表或数字表的另一个名称。

仪表板

显示在一个位置中的多个视图的集合,您可在其中同时比较和监视各种数据。

数据源

Tableau Reader 所连接到的基础数据。您无法在 Tableau Reader 中更改数据源。

筛选器

视图上的一个控件,用于限制视图中显示的数据。例如,对“区域”应用筛选器以仅包括“西部”。

标记

数据源中的一行或多行的可视表示形式。标记类型可以是条、线、方块等。

打包工作簿

在 Tableau Desktop 或 Tableau Server 中创建的一种工作簿类型。这些文件包含工作簿以及引用的本地文件数据源和背景图像的副本。

窗格

视图中的行和列区域。

存储库位于“我的文档”文件夹中的一个文件夹,用于存储工作簿。

视图

数据在 工作表或仪表板中的可视表示形式。

工作簿

一个或多个工作表和仪表板的集合。

工作表

数据的单一视图。每个工作表可以连接到一个数据源。

[跳转到主要内容](#main-content) # 筛选数据 使用筛选来选择视图中数据的子集,以重点关注该数据或从视图中排除数据。 ## 使用标记或标题进行筛选 您可以单击标记以只选择该标记所表示的数据,使用光标选择一组标记,或者单击标题以选择一部分数据。执行此操作时,标记或标题的数据将突出显示,其他数据显示为灰色。若要再次查看所有数据,请在标记外部的任何位置单击。 ### 保留或排除数据 您可以完全移除所选数据,或者可以只保留所选数据并移除视图中的所有其他数据。 #### 保留或排除数据: 1. 选择要保留或排除的数据的标记或标题。 2. 右键单击(在 Mac 上按住 Control 单击)标记或标题,然后单击“只保留”或“排除”。 ## 使用筛选器卡 筛选器是工作表上显示一定范围的数据的卡。如果工作簿作者包括了筛选器卡,则您可以使用该卡在视图中包括和排除数据。 对于分类数据字段,筛选器显示为每个字段成员的复选框或单选按钮的列表。例如,“日期”字段的筛选器可能会列出以下成员:2011、2012、2013、2014。 ![](/tableau/current/zh-cn/reader/desktop/zh-cn/Img/rfilter1_157x125.png) 若要在筛选器中选择数据,请选择要包括的成员。 工作簿的作者还可以将筛选器设置为排除值,这意味着将从视图中筛选掉选定成员而包含其余成员。当您希望显示大多数成员并排除少数几个成员时,此模式通常非常有用。 对于度量(数值数据),筛选器显示为滑块。左右滑动手柄可定义希望在视图中包含的值范围。例如,您可以对“Sales”(销售额)度量使用筛选器,以便只包含介于 $50,000 和 $85,000 之间的值。 ![](/tableau/current/zh-cn/reader/desktop/zh-cn/Img/rfilter2_156x72.png) 若要指定精确的下限值和上限值,请单击筛选器上的其中一个数字,并输入新值。 ## 重置筛选器 通过单击“撤消”按钮或将工作簿恢复到其上次已保存状态,您可以重置筛选器以及您所做的其他更改。有关如何恢复工作簿的详细信息,请参见[恢复工作簿](https://help.tableau.com/current/reader/desktop/zh-cn/revert.htm)。 [跳转到主要内容](#main-content) # 设置首选语言 可将 Tableau 设置为用支持的语言之一来显示用户界面(菜单、消息等)。所选择的语言是用户界面 (UI) 语言。默认情况下,在安装 Tableau 时,已将语言设置为一种自动设置,该设置可识别您的 Windows 区域设置并使用相应语言(如果支持)。如果使用不支持的语言,则应用程序将默认为英语。 #### 更改语言: 1. 选择“帮助”\>“选择语言”。 2. 重新启动 Tableau Reader。 **注意**: 工作簿作者可为工作簿设置语言(区域设置),用于确定数字、日期、地图标题等的显示方式。在这种情况下,工作簿中的语言设置优先于您为 Tableau Reader 设置的语言。 [跳转到主要内容](#main-content) # 颜色图例 颜色图例可以是分类图例或定量图例。分类图例表示离散类别(例如客户名称和区域),而定量图例表示数值范围(例如销售额和利润)。

分类图例

定量图例

#### 若要编辑分类颜色图例,请执行以下操作: 1. 右键单击(在 Mac 上按住 Control 单击)图例,并选择“编辑颜色”。 2. 在左侧的列表中选择数据项,然后在右侧的色板中选择新颜色。 3. 单击“确定”。 注意:可以在“编辑颜色”对话框右上角的下拉列表中选择其他调色板。 #### 若要编辑定量颜色图例,请执行以下操作: 1. 右键单击(在 Mac 上按住 Control 单击)图例,并选择“编辑颜色”。 2. 单击色坡旁边的颜色指示器,然后在色谱中选择新颜色。 3. 还可以指定下列一个或多个选项: - 渐变颜色 — 将值分组为统一的数据桶,其中每个数据桶都指定有一个唯一颜色。 - 倒序 — 切换范围中的颜色顺序。 - 使用完整颜色范围 — 为范围中的开始数字和结束数字指定全色浓度。 (仅在使用发散调色板时可用)。 4. (可选)使用“高级”选项定义颜色范围的起始值、中心值和结束值。 5. 完成后,单击“确定”。 注意: 可以在“编辑颜色”对话框顶部的下拉列表中选择其他调色板。