---
schema_version: "1"
id: dbe8dfd3a9ef9640efeeea78feaf7d0cbb68ba5c52cf62a412c7d2891a327e26
title: 编辑数据源
collection: tableau
version: current
locale: zh-cn
portal_url: https://docs.salesforce.com/tableau/current/zh-cn/public/desktop/howto_connect.md
canonical_url: https://help.tableau.com/current/public/desktop/zh-cn/howto_connect.htm
source_site: help.tableau.com
content_type: documentation
content_hash: 6598e4d4ed369d87b867e3693b2f811a64e16adc9e95f2feb33272c06c51d231
description: Edit data sources, including joining tables, creating calculations, and renaming fields.
---
[跳转到主要内容](#main-content)

# 编辑数据源

若要增强工作簿的功能，请修改它所依赖的数据源。通过编辑数据源，您可以完成各种任务，例如通过联接操作添加表。若要详细了解常见编辑任务，请参见这些资源：

- **将表添加到数据中**：了解如何[组合数据源中的多个表](https://help.tableau.com/current/pro/desktop/zh-cn/relate_tables.htm)以获得全面的见解并进行更明智的分析。
- **连接到自定义 SQL 查询 (Tableau Desktop)**：了解如何[连接到自定义 SQL 查询](https://help.tableau.com/current/public/desktop/zh-cn/customsql.htm)，使用 SQL 的强大功能根据您的特定要求提取和操作数据。
- **使用存储过程 (Tableau Desktop)**：深入了解何时[使用存储过程](https://help.tableau.com/current/public/desktop/zh-cn/connect_basic_stored_procedures.htm)，使您能够对数据执行预定义的一组操作或计算。

## 如何编辑数据源

1. 从任何工作表的“数据”菜单上，选择数据源。
2. 选择“编辑数据源”。
3. 在数据源页面上，对数据源进行更改。数据表使用新数据源中的数据进行更新。

![在 Tableau 上连接到数据源。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/howto_connect_img_1.01.png)

  

## 数据网格导航

在“数据源”页面中，您可以选择分析和可视化数据。其中一个选项是排序，它使您能够以结构化方式排列数据。通过对列和行进行排序，您可以轻松组织和理解手头的信息。

### 对列进行排序

对列进行排序是一种简单有效的数据排序方式。无论您喜欢根据表还是数据源对它们进行排序，这个过程都很简单。在网格中，您可以通过访问“排序字段”下拉列表并选择所需的排序选项来对列进行排序。

![显示数据源顺序选项的下拉菜单。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/grid_sort_columns.png)

**注意：**当某些任务导致向网格中添加了新列时，可能会出现“已修改”排序状态。

### 对行进行排序

若要按特定顺序排列行，只需使用排序按钮即可。单击一下即可按升序对行进行排序。对于降序排序，请再次单击排序按钮。若要移除选择，请再次单击排序按钮。

![客户名称下拉列表，按字母顺序升序排列。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/grid_sort_rows.png)

## 更改和重置字段名称

在 Tableau 中，拥有清晰且有意义的列（字段）名称对于有效的数据分析和可视化至关重要。

### 重命名字段

若要在 Tableau 中重命名字段，请执行以下操作：

1. 查找您要更改其名称的字段。
2. 双击当前名称。
3. 为字段输入新名称。
4. 按 Enter 或在字段外部单击以保存更改。

![按升序排序的客户名称。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/grid_rename_column.png)

### 重置名称

如果您对字段名称进行了更改并想要恢复为原始名称，Tableau 提供了重置选项:

1. 单击字段下拉菜单。
2. 选择**“重置名称”**。

该名称将重置为其基础数据中指定的原始名称。

![选择了“重置名称”的下拉菜单。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/grid_reset_name.png)

### 恢复自动名称更改

“恢复”命令将重置通过 Tableau 命名改进自动修改的任何字段名称。有关详细信息，请参见[了解字段类型检测和命名改进之处](https://help.tableau.com/current/public/desktop/zh-cn/data_clean_adm.htm)。

### 创建计算。

计算使您能够执行复杂的数据操作并从现有数据集中获得新的见解。Tableau 提供三种主要类型的计算：

- 基本表达式
- 详细级别 (LOD) 表达式
- 表计算

有关选择要使用的计算的帮助，请参见[选择正确的计算类型](https://help.tableau.com/current/pro/desktop/zh-cn/calculations_calculatedfields_understand_which.htm)。

您可以基于数据源中的现有字段创建计算、组或数据桶。若要开始操作，请单击列下拉箭头并选择其中一个选项。

**注意：**如果创建聚合计算，则网格中显示的值没有意义，直至在视图的详细级别上下文中使用计算为止。

![下拉菜单显示用于创建计算字段的所选选项。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/grid_calcs_groups_bins.png)

### 查看数据提取数据

使用 Web 数据连接器时，您可以在网格中查看提取的数据。这包括纯数据提取计算，例如 MEDIAN。请务必注意，在数据提取模式下，数据源中的行顺序可能与实时模式下的行顺序不同。

![显示 MEDIAN 销售额的数据提取计算的视图。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/grid_extract.png)

### 复制值

若要复制网格中的值，请按照下列步骤操作。

1. 选择所需的值。
2. 右键单击选定的值。
3. 从菜单中选择**“复制”**。

## 检查您的语义

使用 Tableau 中的元数据网格分析和修改数据源的语义。网格提供了一种评估数据中的列及其各自数据类型的方法。您可以执行例行管理任务，例如列重命名、隐藏、更改数据类型以及修改列的地理角色。

**注意：**当处理多维数据集数据源时，具体的语义管理任务可能会有所不同。

### 默认语义视图

成功配置数据源后，信息将出现在网格中。在连接到多维数据集（多维）数据源时，数据将自动呈现。对于 Salesforce 或 Tableau 数据提取等替代数据源类型，默认视图可能有所不同。

### 查看语义

元数据网格将数据源中的列显示为行，提供有关每列的基本信息。这包括列的数据类型、Tableau 中的字段名称以及远程字段名称。

### 管理语义

根据所连接到的数据类型，您可以执行像一次性隐藏多个列或快速重命名列这样的任务。

## 更改数据源在工作簿中的位置

当您处理工作簿中的数据时，有时可能需要更改数据源的位置。无论数据源的名称或位置已更改，还是您想要将分析应用到类似的数据源，本部分都将引导您完成将工作簿重定向到正确位置的过程，而不会丢失任何工作。

### 更改数据源的位置

1. 在“数据”窗格中右键单击希望编辑的数据源。
2. 从菜单中，选择**“编辑连接”**。
3. 在“编辑连接”对话框中，您有两个选项：
    - 通过浏览计算机的文件系统转到数据源的新位置。
    - 通过单击**“浏览”**按钮并选择不同的文件来完全选择一个新的数据源。
4. 选择新位置或数据源后，选择**“确定”**保存更改。

![显示与 Microsoft Excel 文件的连接的 Tableau 窗口。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/howto_connect_img_201.png)

## 替换字段引用

替换数据源之后，使用原始数据源的工作簿中的所有工作表将更新为新数据源。但是，如果新数据源的字段名与原始字段名不同，则会以感叹号标记无效字段。若要解决此问题，请替换这些字段的引用。

假设您有一个连接到某个数据源的工作簿，其中包含一个名为“Customer Name”（客户名称）的字段。您替换数据源，并且其中一个字段名称为“Name”（名称）。在这种情况下，“Customer Name”（客户名称）字段仍会出现在“数据”窗格中，但被标记为无效。

若要使该字段再次有效，请替换其引用。这意味着您可以将无效字段映射到新数据源中的有效字段。在此处，将“Customer Name”（客户名称）映射到“Name”（名称）。

![数据源字段。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/howto_connect_img_501.png)

### 替换字段引用

1. 在“数据”窗格中右键单击（在 Mac 上按住 Control 单击）无效字段。
2. 选择**“替换引用”**。
3. 在“替换引用”对话框中，从新数据源中选择一个与无效字段相对应的字段。

![字段上下文菜单，带有替换引用的选项。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/howto_connect_img_502.png)

## 重命名数据源

当您在 Tableau Desktop 中建立与数据源的连接时，系统会提示您为其指定名称。此名称用于标识 Tableau 中的数据源，当您在单个工作簿中有多个数据源时，此名称会很有帮助。它允许您跟踪每个连接的具体细节。

### 重命名数据源

1. 转到“数据”菜单。
2. 选择**“重命名”**。

通过适当命名连接，您可以轻松区分不同的数据源并有效地管理它们。还可以通过在“数据”菜单上选择数据源并选择**“属性”**来查看连接的属性。

![数据源窗格上的“编辑连接”选项。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/howto_connect_img_401.png)

## 复制数据源 (Tableau Desktop)

有时，您需要对数据源进行更改，例如添加更多表、隐藏和显示字段或设置字段默认值。进行这些更改会影响使用该数据源的所有工作表。您可对数据源进行复制，以便能够进行更改而不影响现有工作表。若要在 Tableau Desktop 中复制数据源，请执行以下步骤：

1. 在 Tableau Desktop 中打开工作簿。
2. 转到屏幕顶部的“数据”菜单。
3. 选择要复制的数据源。
4. 从下拉菜单中选择**“复制”**。

**注意：**复制数据源后，副本的名称将附加“副本”。这确保您可以区分原始源和重复源。

![复制数据源并将其拖到画布上。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/howto_connect_img_301.png)