---
schema_version: "1"
id: f0e47f81e723187c7cbacef09e43efac7d2b7eb17c2825045d76e2e2c7b85402
title: 针对辅助功能制作视图
collection: tableau
version: current
locale: zh-cn
portal_url: https://docs.salesforce.com/tableau/current/zh-cn/public/desktop/accessibility_create_view.md
canonical_url: https://help.tableau.com/current/public/desktop/zh-cn/accessibility_create_view.htm
source_site: help.tableau.com
content_type: documentation
content_hash: cf8041b192497a10ab5911de9683e523fd786252fabd0a7e907ade0d3e746772
description: Author and publish WCAG-compliant accessible views in Tableau Desktop, including descriptive alt text and titles.
---
[跳转到主要内容](#main-content)

# 针对辅助功能制作视图

本文提供[设计无障碍视图的最佳做法](https://help.tableau.com/current/public/desktop/zh-cn/accessibility_best_practice.htm)中所讨论设计准则的详细信息，并逐步介绍如何在 Tableau Desktop 中创建这些视图。

## 常规步骤

作为内容作者，您可以按照以下一般步骤创建有助于您符合 Web 内容辅助功能准则 (WCAG) 的视图：

**步骤 1：**按照辅助功能最佳实践制作视图。

**步骤 2：**将视图发布到 Tableau Server 或 Tableau Cloud（版本 10.2 及更高版本）。

**步骤 3：**共享链接，以便用户访问 Tableau Cloud 或 Tableau Server 中的内容，或将视图嵌入网页中。

通过使用最佳实践指南创建视图可以使它们更易于访问；屏幕阅读器将它们视为带有标题和描述的图像。用户将能够使用键盘导航打开“查看数据”窗格，以及访问视图的基础数据。

## 构建视图

在 Tableau 中创建高效视图时所适用的许多原则也适用于创建易于访问的视图。创建易于访问的视图的主要不同之处在于，当您在视图中使用颜色时，应始终提供其他类型的标记编码。您还希望在视图中更自由地使用文本，为视图及其标记提供上下文。

### 保持简单

在创建易于访问的视图时，使视图保持简单。保持简单可帮助用户更轻松地了解数据中的关系和交集。

如何才能使视图更加简单？只强调最相关和最重要的数据。减少视图中的标记数，仅显示所需要的标记。限制视图中的详细级别和粒度以防止认知超载。

设计视图时，请谨记，用户将会访问视图中的基础数据。您包括在视图中的数据就是屏幕阅读器在“查看数据”窗格的“摘要”选项卡中读取的数据。

保持简单的相关准则：

- [限制视图中的标记数](#LimitMarks)
- [调整视图方向以实现易读性](#OrientForLegibility)
- [限制单个视图中的颜色和形状数](#LimitColorsShapes)
- [在给定时间使用筛选器减少视图中的标记数](#UseFiltersInViews)

#### 限制视图中的标记数

使标记数保持在 1000 个以下，确保视图将在浏览器中（而不是服务器上）渲染。

**注意**：客户端呈现的视图比服务器呈现的视图更易于访问。为了确保嵌入的视图在浏览器中渲染，务必要使视图包含的标记数少于 1000（包括图例和筛选器中的项）。

在 Tableau Desktop 中制作视图时，您可以（在窗口的左下角）看到视图中的标记数。

包含太多标记的视图示例

此示例显示的视图包含超过 20,000 个标记。该视图显示（相对聚合视图而言）更加细化的数据详细级别。视图中已添加了多个维度（“Region”（区域）、“Category”（类别）、“Sub-Category”（子类））以及度量（“Sales”（销售额）、“Profit”（利润）、“Profit per Order”（每订单利润）和“Profit Ratio”（利润率））。“Product Name”（产品名称）位于“详细信息”上，从而为数据集中包括的每个产品增加了一个标记。

![包含超过 2000 个标记的可视化项](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_toomanymarks.png)

**标记数较少的视图示例**

下一个示例显示更易于访问的视图（少于 100 个标记）。数据已聚合，并显示较粗略的数据详细级别。视图中使用了两个维度（“Region”（区域）和“Product Category”（产品类别））以及一个度量（“Sales”（销售额））。

有关这些概念的更多详细信息，请参见[Tableau 中的数据聚合](https://help.tableau.com/current/public/desktop/zh-cn/calculations_aggregation.htm)以及[维度会对视图中的详细级别产生怎样的影响](https://help.tableau.com/current/public/desktop/zh-cn/datafields_typesandroles.htm#DimLOD)。

![包含少于 100 个标记的可视化项](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_fewermarks.png)

可通过多种方式来限制标记数：

- 创建聚合数据的视图，而不是在视图中显示更加细化的详细级别。不要将包含数千个值的维度放在“标记”卡区中的**“详细信息”**功能区上。
- 如果要使用分层结构中的维度，但不想让视图中有分层结构，请使用该特定维度的副本。复制要使用的字段，并使用复制的维度版本构建视图。
    
    这会使用户无法展开嵌入视图中的分层结构，从而可能增加视图中的标记数，导致视图在服务器上（而不是浏览器中）渲染。
    
    ![复制维度的菜单过程](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_nonhierarch_dimension.png)
    
    1. 右键单击分层结构中的某个维度，然后选择“拷贝”。该维度的副本将出现。
    2. 右键单击复制的维度，然后选择“重命名”。为复制的维度指定一个有意义的唯一名称。现在使用该维度来构建视图。
- 限制用于创建视图的度量和维度的数量。
    
    **不易于访问**：“行”上有三个度量，“列”上有四个维度。字段更多，创建的视图就更复杂。
    
    ![复杂视图，“行”上有四个度量，“列”上有三个维度](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_toomanyfields.png)
    
    **更易于访问**：“列”上有两个维度，“行”上有一个度量。视图结构中的字段越少，认知超载就越轻。
    
    ![简化的视图，“列”上有两个维度，“行”上有一个度量](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_fewerfields_cbpalette.png)

#### 调整视图方向以实现易读性

相对于垂直方向的标签，水平方向的标签和标题更易于阅读。

**不易于访问**：在此示例中，文本垂直显示。

![带有垂直标签的柱形图](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_verticalmarklabels.png)

**更易于访问**：在此示例中，视图中增加了空间，使文本能够水平显示。

![带有水平标签的柱形图](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_horizontalmarklabels.png)

若要更改视图及其标题和标签的方向，您可以单击工具栏上的**“交换”**按钮，或者可以调整视图大小，为水平标签留出更多空间。在此示例中，表的大小已调整。有关详细信息，请参见[调整表和单元格的大小](https://help.tableau.com/current/public/desktop/zh-cn/formatting_resizetable.htm)。

![显示并放大了调整大小图标的柱形图。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_resizeview.png)

#### 限制视图中颜色和形状的数量

如果要在“颜色”或“形状”上显示维度，请不要在一个视图中使用超过 10 个颜色和形状，这样用户将能区分每个颜色和形状，并看到重要模式。

**不要这样做**：在以下示例中，线条颜色在应用于产品类型的第 10 个标记后已开始重复。

![具有超过 10 个标记的复杂折线图，其中颜色在 10 个标记后开始重复](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_toomanyshapesandcolors.png)

**要这样做**：在下一个示例中，使用了筛选器来限制一次可显示的标记数。结果是，视图中颜色和形状的数量绝不会超过 10。

![带有已筛选标记的视图，以便一次显示的标记不超过 10 个](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_lessthan10marks.png)

#### 使用筛选器减少视图中的标记数

筛选器有助于让视图中一定数量的标记重点显示您希望用户看到的内容。有关创建筛选器的更详细信息，请参见[筛选视图中的数据](https://help.tableau.com/current/public/desktop/zh-cn/filtering.htm)。

您也可以使用以下筛选器模式，以允许用户控制视图中的数据。Tableau 中支持更易于访问的视图的筛选器模式包括：

- **单值(列表)**：具有单选按钮的筛选器。一次只能选择一项。为用户提供单值筛选器可以很好地减少视图中的标记数。
- **多值(列表)：**具有可同时选择的一系列项目（带复选框）的筛选器。多值筛选器将允许同时显示多个标记。
    
    ![带有单选按钮的单值列表，后跟带有复选框的多值列表](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_filters_list.png)
- **单值(下拉列表)**：包含项目下拉列表的筛选器。一次只能选择一项。为用户提供单值筛选器可以很好地减少视图中的标记数。
- **多值(下拉列表)：**具有可同时选择的项目下拉列表的筛选器。多值筛选器将允许同时显示多个标记。
    
    ![单值下拉列表，后跟带有复选框的多值下拉列表](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_filters_dropdown.png)

若要显示筛选器，请右键单击要用作筛选器的字段，然后选择“显示筛选器”。

![订单日期的子菜单，带有显示筛选器的选项](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_showfilter_date.png)

若要选择筛选器模式，请在筛选器下拉菜单中选择“单值(列表)”、“单值(下拉列表)”、“多值(列表)”或“多值(下拉列表)”筛选器。

![下拉菜单，其中突出显示单值列表、单值下拉列表、多值列表和多值下拉列表选项。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_selectfiltertype.png)

对于“单值(列表)”或“单值(下拉列表)”筛选器，您可以从筛选器中移除“全部”选项。在筛选器下拉菜单中，选择“自定义”，然后清除“显示‘所有’值”选项。

下图显示筛选器中的**“自定义”**选项。

![一个筛选器下拉菜单，带有一个用于定制的子菜单，其中显示了用于显示所有值的选项。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_hideshowall.png)

在工作表中使用多个筛选器时，请谨记以下准则：

- 在创建视图时，将浏览器放大到 200% 进行测试，确保视图中的所有组件都按预期方式显示。
- 避免将筛选器水平放置在工作表中。如果浏览器窗口不够宽，视图中的组件（例如筛选器）将与可视化项重叠。
- 不要在将筛选器添加到视图后改变其位置。如果改变筛选器的位置或顺序，则 Tab 顺序可能会更改。

此示例显示的视图包含针对产品类别的“单值(列表)”筛选器，以及针对产品订单日期的“多值(列表)”筛选器。“单值(列表)”筛选器仅允许一次显示一种产品类型（“全部”处于隐藏状态）。

![ 一个视图，带有针对产品类别的“单值列表”筛选器，以及针对产品订单日期的“多值列表”筛选器。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_filtertolimitmarks.png)

### 显示更多文本并使其有用

在视图中，确保显示标题、说明和标记标签。您可以编辑标题和说明，以提供可帮助用户理解视图的更多上下文和详细信息。

- 要明确一致地说明如何命名视图中的每个对象。
- 提供对可视化项各个组件的关系进行说明的文本。
- 简化文本以移除冗余内容。

您也可以在“数据”窗格中重命名度量和维度，以确保视图中的字段名称有意义。

您可以在视图中显示和编辑以下不同元素：

- **标题（工作表、筛选器和图例）**。显示工作表、筛选器和图例的标题。默认标题文本是筛选器或图例引用的工作表名称或字段名称。您可以编辑任何标题以提供更多上下文。
- **说明（工作表内）**。在工作表中显示说明。默认说明文本提供视图中所显示内容的摘要。您可以添加此文本以提供更多上下文。
- **标签（“标记”卡、“标签”按钮）**。默认情况下，视图中不显示标签，因此您必须选择相应选项以显示标签。

**不易于访问**：此示例显示包含有限文本的视图。许多文本元素未显示：工作表说明、标记标签、描述性标题以及“标题”区域中有关视图的附加文本。并且，未对筛选器和图例标题进行编辑来提供更多上下文。

![带有有限文本的气泡图。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_lackoftext.png)

**更易于访问**：此示例显示同一视图，但显示了多个文本元素来提供更多详细信息和上下文。工作表中显示了标题和说明。工作表标题经过编辑，包括了描述视图中数据显示方式的文本。工作表说明包括 Tableau 自动生成的默认摘要文本。图例标题经过编辑，在此视图中更有意义。标记标签显示利润值，因此用户不必只靠查看颜色来了解。

![添加了标题和说明文字以提供详细信息的气泡图。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_helptextbulbblechart.png)

您也可以构建仅显示文本的视图，例如显示类似数据的此文本表视图示例。

![具有 6 列和一个筛选器的文本表。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_table.png)

显示和编辑工作表的标题和说明

1. 选择“工作表”\>“显示标题”，然后选择“工作表”\>“显示说明”。
    
    ![工作表下拉菜单，旁边带有复选标记，显示标题和显示说明文字](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_showtitlescaptions.png)
2. 在视图顶部的“标题”框中，单击下拉菜单，然后单击**“编辑标题”**。
    
    ![突出显示“编辑标题”的标题下拉框](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_editworksheettitle.png)
    
    在文本区域中键入文本并设置其格式，然后单击**“确定”**。您可以添加除标记文本之外的文本，或者替换标记文本。
3. 在“说明”框中，单击下拉菜单，然后单击**“编辑说明”**。
    
    ![突出显示“编辑说明文字”的说明文字下拉框](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_editcaption.png)
    
    在文本区域中键入文本并设置其格式，单击下拉菜单，然后单击**“确定”**。您可以添加除默认文本之外的文本，或者替换默认文本。

在视图中显示标记标签

- 在“标记”卡中单击**“标签”**，然后单击**“显示标记标签”**。
    
    ![标签菜单展开且显示标记标签框已选中的标记卡](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_showmarklabels.png)

在“数据”窗格中编辑字段名称

1. 右键单击维度或度量，然后单击**“重命名”**。
    
    ![字段选项菜单，显示用于重命名字段的选项。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_renamefield.png)
2. 编辑名称，然后按 Enter。
    
    有关更多详细信息，请参见[重命名字段](https://help.tableau.com/current/public/desktop/zh-cn/datafields_dwfeatures.htm#Rename)。

编辑筛选器或图例标题

与图例和筛选器关联的文本应清晰地描述其用途。编辑筛选器和图例的标题以指明功能。在工作表标题或说明中提供的任何指示中按名称引用筛选器。

1. 单击筛选器下拉菜单，然后单击“编辑标题”。
    
    ![筛选器的下拉菜单，显示用于编辑筛选器标题的选项。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_editfiltertitle.png)
2. 编辑文本，然后选择**“确定”**。
    
    ![编辑标题格式设置框，其中包含用于更改标题、字体、大小和字体样式的选项。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_editfiltertitle2.png)

#### 字体大小  

增加文本的字体大小可以使其更易于访问。选择“格式”\>“工作簿”以更改整个工作簿的默认文本大小。有关更多详细信息，请参见[设置工作内容的格式](https://help.tableau.com/current/public/desktop/zh-cn/formatting.htm)。  
  
![Tableau Desktop 中的工作簿格式设置菜单](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_wkbkformat1.png) ![Tableau Desktop 中工作簿级别的“设置字体格式”菜单](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_wkbkformat2_defaults.png)  

您还可以在工作表级别更改字体大小。

### 编辑替代文本以使其更具描述性（Tableau Cloud 和 Tableau Desktop）

从 Tableau Cloud 23.2 和 Tableau Desktop 23.3 开始，您可以自定义 Tableau 自动生成的替代文本，这有助于使其对您的受众更具描述性和更有意义。替代文本描述图像在网页上的外观或功能，可由屏幕阅读器朗读出来。它是在网页代码中实现的，不会显示在可视化项上。

在仪表板中，您可以通过上下文菜单访问替代文本编辑器。

1. 点击可视化项将其选中，展开“更多选项”菜单，然后选择“辅助功能”。
2. 更新替代文本描述框中的替代文本，然后选择“确定”。  
      
    ![在仪表板中处理以将替代文本添加到可视化项](/tableau/current/zh-cn/public/desktop/zh-cn/Img/accessibility_dashboard_alttext.gif)

在工作表中，您可以通过工具栏或“数据指南”窗格访问替代文本编辑器。

从工具栏中：  

1. 选择“工作表”，并选择“辅助功能”。
2. 更新替代文本描述框中的替代文本，然后选择“确定”。

从“数据指南”窗格中：

1. 在制作模式下，通过单击“数据指南”![数据指南图标，以路标上的标志表示。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/dataguideicon.png) 图标打开“数据指南”窗格。
2. 在“辅助功能”下，选择“编辑替代文本”。  
      
    ![数据指南窗格中的辅助功能框可编辑替代文本](/tableau/current/zh-cn/public/desktop/zh-cn/Img/accessibility_alttext.png)
3. 更新替代文本描述框中的替代文本，然后选择“确定”。

**注意：**您必须处于制作模式才能编辑替代文本。如果您无权访问“数据指南”，请咨询您的管理员。他们可能隐藏了您组织的“数据指南”。

## 控制标记播报

您可以选择当用户在视图中导航标记时屏幕阅读器读取的信息。这允许您自定义详细级别，并为您的受众群体提供更加个性化的体验。

### 播报标记元数据（默认）

默认情况下，屏幕阅读器会播报标记元数据，其中包括所选标记的字段名称及其对应的值。此设置可确保即使您尚未为视图配置工具提示，数据也可访问。

### 播报工具提示内容

您可以更改此设置，以便屏幕阅读器播报工具提示的内容，而不是原始元数据。如果自定义了工具提示以提供比字段列表更容易理解的叙述或特定上下文，这通常是最佳选择。

例如，对于地图视图，工具提示播报更容易理解。地图元数据通常包括纬度和经度坐标，当辅助技术朗读这些内容时，可能很难理解。即使您尚未自定义工具提示，选择此选项通常也能为地图用户提供更易读且更有意义的体验。

在工作表中，您可以通过工具栏或“数据指南”窗格更改屏幕阅读器朗读的内容。

从工具栏中：  

1. 选择“工作表”，并选择“辅助功能”。
2. 选中“对标记上的替代文本使用标记工具提示”旁边的框，然后选择“确定”。  
      
    ![辅助功能对话框，显示自定义可视化项替代文本的选项，以及一个复选框，指明为标记上的所有替代文本使用标记工具提示。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_mark_tooltips.png)

从“数据指南”窗格中：

1. 在制作模式下，通过单击“数据指南”![数据指南图标，以路标上的标志表示。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/dataguideicon.png) 图标打开“数据指南”窗格。
2. 在“辅助功能”下，选择“编辑替代文本”。
3. 选中“对标记上的替代文本使用标记工具提示”旁边的框，然后选择“确定”。

**注意**：如果使用工具提示的选项在辅助功能设置中不可用（灰显），则意味着工具提示对于该工作表已禁用。若要允许辅助技术播报工具提示内容，您必须首先为可视化项启用工具提示。

## 考虑周到地使用颜色并提供对比度

根据放在“标记”卡中“颜色”上的字段的类型，可以使用不同的调色板。对于您使用的任何调色板，请确保提供足够的对比度，并分配在深淡色谱上彼此不同的颜色。

- 对于维度（离散），建议的做法是使用“色盲”调色板。您可能需要调整分配给不同维度值的颜色。尝试提供足够的对比度，并分配在深淡色谱上彼此不同的颜色。对于单色，请尝试**“渐变颜色”**设置为 5 的**“西雅图灰”**调色板。
- 对于度量（连续），请尝试“渐变颜色”选项设置为 5 的“蓝色”或“橙色-蓝色发散”调色板。您可能需要调整使用的色阶数。对于单色，请考虑**“渐变颜色”**设置为 5 的**“灰色”**调色板。

对于文本颜色，一般准则是文本和文本图像的视觉呈现至少具有 4.5:1（大文本为 3:1）的对比度。Tableau 的默认颜色格式设置遵循这些规定的对比度。您可以使用[对比分析器](https://www.paciellogroup.com/resources/contrastanalyser/)工具来测试文本颜色和背景的对比度。

**重要信息**：在视图中使用颜色时，您还必须提供其他类型的标记编码，例如标签、大小、形状和位置。不要仅仅依靠颜色来传达标记的不同之处。

#### “颜色”上的维度

**不易于访问**：此视图显示放在“颜色”上的一个离散维度的示例，其设置为“Tableau 20”调色板。线条路径提供了有用的位置信息，但无法通过颜色清晰地区分各个线条标记。

![具有离散维度的视图，放置在标记卡上的“颜色”上，该视图设置为 Tableau 20 调色板](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_confusingcolor.png)

**更易于访问**：在下一个示例中，使用的是“色盲”调色板。还使用了形状来加强用颜色显示的内容。

![具有离散维度的视图，放置在标记卡上的“颜色”上，该视图设置为色盲调色板。维度也被放置在形状上，以加强用颜色显示的内容。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_lessthan10marks.png)

#### “颜色”上的度量

**不易于访问**：此视图显示放在“颜色”上的一个连续度量的示例，其设置为带渐变色的“水蓝色”调色板。视图的颜色对比不够强烈，深淡色谱上的对比也不够。使用大小对此视图有所帮助，但对于有色觉缺陷的用户而言，这种调色板可能很难让他们看到标记之间的对比差异。

![使用蓝青色调色板的气泡图。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_bubble_notgoodcolor.png)

**更易于访问**：此视图使用带有渐变颜色的“橙色-蓝色发散”调色板。此调色板改进了标记之间的对比度。

![使用具有阶梯颜色的橙蓝色发散调色板的气泡图。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_bubble_goodcolor.png)

选择调色板

视图中的“颜色”上必须已经有度量或维度，此选项才可用。

1. 在“标记”卡上单击**“颜色”**，然后单击“编辑颜色”。
2. 对于“选择调色板”，单击下拉箭头并选择调色板。
    
    此示例显示选择“色盲”调色板的操作。
    
    ![标记卡上的编辑颜色菜单中显示的色盲调色板。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_colorblindpalette.png)
    
    对于“色盲”调色板，单击**“分配调色板”**，然后单击“确定”。否则，单击**“确定”**。
    
    更改值的颜色：
    
    1. 单击左侧位于“选择数据项”下的一个值。
    2. 在右侧的调色板中单击一种新颜色。将光标悬停在色卡上来确定颜色。为想要更改的多个值重复该步骤。
    3. 单击“确定”退出“编辑颜色”对话框。
    
    以下示例显示“渐变颜色”设置为 5 个色阶的“橙色-蓝色发散”调色板。
    
    ![“渐变颜色”设置为 5 个色阶的“橙色-蓝色发散”调色板。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_orangebluepalette.png)
3. 对于“色盲”调色板，单击**“分配调色板”**，然后单击“确定”。否则，单击**“确定”**。
    
    有关颜色和调色板的详细信息，请参见[颜色属性](https://help.tableau.com/current/public/desktop/zh-cn/viewparts_marks_markproperties.htm#ColorProp)。

### 提供颜色以外的视觉提示：位置、大小和形状

为字段值使用颜色时，您还必须提供其他类型的标记编码，[例如标签](#UseText)，以及位置、大小和形状。为相同字段值使用位置、大小或形状以加强标记之间的差异。这些机制都可向用户传达有关数据的信息。

如果使用颜色来显示度量或维度值，请确保为分配给不同标记的颜色提供足够的深淡色谱对比。

**不易于访问**：此示例显示未使用颜色、形状或大小来创建对比的同一散点图。标记的位置提供了有意义的信息，但视图还可以使用更多视觉提示。

![一个散点图，未使用颜色、形状或大小来创建对比](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_suboptimal_scatterplot.png)

**更易于访问**：此示例显示一个基于颜色和形状使用的计算字段，名为“Quadrant”（象限）。用了位置、颜色和形状来区分每个标记。轴也阐明了标记位置和含义。

![一个散点图，其中包含用于创建对比度的颜色、形状和大小以及用于阐明位置的轴。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_scatterplotstructure.png)

### 组合使用

下面的这个示例演示文本、形状、颜色和大小如何能结合在一起创建一个易于访问的视图。销售额由每个圆形（标记）的大小表示。利润由颜色和文本表示。视图的标题和说明已显示，并经过编辑来提供更多上下文。筛选器和图例标题也已经过编辑来提供更多上下文。

![一个气泡图，其中的文本、形状、颜色和大小结合在一起创建一个易于访问的视图。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_allinone.png)

## 演练：从不易于访问到更易于访问的过程

让我们将一个不很容易访问的 Viz 转换为一个很容易访问的 Viz。这个起始视图中的数据具有比较细化的详细级别和结构，可能会导致屏幕阅读器认知超载。

![带有大量标记、最少文本和极小颜色对比度的水平条形图。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_walkthru_originalview.png)

此视图设计为显示每个销售区域的销售总额以及利润率，用于确定哪些类型的产品看起来销量很好，但实际上不盈利。也显示了利润以及每订单利润。

我们将根据本文中前面提到的[概念和最佳做法](#BuildAccViews)对其进行更改。

### 步骤 1：减少视图中的详细级别。

由于“Product Name”（产品名称）维度位于“详细信息”上，因此数据集中的每个产品在视图中都用一个标记表示。

- 从“详细信息”中移除“Product Name”（产品名称）。这一更改可将视图中的标记数从超过 20,000 个减少到 272 个。

减少视图中的标记数可帮助确保嵌入视图将在服务器（而不是浏览器）上渲染。

![具有 272 个标记的水平条形图](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_walkthru_limitdetail.png)

### 步骤 2：创建聚合程度更高的数据视图。

1. 减少“列”上的度量数以及“行”上的维度数。
2. 移除“Region”（区域）（我们可以为区域使用筛选器）。标记数变为 68。
3. 将“Category”（类别）和“Sub-Category”（子类）（这两个维度都是产品分层结构的一部分）替换为已重命名为“Product category”（产品类别）和“Product type”（产品类型）的副本（不是分层结构的一部分）。移除“Sub-Category”（子类）筛选器。
    
    这样做会使用户无法展开嵌入视图中的分层结构，从而可能增加视图中的标记数，导致视图在服务器上（而不是浏览器中）渲染。

![具有 68 个标记的水平条形图。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_walkthru_limitdimensions.png)

此视图的聚合和简化程度已经更高，但我们将继续操作。

- 将“Profit”（利润）、“Profit per Order”（每订单利润）和“Profit Ratio”（利润率）从“列”功能区移到**“工具提示”**。

标记数现在为 17。数据中的基础详细信息将仍然可在“查看数据”窗口中找到，但减少的标记数可确保视图将更易于访问，因为视图将在浏览器中渲染。

![具有 17 个标记的水平条形图。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_walkthru_limitmeasures.png)

### 步骤 3：检查调色板设置。

调色板设置为“橙色-蓝色发散”。

- 将**“渐变颜色”**设置为 5。

![具有 17 个标记的水平条形图，使用橙蓝色发散调色板，渐变颜色设置为 5。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_walkthru_steppedcolor.png)

### 步骤 4：更新并在视图中显示文本。

1. 更改标题以使其对新视图有意义。
2. 显示工作表说明。
3. 显示标记标签。
4. 将“Profit Ratio”（利润率）拖到“标记”卡中的“标签”。
5. 编辑筛选器和图例标题。

![具有 17 个标记的水平条形图，使用橙蓝色发散调色板，渐变颜色设置为 5，并带有标题、标记标签和工作表说明文字。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_walkthru_text.png)

### 步骤 5：打开“查看数据”窗口并显示“摘要”选项卡。

这是对于此视图屏幕阅读器将读取的文本。四个度量包括在每种产品类型的基础数据中。

![“查看数据”窗口的“摘要”选项卡显示可视化项的基础数据表](/tableau/current/zh-cn/public/desktop/zh-cn/Img/access_walkthru_viewdata_summary.png)

### 发布到 Tableau Public

为了防止用户在视图工具栏中看到“编辑”选项，请在发布工作簿时将“Web 编辑”权限设置为“拒绝”。当您发布不应允许用户访问 Web 编辑模式的工作簿时，您还应告知 Tableau Cloud 管理员。

1. 在 Desktop 中，选择“服务器”>“发布工作簿”。
2. 在“权限”下，选择“编辑”，选择“所有用户”，然后再次选择“编辑”。
    
    ![选中了所有用户的 Web 编辑权限框。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/accessibility_web_edit_allusers.png)
3. 对于“Web 编辑”权限，选择“拒绝”。单击“应用”，然后单击“确定”。
    
    ![对于所有用户设置为选中的 Web 编辑单选按钮。](/tableau/current/zh-cn/public/desktop/zh-cn/Img/accessible_web_edit_permissions.png)