---
schema_version: "1"
id: dbfb3cb941f77f0fa153b41b76e0435fe9a1fd821cba842f1135caf0ac796ed7
title: 在 Web 上编辑 Tableau 视图
collection: tableau
version: current
locale: zh-cn
portal_url: https://docs.salesforce.com/tableau/current/zh-cn/pro/desktop/web_author_build_view.md
canonical_url: https://help.tableau.com/current/pro/desktop/zh-cn/web_author_build_view.htm
source_site: help.tableau.com
content_type: documentation
content_hash: 775c67bcea8b18e12d32c89968ccbd937745bd5f699c1a588e808df3dad4aa1e
description: Edit and create Tableau views on the web.
---
[跳转到主要内容](#main-content)

# 在 Web 上编辑 Tableau 视图

如果在查看 Tableau Cloud 或 Tableau Server 中的视图时可看到“编辑”按钮，则意味着您可以对视图进行更改。根据您的访问级别和权限，您可以执行以下操作：

- 编辑现有已发布工作簿，并为视图、仪表板和故事添加工作表。
- 基于发布的数据源创建和编辑新工作簿。
- 编辑现有工作簿，并在浏览器中添加工作表，或者通过在 Tableau Desktop 中打开工作簿来添加工作表。
- 在进行编辑时连接到不同的已发布数据源。有关详细信息，请参见[在进行 Web 编辑时连接到发布的数据源](https://help.tableau.com/current/pro/desktop/zh-cn/examples_tableauserver.htm#Connect)。

有关如何在 Tableau 中构建不同类型的图表和视图的详细信息，请参见[构建图表和分析数据](https://help.tableau.com/current/pro/desktop/zh-cn/design_and_analyze.htm)。

**注意：**不支持使用移动 Web 浏览器或 Tableau Mobile 应用在移动设备上编辑视图。您必须使用桌面 Web 浏览器。

## 编辑发布的视图

1. 登录到站点，然后打开包含要编辑的视图的工作簿，或显示“浏览”页面中的“所有视图”。
2. 打开视图。
3. 在视图工具栏中单击“编辑”。
    
    ![视图工具栏。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/web_author_who1.png)
    
    单击“编辑”时，视图将在 Web 制作模式下打开。
    
    ![从视图工具栏中选择“编辑”后，视图将以 Web 制作模式打开。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/web_author_who1b.png)
    
    现在即可编辑视图。
    
    **注意：**如果您拥有 Tableau Desktop 版本 2021.2 或更高版本，您还可以在 Tableau Desktop 中打开工作簿并在其中进行编辑。在制作工具栏中选择“在 Desktop 中编辑”图标 ![桌面图标。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/open_desktop_icon.png) 以打开，然后在完成后将工作簿发布到站点。
    
    若要了解如何构建图表或仪表板，请参见 [Creator：Web 制作入门](https://help.tableau.com/current/pro/desktop/zh-cn/getstarted_web_authoring.htm) 和[在视图中浏览和分析数据](https://help.tableau.com/current/pro/desktop/zh-cn/data_explore_analyze_interact.htm)中的“**步骤 4**”。
4. 您可使用的“保存”选项将因 Tableau 站点管理员设置的权限而异。
    
    - 若要关闭视图而不保存更改，请选择“文件”\>“关闭”。
    - 若要将您的工作保存在当前工作簿中，请选择“文件”\>“发布”。
    - 若要将您的工作另存为新工作簿，请选择“文件”\>“发布为”。Creator 可以选择一个位置来保存工作簿，无论是在项目中还是保存到他们的私有个人空间中。Explorer 只能保存到个人空间。有关个人空间的详细信息，请参见[在个人空间中创建和编辑私有内容](https://help.tableau.com/current/pro/desktop/zh-cn/personal_space.htm)。
    
    **注意：**如果您在 Tableau Desktop 中编辑了工作簿并想要发布更改，请选择“服务器”>“发布工作簿”，然后选择“发布”。工作簿的位置和名称将填充在“发布”对话框中。

## 通过已发布数据源在 Web 上创建新工作簿

1. 登录到 Tableau Cloud 或 Tableau Server 上的站点。
2. 打开包含要使用的数据源的项目，或者显示“所有数据源”。
3. 单击数据源名称旁边的“...”打开操作菜单，然后单击“新建工作簿”。
    
    ![“新建工作簿”按钮](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/web_author_workbook.png)
    
    一个新的空白工作簿将在 Tableau Server Web 编辑环境中打开。