---
schema_version: "1"
id: 6f7b45a43983b1f225f7e17a43ff14df003705df826ce39de93541e7af89213f
title: 为工具提示创建视图（工具提示内部可视化项）
collection: tableau
version: current
locale: zh-cn
portal_url: https://docs.salesforce.com/tableau/current/zh-cn/pro/desktop/viz_in_tooltip.md
canonical_url: https://help.tableau.com/current/pro/desktop/zh-cn/viz_in_tooltip.htm
source_site: help.tableau.com
content_type: documentation
content_hash: 5e1e408c0b11b03c6d6c4c1b71cdaaba99e41be2bd28c7894032b7e45ec7423b
description: Embed a visualization within a tooltip using Viz in Tooltip.
---
[跳转到主要内容](#main-content)

# 在工具提示中创建视图（工具提示内部可视化项）

当您制作视图并寻找方法向受众展示有关数据的更多详细信息时，您可以在工具提示中嵌入可视化项（也称为“工具提示内部可视化项”）。

![当鼠标悬停在条形图中的标记上时，工具提示内部可视化项会显示一个表格。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/ViT-basic.png)

当用户将光标悬停在标记上时，工具提示将通过另一个可视化项显示针对该标记筛选的相关数据和详细信息。

您可以在工具提示中显示相关可视化项，帮助您的受众从不同层次或更深入地了解数据，同时可使他们保留在当前上下文中，并可最大限度地提高当前视图的可用空间。

**观看视频：**有关高级技巧，请观看时长 55 分钟的免费视频演示文稿[下一级别的工具提示内部可视化项](https://youtu.be/0V6PvROxv3s)。  
  
有关如何编辑常规工具提示的信息，请参见[设置工具提示的格式](https://help.tableau.com/current/pro/desktop/zh-cn/formatting_specific_titlecaption.htm#Format_tooltips)。

## 创建工具提示内部可视化项的一般步骤

1. 在 Tableau 内的_源_工作表中创建可视化项。
2. 在_目标_工作表中创建可视化项以充当工具提示内部可视化项。为工作表指定一个可帮助您将其标识为工具提示内部可视化项的名称。
3. 在源工作表中，单击“标记”卡中的“工具提示”。在工具提示编辑器中，插入对工具提示内部可视化项目标工作表的引用。有关详细信息，请参见[配置工具提示内部可视化项](#ConfigureViT)。
4. **可选**：为工具提示内部可视化项隐藏目标工作表。有关详细信息，请参见[在工具提示中创建视图（工具提示内部可视化项）](#hidesheet).
5. 通过将光标悬停在源工作表视图中的不同标记上来测试生成的工具提示内部可视化项。如果工具提示内部可视化项对于工具提示窗口而言太大，请调整目标工作表可视化项的高度和宽度。您可能还要考虑简化目标可视化项中的结构和详细信息。有关详细信息，请参见[更改工具提示内部可视化项的大小](#Size)。

**注意：**

默认情况下，工具提示内部可视化项的筛选级别是_所有字段。_通过在_所选字段_上定义筛选器来更改工具提示内部可视化项的详细级别。有关详细信息，请参见[更改工具提示内部可视化项的筛选器](#Filters)。

在 Tableau 版本 2023.3 及更高版本中，工具提示内部可视化项不适用于合计和总计。

**注意：**默认情况下，工具提示内部可视化项的筛选级别是_所有字段。_通过在_所选字段_上定义筛选器来更改工具提示内部可视化项的详细级别。有关详细信息，请参见[更改工具提示内部可视化项的筛选器](#Filters)。  
  
在 Tableau 版本 2023.3 及更高版本中，工具提示内部可视化项不适用于合计和总计。

## 配置工具提示内部可视化项

您将需要_源_工作表可视化项和_目标_工作表可视化项，以创建工具提示内部可视化项。

这些步骤使用的示例源视图是一个按州/省/市/自治区显示销售利润的地图，使用的示例目标工作表具有一个按产品子类别显示利润的图表。

### 在工作表中创建源和目标可视化项

1. 在 Tableau 中，确定要用作源可视化项的工作表。或者在新工作表上构建一个新可视化项。这将是您的源视图。
2. 创建一个新工作表来充当目标可视化项。
    
    使目标视图中使用的筛选器数保持最少。
3. 为目标视图命名，以便您将能够在其他工作表的列表中将其识别出来。

### 在源工作表工具提示中插入对目标工作表的引用

1. 在源工作表中，单击“标记”卡中的“工具提示”按钮以打开工具提示编辑器。
    
    ![工具提示编辑器窗口。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/vit-tooltipeditor-novit.png)
2. 在工具提示编辑器中，单击“插入”菜单。在“插入”菜单中，选择“工作表”，然后选择目标工作表。
    
    例如：
    
    ![插入菜单，显示用于选择目标工作表的工作表选项。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/vit-insert-targetsheet.png)
    
    系统会自动添加工具提示内部可视化项的标记。（在此示例中，原始标记字段已被删除。）
    
    ![工具提示内部可视化项的标记。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/vit-targetsheetmarkup-default.png)
    
    _为工具提示内部可视化项自动生成的标记示例_
    
    这是此示例的结果标记：
    
    `<Sheet name="Tooltip: Profit by Sub-Category" maxwidth="300" maxheight="300" filter="<All Fields>">`
    
    默认情况下，会在所有字段上筛选工具提示内部可视化项（在所有可能的字段上并且在最具体的详细信息级别进行筛选）。
    
    单击“确定”。
3. 返回到源工作表并测试工具提示内部可视化项。将光标悬停在其他标记上以查看所生成的工具提示内部可视化项。根据需要对目标视图进行调整以改善工具提示内部可视化项。
    
    ![调整大小之前的工具提示内部可视化项。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/vit-sourcesheet-test.png)
    
    此示例中的工具提示内部可视化项会显示一条消息，以指明目标视图中的某些数据未显示。如果看到此消息，您可以在工具提示内部可视化项的参数中调整高度和宽度设置，从而增大视图大小。

## 更改工具提示内部可视化项的大小

您可以手动更改 `maxwidth` 和 `maxheight` 值来调整工具提示内部可视化项的大小。默认大小为 300 x 300 像素。要更改大小，请用另一个值手动替换 `"300"`。如果您需要设置大于 600 像素的值，则可能需要重新考虑目标视图是否非常适合工具提示内部可视化项。

1. 在源工作表中，单击“标记”卡中的“工具提示”按钮以打开工具提示编辑器。
2. 为 `maxwidth` 和 `maxheight` 选择数字值，然后键入不同的值来替换此值。例如：
    
    `<Sheet name="Tooltip: Profit by Sub-Category" maxwidth="500" maxheight="500" filter="<All Fields>">`
3. 单击“确定”
    
    ![调整大小后的工具提示内部可视化项。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/vit-resized.png)
    
    宽度和高度均设置为 500 像素的工具提示内部可视化项的示例。作者还为目标工作表视图中的标题文本创建了更多空间。

## 更改工具提示内部可视化项的筛选器

默认情况下，工具提示内部可视化项的筛选级别是_所有字段。_这意味着，将依据当前视图中的所有维度（不包括“筛选器”功能区上的字段）按最具体的详细级别对视图进行筛选。

您可以通过在所选字段上定义筛选器（类似在筛选操作中的所选字段上进行筛选）来更改工具提示内部可视化项的详细信息级别。

1. 在源工作表中，单击“标记”卡中的“工具提示”按钮以打开工具提示编辑器。
2. 将光标放在筛选器值 (`filter="<_place cursor here_>"`) 中，然后单击“插入”菜单以选择可用字段。或者，用视图中的字段名称手动替换 <_All Fields_\> 值。例如：
    
    `<Sheet name="Tooltip: Profit by Sub-Category" maxwidth="300" maxheight="500" filter="<State>">`
    
    您也可以通过用逗号分隔字段名称来筛选多个所选字段。例如：
    
    `<Sheet name="Tooltip: Profit by Sub-Category" maxwidth="300" maxheight="500" filter="<Country>,<State>">`
    
    若要按日期级别进行筛选，您需要包含使用字段名称指定日期级别的字符串。例如：
    
    `<Sheet name="Tooltip: Profit by Month" maxwidth="300" maxheight="300" filter="<MONTH(Order Date)>">`
    
    **注意：**工具提示内部可视化项脚本中的日期筛选器必须与视图中字段的日期级别完全匹配。

## 隐藏或显示工具提示内部可视化项工作表

通过与用于仪表板和故事的选项类似的选项，您可以为工具提示内部可视化项隐藏和显示工作表。

### 隐藏工具提示内部可视化项工作表

**注意**：如果源工作表对于仪表板处于隐藏状态，则您首先需要从其仪表板中取消隐藏该工作表，以便能够访问。有关详细信息，请参见[管理仪表板和故事中的工作表](https://help.tableau.com/current/pro/desktop/zh-cn/environ_workbooksandsheets_sheets_hideshow.htm)。

若要隐藏工具提示内部可视化项工作表，请在作为工具提示内部可视化项的目标工作表的标签中，选择“隐藏”。

![隐藏工作表。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/hide-vit-sheet.gif)

### 显示工具提示内部可视化项工作表

若要显示工具提示内部可视化项工作表，请在源工作表的标签中单击“取消隐藏所有工作表”。

![取消隐藏工作表。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/show-vit-sheet.gif)

## 工具提示内部可视化项的示例

当您创建工具提示内部可视化项时，用户可以将光标悬停在标记上，以在原始视图的上下文中以检查按需随选的详细信息。工具提示内部可视化项是另一个视图中与当前视图中的标记相关的静态数据图像。如果将光标悬停在标记上或者选择标记，则会在其工具提示中显示针对该标记筛选的另一个工作表中的数据。

**观看视频：**若要查看更多示例和相关概念，请观看时长 55 分钟的免费视频演示文稿[下一级别的工具提示内部可视化项](https://youtu.be/0V6PvROxv3s)。  

使用工具提示内部可视化项可以显示：

- 另一个详细信息级别的数据
    
    ![当鼠标悬停在条形图中的标记上时，工具提示内部可视化项会显示一个表格。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/ViT-basic.png)
- 不同但相关的数据
    
    ![当鼠标悬停在条形图中的标记上时，工具提示内部可视化项会显示不同的图表。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/vit-contextfilter.png)
- 标记值随时间变化情况
    
    ![当将鼠标悬停在条形图中的标记上时，工具提示内部可视化项会显示折线图，以显示随时间的变化。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/vit-currentperiodtrendovertime.png)
- 一个工具提示中的多个可视化项
    
    ![当鼠标悬停在条形图上的标记上时，工具提示内部可视化项会显示折线图和条形图。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/vit-multipleviewsintooltip.png)
- 主视图的图例
    
    ![工具提示内部可视化项显示主视图的图例。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/vit-legend.png)

当您在工具提示中显示相关视图时，可以帮助您的受众更深入地了解数据，同时可最大限度地提高当前视图的可用空间。

## 关于使用和配置工具提示内部可视化项的提示和注意事项

- 您可以使用工作表来创建工具提示内部可视化项，但不能使用仪表板或故事来创建工具提示内部可视化项。
- 工具提示内部可视化项是目标视图的静态图像，而不是交互式工作表。工具提示内部可视化项不能具有其自己的工具提示内部可视化项。
- 您将需要_源_工作表可视化项和_目标_工作表可视化项，以创建工具提示内部可视化项。您将需要创建一个目标视图，以使其在工具提示编辑器中可用。
- 对于您计划在工具提示中显示的目标工作表，请使用标准命名方案，例如“工具提示：_视图名称_”。使用标准命名方案将帮助您跟踪您正在工具提示中使用的视图。
- 对于目标视图，请考虑视图数据的大小以及视图在工具提示中的外观。您可以在配置工具提示内部可视化项时指定其大小，但是在发布之前，您将需要查看其显示方式，并且可能需要对视图进行调整。
    
    请记住，目标视图显示在源视图的上下文中。使目标可视化项保持简单可帮助提高性能和减轻认知负荷。
- 如果在源工作表中单击“智能显示”并且其更改视图结构，则包括工具提示内部可视化项引用在内的所有工具提示编辑都将重置。您将需要重新配置工具提示内部可视化项。
- 一个工具提示内部可视化项一次可引用一个目标工作表，因为筛选器直接应用于引用的工作表。当工具提示中已经使用工作表作为目标工作表时，无法在工具提示编辑器中选择工作表。
- 默认情况下，系统会在_所有字段_上筛选工具提示内部可视化项，这会在标识匹配记录时（在最具体的详细信息级别）考虑视图中的所有字段。您可以通过在_所选字段_上定义筛选器（类似在筛选操作中的**所选字段**上进行筛选）来更改工具提示内部可视化项的详细信息级别。有关相关详细信息，请参阅[创建高级突出显示动作](https://help.tableau.com/current/pro/desktop/zh-cn/actions_highlight_advanced.htm)。
    
    针对_所选字段_筛选的操作无法跨不同数据源工作。如果源视图和目标视图使用不同的数据源，则针对_所有字段_筛选的操作会自动检测共有字段（如果它们具有相同的别名），并针对这些字段进行筛选。但是，针对_所选字段_筛选的操作将不起作用。