---
schema_version: "1"
id: c781af9309b1f134eebff42c0a4c3098bfaa4ad8f33ff794fdd1e16a2d49070c
title: 打包工作簿
collection: tableau
version: current
locale: zh-cn
portal_url: https://docs.salesforce.com/tableau/current/zh-cn/pro/desktop/save_savework_packagedworkbooks.md
canonical_url: https://help.tableau.com/current/pro/desktop/zh-cn/save_savework_packagedworkbooks.htm
source_site: help.tableau.com
content_type: documentation
content_hash: 886b1361d32ed8ac4ba8518876005348b79e3f40a529296e432d2483160a1cb9
description: Create or unpackage packaged workbooks (.twbx) in Tableau Desktop.
---
[跳转到主要内容](#main-content)

# 打包工作簿

工作簿通常引用外部资源。例如，工作簿可能会引用背景图像或本地文件数据源，例如 Excel 文件、Access 文件和 Tableau 数据提取文件 (.hyper)。

保存工作簿时，也将保存指向这些资源的链接。下次打开该工作簿时，将自动用所有数据和图像更改来更新视图。大多数情况下，您需要以这种方式来保存工作簿。但是，如果计划与无权访问所引用资源或 Tableau Server 的某个人共享工作簿，则可能需要改为保存打包的工作簿。

打包工作簿包含工作簿以及所有本地文件数据源和背景图像的副本。该工作簿不再链接到原始数据源和图像。将以 .twbx 文件扩展名来保存这些工作簿。其他用户可以使用 Tableau Desktop 或 Tableau Reader 打开打包的工作簿。

**注意：**.twbx 文件的内容以纯文本形式存储。打开文件的任何人都可以读取所有数据，包括可能为数据提供语义线索的筛选器值。

## 创建具有基于文件的数据源的 .twbx

1. 选择“文件”>“另存为”。
2. 在“另存为”对话框中指定打包工作簿的文件名。
3. 在“保存类型”下拉列表中选择“Tableau 打包工作簿”。
    
    ![将文件另存为 Tableau 打包工作簿。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/save_packaged3.png)
4. 单击“保存”。

默认位置为 Tableau 存储库的 Workbooks 文件夹。不过，您可以选择将打包工作簿保存到任何目录。

打包工作簿中包括以下文件：

- 背景图像
- 自定义地理编码
- 自定义形状
- 本地多维数据集文件
- Microsoft Access 文件
- Microsoft Excel 文件
- Tableau 数据提取文件 (.hyper)
- 文本文件（.csv、.txt 等）

如果您要共享的打包工作簿包含 Microsoft Excel 或 Access 2007 数据源，则打开此工作簿的人员必须在其计算机上安装 Microsoft Excel 和 Access 2007 或 Office 2007 数据连接组件。Tableau 的 [Tableau 驱动程序](http://www.tableau.com/zh-cn/drivers)页面上提供了这些数据连接组件。

## 创建具有并非基于文件的数据源的 .twbx

如果工作簿包含与企业数据源或其他并非基于文件的数据源（例如 Microsoft SQL、Oracle 或 MySQL）的连接，则必须从数据源中提取数据才能将数据包括在打包工作簿 (.twbx) 中。

1. 在此工作簿中，右键单击“数据”窗格中的数据源，然后选择“提取数据”。
    
    ![带有提取数据选项的菜单。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/SendingPackagedWorkbook_ExtractData.png)
2. 在“提取数据”对话框中，单击“数据提取”按钮以提取数据源中的所有数据。
    
    ![“提取数据”对话框，其中包含用于指定数据存储和提取设置的选项。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/extract1.png)
    
    数据提取完成后，数据源图标会更改，以指明数据提取对该数据源有效。存在由箭头连接的两个圆柱体，而不是单个圆柱体。
    
    ![数据窗格中的数据提取刷新图标。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/SendingPackagedWorkbook_ExtractIcon.png)
3. **可选：** 对工作簿中的每个数据源重复上述步骤。
4. 选择“文件”\>“另存为”。
5. 在“保存类型”下拉菜单中，选择“Tableau 打包工作簿(\*.twbx)”。
    
    ![将文件另存为 Tableau 打包工作簿。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/save_packaged3.png)
    
    为所有非基于文件的数据源创建了数据提取并保存了打包的工作簿后，您可以发送您的工作簿。

## 创建具有 Tableau Server 数据源的 .twbx

如果工作簿包含与已发布的 Tableau Server 数据源的连接，您必须下载 Tableau Server 数据源的本地副本，提取其数据，然后替换与本地副本的连接才能将其包括在打包工作簿 (.twbx) 中。

1. 在工作簿中，右键单击“数据”窗格中发布的数据源，然后选择“创建本地副本”。
    
    ![选择了“创建本地副本”选项的菜单。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/SendingPackagedWorkbook_localcopy.png)
    
    已发布的数据源的一个副本将添加至“数据”窗格。
2. 右键单击本地副本，然后选择“提取数据”。  
    **注意：**如果本地副本是已发布的数据提取，则可以跳过此步骤。
    
    ![带有提取数据选项的菜单。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/SendingPackagedWorkbook_ExtractData.png)
3. 在“提取数据”对话框中，单击“数据提取”按钮以提取数据源中的所有数据。创建数据源的数据提取将允许您要与其共享工作簿的人员访问数据源的副本。
    
    ![“提取数据”对话框，其中包含用于指定数据存储和提取设置的选项。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/extract1.png)
4. 在“数据”窗格中，右键单击已发布的数据源，然后选择“替换数据源”。
    
    ![光标位于“替换数据源...”上方的下拉菜单。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/SendingPackagedWorkbook_replacedatasource.png)
5. 验证已发布的数据源是否将由本地数据源替换，然后单击“确定”。
    
    ![用于替换数据源的系统对话框。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/SendingPackagedWorkbook_replacedialogbox.png)
6. 右键单击已发布的数据源，然后单击“关闭”。
7. 选择“文件”\>“另存为”。
8. 在“保存类型”下拉菜单中，选择“Tableau 打包工作簿(\*.twbx)”。
    
    ![将工作簿保存为 Tableau 打包工作簿的选项。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/SendingPackagedWorkbook_Twbx1.png)
    
    在创建本地副本及其数据提取并保存了打包工作簿之后，您可以发送工作簿。

## 解包 .twbx

可以解包打包的工作簿。

在 Windows 或 macOS 计算机上，使用 .zip 扩展名重命名文件（例如，从 myfile.twbx 重命名为 myfile.zip），然后双击该文件。

解包工作簿时，您将获得常规工作簿文件 (.twb)，以及包含与工作簿打包在一起的数据源和图像的文件夹。