---
schema_version: "1"
id: aa554a198c7433bd23c6c6a67d8e2f10999c09ff34467cd3b39b0a810924db2c
title: 设置文本格式
collection: tableau
version: current
locale: zh-cn
portal_url: https://docs.salesforce.com/tableau/current/zh-cn/pro/desktop/formatting_fonts_beta.md
canonical_url: https://help.tableau.com/current/pro/desktop/zh-cn/formatting_fonts_beta.htm
source_site: help.tableau.com
content_type: documentation
content_hash: 5a1637558e8b9709231ad14166303c1f7436325ff295f1a1998cfa797ee79d6d
description: Format text including fonts, alignment, tooltips, titles, and captions.
---
[跳转到主要内容](#main-content)

# 设置文本格式

选择恰当的字体可以让您的可视化项更加出色。不管是要更改字体大小、位置、颜色还是方向，Tableau 都能为文本提供了各种各样的自定义选项。

在此级别进行格式设置更改时，所做更改只会应用于您正在处理的视图。请参见[在工作簿级别设置格式](https://help.tableau.com/current/pro/desktop/zh-cn/formatting_workbook.htm)，以了解如何进行适用于工作簿中的每个视图的更改。

若要访问工作表级别的格式请选择“格式”菜单，然后选择要设置格式的视图部分，如“字体”或“边框”。

> [!TIP]
> 
> **提示**：此内容仅适用于设置文本格式。如果需要操作文本内容，请参见[字符串函数](https://help.tableau.com//current/pro/desktop/zh-cn/functions_functions_string.htm "Tableau 帮助中“字符串函数”的链接")。

## 设置字体格式

如果您在 Tableau Server 或 Tableau Cloud 中工作，请选择“格式”，然后从菜单中选取您想要设置格式的元素。您可以选择设置单个标题、说明、图例、筛选器和集、荧光笔以及参数的格式。您也可以在“格式”菜单中清除工作表格式。

如果您在 Tableau Desktop 中工作，请选择“格式”\>“字体”。“设置字体格式”控制窗格将打开。此控制窗格让您能自定义视图中的文本。

工作表

在工作表级别编辑字体会将您所做的更改应用于视图中除“标头”和“工具提示”字段之外的所有文本字段。

注意：Tableau 将“工作表”格式设置视为新的默认值，对任何其他字段（例如标题、区或标头）所做的任何更改将覆盖“工作表”格式。

![设置工作表字体的格式。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/format_fonts_worksheet.gif)

区

在此处调整字体将影响 Tableau 显示可视化项结果的区视图。  
![设置区字体的格式。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/format_fonts_pane-.gif)  

标头

选择此选项以调整视图中标头的字体。标头显示可视化项中使用的维度。

![设置标题字体的格式。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/format_fonts_header.gif)

工具提示

在此处调整字体会将更改应用于工具提示中的所有文本以及将光标悬停在视图中的标记上时弹出的字段。如果要对工具提示中的字段进行更多控制，请参见[设置文本格式](#Format_tooltips)。

![设置工具提示字体的格式。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/format_fonts_tooltip.gif)

标题

选择此格式设置选项可快速调整“标题”的外观。有关详细信息，请参见[设置文本格式](#Format_titles,_captions,_and_legend_titles)。

![设置标题字体的格式。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/format_fonts_title.gif)

合计区

在区级别调整合计的字体将更改小计和总计。有关设置合计的信息，请参见[在可视化项中显示合计](https://help.tableau.com/current/pro/desktop/zh-cn/calculations_totals_grandtotal_turnon.htm)。

![设置“合计”区字体的格式。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/format_fonts_Total_pane.gif)

合计标头

在标头处调整合计的字体将更改视图中“合计”和“总计”标签的外观。

![设置“总计”标题字体的格式。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/format_fonts_total_header.gif)

总计区

选择此选项以调整视图中总计结果的字体。

![设置总计区字体的格式。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/format_fonts_grandtotal_pane.gif)

总计标头

选择此选项以调整视图中总计标签的字体。

![设置总计标题字体的格式。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/format_fonts_grandtotal_header.gif)

行和列文本格式设置

如果行和列功能区上都有维度，您可以通过“格式设置”窗格上的“行”和“列”选项卡独立设置字体的格式。

![字体格式设置对话框，带有用于设置行和列字体格式的选项。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/format_fonts_rows_columns.png)

字体格式设置选项仅适用于选择的“标头”、“合计”和“总计”。

## 设置文本对齐方式格式

Tableau 使用视觉最佳实践来确定视图中文本的对齐方式，但您也可以对文本对齐方式进行自定义。例如，您可以更改标题文本的方向，使其以水平（默认）方式显示，而不是以垂直（向上）方式显示。

若要设置文本对齐方式格式，请选择“设置格式”\>“对齐方式”打开文本对齐方式窗格。

![设置字体对齐方式格式。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/formatting_alignment2.gif)  

对于每个文本区域，可以指定以下对齐方式选项：

**水平** - 控制文本是靠左对齐、靠右对齐还是居中对齐。

**垂直对齐** - 控制文本是靠上对齐、居中对齐还是靠下对齐。

**方向** - 旋转文本，使其水平排列（默认）、自上而下排列（向上）或自下而上排列（向下）。

**换行** - 控制长的标题是换行到下一行还是缩短。它不控制可视化项中的文本标记。

注意：如果单元格不够大，无法显示多行文本，则启用换行不会有明显效果。如果出现这种情况，可以将光标悬停在单元格上，直至出现双向箭头，然后单击并向下拖动以扩大单元格。

在确定何时开始或结束换行时，Tableau 遵循国家标准。

## 设置工具提示的格式

工具提示是将指针悬停在视图中的一个或多个标记上时出现的详细信息。工具提示还提供一些便利工具，用于快速筛选或移除所选内容、选择具有相同值的标记或查看基础数据。可以编辑工具提示，使它同时包含静态和动态文本。还可以修改在自动工具提示中包含的字段。

**编辑工具提示：**

1. 选择“工作表”\>“工具提示”。工具提示是针对每个工作表指定的，可使用“编辑工具提示”对话框顶部的格式设置工具来设置其格式。使用该对话框顶部的“插入”菜单可添加动态文本，如字段值、工作表属性等。
    
    ![“编辑工具提示”对话框。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/richtext2.png)
2. 使用“编辑工具提示”对话框顶部的格式设置工具。
3. （可选）使用该对话框顶部的“插入”下拉列表可添加动态文本，例如字段值、工作表属性等。
    
    使用“插入”菜单上的“所有字段”选项可以添加视图中使用的所有字段名称和值。插入“所有字段”参数会随视图的更改而更新工具提示。您也可以使用“所有字段”选项来排除字段。
4. （可选）选择“包括命令按钮”选项以在工具提示中显示筛选和“查看数据”选项。例如，包括命令按钮会在工具提示的底部添加“只保留”、“排除”和“查看数据”按钮。这些命令按钮将在 Tableau Desktop 中提供，以及在将视图发布到 Web 时或在移动设备上查看视图时提供。
5. （可选）选中“允许按类别选择”复选框，以通过单击工具提示中的离散字段来选择视图中具有相同值的标记。有关详细信息，请参见[工具提示](https://help.tableau.com/current/pro/desktop/zh-cn/view_parts.htm#Tooltips)。

## 编辑工作表标题、说明和图例标题

1. 执行以下操作之一：
    
    - 在 Tableau Server 或 Tableau Cloud 上，双击想要更改的项。
    - 在 Tableau Desktop 上，右键单击（在 Mac 上按住 Control 单击）要更改的项，并选择“编辑 <项>”，例如，“编辑标题”。
    - 在工作表中，将光标悬停在标题上，单击右侧的下拉箭头，并从上下文菜单中选择“编辑标题”或“编辑说明”。
2. 在“编辑”对话框中，修改文本并设置字体、大小、样式、颜色和对齐方式。使用“插入”菜单可添加动态文本，例如工作表属性和字段值。单击**“确定”**。
    
    ![标有“编辑标题”的对话框，其中带有可编辑的工作表名称文本字段。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/title3.png)
    
    若要将标题重置为默认设置，请单击“重置”。