---
schema_version: "1"
id: da6728330586e32ad6be914587c3edcf1557ac340075c85abd17fa3be1d70a96
title: “分析”窗格
collection: tableau
version: current
locale: zh-cn
portal_url: https://docs.salesforce.com/tableau/current/zh-cn/pro/desktop/environ_workspace_analytics_pane.md
canonical_url: https://help.tableau.com/current/pro/desktop/zh-cn/environ_workspace_analytics_pane.htm
source_site: help.tableau.com
content_type: documentation
content_hash: d9509e9e50c9e02b68632e1b87d65fc6c47e01ef9ad4ef2b5f6fbc6a3be4b024
description: Use the Analytics pane to add reference lines, trend lines, forecasts, and box plots to a view.
---
[跳转到主要内容](#main-content)

# 将高级分析应用于视图（“分析”窗格）

从“分析”窗格中将参考线、盒形图、趋势线、预测和其他项拖入视图。通过单击左侧栏顶部的选项卡，可以在“数据”窗格与“分析”窗格之间切换。

![显示用于向视图添加分析对象的选项的“分析”窗格。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/environ_analytics_pane.png)

Tableau Desktop“分析”窗格

在 Tableau Desktop 中，“分析”窗格、菜单或视图的上下文中提供了用于将分析对象添加到视图中的选项。举例来说，参考线和区间可在编辑轴时找到，而趋势线和预测可从“分析”菜单中找到。

在“分析”窗格中，能够拖放各个选项。

在 Web 上，大多数分析对象都可以从“分析”窗格中获得。

## 向视图中添加分析对象

若要从“分析”窗格中添加项，请将该项拖入视图。将项目从“分析”窗格中拖出时，Tableau 将显示该项目的可能目标。选择范围因项类型和当前视图而异。

举一个简单的例子，放置目标区域将提供以下三个选项：

![“带四分位点的中值”胶囊已拖到工作表上的可视化项。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/analytics_drop_options_simple.png)

术语表、区和单元格定义了项的作用域：

![比较了 2009 年和 2010 年三个地区的销售额的三个条形图，显示了整个表格、每个窗格和每个单元格的平均销售额。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/reflines_scope1.png)

对于更复杂的视图（例如，带有双轴的视图），Tableau 将显示如下放置目标区域：

![为表格、窗格和单元格显示的“添加带四分位点的中值”选项。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/analytics_drop_options.png)

如果将项放在放置目标区域顶部标题中的三个较大方框的其中一个方框中（例如，“表”方框），则会为每个轴添加单独的“带四分位点的中值”。

![折线图直观地描绘了利润和销售额随时间变化的相关性。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/analytics_drop_table_result_497x310.png)

但如果将项放在与特定度量对齐的下面六个方框的任何一个方框中，则只会具有指定范围的对应轴上添加“带四分位点的中值”。

## 从视图中删除分析对象

您可以通过单击“撤消”从视图中删除分析对象，也可以将该对象从视图中拖出以将其删除。

也可单击项并从工具提示中选择“移除”。

**注意**：某些“分析”窗格项（“带四分位点的中值”和“CI 为 95% 的平均值”）会同时添加参考线和参考分布。除非使用“撤消”，否则您将需要单独删除这些项。

## 在视图中编辑分析对象

若要编辑通过“分析”窗格添加的项，请单击该项并从工具提示中选择“编辑”。有关其他编辑选项，请参见下面的“分析对象定义”下的特定项类型部分。

## 分析对象定义

可从“分析”窗格中将以下项拖放到视图中。如果分析对象无法应用于视图中字段的当前配置，则该分析对象不可用。

### 常量线

向视图添加一条或多条常量线。可以为特定度量、所有度量或日期维度添加常量线。在添加常量线时，Tableau 将显示一个“值”提示，您在其中指定常量的值：

![值字段，其中手动输入了该字段的日期。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/analytics_drop_constant.png)

在 Tableau Desktop 中，日期值的“值”提示是一个日历控件：

![带有日历的值字段，用于选择恒定日期值。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/analytics_drop_constant_date.png)

您可以单击生成的常量线，并选择“编辑”或“移除”。Tableau Desktop 中有第三个选项：设置格式。选择“编辑”可打开“编辑参考线”对话框。有关详细信息，请参见**参考线、参考区间、参考分布和参考箱**一文中的[编辑现有参考线、参考区间和参考分布](https://help.tableau.com/current/pro/desktop/zh-cn/reference_lines.htm#Edit_Existing_Reference_Lines_and_Bands)。在 Tableau Desktop 中编辑线的另一种方式是右键单击（在 Mac 上按住 Control 单击）相关轴并选择“编辑参考线”。

### 平均线

向视图添加一条或多条平均线。可以为特定的度量或所有度量添加平均线。

您可以单击生成的平均线并选择其他聚合，例如“合计”或“总和”。您也可以选择“编辑”或“移除”。Tableau Desktop 中有第三个选项：设置格式。选择“编辑”可打开“编辑参考线”对话框。有关详细信息，请参见**参考线、参考区间、参考分布和参考箱**一文中的[编辑现有参考线、参考区间和参考分布](https://help.tableau.com/current/pro/desktop/zh-cn/reference_lines.htm#Edit_Existing_Reference_Lines_and_Bands)。在 Tableau Desktop 中编辑线的另一种方式是右键单击（在 Mac 上按住 Control 单击）相关轴并选择“编辑参考线”。

### 带四分位点的中值

向视图添加一组或多组中值线及分布区间。可以为特定的度量或所有度量添加带四分位点的中值。

分布区间作为四分位点计算；中间两个四分位点带阴影。

可以单击生成的中值线或分布，并选择“编辑”或“移除”。Tableau Desktop 中有第三个选项：设置格式。必须单独对中值线和分布进行编辑、设置格式或移除。选择“编辑”可打开“编辑参考线”对话框。您必须单击分布区间的外边缘才能看到选项 — 在区间的中间单击没有效果。有关详细信息，请参见**参考线、参考区间、参考分布和参考箱**一文中的[编辑现有参考线、参考区间和参考分布](https://help.tableau.com/current/pro/desktop/zh-cn/reference_lines.htm#Edit_Existing_Reference_Lines_and_Bands)。在 Tableau Desktop 中编辑线或分布的另一种方式是：右键单击（在 Mac 上按住 Control 单击）相关的轴，并选择“编辑参考线”。子菜单将提供两个选择：“四分位点”和“中值”。

有关分布类型（包括四分位点）的信息，请参见[添加参考分布](https://help.tableau.com/current/pro/desktop/zh-cn/reference_lines.htm#Add_Reference_Distributions)一文中的**添加参考分布**。

### 盒形图

向视图添加一个或多个盒形图。可以为特定的度量或所有度量添加盒形图。盒形图的作用域始终是单元格（绝不会是表或窗格）。

单击或将鼠标悬停在盒形图中的任何水平线上以查看有关须线、四分位点和中值的统计信息。

您也可以在单击某条线时选择“编辑”或“移除”。Tableau Desktop 中有第三个选项：设置格式。选择“编辑”可打开“编辑参考线”对话框。在 Tableau Desktop 中编辑盒形图的另一种方式是右键单击（在 Mac 上按住 Control 单击）相关轴并选择“编辑参考线”。

**注意**：在 Tableau Desktop 中，有两个在“分析”窗格中名为“盒形图”的项目。对于“汇总”部分的“盒形图”选项，Tableau 将为指定目标自动添加盒形图。对于“自定义”部分的“盒形图”选项，Tableau 将在您指定目标之后打开对话框。

### 合计

向视图添加合计。添加合计时，放置选项是“小计”、“列总计”和“行总计”。

有关详细信息，请参见[在可视化项中显示合计](https://help.tableau.com/current/pro/desktop/zh-cn/calculations_totals_grandtotal_turnon.htm)。

若要移除合计，请单击相关列或行标题，并选择“移除”。

在 Tableau Desktop 中，在添加合计并通过工具提示设置聚合之后，您也可以单击合计列或行标题：

![展开的下拉菜单，显示“自动”、“总和”、“平均值”、“最小值”和“最大值”选项。](/tableau/current/zh-cn/pro/desktop/zh-cn/Img/analytics_pane_configure_totals.png)

### CI 为 95% 的平均值

添加一组或多组包含分布区间的平均线；分布区间按 95% 的置信区间配置。可以为特定的度量或所有度量添加这些项。

置信区间分布区间将总体平均值占时间 95% 的区域显示为阴影。

可以单击生成的平均线或分布，并选择“编辑”或“移除”。Tableau Desktop 中有第三个选项：设置格式。选择“编辑”可打开“编辑参考线”对话框。必须单独对平均线和分布进行编辑、设置格式或移除。您必须单击分布区间的外边缘才能看到选项 — 在区间的中间单击没有效果。在 Tableau Desktop 中编辑线或分布的另一种方式是：右键单击（在 Mac 上按住 Control 单击）相关的轴，并选择“编辑参考线”。子菜单将提供两个选择：“平均”和“95% 置信区间”。

您也可以通过将线和区间拖离视图来将它们移除。

### CI 为 95% 的中值

添加一组或多组包含分布区间的中值线；分布区间按 95% 的置信区间配置。可以为特定的度量或所有度量添加这些项。

置信区间分布区间将总体中值占时间 95% 的区域显示为阴影。

可以单击生成的中值线或分布，并选择“编辑”、“设置格式”或“移除”。Tableau Desktop 中有第三个选项：设置格式。选择“编辑”可打开“编辑参考线”对话框。必须单独对中值线和分布进行编辑、设置格式或移除。您必须单击分布区间的外边缘才能看到选项 — 在区间的中间单击没有效果。在 Tableau Desktop 中编辑线或分布的另一种方式是：右键单击（在 Mac 上按住 Control 单击）相关的轴，并选择“编辑参考线”。子菜单将提供两个选择：“中值”和“95% 置信区间”。

您也可以通过将线和区间拖离视图来将它们移除。

### 趋势线

向视图添加一条或多条趋势线。添加趋势线时，放置选项会识别在 Tableau 中可用的趋势线模型类型：“线性”、“对数”、“指数”和“多项式”。对于某些视图，这些选项只有一部分可用。

有关详细信息，请参见[趋势线模型类型](https://help.tableau.com/current/pro/desktop/zh-cn/trendlines_add.htm#modeltype)。

单击趋势线以将其移除或对其进行编辑，或者查看统计定义。您也可以通过将趋势线拖离视图来将其移除。

### 预测

向视图添加预测。此选项仅在 Tableau Desktop 中可用 — 在 Web 上编辑视图时不可用。只有当视图中至少有一个度量时，才能进行预测。

不支持对基于多维数据源的视图进行预测。另外，视图不能包含以下任何内容：

- 表计算
- 解聚的度量
- 百分比计算
- 总计或小计
- 使用聚合的日期值设置精确日期

包含 Null 值的时间系列也存在限制。

有关详细信息，请参见[预测](https://help.tableau.com/current/pro/desktop/zh-cn/forecasting.htm)。

若要移除、编辑或读取当前预测的说明，请转到“分析”菜单，然后选择“预测”。

### 自定义参考线

可以为视图中的特定度量或所有度量添加参考线。

将参考线从“分析”窗格拖放到目标上后，Tableau 将自动打开一个编辑对话框。有关可用选项的信息，请参见**参考线、参考区间、参考分布和参考箱**一文中的[添加参考线](https://help.tableau.com/current/pro/desktop/zh-cn/reference_lines.htm#Add_a_Reference_Line)。若要稍后返回到到此对话框，请单击线并选择“编辑”。

### 自定义参考区间

可以为视图中的特定度量或所有度量添加参考区间。

将参考区间从“分析”窗格拖放到目标上后，Tableau 将自动打开对话框。有关可用选项的信息，请参见[添加参考区间](https://help.tableau.com/current/pro/desktop/zh-cn/reference_lines.htm#Add_Reference_Bands)一文中的**添加参考区间**。若要稍后返回到此对话框，请单击区间，并选择“编辑”。单击参考区间的外边缘才能看到选项 — 在区间的中间单击没有效果。

### 自定义分布区间

可以为视图中的特定度量或所有度量添加参考分布。

将参考分布从“分析”窗格拖放到目标上后，Tableau 将自动打开对话框。有关可用选项的信息，请参见[添加参考分布](https://help.tableau.com/current/pro/desktop/zh-cn/reference_lines.htm#Add_Reference_Distributions)一文中的**添加参考分布**。若要稍后返回到此对话框，请单击区间，并选择“编辑”。单击分布区间的外边缘才能看到选项 — 在区间的中间单击没有效果。

### 自定义盒形图

在 Tableau Desktop 中（而不是在 Web 上编辑视图时），您可以将盒形图从“分析”窗格的拖放到目标上。（但请记住，在 Web 上，您可以通过“分析”窗格上的“汇总”部分添加盒形图。）当您从“自定义”部分拖出盒形图时，Tableau 将自动打开“编辑参考线、参考区间或参考箱”对话框。有关可用选项的信息，请参见[添加盒形图](https://help.tableau.com/current/pro/desktop/zh-cn/reference_lines.htm#Add_a_Box_Plot)一文中的**添加盒形图**。盒形图的作用域始终是单元格（绝不会是表或窗格）。

单击盒形图中的任何水平线以查看有关须线、四分位点和中值的统计信息。

若要稍后返回到此对话框，请单击区间，并选择“编辑”。