---
schema_version: "1"
id: 56074bae5db23d90780261aeb1345845799a9beab0652eb150b8ef13323a6684
title: 使用增量刷新来刷新流程数据
collection: tableau
version: current
locale: zh-cn
portal_url: https://docs.salesforce.com/tableau/current/zh-cn/prep/prep_incremental_refresh.md
canonical_url: https://help.tableau.com/current/prep/zh-cn/prep_incremental_refresh.htm
source_site: help.tableau.com
content_type: documentation
content_hash: caa7bb930357c9ba5dd194155041e965bb0a7b12d8677a8c6ab747bb06a85e73
description: Refresh flow data using incremental refresh in Tableau Prep.
---
[跳转到主要内容](#main-content)

# 使用增量刷新来刷新流程数据

**注意**：从版本 2020.4.1 开始，您现在可以在 Tableau Server 和 Tableau Cloud 中创建和编辑流程。除非特别指出，本主题中的内容适用于所有平台。有关在 Web 上制作流程的详细信息，请参见 Tableau Server 帮助中的 [Web 上的 Tableau Prep](https://help.tableau.com/current/server/zh-cn/prep_web_auth.htm)。

从 Tableau Prep Builder 版本 2020.2.1 开始以及在 Web 上，您可以将流程输入和输出配置为以增量方式刷新，以便在流程运行时仅检索和处理新行，从而节省时间和资源。

举例来说，如果流程包含每天更新的事务数据，则可以设置增量刷新以便每天仅检索和处理新事务，然后每周或每月运行一次完全刷新以刷新所有流程数据。

## 增量刷新要求和限制

### 要求

若要使用增量刷新来运行流程，Tableau Prep 需要以下信息：

- 用于检测输入表中的新行的字段。
- 用于将流程输出中最后一个处理的值与输入中的值进行比较以确定哪些行是新行的字段。有关详细信息，请参见[使用 Append 进行增量刷新](#refreshAppend)。
- 您希望如何将新数据写入表。您可以将新数据添加到现有表、使用新数据覆盖表数据，或者从 Tableau Prep Builder 版本 2020.3.1 开始以及在 Web 上，替换现有表中的数据。

### 限制

- 使用 Salesforce 连接器对流程输入运行增量刷新时，需要 Tableau Prep 版本 2021.1.2 或更高版本。
- 将流程输出写入 Microsoft Excel、Amazon S3、CRM Analytics 或 Databricks 时，当前不支持增量刷新。
- 输出 .csv 文件仅支持“创建表”。
- 输出到本地或已发布的 .hyper 数据提取仅支持“追加到表”。

## 流程刷新选项

Tableau Prep 使您能够选择如何刷新数据，以及如何使用流程输出更新表。下表描述了不同的选项及其优点。

<table style="width: 100%;" class="simple-table"><colgroup><col><col><col><col></colgroup><tbody><tr><th>刷新组合</th><th>处理的数据</th><th>表更新</th><th>好处</th></tr><tr><td><span class="uicontrol">完全刷新</span> + <span class="uicontrol">创建表</span></td><td>全部</td><td>使用完整数据集创建或覆盖现有表。</td><td><p>在每次流程运行时刷新所有数据。</p></td></tr><tr><td><span class="uicontrol">完全刷新</span> + <span class="uicontrol">追加到表</span></td><td>全部</td><td>将新行添加到现有表。</td><td>在每次流程运行时跟踪新数据和现有数据。<span class="uicontrol">“追加到表”</span>不可用于 .csv 输出类型。</td></tr><tr><td><span class="uicontrol">完全刷新</span> + <span class="uicontrol">替换数据</span></td><td>全部</td><td>替换现有表中的行。</td><td>保留现有的表架构结构，但将所有数据替换为每个流程运行。</td></tr><tr><td><span class="uicontrol">增量刷新</span> + <span class="uicontrol">创建表</span></td><td>仅新行</td><td>仅使用新行创建或覆盖现有表。</td><td>创建一个仅使用新行作为完整数据集的新表。<p>如果流程运行时输出数据源不存在或无法连接，则流程将失败。需要完全刷新才能创建输出，然后才能以增量方式使用它。</p></td></tr><tr><td><span class="uicontrol">增量刷新</span> + <span class="uicontrol">追加到表</span></td><td>仅新行</td><td>将新行添加到现有表。</td><td><p>仅将新行添加到现有表。<span class="uicontrol">“追加到表”</span>不可用于 .csv 输出类型。请参见<a href="#refreshAppend" class="xref">使用 Append 进行增量刷新</a>。</p></td></tr><tr><td><span class="uicontrol">增量刷新</span> + <span class="uicontrol">替换数据</span></td><td>仅新行</td><td>仅将现有表中的所有行替换为新行。</td><td>保留现有的表架构结构，但将所有数据替换为新行，使此数据集成为您的完整数据集。</td></tr></tbody></table>

## 配置增量刷新

若要将流程配置为使用增量刷新，需要在要使用此选项的“输入”步骤和“输出”步骤上同时指定设置。在“输入”步骤中，指定 Tableau Prep 如何查找新行。在“输出”步骤中，指定如何将新行写入表。运行流程时，可以选择完全或增量刷新类型。

> [!TIP]
> 
> **提示**：为增量刷新配置输入和输出步骤后，可以保留配置并重复使用它们。复制并粘贴步骤以在当前流程的其他位置或 Tableau Prep Builder 中使用它们，或使用“将步骤另存为流程”将选定步骤保存到本地文件或服务器以在其他流程中重用这些步骤。有关复制、粘贴或重用步骤的详细信息，请参见[复制步骤、操作和字段](https://help.tableau.com/current/prep/zh-cn/prep_copy_reuse_steps.htm)。

1. 在流程窗格中，选择要为增量刷新配置的输入步骤。
2. 在“设置”选项卡的“输入”窗格中，在“增量刷新”（以前版本中为“设置增量刷新”部分）下设置以下选项：
    
    - 选择“启用增量刷新”（以前版本中为“启用”）。
    - 输入字段（以前版本中为“使用字段标识新行”）：选择要在输入数据中刷新的字段。必须为此字段分配“数字(整数)”、“日期”或“日期或时间”数据类型。目前，您只能选择单个字段。
        
        **注意**：您可以稍后在流程中移除或重命名此字段，只要在“输出字段”（以前版本中为“输出中的字段名称”）中指定的字段可用于将此字段与最新输出进行比较来查找新行。
    - 输出：选择与您的输入相关的输出，其中包括将用于比较行的字段。
    - 输出字段（以前版本中为“输出中的字段名称”）：选择要用于将流程输出中最后处理的值与输入中的值进行比较来查找新行的字段。此字段的数据类型和名称必须与在“输入字段”（以前版本中为“使用字段标识新行”）中指定的字段的数据类型相同。
        
        ![输入步骤设置，其中突出显示了“增量刷新”部分。 ](/tableau/current/zh-cn/prep/zh-cn/Img/prep_incremental_input.png)
    
    ### 使用 Append 进行增量刷新
    
    增量刷新首先在输出中搜索增量字段的现有最大值。然后，它会筛选输入中的行，以仅添加增量字段中值较大的行。例如：
    
    现有表：
    
    <table style="width: 100%;" class="simple-table"><colgroup><col style="width: 297px;"><col></colgroup><tbody><tr><td>第 1 列</td><td>第 2 列</td></tr><tr><td>ID 5</td><td>第 5 行</td></tr></tbody></table>
    
    根据第 1 列将新行追加到表中：
    
    <table style="width: 100%;" class="simple-table"><colgroup><col><col></colgroup><tbody><tr><td>第 1 列</td><td>第 2 列</td></tr><tr><td>ID 1</td><td>新行1</td></tr><tr><td>ID 6</td><td>新行 6</td></tr></tbody></table>
    
    - 未添加新行1。
    - 添加了新行 6。

## 配置写入选项

若要完成增量刷新设置，请设置输出“写入选项”以指定如何将新行写入表。与配置的输入步骤相关的所有输出都选择了默认写入选项，但您可以将其更改为支持的选项。

您可以将行输出到文件（仅限 Tableau Prep Builder）、已发布的数据源或数据库。某些数据库具有数据限制或要求。有关数据库限制和要求的信息，请参见[将流程输出数据保存到外部数据库](https://help.tableau.com/current/prep/zh-cn/prep_save_share.htm#save-flow-output-data--to-external-databases)。

默认情况下，针对本地或已发布的 .hyper 数据提取的输出设置为 “追加到表”。针对 .csv 文件类型的输出设置为“创建表”。

1. 在流程窗格中，选择要为增量刷新配置的输出步骤。
2. 在“输出”窗格中的“写入选项”部分，查看默认写入选项并根据需要进行任何更改。
    
    - 创建表：此选项创建新表，或将现有表替换为新输出。
    - 追加到表：此选项将新数据添加到现有表中。如果表不存在，则在首次运行流程时创建一个新表，后续运行会将新行添加到此表。不可用于 .csv 输出类型。有关支持的刷新组合的详细信息，请参见[流程刷新选项](#refresh-options)。
    - 替换数据（Tableau Prep Builder 版本 2020.3.1 及更高版本以及在 Web 上）：当您要将输出写回数据库中的现有表时，此选项可用。它将数据库表中的数据替换为流程数据，但保留表架构结构。
    
    ![选择了“附加到表”选项的“将输出保存到”菜单。 ](/tableau/current/zh-cn/prep/zh-cn/Img/prep_incremental_output4.png)

## 运行流程

您可以在 Tableau Prep Builder 中、在 Web 上或通过命令行使用增量刷新来运行单个流程。有关通过命令行运行流程的信息，请参见[在启用增量刷新的情况下运行流程](https://help.tableau.com/current/prep/zh-cn/prep_run_commandline.htm#incremental-refresh)。

如果启用了包含 Tableau Prep Conductor 的 Data Management，则可以通过在 Tableau Server 或 Tableau Cloud 上设置计划来使用增量刷新运行流程。

**注意**：在以前的版本中，写入选项在 Tableau Prep Builder 中设置，在 Tableau Server 或 Tableau Cloud 中运行流程时，无法对其进行更改。从 Tableau Server 和 Tableau Cloud 版本 2020.4 开始，可以直接在 Web 中编辑流程。有关使用 Web 上的 Tableau Prep 的详细信息，请参见 Tableau Server 帮助中的 [Web 上的 Tableau Prep](https://help.tableau.com/current/server/zh-cn/prep_web_auth.htm)。

在使用增量刷新运行流程之前，您需要先运行完全刷新以在输出位置中创建输出数据源。后续流程运行随后可以使用增量刷新过程，并仅检索和处理新行，除非缺少增量刷新配置数据，或者现有输出已移除。

若要运行完全刷新，请从顶部菜单或“输出”窗格上的下拉按钮中选择“完全刷新”，或者单击流程上的“运行流程”按钮。

- 若要使用增量刷新在 Tableau Prep 中运行流程，请从以下位置之一选择“增量刷新”：
    - 从顶部菜单中，单击“运行”按钮上的下拉选项。
        
        ![允许您选择完全刷新或增量刷新的窗口，其中增量刷新突出显示。](/tableau/current/zh-cn/prep/zh-cn/Img/prep_incremental_run_menu.png)
    - 从“输出”窗格中，单击“运行流程”按钮上的下拉选项。
        
        ![显示用于执行数据流的“完全刷新”和“增量刷新”选项的对话框。](/tableau/current/zh-cn/prep/zh-cn/Img/prep_incremental_run_button.png)
    - 从“流程”窗格中，单击“输出”步骤旁边“运行”按钮上的下拉选项。
        
        ![带有使用完全刷新或增量刷新创建表的选项的对话框。](/tableau/current/zh-cn/prep/zh-cn/Img/prep_incremental_run_menu_flow.png)
    
    如果启用了增量刷新的一个输入与多个输出关联，这些输出必须一起运行，并且必须使用相同的刷新类型。在 Tableau Prep 中运行刷新时，将显示一个对话框，告知您必须同时运行这两个输出。
    
    ![运行流程（增量刷新）对话框，其中包含输出和刷新类型以及“运行流程”按钮的表格。](/tableau/current/zh-cn/prep/zh-cn/Img/prep_incremental_warning1.png)