---
schema_version: "1"
id: 154db69e74c37bf469a93e9ad2c290710977cf51ee2a96b1c20c68c6263662cf
title: 使用嵌入式数据源
collection: tableau
version: current
locale: zh-cn
portal_url: https://docs.salesforce.com/tableau/current/zh-cn/online/to_bridge_eds.md
canonical_url: https://help.tableau.com/current/online/zh-cn/to_bridge_eds.htm
source_site: help.tableau.com
content_type: documentation
content_hash: 73a6bac9b4f40670290c011cf41cb7654e1b22551b5d539dde59d99424bc2495
description: Use embedded data sources with Tableau Bridge.
---
[跳转到主要内容](#main-content)

# 使用嵌入式数据源

Tableau Bridge 支持嵌入式数据源 (EDS) 和已发布数据源。借助 EDS 支持，可以按原样迁移需要 Bridge 的现有内容，而不是将嵌入式数据源转换为已发布数据源。

**注意**：对于包含嵌入式数据源的 Bridge 数据提取刷新连接，您可以合并来自多个源的数据。请参见[多个连接方案](https://help.tableau.com/current/online/zh-cn/to_bridge_manage.htm)。

## 注意事项

- Bridge 最多可支持每个客户端 16 个实时查询。借助嵌入式数据源支持，刷新配额会有额外计数。
- 有关 Tableau Bridge 如何影响站点容量的信息，请参见 [Bridge 站点容量](https://help.tableau.com/current/online/zh-cn/to_bridge_site_capacity.htm)。
- 当数据嵌入到工作簿中时，它是工作簿独有的；其他 Tableau Desktop 用户无法连接到它。您可以设置数据提取刷新计划，就像为已发布的数据源设置计划一样。
- 每个嵌入的数据源具有单独的数据连接。当连接到重复的数据副本时，性能可能会受到影响，例如，当连接到相同的原始数据并且每个工作簿都有自己的刷新计划时。
- 一旦配置了数据源的池映射和私有网络允许列表，现有的计划作业将被路由到 Bridge。这是因为嵌入式数据源的网络类型由池映射和私有网络允许列表确定。
- 已发布数据源通常是长时间运行的数据提取刷新任务的最佳选择。有关详细信息，请参见[优化 Bridge 刷新性能](https://help.tableau.com/current/online/zh-cn/to_bridge_eds_performance.htm)。
- 使用 Tableau Bridge 刷新的嵌入式数据提取使用实时查询。数据提取是在 Tableau Cloud 服务器上写入的，而不是在 Tableau Bridge 客户端计算机上写入的。因此，在计划组织的嵌入式数据提取使用量时，请考虑实时查询超时。请参见[超时限制](https://help.tableau.com/current/online/zh-cn/to_bridge_scale.htm#timeout)。

### 限制

- 不支持 Bridge 旧版计划。
- 默认池不支持嵌入式数据源。您必须使用已配置的池。有关详细信息，请参见[配置 Bridge 客户端池](https://help.tableau.com/current/online/zh-cn/to_enable_bridge_live_connections.htm)。
- 当连接是嵌入式数据源时，Bridge 不支持文件数据（例如 .cvs 和 .xlsx）的实时连接。
- Bridge Windows 客户端支持嵌入式数据源文件的数据提取刷新。您必须对嵌入式数据源使用已配置的池，并且文件路径必须使用 UNC 格式。Tableau 建议将文件大小限制为 5 GB。
- 适用于容器的 Linux 版 Bridge 不支持文件数据。
- 如果数据源是嵌入式，则使用 Tableau REST API 发布的工作簿或使用 API 的工具（例如 Content Migration Tool）不支持通过 Tableau Bridge 进行数据刷新。
    - 此限制也适用于直接在 Tableau Cloud Web 界面中使用“上载”选项手动上载的工作簿。
    - 对于指向 UNC 路径的 Excel 或平面文件，使用 REST API 进行发布将导致 [`FAKEPATH` 错误](https://help.salesforce.com/s/articleView?id=005232592&type=1)。出现此错误的原因是，基于 API 的发布过程无法正确解析 Bridge 客户端的本地或网络文件路径。
    - 解决办法：为了确保嵌入的 Excel 数据源可以使用 Tableau Bridge 成功刷新，您必须直接从 Tableau Desktop 中发布工作簿。或者，我们建议将数据源单独发布到 Tableau Cloud，然后将工作簿连接到该已发布的数据源。

### 具有实时连接的嵌入式数据源

1. 为数据源设置池映射。有关详细信息，请参见[“配置 Bridge 客户端池”](https://help.tableau.com/current/online/zh-cn/to_enable_bridge_live_connections.htm)。
2. 从 Tableau Desktop 中将数据源连接设置为“实时”。
3. 从工作表中，单击“服务器”\>“发布工作簿”。

![](/tableau/current/zh-cn/online/zh-cn/Img/bridge_eds_wb.png)

5. 若要查看工作簿中嵌入的数据源，请单击“数据源”。

![](/tableau/current/zh-cn/online/zh-cn/Img/bridge_eds_ds.png)

7. 单击“发布”。

发布工作簿后，将使用工作簿中包含的数据源来呈现工作簿。

### 具有数据提取连接的嵌入式数据源

1. 为数据源设置池映射。有关详细信息，请参见[“配置 Bridge 客户端池”](https://help.tableau.com/current/online/zh-cn/to_enable_bridge_live_connections.htm)。
2. 从 Tableau Desktop 中将数据源连接设置为“数据提取”。
3. 单击工作表，然后在“将数据提取另存为”表单中，为数据提取数据源提供一个名称。
4. 从工作表中，单击“服务器”\>“发布工作簿”。

![](/tableau/current/zh-cn/online/zh-cn/Img/bridge_EDS_extract2.png)

6. （可选）在“管理数据源”菜单中，选择允许刷新访问。

![](/tableau/current/zh-cn/online/zh-cn/Img/bridge_EDS_extract_access.png)

8. 单击“发布”。

发布工作簿后，将使用工作簿中包含的数据源来呈现工作簿。

### 编辑数据源

或者，在发布工作簿后，您可以从“数据源”选项卡或工作簿将连接类型从“实时”更改为“数据提取”。您也可以将工作簿中的连接类型从“数据提取”更改为“实时”。

若要从“数据源”选项卡中将连接类型从“实时”更改为“数据提取”：

1. 转到“数据源”选项卡。
2. 从“操作”菜单中，选择“数据提取”。

![](/tableau/current/zh-cn/online/zh-cn/Img/bridge_eds_extract.png)

若要从工作簿中将连接类型从“实时”更改为“数据提取”：

1. 转到“视图”选项卡。
2. 单击“编辑工作簿”。

![](/tableau/current/zh-cn/online/zh-cn/Img/bridge_eds_edit_workbook.png)

4. 单击左下角的“数据源”选项卡，然后单击右上角的“数据提取”。
5. 单击“创建数据提取”。

当工作簿数据源更改为“数据提取”时，会自动创建一个作业。

若要将连接类型从“数据提取”更改为“实时”，请从工作簿中更改连接。请勿从“数据源”选项卡中将数据源从“数据提取”更改为“实时”。

1. 转到“视图”选项卡。
2. 单击“编辑工作簿”。

![](/tableau/current/zh-cn/online/zh-cn/Img/bridge_eds_edit_workbook.png)

4. 单击左下角的“数据源”选项卡，然后单击右上角的“实时”。
5. 单击“发布”并刷新工作簿页面。

### 查看刷新作业

可以从“作业”页面查看多种任务类型。

对于使用 Bridge 的嵌入式数据源，任务类型为“数据提取刷新/创建”。对于使用 Bridge 客户端的已发布数据源，任务类型为“Bridge 刷新”。

![](/tableau/current/zh-cn/online/zh-cn/Img/bridge_eds_jobs2.png)

> [!IMPORTANT]
> 
> **注意**：将已发布工作簿连接类型从“实时”更改为“数据提取”时，将创建一个计划作业。但是，“任务类型”并不表明 Bridge 客户端已用作计划作业刷新或运行“立即刷新”时的数据源。任务类型列为“数据提取刷新/创建”。

### 刷新数据提取

您可以直接在 Tableau Cloud 上刷新使用大部分云数据提供程序托管的数据的数据提取。

1. 登录到向其发布数据源的 Tableau Cloud 站点。
2. 在“数据源”页面上，选择要刷新的数据源旁边的“更多操作”图标 (…)，然后从菜单中选择“刷新数据提取”。

![](/tableau/current/zh-cn/online/zh-cn/Img/bridge_edsextract_refresh.png)

4. 选择“刷新数据提取”会计划刷新，但不会立即运行刷新。若要运行刷新，请转到“数据提取刷新”选项卡，选择数据源旁边的“更多操作”图标 ( ... )，然后单击“立即运行”。

## 此部分中的其他文章