---
schema_version: "1"
id: 076f19fab99c55b592cbe8e5220138c6a2bdf588e45e418d6e878536825ba215
title: 设置动画格式
collection: tableau
version: current
locale: zh-cn
portal_url: https://docs.salesforce.com/tableau/current/zh-cn/online/formatting_animations.md
canonical_url: https://help.tableau.com/current/online/zh-cn/formatting_animations.htm
source_site: help.tableau.com
content_type: documentation
content_hash: f41016efd8040fb2687d19403a2a634b920bfdced3c2b459f34207722827e92f
description: Format animations to highlight changing patterns and transitions in visualizations.
---
[跳转到主要内容](#main-content)

# 设置动画格式

为可视化项设置动画，以更好地突出显示数据中不断变化的模式、显示峰值和异常值，并查看数据点如何进行聚类和分离。

动画在筛选、排序和缩放设置、不同页面以及对筛选器、参数和设置操作的更改之间进行视觉过渡。当可视化项以动画方式显示对这些更改的响应时，查看者可以更清楚地看到数据有何不同，从而帮助他们做出更明智的决策。

## 了解同步动画和顺序动画

制作动画时，您可以在两种不同的样式之间进行选择：同步动画或顺序动画。下面是每种类型的示例。

### 同步动画

在更简单的图表和仪表板中显示值更改时，默认的同步动画更快且效果良好。

![Tableau 动画。](/tableau/current/zh-cn/online/zh-cn/Img/animations.gif)  
单击上图可重播动画。

### 顺序动画

顺序动画需要更多的时间，但通过逐步呈现更改可以来使复杂的更改更加清晰。

![顺序动画。](/tableau/current/zh-cn/online/zh-cn/Img/animations_sequential.gif)  
单击上图可重播动画。

## 为工作簿中的可视化项设置动画

创建新工作簿时，Tableau 默认为您的可视化项启用动画。您可以在用户和工作簿级别打开或关闭动画。  

1. 选择“设置格式”\>“动画”。
2. 如果要为每个工作表设置动画，请在“工作簿默认值”下单击 “打开”。然后执行以下操作：
    - 对于“持续时间”，选择一个预设值，或指定最长 10 秒的自定义持续时间。
    - 对于“样式”，请选择“同步”以一次播放所有动画，或选择“顺序”以淡出效果显示标记，对标记进行移动和排序，然后以淡入效果显示标记。
3. 若要针对特定工作表覆盖工作簿默认值，请在“选定工作表”下更改设置。
    
    **注意：**在“选定工作表”部分，“(默认)”指明自动反映相关工作簿“默认”设置的设置。
    
    ![动画窗格，包含用于在工作簿或工作表级别配置动画的选项。](/tableau/current/zh-cn/online/zh-cn/Img/animations_pane.png)

若要重播动画，请单击工具栏中的“重播”按钮。从“重播”按钮中，您还可以选择动画重播的速度：实际速度、2 倍速度或 1/2 倍速度。

![用于选择重播速度的“重播”按钮下拉菜单](/tableau/current/zh-cn/online/zh-cn/Img/replay_speed.png)

## 重置工作簿的动画设置

您可以重置动画以将整个工作簿恢复为到默认动画设置。请注意，默认情况下这将关闭动画。

1. 选择“设置格式”\>“动画”。
2. 在“动画”窗格的中间，单击“重置所有工作表”。

## 完全禁用所有动画

创建新工作簿时，默认情况已启用动画。如果您在查看可视化项时发现发现动画会分散注意力，则可以完全禁用动画，使它们永远不会播放。（这不是系统范围的设置;每个用户都需要单独应用该设置。）

- 在 Tableau Desktop 中，选择“帮助”\>“设置和性能”，然后取消选择“启用动画”。
- 在 Tableau Cloud 或 Tableau Server 中，单击浏览器右上角的个人资料图像或首字母缩写，然后选择“我的帐户设置”。然后向下滚动到页面底部，取消选择“启用动画”，然后单击“保存更改”。

**注意：**禁用动画后，您仍然可以在制作模式下选择“设置格式”\>“动画”并调整设置，但它们将不起作用。

## 设置轴动画的小数格式

如果度量的小数位数设置为默认值，则轴动画期间显示的小数位数可能会在轴动画期间波动。为避免这种情况，请设置为度量显示的小数位数的格式。有关详细信息，请参见[设置数字和 Null 值的格式](https://help.tableau.com/current/pro/desktop/zh-cn/formatting_specific_numbers.htm)。

## 为什么动画无法播放

### 服务器呈现

如果可视化项是服务器呈现的，则动画不会播放。为了确保可视化项在客户端计算机或移动设备上呈现，请使用以下方法：

- 如果您是可视化项作者，请[降低可视化项复杂性](https://help.tableau.com/current/pro/desktop/zh-cn/perf_visualization.htm)。
- 如果您是 Tableau Server 管理员，请[提高客户端呈现的复杂性阈值](https://help.tableau.com/current/server/zh-cn/browser_rendering.htm)。

**注意：**在处理能力较低的计算机上，动画可能会显得断断续续，但用户可以继续与可视化项进行交互，响应不会出现延迟。

### 不支持的浏览器和功能

除 Internet Explorer 外，所有 Web 浏览器都支持动画。

以下 Tableau 功能不会以动画方式显示：

- Web 浏览器中的地图、多边形和密度标记
- 饼图和文本标记
- 标题
- 预测、趋势和参考线
- 页面历史记录痕迹（如果可视化项包含这些痕迹，请关闭动画以避免意外行为。）