---
schema_version: "1"
id: dcca5953e999c284533763dcf08c01b89c527f5273929133106711280b6a17d8
title: 在安装之后更改安装设置
collection: tableau
version: current
locale: zh-cn
portal_url: https://docs.salesforce.com/tableau/current/zh-cn/desktopdeploy/desktop_deploy_setting_changes.md
canonical_url: https://help.tableau.com/current/desktopdeploy/zh-cn/desktop_deploy_setting_changes.htm
source_site: help.tableau.com
content_type: documentation
content_hash: 8e43d5065ffdb30a9b34024d3482dc0350eece7e82181b3f1cc8e76718706944
description: Change Tableau Desktop installation settings after install, like language and repository location.
---
[跳转到主要内容](#main-content)

# 在安装之后更改安装设置

安装 Tableau Desktop 和 Tableau Prep Builder 时，有一些默认开启的功能。例如，对于 Tableau Desktop，安装过程中将会安装产品自动更新或用户工作簿自动保存功能。但您可能有一些不希望用户访问的功能，例如上载崩溃转储文件和日志的功能。作为管理员，您可以关闭其中一些功能。

对于 Windows，您还可以将自定义内容配置为显示在“发现”窗格中，将默认加速器工作簿替换为自定义示例工作簿，并在安装过程中关闭某些功能。有关这些功能的列表，请参见“通过命令行安装 Tableau Desktop 和 Tableau Prep Builder”中的[通过命令行安装](https://help.tableau.com/current/desktopdeploy/zh-cn/desktop_deploy_automate.htm#installer_properties)。

对于 Mac，您可以配置自定义发现窗格内容，将默认加速器工作簿替换为自定义工作簿， 或仅在安装之后关闭某些功能。若要为“发现”窗格配置自定义内容，将示例工作簿替换为自定义示例，或在安装后更改设置（Windows 和 Mac），您可以更改注册表或 `.plist` 文件，然后重新启动应用程序以查看更改。

若要将更改部署到远程计算机，您可以从注册表 (Windows) 或 .plist (Mac) 文件中导出设置，修改想要关闭的设置，然后使用修改后的文件创建一个自动化脚本，将更新推送到安装了 Tableau Desktop 的每台计算机。

> [!IMPORTANT]
> 
> **重要信息：**在对注册表文件进行任何更改之前，请始终备份该文件。不正确地编辑 Windows 注册表可能会对计算机造成严重影响。

## 设置显示语言（可选）

首次运行 Tableau Desktop 或 Tableau Prep Builder 时，它将使用“用户区域设置”设置识别您的计算机区域设置，并在支持时使用相应的语言。如果您使用的是不支持的语言，则应用程序默认为英语。

对于 Tableau Prep Builder，数字和日期的显示格式取决于安装了应用程序的计算机上操作系统的区域设置。对于 Tableau Desktop，您可以配置工作簿的日期和数字格式。有关详细信息，请参见 Tableau 用户帮助中的[语言和区域设置](https://help.tableau.com/current/pro/desktop/zh-cn/workbook_language.htm)。

若要配置 Tableau Desktop 或 Tableau Prep Builder 以不同的语言显示用户界面（菜单、消息等），请执行以下操作，然后重新启动应用程序以应用更改。

1. 在顶部菜单中选择“帮助”。
2. 选择“选择语言”。
3. 从列表中选择语言。

## 更改“我的 Tableau 存储库”位置（可选）

在安装过程中，Tableau Desktop 和 Tableau Prep Builder 会在您的计算机的文档文件夹中创建“我的 Tableau <应用程序> 存储库”文件夹结构。举例来说，如果因为需要将数据放在网络服务器（而不是本地计算机）上的原因，您需要将此存储库转移到另一个位置，则可以指定一个新位置，并将 Tableau Desktop 或 Tableau Prep Builder 指向该新文件夹。

为存储库设置新位置时，请遵循以下规则：

- 新文件夹必须为目录。
- 您必须具有写入新文件夹的权限。
- 新文件夹不能位于现有“我的 Tableau 存储库”文件夹结构中。

**注意：**更改存储库位置不会移动原始存储库中包含的文件。相反，Tableau 会创建一个您可在其中存储文件的新存储库。

1. 打开 Tableau Desktop 或 Tableau Prep Builder。
2. 从顶部菜单中，选择“文件”\>“存储库位置”。
3. 在“选择存储库文件夹”对话框中，选择一个将充当新存储库位置的新文件夹。
4. 重新启动应用程序以使用新存储库。

## 将“发现”窗格配置为显示自定义内容（仅限 Tableau Desktop）

默认情况下，Tableau 在 Tableau Desktop 的“发现”窗格中提供培训、博客文章和公共可视化项链接等信息，来帮助用户开始使用 Tableau。“发现”窗格在启动时显示并保留在开始页面上，以便用户可以随时找到这些链接和信息。

![Tableau 的“发现”窗格。](/tableau/current/zh-cn/desktopdeploy/zh-cn/Img/custom_discover_pane1.png)

但是，您可能希望使用“发现”窗格来显示特定于组织的内容。为此，您可以为托管在使用已启用 https 的 URL 提供的 Web 服务器创建自己的网页，然后使用 “DiscoverPane”键和“DiscoverPaneURL”值将 Tableau 提供的默认内容替换为自定义网页中的内容。

**注意**：为了获得最佳效果，请不要使用包含 javascript 或 redirects 的网页。

![Tableau 的“发现”窗格。](/tableau/current/zh-cn/desktopdeploy/zh-cn/Img/custom_discover_pane2.png)

为了帮助您快速开始操作，Tableau Desktop 提供了一个[模板](https://github.com/tableau/discover-pane-template)，该模板的布局与 Tableau 提供的“发现”窗格的布局相同。只需下载该模板，并将链接替换为自定义内容即可。该模板包括指标、布局结构和内容链接部分。

### Windows

通过将 `DISCOVERPANEURL="<https://YourWebPage.com>"` 属性添加到命令行，可以在使用命令行进行安装期间将“发现”窗格配置为指向自定义网页。如果要在安装完成后将“发现”窗格配置为使用自定义内容，请按照以下步骤操作。重新启动应用程序以查看更改。

1. 作为安装了 Tableau 的计算机上的管理员，请在对注册表文件进行任何更改之前将其备份。
2. 打开注册表编辑器 (`regedit.exe`)。
3. 导航到以下注册表路径：
    
    `Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau <version>`。例如，`Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau 2020.1`
4. 右键单击您的 Tableau 版本，然后选择“新建”\>“项”，并将其命名为 DiscoverPane。
5. 在新的“DiscoverPane”键的右侧窗格中，右键单击并选择“新建”\>“字符串值”，并将其命名为“DiscoverPaneURL”。
6. 右键单击新的 DiscoverPaneURL 字符串值，并选择“修改”。 然后在“编辑字符串”对话框的“值数据”字段中，输入自定义网页的 URL。 您的内容必须使用启用了 https 的 URL 托管。不支持使用启用了 http 的 URL。
    
     例如，`https://help.tableau.com/current/desktopdeploy/en-us/desktop_deploy_user.htm`。
    
    ![注册表编辑器，显示包括 Tableau 在内的各种软件的目录和设置。](/tableau/current/zh-cn/desktopdeploy/zh-cn/Img/custom_discover_pane_Regedit.png)
7. 若要将“发现”窗格重置回 Tableau Desktop 默认内容，请修改 DiscoverPaneURL 值并清除您输入的自定义网页 URL，同时将“值数据”字段留空。重新启动 Tableau Desktop，“发现”窗格时将显示默认 Tableau 内容。

### Mac

通过添加 DiscoverPane 键和 DiscoverPaneURL 值来修改 /Users/<local user>/Library/Preferences/com.tableau.Tableau-<version>.plist。重新启动应用程序以查看更改。

1. 通过从“终端”命令提示符运行以下命令，将值设置为自定义 URL。使用如下所示的相同大小写。
    
    `defaults write com.tableau.Tableau-<version> DiscoverPane.DiscoverPaneURL <https://YourWebPageURL>`
    
    例如，在 Tableau Desktop 2020.1 中，使用此命令：
    
    `defaults write com.tableau.Tableau-<version> DiscoverPane.DiscoverPaneURL https://help.tableau.com/current/desktopdeploy/en-us/desktop_deploy_user.htm`
2. 若要将“发现”窗格重置回 Tableau Desktop 默认内容，请运行以下命令：
    
    `defaults write com.tableau.Tableau-<version> DiscoverPane.DiscoverPaneURL " "`
    
    重新启动 Tableau Desktop，“发现”窗格时将显示默认 Tableau 内容。

## 将加速器工作簿替换为自定义工作簿（仅限 Tableau Desktop）

默认情况下，Tableau 提供三个打包加速器来帮助用户探索 Tableau。（在版本 2022.2 之前，这些加速器被称为示例工作簿。）从版本 2021.3 开始，您最多可以创建 5 个针对特定用户的打包工作簿，并将 Tableau 在“开始”页面的“加速器”部分提供的加速器替换为您的自定义工作簿。

**注意**：安装 Tableau Server 时，您可以选择在默认站点中包含示例工作簿。如果在安装过程中选中了“包括示例”选项，您可以将自定义示例工作簿从 Tableau Desktop 发布到您服务器上的“Tableau 示例”项目。

![连接页面上提供的 Tableau 加速器。](/tableau/current/zh-cn/desktopdeploy/zh-cn/Img/desktop_custom_samples.png)

自定义示例工作簿必须满足以下要求：

- 您一次最多可以包含 5 个示例工作簿。
- 仅支持打包工作簿 (.twbx) 文件。
- 工作簿必须存储在 Tableau 和用户具有“读取”访问权限的本地计算机上的目录中。不支持网络目录。
- 工作簿文件名不能包含字符 '、"、<、> 或 &。

**注意**：升级到新发布版本（例如 2021.4）时，不会保留自定义示例。通过命令行安装升级或在升级后修改注册表 (Windows) 或 .plist (MacOS) 时，您需要为自定义示例指定文件路径。

### 开始之前

**Windows 和 Mac**

在存储示例的本地计算机上创建一个目录，并添加最多 5 个示例打包工作簿 (.twbx) 文件。

您可以根据需要替换工作簿文件，但 5 是可以在“开始”页面上显示的最大工作簿数量。有关替换自定义工作簿的信息，请参见[管理自定义工作簿](#manage_custom_samples)。

### Windows

**通过命令行**

通过命令行安装时，添加属性 `CUSTOMSAMPLESDIR="path to directory"`。

例如：`tableauDesktop-64bit-2021-3-0.exe /quiet /norestart ACCEPTEULA=1 CUSTOMSAMPLESDIR="C:\Users\mkim\Documents\My Tableau Repository\CustomSamples"`

当您启动 Tableau Desktop 时，您应该会在“开始”页面上看到您的自定义示例。

**通过注册表安装后**

若要在安装完成后配置自定义示例目录，请按照以下步骤操作。重新启动应用程序以查看更改。

1. 作为安装了 Tableau 的计算机上的管理员，请在对注册表文件进行任何更改之前将其备份。
2. 打开注册表编辑器 (`regedit.exe`)。
3. 导航到以下注册表路径：
    
    `Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau <version>`。例如，`Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau 2021.3`
4. 创建一个名为 Samples 的新文件夹。在 Tableau 版本的文件夹上右键单击，选择“新建”\>“项”，然后重命名新的文件夹。
    
    ![显示用于创建新项的选项的 Tableau 版本菜单。](/tableau/current/zh-cn/desktopdeploy/zh-cn/Img/desktop_deploy_custom_samples1.png)
5. 右键单击您刚刚创建的 Samples 文件夹，选择“新建”\>“字符串值”，并将其命名为 CustomSamplesDir。
    
    ![下拉菜单中包含“新建”、“查找...”和“删除”等选项。](/tableau/current/zh-cn/desktopdeploy/zh-cn/Img/desktop_deploy_custom_samples2.png)
6. 右键单击新的 CustomSamplesDir 字符串值，并选择“修改”。然后在“编辑字符串”对话框的“数值数据”字段中，输入之前设置的目录的完整 Windows 文件路径。
    
    ![显示文件夹和文件分层结构的注册表编辑器窗口。](/tableau/current/zh-cn/desktopdeploy/zh-cn/Img/desktop_deploy_custom_samples3.png)
7. 重新启动 Tableau Desktop 以查看更改。该部分现在的标题为“您的自定义工作簿”。
    
    ![带有自定义工作簿的 Tableau 连接页面。](/tableau/current/zh-cn/desktopdeploy/zh-cn/Img/desktop_deploy_custom_samples4.png)
8. 若要重置为 Tableau Desktop 默认内容，请修改 CustomSamplesDir 值并清除您输入的目录路径，同时将“数值数据”字段留空。重新启动 Tableau Desktop 后，“开始”页面的“加速器”部分将显示默认 Tableau 内容。

### Mac

通过添加 Samples.CustomSamplesDir 键和示例目录路径值来修改 /Users/<local user>/Library/Preferences/com.tableau.Tableau-<version>.plist。重新启动应用程序以查看更改。

1. 通过从“终端”命令提示符运行以下命令，将值设置为自定义示例目录。使用如下所示的相同大小写。
    
    `defaults write com.tableau.Tableau-<version> Samples.CustomSamplesDir <your directory path>`
    
    例如，在 Tableau Desktop 2021.3 中，使用此命令：
    
    `defaults write com.tableau.Tableau-2021.3.0 Samples.CustomSamplesDir "/Users/mkim/Documents/My Tableau Repository/CustomSamples"`
2. 若要重置回 Tableau Desktop 默认内容，请运行此命令：
    
    `defaults write com.tableau.Tableau-<version> Samples.CustomSamplesDir " "`
    
    重新启动 Tableau Desktop 后，“开始”页面的“加速器”部分将显示默认 Tableau 内容。

### 管理自定义工作簿

将自定义示例工作簿添加到 Tableau Desktop 时，会在您首次打开应用程序时创建的自定义示例文件夹中自动生成 custom.manifest 文件和工作表缩略图。

使用新工作簿替换自定义示例工作簿时，您需要删除 custom.manifest 文件，以便可以生成新文件。删除工作表缩略图是可选的。

![显示文件列表的窗口，包括一个文档和几个折线图。](/tableau/current/zh-cn/desktopdeploy/zh-cn/Img/desktop_deploy_custom_samples5.png)

1. 导航到本地目录中的自定义示例文件夹。
2. 删除 custom.mainfest 文件。
3. 从自定义示例文件夹中删除或移动这些工作簿的工作簿和任何工作表缩略图（可选）。
4. 将新的打包 (.twbx) 工作簿添加到您的自定义示例文件夹。
5. 重新启动应用程序。

## 关闭产品更新

“产品更新”功能使用户可自动接收产品更新，或者在维护更新可用时检查并安装相应更新。若要在 Tableau Desktop 安装之后关闭产品更新，您必须为安装了 Tableau 的每台计算机更新注册表 (Windows) 或 `.plist` 文件 (Mac) 中的 `AutoUpdateAllowed` 项。

### Windows

1. 作为安装了 Tableau 的计算机上的管理员，请在对注册表文件进行任何更改之前将其备份。
2. 打开注册表编辑器 (`regedit.exe`)。
3. 将 `AutoUpdateAllowed` 注册表项设置为 `0`。下表列出了不同产品的该项所在位置。

<table><tbody><tr><td style="font-weight: bold;">产品</td><td style="font-weight: bold;">位置（64 位 Tableau 和 Windows）</td></tr><tr><td><p><span class="mc-variable Variables.TabsProductDesktop variable">Tableau Desktop</span></p></td><td><code>HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau <i>&lt;version&gt;</i>\AutoUpdate</code></td></tr><tr><td><p><span class="mc-variable Variables.TabsProductDesktop variable">Tableau Desktop</span> Public Edition</p></td><td><code>HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau Public <i>&lt;version&gt;</i>\AutoUpdate</code></td></tr><tr><td><p>Tableau Reader</p></td><td><code>HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau Reader <i>&lt;version&gt;</i>\AutoUpdate</code></td></tr></tbody></table>

若要再次启用产品更新，请按照相同的过程进行操作，但将注册表项设置为 `1`，而不是 `0`。

### Mac

从终端命令提示符中运行以下命令之一。

<table><thead><tr><th>产品</th><th>命令</th></tr></thead><tbody><tr><td><span class="mc-variable Variables.TabsProductDesktop variable">Tableau Desktop</span></td><td><code>defaults write com.tableau.Tableau-<em>&lt;version&gt;</em> AutoUpdate.AutoUpdateAllowed "0"</code><p>例如，在 <span class="mc-variable Variables.TabsProductDesktop variable">Tableau Desktop</span> 2019.1 中，使用此命令：</p><p><code>defaults write com.tableau.Tableau-2019.1 AutoUpdate.AutoUpdateAllowed "0"</code></p></td></tr><tr><td><span class="mc-variable Variables.TabsProductDesktop variable">Tableau Desktop</span> Public Edition</td><td><code>defaults write com.tableau.Tableau-Public-<em>&lt;version&gt;</em> AutoUpdate.AutoUpdateAllowed "0"</code></td></tr><tr><td>Tableau Reader</td><td><code>defaults write com.tableau.Tableau-Reader-<em>&lt;version&gt;</em> AutoUpdate.AutoUpdateAllowed "0"</code></td></tr></tbody></table>

若要再次启用产品更新，请运行相同的命令，但指定 `1`，而不是 `0`。

## 关闭文件恢复

利用文件恢复功能，Tableau Desktop 和 Tableau Prep Builder（版本 2020.3.3 及更高版本）能够保存用户的工作簿或流程文件，使用户在应用程序意外停止时不会丢失工作。当用户重新打开 Tableau 时，将显示一个对话框，其中包含可从中进行选择已恢复文件的列表。用户可以打开其已恢复的文件并从其中断的位置继续，或者可以删除不需要的任何文件。如果用户删除文件，则会丢弃自上次保存以来他们所做的任何更改。

如果用户删除 Tableau Desktop 列表中或 Tableau Prep Builder的“已恢复流程”文件夹中的的所有文件，则在生成新的已恢复文件之前，恢复对话框将不再显示。

默认情况下已启用文件恢复功能。如果要禁用它，可以更改属性 `AUTOSAVE` (Tableau Desktop) 或 maestro.appSetting.autosave 设置 (Tableau prep Builder) 设置。单击产品选项卡以查看用于关闭文件恢复的步骤。

关闭文件恢复功能时，用户将无法使用“启用自动保存”菜单选项。 如果要在安装之后重新启用该功能，您可以部署注册表（或 Mac 的 .plist）更新，以为安装了 Tableau 的每台计算机更改 `AUTOSAVE` 属性设置。有关如何在安装期间通过命令行控制此设置的详细信息，请参见[通过命令行安装](https://help.tableau.com/current/desktopdeploy/zh-cn/desktop_deploy_automate.htm#installer_properties)。

若要在 Tableau Desktop 安装之后关闭文件恢复，您必须为安装了 Tableau 的每台计算机更新注册表 (Windows) 或 `.plist` 文件 (Mac) 中的 `AutosaveAllowed` 项。

### Windows

1. 作为安装了 Tableau Desktop 的计算机上的管理员，请在对注册表文件进行任何更改之前将其备份。
2. 打开注册表编辑器 (`regedit.exe`)。
3. 将 `AutosaveAllowed` 注册表项设置为 `0`。
    
    注册表项位置：`HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau _<version>_\Autosave`

若要再次启用文件恢复，请按照相同的过程进行操作，但将 `AutosaveAllowed` 注册表项设置为 `1`，而不是 `0`。

### Mac

从终端命令提示符中运行以下命令。

`defaults write com.tableau.Tableau-_<version>_ Autosave.AutosaveAllowed "0"`

例如，在 Tableau Desktop 2020.3 中，使用此命令：

`defaults write com.tableau.Tableau-2020.3 Autosave.AutosaveAllowed "0"`

若要再次启用文件恢复，请运行相同的命令，但指定 `Autosave.AutosaveAllowed "1"`，而不是 `"0"`。

在安装过程中，可以通过命令行 (Windows) 关闭文件恢复功能，也可以在自定义安装部分中清除“安装类型”步骤上的“启用崩溃恢复”复选框来关闭该功能。有关如何在安装过程中关闭文件恢复功能的信息，请参见[开始之前](https://help.tableau.com/current/desktopdeploy/zh-cn/desktop_deploy_download_and_install.htm#Install)。

若要在安装 Tableau Prep Builder 后启用或关闭文件恢复功能，您必须为安装 Tableau Prep Builder 的每台计算机更改 `maestro.appSettings.autosave` 设置的属性。

### Windows

1. 在安装 Tableau Prep Builder 的计算机上，以管理员身份导航到 app 文件夹。例如：
    
    `C:\Program Files\Tableau\Tableau Prep Builder 2020.3\resources\app`
2. 在 app 文件夹中，打开 `application.properties` 文件。
3. 设置 `maestro.appSettings.autosave=false`

若要再次启用文件恢复，请按照相同的过程进行操作，但设置 `maestro.appSettings.autosave=true`。

### Mac

1. 导航到 `/Library/Application Support/Tableau Prep Builder/`
2. 在文本编辑器中打开 `application.properties` 文件。
3. 将 `maestro.appSettings.autosave=true` 更改为 `maestro.appSettings.autosave=false`
4. 保存更改并关闭该文件。

若要再次启用文件恢复，请按照相同的过程进行操作，但将 `maestro.appSettings.autosave=false` 更改为 `maestro.appSettings.autosave=true`。

## 关闭使用情况报告

Tableau 会收集数据，帮助我们了解产品的使用情况，以便改进现有功能并开发新的功能。所有使用情况数据均依据[隐私政策](https://www.salesforce.com/company/privacy/)收集和处理。如果您不想参与此选项，可通过在安装过程中或安装之后选择退出。

有关我们收集的数据类型的信息，请参见 [Tableau 产品使用情况数据](https://www.tableau.com/zh-cn/product-usage-data)。

如果不想参与此选项，可通过在安装过程中选中选择退出复选框来选择退出，或者通过添加包括 `SENDTELEMETRY="0"` 属性的命令行从命令行中选择退出 (Windows)。

有关在用户界面中禁用此选项的信息，请参见[通过用户界面安装](https://help.tableau.com/current/desktopdeploy/zh-cn/desktop_deploy_download_and_install.htm)。有关通过命令行禁用此选项的信息，请参见[通过命令行安装](https://help.tableau.com/current/desktopdeploy/zh-cn/desktop_deploy_automate.htm#Installer_options)。

即使您禁用产品使用情况数据的发送，某些基本产品数据也会发送到 Tableau。如果您不想向 Tableau 发送基本产品数据，也可以禁用此选项。有关详细信息，请参见[基本产品数据](https://help.tableau.com/current/desktopdeploy/zh-cn/usage_data_basic_product_data.htm)。

若要在安装之后选择退出此选项，请执行以下操作之一：

### 从产品中

1. 打开 Tableau Desktop。
2. 从顶部菜单中，选择“帮助”\>“设置和性能”。
3. 单击“不发送产品使用情况数据”。
    
    ![“设置和性能”子菜单，显示选择不共享产品使用数据的选项。](/tableau/current/zh-cn/desktopdeploy/zh-cn/Img/prep_usage_data_optout.png)

### 通过注册表

若要在系统级别关闭使用情况报告，请按照适用于您的操作系统的说明进行操作。

**Windows**

打开命令提示符并运行以下命令：

`REG ADD "HKLM\Software\Tableau\<Tableau Version>\Telemetry" /v TelemetryEnabled /t REG_DWORD /d 0`

或者，执行以下步骤：

1. 作为安装了 Tableau Desktop 的计算机上的管理员，请在对注册表文件进行任何更改之前将其备份。
2. 打开注册表编辑器 (`regedit.exe`)。
3. 将 `TelemetryEnabled` 注册表项设置为 `0`。
    
    注册表项位置：`HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau _<version>_\Telemetry`

若要再次启用使用情况报告，请按照相同的过程进行操作，但将注册表项设置为 `1`，而不是 `0`。

Mac

从终端命令提示符中运行以下命令。

`defaults write com.tableau.Tableau-_<version>_ Telemetry.TelemetryEnabled "0"`

例如，在 Tableau Desktop 2019.4 中，使用此命令：

`defaults write com.tableau.Tableau-2019.4 Telemetry.TelemetryEnabled "0"`

若要再次启用使用情况报告，请运行相同的命令，但指定 `1`，而不是 `0`。

若要在安装之后选择退出此选项，请执行以下操作之一：

### 从产品中

1. 以管理员身份打开 Tableau Prep Builder。
    
    - **Windows**：右键单击应用程序并选择“以管理员身份运行”。
    - **MacOS** ：在终端命令提示符下运行 `sudo /Applications/Tableau\ Prep\ Builder\ <version>.app/Contents/MacOS/Tableau\ Prep\ Builder`。
2. 从顶部菜单中，选择“帮助”\>“设置和性能”。
3. 单击“不发送产品使用情况数据”。
    
    **注意：**在版本 2019.3.2 及更低版本中，单击“共享使用情况数据以改进 Tableau Prep Builder”以清除复选标记
    
    ![“设置和性能”子菜单，显示选择不共享产品使用数据的选项。](/tableau/current/zh-cn/desktopdeploy/zh-cn/Img/prep_usage_data_optout.png)

#### 从属性文件中

**Windows**

1. 导航到 Tableau Prep Builder 安装目录中的 app 文件夹。例如，`C:\Program Files\Tableau\Tableau Prep Builder <version>\resources\app`
2. 在文本编辑器中打开 telemetryConfig.properties 文件。
3. 将 `maestro.telemetry.enabled=true` 更改为 `maestro.telemetry.enabled=false`
4. 保存更改并关闭该文件。

**Mac**

对于 Mac，此设置特定于用户。此设置不适用于系统上的任何其他用户，除非他们重新安装应用程序。

1. 导航到 `~/Library/Application Support/Tableau Prep Builder/`
2. 在文本编辑器中打开 telemetryConfig.properties 文件。
3. 将 `maestro.telemetry.enabled=true` 更改为 `maestro.telemetry.enabled=false`
4. 保存更改并关闭该文件。

## 关闭错误报告

如果 Tableau Desktop 或 Tableau Prep Builder 遇到问题并意外关闭，则会生成崩溃转储文件和日志，并放在 My Tableau 或 My Tableau Prep Builder 存储库中的 Logs 文件夹中。默认情况下已启用此选项。

这些文件中的数据可能包括特定于计算机的信息、发生崩溃时内存内容的快照（其中可能包括应用程序活动详细信息、数据连接信息、用户执行的操作，或正在 Tableau 中处理的数据），以及可识别客户的信息。

如果您的组织受数据隐私法规的约束，您可以禁用此选项。您需要完成不同的步骤来为 Tableau Desktop 和 Tableau Prep Builder 禁用此选项。单击下面的选项卡可查看适用于您的应用程序的说明。

对于 Tableau Desktop，用户下次打开应用程序时，将会打开一个对话框提示，使用户能够执行以下操作之一：

- 上载崩溃文件。
- 拒绝上载崩溃文件。
- 永久选择不上载崩溃文件。

如果用户上载文件，系统会使用 2048 位 RSA 密钥将文件一起压缩为一个加密包并发送到 Tableau，以便工程师能够进行分析，并确认导致崩溃的问题。

加密包包括：

- 崩溃转储文件 (.dmp)
- 与崩溃相关的错误日志文件 (.log)
- 与崩溃相关的清单文件 (.maifest)

如果您的组织须遵守数据隐私法规，您可以通过编辑注册表 (Windows) 或在每个桌面上运行脚本 (Mac) 来禁用此提示，使其不再显示，从而防止用户上载崩溃转储文件和日志。

### Windows

1. 作为安装了 Tableau 的计算机上的管理员，请在对注册表文件进行任何更改之前将其备份。
2. 打开注册表编辑器 (`regedit.exe`)
3. 将 `CrashReportUpload` 注册表项设置为 `2`。
    
    注册表项位置：`HKEY_CURRENT_USER\Software\Tableau\_<version>_\Prompts`

### Mac

从终端命令提示符中运行以下命令：

`defaults write com.tableau-<TABLEAU VERSION>.plist Prompts.CrashReportUpload -string 2`

例如，在 Tableau Desktop 2019.1 中，使用此命令：

`defaults write com.tableau.Tableau-2019.1.plist Prompts.CrashReportUpload -string 2`

对于 Windows 版 Tableau Prep Builder，您可以在安装过程中通过在“自定义”对话框上清除“启用错误报告”复选框来关闭错误报告选项，或通过包括属性 `CRASHDUMP="0"` 从命令行中关闭该选项。

若要在安装之后关闭此选项，请向 application.properties 文件的“application properties”部分添加 `maestro.enable_fault_reporting=false` 行。

此文件位于 `C:\Program Files\Tableau\<Tableau Prep Builder version>\resources\app` 中。

## 为仪表板关闭网页对象（仅限 Tableau Desktop）

网页对象在仪表板的某个部分中显示目标 URL。在安装过程中，请参见[通过命令行安装](https://help.tableau.com/current/desktopdeploy/zh-cn/desktop_deploy_automate.htm#installer_properties)以禁用这些对象中的 URL 显示。安装后，完成以下步骤。

### Windows

1. 作为安装了 Tableau 的计算机上的管理员，请在对注册表文件进行任何更改之前将其备份。
2. 打开注册表编辑器 (`regedit.exe`)
3. 将 `WebViewToggleWebZonesEnabled` 注册表项设置为 `0`。
    
    注册表项位置：`HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\_<version>_\Settings`

### Mac

从终端命令提示符中运行以下命令。

`defaults write /Library/Preferences/com.tableau.Tableau-<version>.plist Settings.WebViewToggleWebZonesEnabled -integer 0`

例如，在 Tableau Desktop 2020.4 中，使用此命令：

`defaults write /Library/Preferences/com.tableau.Tableau-2020.4.plist Settings.WebViewToggleWebZonesEnabled -integer 0`

若要再次启用网页对象，请运行相同的命令，但指定 `-integer 1`，而不是 `-integer 0`。

## 禁用仪表板和可视化项扩展程序（仅限 Tableau Desktop）

仪表板和可视化项扩展程序借助 Tableau 和第三方开发人员创建的 Web 应用程序来扩展仪表板和 Tableau 的原生可视化功能。

Tableau 支持两种标准的扩展程序：Tableau 可信扩展程序（在 Tableau Web 服务器上运行，并在部署前经过 Tableau 主导的审查），或支持网络的扩展程序（在第三方 Web 服务器上运行）。支持网络的扩展程序支持的方案包括扩展程序直接托管在本地网络内部或由本地网络外部的非 Tableau 第三方服务托管的实例，例如作为合作伙伴开发人员提供的生产服务...有关仪表板和可视化项扩展程序的详细信息，请参见[使用仪表板扩展程序](https://help.tableau.com/current/pro/desktop/zh-cn/help.htm#dashboard_extensions.htm)和[将可视化项扩展程序添加到工作表](https://help.tableau.com/current/pro/desktop/zh-cn/viz_extensions.htm)。有关部署选项的详细信息，请参见[扩展程序安全性 - 部署最佳做法](https://help.tableau.com/current/server/zh-cn/security_extensions.htm)。

扩展程序默认情况下处于启用状态，从而允许在 Tableau Desktop 上使用 Tableau 可信扩展程序和支持网络的扩展程序。Tableau 可信扩展程序会自动运行，而支持网络的扩展程序在运行前需要用户权限。

如果要在安装期间禁用扩展程序，请设置以下属性。有关详细信息，请参见[通过命令行安装](https://help.tableau.com/current/desktopdeploy/zh-cn/desktop_deploy_automate.htm#installer_properties)。

- `DISABLEEXTENSIONS="1"`：禁用所有扩展程序类型。
- `DISABLENETWORKEXTENSIONS`\="1"：仅禁用支持网络的扩展程序。
- `DISABLESANDBOXEXTENSIONS`\=“1”： 仅禁用 Tableau 托管的沙盒化扩展程序
- `DISABLETABTRUSTEDEXTENSIONS` =“1”：仅禁用由 Tableau 托管的 Tableau 构建的扩展程序
- `DISABLE3PTRUSTEDEXTENSIONS` =“1”：仅禁用由 Tableau 托管的 Tableau 可信合作伙伴构建的扩展程序
    
    这些配置将禁止在 Tableau Desktop 安装中使用扩展程序或特定类型的扩展程序。用户仍将看到用于加载仪表板和可视化项扩展程序的选项，并有权访问 Tableau Exchange，但 Tableau Desktop 将根据应用的配置阻止使用扩展程序运行。

### 安装后禁用所有扩展程序

若要在安装后禁用所有扩展程序，请编辑注册表 (Windows) 或使用以下说明在每个桌面上运行脚本 (MacOS)。

#### Windows

1. 作为安装了 Tableau 的计算机上的管理员，请在对注册表文件进行任何更改之前将其备份。
2. 打开注册表编辑器 (`regedit.exe`)
3. 将 `DisableExtensions` 注册表项设置为 1。
    
    注册表项位置：`HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau <version>\Settings\Extensions\DisableExtensions`

#### Mac

从终端命令提示符中运行以下命令：

`defaults write com.tableau.tableau-<TABLEAU VERSION>.plist Settings.Extensions.DisableExtensions "1"`

例如，在 Tableau Desktop 2019.4 中，使用此命令：

`defaults write com.tableau.tableau-2019.4.plist Settings.Extensions.DisableExtensions "1"`

### 安装后禁用特定类型的扩展程序

从 Tableau Desktop 2025.3 开始，桌面管理员可以在安装后启用和禁用特定类型的扩展程序。编辑注册表 (Windows) 或使用以下说明在每个桌面上运行脚本 (MacOS)。

#### Windows

作为安装了 Tableau 的计算机上的管理员，请在对注册表文件进行任何更改之前将其备份。

打开注册表编辑器 (regedit.exe)

将以下任意注册表项更新为 1 以禁止每种类型的扩展程序：

- `DISABLENETWORKEXTENSIONS`\="1"：仅禁用支持网络的扩展程序。
- `DISABLESANDBOXEXTENSIONS`\=“1”： 仅禁用 Tableau 托管的沙盒化扩展程序
- `DISABLETABTRUSTEDEXTENSIONS` \=“1”：仅禁用由 Tableau 托管的 Tableau 构建的扩展程序
- `DISABLE3PTRUSTEDEXTENSIONS` \=“1”：仅禁用由 Tableau 托管的 Tableau 可信合作伙伴构建的扩展程序

注册表项位置：`HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau <version>\Settings\Extensions\`

#### Mac

从终端命令提示符中运行以下命令之一：

- 仅禁用支持网络的扩展程序：
    
    `defaults write com.tableau.tableau-<TABLEAU VERSION>.plist Settings.Extensions.DisableNetworkExtensions` "1"
- 仅禁用 Tableau 托管的沙盒化扩展程序：
    
    `defaults write com.tableau.tableau-<TABLEAU VERSION>.plist Settings.Extensions.DisableSandboxExtensions` "1"
- 仅禁用由 Tableau 托管的 Tableau 构建的扩展程序：
    
    `defaults write com.tableau.tableau-<TABLEAU VERSION>.plist Settings.Extensions.DisableTabTrustedExtensions` "1"
- 仅禁用由 Tableau 托管 Tableau 可信合作伙伴构建的扩展程序：
    
    `defaults write com.tableau.tableau-<TABLEAU VERSION>.plist Settings.Extensions.Disable3PTrustedExtensions` "1"

例如，若要在 Mac Tableau Desktop 2025.3 中仅禁用支持网络的扩展程序，请使用此命令：

`defaults write com.tableau.tableau-2025.3.plist Settings.Extensions.DisableNetworkExtensions` "1"

## 更改日志文件夹位置

若要在 Tableau Desktop 上更改默认日志文件夹位置，请参见知识文章[在 Tableau Desktop 上更改日志文件夹位置](https://help.salesforce.com/s/articleView?id=005166930&type=1)。