---
schema_version: "1"
id: 4a102be1b9b23d7217ac780f476964510cc68b88cd07f96c70ebe37dcc7ffdcf
title: ログ ファイルのスナップショット (ログのアーカイブ)
collection: tableau
version: current
locale: ja-jp
portal_url: https://docs.salesforce.com/tableau/current/ja-jp/server/logs_archive.md
canonical_url: https://help.tableau.com/current/server/ja-jp/logs_archive.htm
source_site: help.tableau.com
content_type: documentation
content_hash: 31c42aae887a1ffb04fc972dd339dd8e91dc8e880934511718ad7d0349e1721f
description: Generate and send log file snapshots (archive logs) for Tableau Server.
---
[メイン コンテンツに進む](#main-content)

# ログ ファイルのスナップショット (ログのアーカイブ)

Tableau Server には、アーカイブ目的でログ ファイルのスナップショットを生成する機能があります。定期的なサーバー メンテナンスの一環として古いログ ファイルのクリーンアップや削除を計画している場合、それを削除する前に、サーバー外の保存場所にログ ファイルをアーカイブすることを検討するかもしれません。

**注**: 以前のバージョンの Tableau Server for Windows でのログ収集に関する説明は、[Tableau ヘルプ](https://www.tableau.com/ja-jp/support/help) ページのアーカイブされたオンライン ヘルプを参照してください。

または、あるケースに関して Tableau サポートと協力している場合には、サポート エンジニアがサーバー ログ ファイルのスナップショットを要求する場合があります。

このトピックで説明する内容:

- ログ ファイルのスナップショットを作成する方法
- Tableau Server 管理ツールから Tableau サポートに直接スナップショットを送信する方法
- スナップショットをダウンロードする方法
- アーカイブ済みのログを削除する方法

1. ブラウザーで TSM を開きます。
    
    https://<tsm-computer-name>:8850詳細については、「[Tableau サービス マネージャーの Web UI へのサインイン](https://help.tableau.com/current/server/ja-jp/sign_in_tsm.htm)」を参照してください。
2. \[メンテナンス\] をクリックします。
3. ログ ファイルのスナップショットを作成します。
    
    1. サーバーの \[メンテナンス\] ページの \[ログ ファイル\] で、\[ログ ファイルのスナップショットを作成\] をクリックします。
        
        オプションのダイアログが表示されます。
        
        ![ログ ファイルのスナップショットを生成するためのフォーム フィールドを含むダイアログ ボックス。](/tableau/current/ja-jp/server/ja-jp/Img/tsm-ui-log-snapshot-win.png)
    2. \[オプション\] ページで、\[説明\]、含めるログ ファイルの期間の \[範囲\]、含めるログの種類 (オプション) など (\[netstat 情報を含める\]、\[MSInfo を含める\]、\[Postgres データを含める\]、\[最近のクラッシュ ダンプを含める\])、必要なオプションを入力するか選択し、\[ログ ファイルのスナップショットを作成\] をクリックします。
    
    ログ ファイルのスナップショットが、TSM および Tableau Server がインストールされているコンピューターの固定された場所に保存されます。マルチノード インストールを行う場合、スナップショットはクラスタの最初のノードに保存されます。この場所は、`basefilepath_log_archives` 変数で指定します。
    
    既定ではスナップショットは次に保存されます。
    
    `C:\ProgramData\Tableau\Tableau Server\data\tabsvc\files\log-archives`
    
    現在の場所は `basefilepath.log_archives` 設定をクエリして確認でき、`basefilepath.log_archive` に新しい値を指定することで場所を変更できます。詳細については、[tsm ファイル パス](https://help.tableau.com/current/server/ja-jp/cli_default_filepaths_tsm.htm)を参照してください。
4. スナップショットの生成後は、それを選択してテクニカル サポートへのアップロード、ローカル マシンへのダウンロード、または削除を行えます。
    
    ![生成されたログ ファイルと、ログ ファイルを生成、ダウンロード、アップロード、または削除するためのオプションを含むテーブル。](/tableau/current/ja-jp/server/ja-jp/Img/tsm-maint-gen-snapshot-actions.png)
5. スナップショットのローカル コピーをダウンロードするには、またはそれを削除するには、\[ログ ファイル\] でスナップショットを選択し、該当する \[アクション\] を選択します。

### Tableau サポート用のログのスナップショットのアップロード

1. \[メンテナンス\] タブをクリックします。
2. 送信するスナップショットを選択します。
    
    ![生成されたログ ファイルと、ログ ファイルを生成、ダウンロード、アップロード、または削除するためのオプションを含むテーブル。](/tableau/current/ja-jp/server/ja-jp/Img/tsm-maint-gen-snapshot-actions.png)
3. \[テクニカル サポート ケースへのアップロード\] をクリックします。
4. 表示されるダイアログで \[サポート ケース番号\] および \[連絡先メール アドレス\] に入力し、\[スナップショットのアップロード\] をクリックします。
    
    ![Tableau テクニカル サポートに送信するログ ファイル スナップショットの詳細を入力するためのフィールドがある、テクニカル サポート ケースへのアップロード ウィンドウ。](/tableau/current/ja-jp/server/ja-jp/Img/tsm-maint-snapshot-upload.png)

ログ アーカイブを Tableau サポートに送信するその他の方法については、Salesforce ヘルプの[「Tableau への大きなファイルの送信」](https://help.salesforce.com/s/articleView?id=001537676&type=1)を参照してください。

[`tsm maintenance ziplogs`](https://help.tableau.com/current/server/ja-jp/cli_maintenance_tsm.htm#tsm4ziplogs) コマンドを使用して、Tableau Server ログ ファイルのスナップショットのアーカイブを作成します。

既定では、このコマンドによりすべてのログ ファイルを含む zip ファイルが作成されます。Tableau Server の分散インストールを実行している場合、初期ノードからこの手順を実行します。すべてのノードからのログが zip ファイルに含まれます。

ログ ファイルのスナップショットを作成するには、次の手順を実行します。

1. 最初のノードで、管理者としてコマンド プロンプトを開きます。
2. 次のコマンドを入力します。
    
    `tsm maintenance ziplogs -l -f <filename>`
    
    ここで、`<filename>` は作成する zip アーカイブ ファイルの名前です。スペースを含まない一意の名前を指定します。同じファイル名の ziplog が既存する場合は、コマンドに `-o` オプションを含めて強制的な上書き、既存ファイルの削除、または別の名前の指定を行わない限り、ファイルの作成に失敗します。
    
    スナップショットの時間範囲と、含めるログのタイプを指定することができます。たとえば、エラーが発生したタイミングがわかっている場合は、`--startdate` オプションと `--enddate` オプションを使用して、エラー発生前後の数時間からログをキャプチャします。
    
    `tsm maintenance ziplogs -f <filename> --startdate "<mm/dd/yyyy H:mm>" --enddate "<mm/dd/yyyy H:mm>"`
    
    詳細については、[tsm maintenance ziplogs](https://help.tableau.com/current/server/ja-jp/cli_maintenance_tsm.htm#tsm4ziplogs)を参照してください。
    
    ログ ファイルのスナップショットが、TSM および Tableau Server がインストールされているコンピューターの固定された場所に保存されます。マルチノード インストールを行う場合、スナップショットはクラスタの最初のノードに保存されます。この場所は、`basefilepath_log_archives` 変数で指定します。
    
    既定では、ログ ファイルのスナップショットは次の場所に保存されます。
    
    `C:\ProgramData\Tableau\Tableau Server\data\tabsvc\files\log-archives`
    
    `basefilepath.log_archives` 設定を照会すると、現在の場所を見つけることができます。
    
    tsm configuration get -k basefilepath.log\_archive
    
    `basefilepath.log_archive`をクリックし、新しい値を指定して場所を変更します。
    
    tsm configuration set -k basefilepath.log\_archive -v "<drive>:\\new\\directory\\path"
    
    詳細については、[tsm ファイル パス](https://help.tableau.com/current/server/ja-jp/cli_default_filepaths_tsm.htm)を参照してください。

### Tableau Support のログ アーカイブの送信

カスタマー サポート ケースの一部としてログ ファイルを Tableau サポートへ送信できます (カスタマー サポート ケース番号が必要)。ログ ファイルを送信する前に、`tsm maintenance ziplogs` コマンドを使用して、ログ ファイルを単一の zip ファイル アーカイブにまとめます。

- コマンド プロンプトで、次のコマンドを入力します。
    
    `[tsm maintenance send-logs](https://help.tableau.com/current/server/ja-jp/cli_maintenance_tsm.htm#tsmSendLogs) -f <zip file name> -c <case number> -e <email address>`
    
    ここで、`<case number>` はサポート ケース番号、`<email address>` はこのサポート ケースの連絡先メール、`<zip file name>` は .zip ファイル拡張子が付いたアーカイブのファイル名です。

ログ アーカイブを Tableau サポートに送信するその他の方法については、Salesforce ヘルプの[「Tableau への大きなファイルの送信」](https://help.salesforce.com/s/articleView?id=001537676&type=1)を参照してください。