# tableau Tableau Desktop and Web Authoring (pro) - Full Documentation [メイン コンテンツに進む](#main-content) # 高度な分析のビューへの適用 (\[アナリティクス\] ペイン) \[アナリティクス\] ペインから、リファレンス ライン、箱ヒゲ図、傾向線、予測などのアイテムをビューにドラッグします。\[データ\] ペインと \[アナリティクス\] ペインを切り替えるには、左側のサイド バーの上部にあるタブをクリックします。  Tableau Desktop の \[アナリティクス\] ペイン Tableau Desktop では、アナリティクス オブジェクトをビューに追加するオプションを \[アナリティクス\] ペインまたはメニュー、あるいはビューのコンテキストで使用できます。たとえば、軸を編集するときはリファレンス ラインおよびバンドを使用でき、傾向線と予測値は \[アナリティクス\] メニューから使用できます。 \[アナリティクス\] ペインでは、ドラッグ & ドロップでさまざまなオプションにアクセスできます。 Web では、ほとんどのアナリティクス オブジェクトを \[アナリティクス\] ペインから使用できます。 ## アナリティクス オブジェクトのビューへの追加 \[アナリティクス\] ペインからアイテムを追加するには、アイテムをビューにドラッグします。\[アナリティクス\] ペインからアイテムをドラッグすると、Tableau によって、そのアイテムをドロップできる場所が表示されます。選択の範囲は、アイテムの種類と現在のビューによって異なります。 単純なケースでは、ドロップ ターゲット領域で次の 3 つのオプションが提供されます。  表、ペイン、およびセルという各用語は、アイテムのスコープを定義する際に使用されます。  二重軸を含むビューなど、より複雑なビューの場合は、次のようなドロップ ターゲット領域が表示されます。  ドロップ ターゲット領域の上部にあるヘッダーの 3 つの大きなボックスのいずれかに (たとえば、表ボックスに) アイテムをドロップすると、各軸に四分位数付きの個別の中央値が追加されます。  特定のメジャーを基準にして整列する下の 6 つのボックスのいずれかにアイテムをドロップすると、四分位数付き中央値は、指定されたスコープで対応する軸に対してのみ追加されます。 ## アナリティクス オブジェクトをビューから削除 \[元に戻す\] をクリックしてビューからアナリティクス オブジェクトを削除するか、オブジェクトをビューの外にドラッグして削除できます。 また、アイテムをクリックして、ツールヒントから \[削除\] を選択することもできます。 **注**: いくつかの \[アナリティクス\] ペイン アイテムは (四分位数付き中央値および 95% 信頼区間の平均)、リファレンス ラインとリファレンス分布を追加します。\[元に戻す\] を使用しない場合は、これらのアイテムを個別に削除する必要があります。 ## アナリティクス オブジェクトのビューでの編集 \[アナリティクス\] ペインから追加したアイテムを編集するには、アイテムをクリックし、ツールヒントから \[編集\] を選択します。編集オプションの詳細については、下の「アナリティクス オブジェクトの定義」の特定のアイテムの種類に関するセクションを参照してください。 ## アナリティクス オブジェクトの定義 次のアイテムは、\[アナリティクス\] ペインからドラッグしてビューにドロップできます。アナリティクス オブジェクトをビュー内のフィールドの現在の構成に適用できない場合は、このオブジェクトを使用できません。 ### 定数線 1 つもしくは複数の定数線をビューに追加します。定数線を、特定のメジャー、すべてのメジャー、または日付ディメンションに追加できます。定数線を追加すると、Value プロンプトが表示され、定数の値を指定するように求められます。  Tableau Desktop では、日付値の Value プロンプトがカレンダー コントロールになります。  表示された定数線をクリックし、\[編集\] または \[削除\] を選択できます。Tableau Desktop には、3 つ目のオプションとして \[書式設定\] があります。\[編集\] を選択すると、\[リファレンス ラインの編集\] ダイアログ ボックスが開きます。詳細については、「**リファレンス ライン、リファレンス バンド、リファレンス分布、およびリファレンス ボックス**」記事の「[既存のリファレンス ライン、リファレンス バンド、リファレンス分布の編集](https://help.tableau.com/current/pro/desktop/ja-jp/reference_lines.htm#Edit_Existing_Reference_Lines_and_Bands)」を参照してください。Tableau Desktop でラインを編集するもう 1 つの方法として、関連する軸を右クリック (Mac では Control を押しながらクリック) し、\[リファレンス ラインの編集\] を選択できます。 ### 平均線 1 つもしくは複数の平均線をビューに追加します。平均線を特定のメジャーまたはすべてのメジャーに追加できます。 表示された平均線をクリックし、総計や合計など、別の集計を選択することができます。\[編集\] または \[削除\] を選択することもできます。Tableau Desktop には、3 つ目のオプションとして \[書式設定\] があります。\[編集\] を選択すると、\[リファレンス ラインの編集\] ダイアログ ボックスが開きます。詳細については、「**リファレンス ライン、リファレンス バンド、リファレンス分布、およびリファレンス ボックス**」記事の「[既存のリファレンス ライン、リファレンス バンド、リファレンス分布の編集](https://help.tableau.com/current/pro/desktop/ja-jp/reference_lines.htm#Edit_Existing_Reference_Lines_and_Bands)」を参照してください。Tableau Desktop でラインを編集するもう 1 つの方法として、関連する軸を右クリック (Mac では Control を押しながらクリック) し、\[リファレンス ラインの編集\] を選択できます。 ### 四分位数付き中央値 1 つまたは複数の中央値の線と分布バンドをビューに追加します。四分位数付き中央値を特定のメジャーまたはすべてのメジャーに追加します。 分布バンドは、四分位数として計算されます。中央の 2 つの四分位数が網掛けされます。 表示された中央値の線または分布をクリックし、\[編集\] または \[削除\] を選択できます。Tableau Desktop には、3 つ目のオプションとして \[書式設定\] があります。中央値の線と分布は、別々に編集、書式設定、または削除する必要があります。\[編集\] を選択すると、\[リファレンス ラインの編集\] ダイアログ ボックスが開きます。オプションを表示するには、分布バンドの外縁をクリックする必要があります。バンドの中央をクリックしても何も表示されません。詳細については、「**リファレンス ライン、リファレンス バンド、リファレンス分布、およびリファレンス ボックス**」記事の「[既存のリファレンス ライン、リファレンス バンド、リファレンス分布の編集](https://help.tableau.com/current/pro/desktop/ja-jp/reference_lines.htm#Edit_Existing_Reference_Lines_and_Bands)」を参照してください。Tableau Desktop で線または分布を編集するもう 1 つの方法として、関連する軸を右クリック (Mac では Control を押しながらクリック) し、\[リファレンス ラインの編集\] を選択できます。サブメニューには 2 つの選択肢があります。\[四分位数\] と \[中央値\] です。 四分位数を含む分布の種類については、**「リファレンス ライン、リファレンス バンド、リファレンス分布、およびリファレンス ボックス」**記事の[リファレンス分布の追加](https://help.tableau.com/current/pro/desktop/ja-jp/reference_lines.htm#Add_Reference_Distributions)を参照してください。 ### ボックス プロット 1 つもしくは複数のボックスプロットをビューに追加します。ボックスプロットを特定のメジャーまたはすべてのメジャーに追加できます。ボックスプロットのスコープは、常に \[セル\] です (\[表\] または \[ペイン\] ではありません)。 ボックス プロットのいずれかの横線をクリックまたはポイントすると、ヒゲ、四分位数、中央値についての統計情報が表示されます。 線をクリックしたときに、\[編集\] または \[削除\] を選択することもできます。Tableau Desktop には、3 つ目のオプションとして \[書式設定\] があります。\[編集\] を選択すると、\[リファレンス ラインの編集\] ダイアログ ボックスが開きます。Tableau Desktop で箱ヒゲ図を編集するもう 1 つの方法として、関連する軸を右クリック (Mac では Control を押しながらクリック) し、\[リファレンス ラインの編集\] を選択できます。 **注**: Tableau Desktop では、\[アナリティクス\] ペインに "ボックス プロット" という名前の 2 つのアイテムがあります。\[要約\] セクションの \[ボックス プロット\] オプションでは、指定されたターゲットに対してボックス プロットが自動的に追加されます。\[カスタム\] セクションの \[箱ヒゲ図\] オプションでは、ターゲットを指定するとダイアログが開きます。 ### 合計 合計をビューに追加します。合計を追加すると、ドロップダウン リストには \[小計\]、\[列の総計\]、および \[行の総計\] が表示されます。 詳細については、[ビジュアライゼーションでの合計の表示](https://help.tableau.com/current/pro/desktop/ja-jp/calculations_totals_grandtotal_turnon.htm)を参照してください。 合計を削除するには、関連する列または行ヘッダーをクリックし、\[削除\] を選択します。 Tableau Desktop では、合計を追加した後に合計の列見出しまたは行見出しをクリックし、ツールヒントからその集計を設定することもできます。  ### 95% 信頼区間の平均 分布バンドと共に 1 つまたは複数の平均線のセットを追加します。分布バンドは、95% の信頼区間で構成されます。これらのアイテムを特定のメジャーまたはすべてのメジャーに追加できます。 信頼区間の分布バンドは、母集団平均が 95% の確立で入る範囲を網掛けします。 表示された中央値の線または分布をクリックし、\[編集\] または \[削除\] を選択できます。Tableau Desktop には、3 つ目のオプションとして \[書式設定\] があります。\[編集\] を選択すると、\[リファレンス ラインの編集\] ダイアログ ボックスが開きます。平均線と分布は、別々に編集、書式設定または削除する必要があります。オプションを表示するには、分布バンドの外縁をクリックする必要があります。バンドの中央をクリックしても何も表示されません。Tableau Desktop で線または分布を編集するもう 1 つの方法として、関連する軸を右クリック (Mac では Control を押しながらクリック) し、\[リファレンス ラインの編集\] を選択できます。サブメニューには 2 つの選択肢があります。\[平均\] と \[95% 信頼区間\] です。 線やバンドは、ビューの外側にドラッグして削除することもできます。 ### 95% 信頼区間の中央値 分布バンドと共に 1 つまたは複数の中央値の線のセットを追加します。分布バンドは、95% の信頼区間で構成されます。これらのアイテムを特定のメジャーまたはすべてのメジャーに追加できます。 信頼区間の分布バンドは、母集団の中央値が 95% の確率で入る範囲を網掛けします。 表示された中央値の線または分布をクリックし、\[編集\]、\[書式設定\]、または \[削除\] を選択できます。Tableau Desktop には、3 つ目のオプションとして \[書式設定\] があります。\[編集\] を選択すると、\[リファレンス ラインの編集\] ダイアログ ボックスが開きます。中央値の線と分布は、別々に編集、書式設定、削除する必要があります。オプションを表示するには、分布バンドの外縁をクリックする必要があります。バンドの中央をクリックしても何も表示されません。Tableau Desktop で線または分布を編集するもう 1 つの方法として、関連する軸を右クリック (Mac では Control を押しながらクリック) し、\[リファレンス ラインの編集\] を選択できます。サブメニューには 2 つの選択肢があります。\[中央値\] と \[95% 信頼区間\] です。 線やバンドは、ビューの外側にドラッグして削除することもできます。 ### 傾向線 1 つもしくは複数の傾向線をビューに追加します。傾向線を追加する時に、ドロップダウン メニューには Tableau で使用できる傾向線モデルの種類が表示されます。線形、対数、指数、および多項です。いくつかのビューでは、これらのオプションのサブセットのみを使用できます。 詳細については、「[傾向線モデル タイプ](https://help.tableau.com/current/pro/desktop/ja-jp/trendlines_add.htm#modeltype)」を参照してください。 傾向線をクリックして削除または編集するか、統計的定義を表示します。傾向線は、ビューの外側にドラッグして削除することもできます。 ### 予測 予測をビューに追加します。このオプションは Tableau Desktop でのみ使用可能で、Web 上のビューで編集している場合は使用できません。予測は、ビューに少なくとも 1 つのメジャーがあるときにのみ可能です。 多次元データ ソースに基づくビューでは、予測はサポートされていません。また、ビューには以下を含めることはできません。 - 表計算 - 非集計メジャー - 割合計算 - 総計または小計 - 集計が \[正確な日付\] に設定された日付値 NULL 値を含む時系列には制約もあります。 詳細については、[予測](https://help.tableau.com/current/pro/desktop/ja-jp/forecasting.htm)を参照してください。 現在の予測の説明を削除、編集、または読み取るには、\[分析\] メニューから \[予測\] を選択します。 ### カスタム リファレンス ライン ビュー内の特定のメジャーまたはすべてのメジャーに対してリファレンス ラインを追加できます。 リファレンス ラインを \[アナリティクス\] ペインからドラッグしてターゲットにドロップすると、Tableau で自動的に編集ダイアログ ボックスが開かれます。使用可能なオプションについては、**「リファレンス ライン、リファレンス バンド、リファレンス分布、およびリファレンス ボックス」**記事の[リファレンス ラインの追加](https://help.tableau.com/current/pro/desktop/ja-jp/reference_lines.htm#Add_a_Reference_Line)を参照してください。後でこのダイアログ ボックスに戻るには、線をクリックして、\[編集\] を選択します。 ### カスタム リファレンス バンド ビュー内の特定のメジャーまたはすべてのメジャーに対してリファレンス バンドを追加できます。 リファレンス バンドを \[アナリティクス\] ペインからドラッグしてターゲットにドロップすると、編集ダイアログ ボックスが自動的に開きます。使用可能なオプションについては、**「リファレンス ライン、リファレンス バンド、リファレンス分布、およびリファレンス ボックス」**記事の[リファレンス バンドの追加](https://help.tableau.com/current/pro/desktop/ja-jp/reference_lines.htm#Add_Reference_Bands)を参照してください。後でこのダイアログ ボックスに戻るには、バンドをクリックして \[編集\] を選択します。オプションを表示するには、リファレンス バンドの外縁をクリックする必要があります。バンドの中央をクリックしても何も表示されません。 ### カスタム分布バンド ビュー内の特定のメジャーまたはすべてのメジャーに対してリファレンス分布を追加できます。 リファレンス分布を \[アナリティクス\] ペインからドラッグしてターゲットにドロップすると、編集ダイアログ ボックスが自動的に開きます。使用可能なオプションについては、**「リファレンス ライン、リファレンス バンド、リファレンス分布、およびリファレンス ボックス」**記事の[リファレンス分布の追加](https://help.tableau.com/current/pro/desktop/ja-jp/reference_lines.htm#Add_Reference_Distributions)を参照してください。後でこのダイアログ ボックスに戻るには、バンドをクリックして \[編集\] を選択します。オプションを表示するには、分布バンドの外縁をクリックする必要があります。バンドの中央をクリックしても何も表示されません。 ### カスタム ボックス プロット Tableau Desktop では (Web上 でビューを編集している場合は除く)、\[アナリティクス\] ペインから箱ヒゲ図をドラッグして、ターゲットにドロップできます。Web でビューを編集している場合は実行できません (ただし、Web 上では、ボックス プロットを \[アナリティクス\] ペインの \[要約\] セクションから追加できることを覚えておいてください)。ボックス プロットを \[カスタム\] セクションからドラッグすると、Tableau で自動的に \[リファレンス ライン、バンド、またはボックスの編集\] ダイアログ ボックスが開きます。使用可能なオプションについては、**「リファレンス ライン、リファレンス バンド、リファレンス分布、およびリファレンス ボックス」**記事の[ボックス プロットの追加](https://help.tableau.com/current/pro/desktop/ja-jp/reference_lines.htm#Add_a_Box_Plot)を参照してください。ボックスプロットのスコープは、常に \[セル\] です (\[表\] または \[ペイン\] ではありません)。 ボックス プロットのいずれかの横線をクリックすると、ヒゲ、四分位数、中央値についての統計情報が表示されます。 後でこのダイアログ ボックスに戻るには、バンドをクリックして \[編集\] を選択します。 [メイン コンテンツに進む](#main-content) # \[データ\] ペイン内のデータ ソースの操作 \[データ\] ペインの一番上には、特定のワークブック内のすべてのデータ ソースがリストされます。使用するデータ ソースをクリックして、選択します。\[データ\] ペインが更新され、そのデータ ソース内の対応するフィールドが表示されます。  \[データ\] ペインでのフィールドの検索の詳細については、[フィールドの検索](https://help.tableau.com/current/pro/desktop/ja-jp/datafields_dwfeatures.htm#Find)を参照してください。 \[データ\] ペインのデータ ソース リストの領域は、場所を節約するためにサイズを変更できます。高さを最小限のサイズに変更した場合、データ ソースを下に向かってスクロールできます。  各データ ソースには、タイプを示すアイコンが表示されます。たとえば、このアイコンは、データ ソースがリレーショナル、キューブ (多次元)、データ抽出のいずれであるかを示すことがあります。Tableau では、Windows のみでキューブ データ ソースをサポートしています。  データ ソースを右クリックすると (Mac では Control を押しながらクリック)、\[データ\] メニューにあるコマンドにアクセスできます。たとえば、データ ソースを右クリック (Mac では Control を押しながらクリック) して、そのデータ ソースの名前変更やエクスポートを行ったり、閉じたりできます。  \[データ\] ペイン内のフィールドをカスタマイズし操作するさまざまな方法については、[データ ペイン内のフィールドの整理とカスタマイズ](https://help.tableau.com/current/pro/desktop/ja-jp/datafields_dwfeatures.htm)、[フィールドの既定の設定の編集](https://help.tableau.com/current/pro/desktop/ja-jp/datafields_fieldproperties.htm)、および[\[データ\] ペイン内のデータ フィールドの操作](datafields_understanddatawindow.htm)を参照してください。 [メイン コンテンツに進む](#main-content) # \[データ\] ペイン内のデータ フィールドの操作 Tableau はワークブックのデータ ソース接続とデータ フィールドを、ワークスペースの左側にある \[データ\] ペインに表示します。 **注**: ビジュアライゼーションの作成開始方法ついては、[はじめに](https://help.tableau.com/current/pro/desktop/ja-jp/gettingstarted_overview.htm)を参照してください。\[データ\] ペインでフィールドをカスタマイズできるさまざまな方法の詳細については、[データ ペイン内のフィールドの整理とカスタマイズ](https://help.tableau.com/current/pro/desktop/ja-jp/datafields_dwfeatures.htm)および[フィールドの既定の設定の編集](https://help.tableau.com/current/pro/desktop/ja-jp/datafields_fieldproperties.htm)を参照してください。 ## \[データ\] ペインのエリア データに接続し、データ ソースを作成すると、接続とフィールドが \[データ\] ペインのワークブックの左側に表示されます。データへの接続の詳細については、[データへの接続と準備](https://help.tableau.com/current/pro/desktop/ja-jp/data.htm)を参照してください。 現在のデータ ソース接続は、\[データ\] ペインの一番上に表示されます。複数の接続を使用できる場合は、接続を 1 つクリックして選択し、データを使用して操作を開始します。 \[データ\] ペイン内のフィールドをビューに追加して、ビジュアライゼーションを構築します。詳細については、[フィールドをビューにドラッグしてビジュアライゼーションの構築を開始する](https://help.tableau.com/current/pro/desktop/ja-jp/buildmanual_dragging.htm)を参照してください。 フィールドは、テーブル (\[データ ソースの表ごとにグループ化\]) やフォルダー (\[フォルダーごとにグループ化\]) で整理できます。ディメンションは灰色の線の上に表示され、メジャーは各テーブルやフォルダーの灰色の線の下に表示されます。テーブルやフォルダーには、最初はディメンションのみ、またはメジャーのみが含まれていることがあります。 - すべての入力フィールドを同じテーブルから取得している場合、計算フィールドは元のフィールドと共にリストされます。 - セットは、元のフィールドと共にテーブルに一覧表示されます。 - パラメーターはワークブックにグローバルに適用され、\[パラメーター\] 領域に表示されます。 - 特定のテーブルに属していないフィールドは、テーブルの下の一般領域に表示されます。これには、集計計算、複数テーブルのフィールドを使用する計算、メジャー ネーム、メジャー バリューなどがあります。 - バージョン 2024.2 以降: フィールド名は、ビューで使用されているフィールドとの関連性がない場合は、\[データ\] ペインに薄い灰色のテキストで表示されます。これらのフィールドは引き続き Viz での分析に使用できますが、関連のないフィールドは、関連しているフィールドとは異なる方法で分析で評価されます。この動作は、[マルチファクト関係があるデータ ソースを使用している](https://help.tableau.com/current/pro/desktop/ja-jp/datasource_mfr_multiple_base_tables.htm "詳細については、「マルチファクト関係データ モデルについて」を参照してください")場合に発生する可能性があります。 \[データ\] ペインにあるデータ ソース接続の下には、現在選択されているデータ ソースで使用できるフィールドがあります。ワークシート内で、\[データ\] ペインと \[分析\] ペインを切り替えることができます。\[アナリティクス\] ペインの詳細については、[高度な分析のビューへの適用 (\[アナリティクス\] ペイン)](environ_workspace_analytics_pane.htm)を参照してください。  \[データ\] ペインの単一テーブルのデータ ソースから取得したフィールド \[データ\] ペインには、次のフィールドが含まれます。 - **ディメンション フィールド** — 定性的値 (名前、日付、地理的データなど) を含むフィールド。ディメンションは、データの分類、区分、詳細の表示に利用できます。ディメンションはビューの詳細レベルに影響します。ディメンションの例には、日付、顧客名、顧客区分などがあります。 - **メジャー フィールド** — 測定可能な数値、定量的な値を含むフィールド。それらに計算を適用し、集計することができます。メジャーをビューにドラッグすると、Tableau はそのメジャーに (既定で) 集計を適用します。メジャーの例: 売上高、収益、従業員数、温度、頻度など。 ディメンションとメジャーの詳細については、[ディメンションとメジャー、青と緑](https://help.tableau.com/current/pro/desktop/ja-jp/datafields_typesandroles.htm)を参照してください。 - **計算フィールド** — 参照元データに含まれているフィールドだけでは回答に必要な情報を確認できない場合は、Tableau で計算を使用して新しいフィールドを作成することができます。これらのフィールドは計算フィールドと呼ばれ、データ ソースの一部として保存されます。 計算フィールドの詳細については、[計算を使用したカスタム フィールドの作成](https://help.tableau.com/current/pro/desktop/ja-jp/calculations_calculatedfields.htm)を参照してください。 - **セット** — 定義するデータのサブセット。セットとは、指定した既存のディメンションや基準に基づくカスタム フィールドです。詳細については、[セットの作成](https://help.tableau.com/current/pro/desktop/ja-jp/sortgroup_sets_create.htm)を参照してください。 MS Analysis Services サーバーまたは Teradata OLAP コネクタの名前付きセットも、Tableau では \[データ\] ペインのこのエリアに表示されます。これらの名前付きセットは、Tableau の他のカスタム セットと同じように操作できます。 - **パラメーター** — 式の中でプレースホルダーとして使用可能な値、または計算フィールドやフィルターの定数値を置き換える値。詳細については、[パラメーターの作成](https://help.tableau.com/current/pro/desktop/ja-jp/parameters_create.htm)を参照してください。 **注:** キューブ (多次元) データ ソースの場合、フィールドはデータベース作成時にディメンションまたはメジャーとして明示的に定義されます。リレーショナル データ ソースでは、Tableau によってフィールドが自動的に整理されます。既定では、テキスト値、日付値、またはブール値が含まれているフィールドはディメンションであり、数値が含まれているフィールドはメジャーです。 既定では、データ ソースで定義されたフィールド名が \[データ\] ペインに表示されます。フィールド名およびメンバー名の変更、階層の作成、フィールドのグループおよびフォルダーへの整理を行うことができます。詳細については、[フィールドの既定の設定の編集](https://help.tableau.com/current/pro/desktop/ja-jp/datafields_fieldproperties.htm)、[データ ペイン内のフィールドの整理とカスタマイズ](https://help.tableau.com/current/pro/desktop/ja-jp/datafields_dwfeatures.htm)、および[階層の作成](https://help.tableau.com/current/pro/desktop/ja-jp/qs_hierarchies.htm)を参照してください。 ## 列がビュー内のメジャー フィールドおよびディメンション フィールドになる データ ソースにはフィールドが含まれています。接続するリレーショナル データ ソースのフィールドは、テーブルまたはビューの列によって決定されます。各フィールドには、顧客名、合計売上高、製品タイプなど、データの一意の属性が含まれています。 キューブ (多次元) データ ソースの場合、フィールドはキューブのディメンションとメジャーによって決定されます。Tableau では、Windows のみでキューブ データ ソースをサポートしています。 これは、Excel ワークシートのフィールドの例です。  ワークシートでビジュアライゼーションの構築を開始すると、\[データ\] ペインで、これらの列がフィールドとして表示されます。詳細については、[\[データ\] ペインのエリア](#Areas)を参照してください。 各フィールドにはデータ型 (必要に応じて変更可能) とロール (不連続ディメンション、連続ディメンション、不連続メジャー、または連続メジャー) があります。詳細については、[データ型](https://help.tableau.com/current/pro/desktop/ja-jp/datafields_typesandroles_datatypes.htm)および[ディメンションとメジャー、青と緑](https://help.tableau.com/current/pro/desktop/ja-jp/datafields_typesandroles.htm)を参照してください。 各フィールドには、既定の集計など、いくつかの既定の設定も含まれています。詳細については、[フィールドの既定の設定の編集](https://help.tableau.com/current/pro/desktop/ja-jp/datafields_fieldproperties.htm)および[Tableau でのデータ集計](https://help.tableau.com/current/pro/desktop/ja-jp/calculations_aggregation.htm)を参照してください。 ## Tableau で自動作成するフィールド \[データ\] ペインには、元のデータにはない多くのフィールド (\[メジャー ネーム\]、\[メジャー バリュー\]、\[レコード数\]、\[緯度\] および \[経度\]) も含めることができます。 ### メジャー ネームとメジャー バリュー - \[メジャー バリュー\] フィールドには、データのすべてのメジャーが連続する値を使用して 1 つのフィールドに集められています。個々のメジャー フィールドを \[メジャー バリュー\] カードの外にドラッグして、これらのフィールドをビューから削除します。 - \[メジャー ネーム\] フィールドには、データのすべてのメジャーの名前が不連続の値を使用して 1 つのフィールドに集められています。 ビジュアライゼーションで \[メジャー バリュー\] と \[メジャー ネーム\] を使用する方法の詳細については、[メジャー バリューとメジャー ネーム](https://help.tableau.com/current/pro/desktop/ja-jp/datafields_understanddatawindow_meavalues.htm)を参照してください。 ### テーブルの数 Tableau 2020.2 以降では、データ ソース内のすべてのテーブルに _NameofTable_ (Count) という形式の \[カウント\] フィールドがあります。テーブル カウント フィールドは、自動的に生成される計算フィールドです。 テーブルの数 = 各テーブルのレコード数の合計 テーブルのレコード数を表示するには、\[カウント\] フィールドをビューにドラッグします。すべてのテーブルの数を表示するには、各テーブルの \[カウント\] フィールドを選択し、\[表示形式\] の \[テキスト テーブル\] をクリックします。 テーブルの \[カウント\] フィールドの上に計算を作成することはできません。このフィールドは、集計専用です。 ### レコード数 (バージョン 2020.2 より前) \[レコード数\] フィールドは、以前のバージョンの Tableau から取得したビジュアライゼーションで使用されている場合に表示されることがあります。 2020.2 より前のバージョンの Tableau では、\[レコード数\] フィールドは自動生成される計算フィールドで、「1」に設定されます。この数値は、データ ソースの各行に関連付けられています。\[レコード数\] フィールドをビューに追加すると、データ ソースのすべての行の合計数 (レコード数) が表示されます。\[レコード数\] フィールドを使用して、さまざまなディメンションの値を簡単に計算することができます。\[レコード数\] を表示して、データの結合が期待通りに行われているかを確認できます。 ### 緯度および経度 (生成) Tableau がフィールドを地理的データとして認識すると、データが自動的にジオコーディングされ、\[緯度 (生成)\] フィールドと \[経度 (生成)\] フィールドが追加されます。これらのフィールドを使用して、ライブ マップにデータを重ねることができます。これらのフィールドの使用方法、および Tableau でマップを作成する際のベスト プラクティスについては、[Tableau のマップおよび地理的データの分析](https://help.tableau.com/current/pro/desktop/ja-jp/maps.htm)、[地理的役割の割り当て](https://help.tableau.com/current/pro/desktop/ja-jp/maps_geographicroles.htm)、および[マップ ビューの作成において Tableau でサポートされる場所データ](https://help.tableau.com/current/pro/desktop/ja-jp/maps_data.htm)を参照してください。 ## \[データ\] ペインで一般的なタスクを実行 **分析のためにデータ ソース接続を選択するには**、\[データ\] ペイン のデータ ソース接続名をクリックします。詳細については、[\[データ\] ペイン内のデータ ソースの操作](multipleconnections_navigateconnections.htm)を参照してください。  データ ソースのコンテキスト メニューを表示するには、トップ メニューにある \[データ\] をクリックしてから、リスト内のデータ ソースをクリックします。詳細については、[データ ソースの編集](https://help.tableau.com/current/pro/desktop/ja-jp/howto_connect.htm)を参照してください。 \[データ\] ペイン内のフィールドを検索するには、拡大鏡アイコンをクリックしてから、テキスト ボックスに入力します。詳細については、[フィールドの検索](https://help.tableau.com/current/pro/desktop/ja-jp/datafields_dwfeatures.htm#Find)を参照してください。 参照元データを表示するには、\[データの表示\] アイコンをクリックします。アイコンは \[データ\] ペインの上部にあります。 ![\[データの表示\] アイコン。](Img/View_Data_Icon.png) 詳細については、[参照元データの表示](https://help.tableau.com/current/pro/desktop/ja-jp/inspectdata_viewdata.htm) ![ビュー内の参照元データを表示する \[データの表示\] ウィンドウ。](Img/environ_workspace_datawindow2.png) Tableau がフィールドをディメンションまたはメジャーとして誤って分類した場合は、そのフィールドを変換して役割を変更することができます。 **メジャーをディメンションに変換するには**、メジャーを灰色の線より上の **\[データ\]** ペイン内の他のディメンションがある場所にドラッグします。詳細については、[メジャーのディメンションへの変換](https://help.tableau.com/current/pro/desktop/ja-jp/datafields_typesandroles_convertdimtomeas.htm)を参照してください。 ## データ フィールドを必要に応じて変更する フィールドをビューにドラッグするときは、特定の既定の設定と文字があります。フィールドのそのインスタンスだけのために、既にビューにあるフィールドをカスタマイズすることができます。あるいは、フィールドがそれらの設定を使用するように、\[データ\] ペインの設定を変更することができます。 そのフィールド データでどのような作業をしたいかによって、ビューのフィールドの定義を管理することができます。 注: ビューにドラッグする前にフィールドの既定の設定を変更するには、右クリック (Mac では Control を押しながらクリック) します。コンテキスト メニューから、設定と既定のプロパティを編集できます。 \[データ\] ペインでフィールドをカスタマイズできるさまざまな方法の詳細については、[データ ペイン内のフィールドの整理とカスタマイズ](https://help.tableau.com/current/pro/desktop/ja-jp/datafields_dwfeatures.htm)および[フィールドの既定の設定の編集](https://help.tableau.com/current/pro/desktop/ja-jp/datafields_fieldproperties.htm)を参照してください。 ## リレーショナル データとキューブ データ リレーショナル データ ソースとキューブ データ ソースの \[データ\] ペインを以下に示します。フィールドがディメンションとメジャーに整理されているという点では、いずれのデータ ソースのペインも実質的に同じに見えます。ただし、キューブ データ ソースにはディメンションの階層が含まれています。たとえば、キューブの \[データ\] ペイン "Employee (従業員)" ディメンションには、\[マネージャー名\] や \[従業員部門\] などの階層メンバーが含まれています。 リレーショナル データ ソースには、階層が含まれていません。ただし、リレーショナル データ ソースに、階層が内在する関連ディメンションがある場合があります。たとえば、データ ソースに Country、State、City のフィールドがあるとします。これらのフィールドを Location という階層にグループ化することができます。これらのリレーショナル階層をドラッグしてドロップすることで、\[データ\] ペインにまとめることができます。詳細については、[階層の作成](https://help.tableau.com/current/pro/desktop/ja-jp/qs_hierarchies.htm)を参照してください。 **注:** Tableau では、Windows でのみキューブ (多次元) データ ソースをサポートしています。  リレーショナル データを使用する \[データ\] ペイン (左側の画像) とキューブデータを使用する \[データ\] ペイン (右側の画像) 矢印をクリックして、リレーショナルとキューブの両方の \[データ\] ペインで、さまざまな階層を展開または折りたたむことができます。\[データ\] ペインをすべて非表示にするには、\[データ\] ペインの右上隅にある最小化ボタン ![上向きと下向きの 2 つの矢印で示される \[データを理解\] ウィンドウ アイコン。](Img/datafields_understanddatawindow_relational1.png) をクリックします。 キューブ データ ソースの詳細については、[キューブ データ ソース](https://help.tableau.com/current/pro/desktop/ja-jp/cubes.htm)を参照してください。 [メイン コンテンツに進む](#main-content) # \[ハイライト\] ツールバー ボタン ハイライト アクションを追加するもう 1 つの方法は、ツール バーのハイライト ボタンの使用です。凡例のハイライトと同様、ツールバーのボタンを使用すると、関連するマークのコレクションをビューの中でハイライトでき、双方向のハイライトと同様に機能します。ハイライトをオンにするには、ツールバー メニューで、ハイライトに使用するフィールドを選択します。ドロップダウン リストには、ビューのアクティブなフィールドが表示されます。次に、関連するデータを表示するためビュー内のマークを選択します。  たとえば、次のビューには、\[ 売上\] と \[収益\] を \[地域\] 別に表示することができます。\[出荷モード\] のハイライトをオンを選択し、マークを選択すると、そのマークの出荷モードを使用して出荷されたその他のマークがすべてハイライトされます。この場合、セカンド クラスで出荷された米国中のすべての製品をすばやく確認できます。  また、ツールバー メニューにより、\[すべてのフィールド\] または\[日付と時刻\] をハイライトできます。\[すべてのフィールド\] を選択すると、レコードの一致を確認する際にビュー内のすべてのフィールドが考慮されます。\[日付と時刻\] を選択すると、ビュー内のすべての "日付" および "時刻" フィールドが考慮されます。 Tableau Desktop で \[ハイライト\] ツールバー ボタンを使用すると、\[アクション\] ダイアログ ボックスでアクションが作成されます。アクションを変更して、より詳細なハイライト動作を作成できます。アクションの編集の詳細については、[詳細なハイライト アクションの作成](https://help.tableau.com/current/pro/desktop/ja-jp/actions_highlight_advanced.htm)を参照してください。 最後に、ツールバー ボタンを使用して、ワークブック全体のハイライトまたはアクティブ シートのみのハイライトを無効にすることもできます。このオプションは凡例のハイライトのみを無効にします。マークを手動でハイライトしたり、ハイライター コントロールを使用する機能はオフになりません。 ツール バーボタンからハイライトをオフにすると、凡例でハイライト アイコンが非表示になり、凡例のコンテキスト メニューで \[選択したアイテムをハイライト\] メニュー オプションが灰色で表示されます。  [メイン コンテンツに進む](#main-content) # 予測オプションの設定 以下のような予測オプションを設定するには、\[予測オプション\] ダイアログ ボックスを使用します。 - 予測期間 - 予測を生成するソース データの範囲と時間的な集計 - 予測モデル - 予測間隔 予測を有効にすると、\[分析\] > \[予測\] > \[予測オプション\] の順に選択して、\[予測オプション\] ダイアログ ボックスを開くことができます。 ## 予測期間 \[予測期間\] セクションでは、未来のどの時点まで予測するかを決めます。次のいずれかを選択します。 - 自動: Tableau により、データに基づいて予測期間が決定されます。 - \[完全一致\]: 指定した単位の数だけ予測を延長します。 - \[まで\]: 将来の指定した時点まで予測を延長します。 ## ソース データ 以下を指定するために \[ソース データ\] セクションを使用します。 - \[集計基準\]: 時系列の時間的な詳細を指定します。既定値 (自動) を設定すると、推定に最適な詳細レベルが選択されます。これは通常、視覚化の時間的な詳細 (つまり、予測の基準となる日付ディメンション) と一致します。ただし、視覚化の時系列が短すぎて推定できないときには、視覚化より細かいレベルの予測モデルを推定することができ、それが望ましい場合もあります。 **注**: 予測するのに日付ディメンションの代わりに整数ディメンションを使用している場合、\[集計基準\] は常に \[期間\] です。[ビューに日付がない場合の予測](https://help.tableau.com/current/pro/desktop/ja-jp/forecast_no_date.htm)を参照してください。 - 最後を無視する: 実際のデータの最後で予測モデルの推定に使用しない期間数を指定します。この期間中は、実際のデータではなく予測データが使用されます。この機能を使用して、予測を誤った方向に導く可能性のある信頼できない期間や末尾の一部分を切り捨てます。**\[ソース データ\]** セクションで指定した予想の詳細レベルが視覚化で指定したレベルより細かい場合は、切り捨てた期間が予想期間になります。その結果、最後部分の実際の視覚化期間が予測期間となる可能性があります。この予測期間は、予想レベルの実際の期間と予測期間の集計です。対照的に、NULL 値はゼロで埋められていないため、予測を行うためにフィルターする必要があります。 - 欠落値をゼロで埋める: 予測しようとしているメジャーに欠落値がある場合、それらの欠落値にゼロを入れるように Tableau に指定できます。 ## 予測モデル \[予測モデル\] セクションでは、予測モデルの生成方法を指定します。 ドロップダウンを使用して、Tableau がすべてのモデル (\[自動\])、季節性コンポーネントがないモデル (\[季節性のない自動\])、または指定するモデル (\[カスタム\]) に最適なものを選択するかどうかを指定してください。 \[カスタム\] オプションを選択する場合、新しい 2 つのフィールドが \[予測オプション\] ダイアログ ボックスに表示され、それを使用するとモデルに傾向文字および季節性文字を指定することができます。  2 つのフィールドで選択肢は同じです。 - なし: 傾向で \[なし\] を選択する場合、モデルでは傾向のデータが評価されません。季節で \[なし\] を選択する場合、モデルでは季節性のデータが評価されません。 - 加算: 加算モデルでは、さまざまな独立した係数の影響を組み合わせると、分離した各計数の影響の合計になります。ビューでは、加算した傾向、加算した季節性、またはその両方のデータを評価することができます。 - 乗算: 乗算モデルでは、さまざまな独立した係数の影響を組み合わせると、分離した各計数の影響の積になります。ビューでは、乗算した傾向、乗算した季節性、またはその両方のデータを評価することができます。 視覚化に 1 つを超える時系列がある場合、同じカスタム モデルを使用して、カスタム オプションにより強制的にそれらの時系列すべてが予測にされます。通常、この方法でモデルを制限すると、モデルの自動選択で作成されるより、モデルの品質が低くなります。 ### 乗算モデルの制約 - 予測になるメジャーに 0 以下の値が 1 つ以上ある場合、または一部のデータ ポイントが、その他のデータ ポイントと比較して極めてゼロに近い場合にも、乗算モデルを使用することはできません。 - 結果の数値が不安定な可能性があるため、乗算した傾向および加算した季節を使用したモデルを指定することはできません。 ## 予測間隔 予測間隔を 90、95、または 99 パーセントに設定するか、カスタム値を入力します。この値は、次の 2 つの場所で使用されます: - 予測を含む予測帯。 - ビューでメジャーの予測結果タイプとして使用できる予測間隔オプション (予測間隔上限および予測間隔下限)。  ## 予測サマリー \[予測オプション\] ダイアログ ボックスの下部にあるテキスト ボックスには、現在の予測の説明が表示されます。予測サマリーは、上記のいずれかの予測オプションを変更するたびに更新されます。予測に問題がある場合、このテキスト ボックスには、問題の解決に役立つ可能性のあるエラー メッセージが表示されます。[予測エラーの解決](https://help.tableau.com/current/pro/desktop/ja-jp/forecast_resolve_errors.htm)を参照してください。 [メイン コンテンツに進む](#main-content) # 予測の説明 \[予測の説明\] ダイアログ ボックスは、Tableau が視覚化用に計算した予測モデルについて説明します。 予測が有効になっていると、\[分析\] >\[予測\] >\[予測の説明\] の順に選択して、このダイアログを開きます。 \[予測の説明\] ダイアログ ボックスの情報は読み取り専用ですが、\[クリップボードにコピー\] をクリックして、画面の内容をドキュメントに貼り付けることができます。 \[予測の説明\] ダイアログ ボックスには、\[サマリー\] タブと \[モデル\] タブがあります。 ## \[予測の説明\] – \[サマリー\] タブ \[サマリー\] タブは、Tableau が作成した予測モデルと、データに見られる一般的なパターンを説明します。 ### 予測モデルの作成に使用されるオプション このセクションには、Tableau が予測の作成に使用するオプションの要約が表示されます。これらのオプションは、Tableau によって自動的に選択されたか、\[予測オプション\] ダイアログ ボックスに指定したものです。 - 時系列—時系列を定義するために使用される連続日付フィールド。場合によっては、この値は実際には日付ではない可能性があります。[ビューに日付がない場合の予測](https://help.tableau.com/current/pro/desktop/ja-jp/forecast_no_date.htm)を参照してください。 - メジャー—値を予想するメジャー。 - 次の予測—予測の長さと日付範囲。 - 次に基づく予測—予測の作成に使用される実際のデータの日付範囲。 - 最後を無視する—無視する実際のデータの最後の期間の数。この期間には予測データが表示されます。この値は、\[予測オプション\] ダイアログ ボックスの \[最後を無視する\] オプションによって決定されます。 - 季節性パターン—データに見られた季節的なサイクルの長さ。季節的なサイクルが予測に見られなかった場合は \[なし\]。 ### 予測サマリー表 予測された各メジャーについて、予測を記述するサマリー表が表示されます。ビューがディメンションにより複数のペインに分かれている場合、各表にディメンションを識別する列が挿入されます。サマリー予測表には、次のフィールドがあります。 - 初期—最初の予測期間の値と予測間隔。 - 初期からの変更—最初と最後の予測推定ポイントの差異。2 つのポイントの間隔は列ヘッダーに表示されます。値がパーセンテージとして表されている場合、このフィールドには、最初の予測期間からの変更率が表示されます。 - 季節変動の影響—これらのフィールドは、季節変動、つまり長い期間にわたって繰り返される変動パターンがあることが特定されたモデルに表示されます。ここには、実績値と予測値を組み合わせた時系列において、最後の完全な季節的サイクルを構成する季節性要素の最大値と最小値が表示されます。季節性要素は、傾向からの逸脱を表すため、ゼロの前後で変化し、季節を通じて合計がゼロになります。 - 貢献度—傾向と季節性が予測にどの程度貢献しているかを表した値。これらの値は常にパーセンテージで表され、合計が 100% になります。 - 品質—予測が実際のデータにどれほど適合しているかを示します。正の値は GOOD、OK、および POOR です。ナイーブ予測は、次の期間の値が現在の期間の値と同等であると想定する予測として定義されます。品質はナイーブ予測に対して相対的に表され、OK は予測の方がナイーブ予測よりエラーが少なく、GOOD は予測のエラーがナイーブ予測のエラーの半分より少なく、POOR は予測の方がエラーが多いことを示します。 ## \[予測の説明\] – \[モデル\] タブ \[モデル\] タブは、予測の基礎となる Holt-Winters 指数平滑法モデルのさらに詳しい統計とスムージング係数値を提供します。予測された各メジャーにつき、メジャーに対して Tableau で作成された予測モデルについて説明する表が表示されます。ビューがディメンションにより複数のペインに分かれている場合、各表にディメンションを識別する列が挿入されます。表は次のセクションで構成されています。 ### モデル \[レベル\]、\[傾向\]、または \[季節\] の各要素が、予測の作成に使用されたモデルの一部であるかを指定します。各要素の値は、次のいずれかです。 - なし—要素がモデルに存在しません。 - 加算—この要素が存在し、他の要素に追加されて全体の予測値になっているものと判断されました。 - 乗算—この要素が存在し、他の要素に乗算されて全体の予測値になっているものと判断されました。 ### 品質メトリクス モデルの品質に関する統計情報を示す一連の指標があります。 #### **RMSE** 平均二乗誤差の平方根:  #### **MAE** 平均絶対誤差:  #### **MASE** 平均絶対スケール誤差:  MASE は、ナイーブ短期予測の誤差の大きさと比較して誤差の大きさを比率で測定します。ナイーブ予測は、今日の値が明日も同じであると仮定します。そのため、MASE 0.5 は、予測の誤差はナイーブ予測の誤差の半分の可能性があるという意味です。これは、MASE 1.0 より良いということであり、ナイーブ予測に等しいということです。これは、すべての値のために定義される正規化統計であり、誤差に均等に重みをつけるため、異なる予測方法の品質と比較するための優れた指標です。 一般的な MAPE 指標に比べて MASE 測定基準の利点は、MASE 基準はゼロを含む時系列に定義されますが、MAPE はそうではありません。また、MASE はエラーに同等の重みを付けますが、MAPE はポジティブ/極端なエラーをより重視します。 #### **MAPE** 平均絶対パーセント誤差:  MAPE は、データの大きさと比較して誤差の大きさを割合として測定します。したがって、MAPE 20 % は、MAPE 60 % より良いということです。誤差は、モデルが推定する反応値と、データ内の各説明値の実際の反応値の間の差です。これは正規化統計であるため、Tableau で計算される異なるモデルの品質を比較するために使用されます。しかし、誤差の種類によっては他の誤差より重みを付けるため、比較によっては信憑性に欠けます。また、値がゼロのデータは定義されません。 #### **AIC** 赤池情報量規準:  赤池弘次により開発された AIC は、モデル品質の指標で、複雑なモデルを制限し、過適合するのを防ぎます。この定義では、_k_ は初期状態を含む推定パラメーター数で、_SSE_ は二乗誤差の合計です。 #### 変数 前述の定義では、変数は以下のとおりです。
| 変数 | 意味 |
| t | 時系列における期間のインデックス。 |
| n | 時系列の長さ。 |
| m | 季節/周期における期間の数。 |
| A(t) | 期間 t 時点でのタイム シリーズの実際の値。 |
| F(t) | 期間 t 時点での近似値または予測値。 |
| 説明のタイプ | 評価 |
|---|---|
|
極値 |
極値は、視覚化されたマークのモデルに基づく、外れ値となる集計マークです。選択したマークは、レコード値がデータで期待値分布の端にある場合に極値を含むと見なされます。 極値は、極値がある場合とない場合の集計マークを比較することによって決定されます。値を削除してもマークがあまり減らなければ、高い得点が得られます。 マークに極値が含まれていても、ただちに、それらの値は外れ値である、または、ビューからそれらのレコードを除外する必要がある、という意味ではありません。選択すべき内容は分析に応じて異なります。説明は単にマーク内の興味深い極値を示しています。たとえば、バナナの価格が 10 セントではなく 10 ドルであるレコードであれば、誤って入力された値だとわかるかもしれません。または、特定の営業担当者がある四半期に優れた成績を収めていたことが明らかになるかもしれません。 |
|
レコード数 |
レコード数は、個数を集計する観点から集計の合計をモデル化して説明したものです。いっぽう、レコードの平均値は、平均を集計する観点からモデル化しています。モデルが合計をより適切に説明するほど、スコアは高くなります。 ここでは、数が多いまたは少ないか、平均が高いまたは低いことが原因で合計が興味深いかどうかについて説明します。 |
|
マークの平均値 |
このタイプの説明は、合計を表す集計マークで使用されます。集計する個数または平均の観点から、SUM(X) = COUNT(X) * AVG(X) の関係を踏まえて、そのマークが他のマークと一致しているかどうかを説明します。 ここでは、数が多いまたは少ないか、平均が高いまたは低いことが原因で合計が興味深いかどうかについて説明します。 |
|
関連するディメンション |
この説明は、視覚化されていないディメンションのカテゴリ間の分析という観点から、分析されたマークのターゲット メジャーをモデル化します。この分析により、モデルの複雑さとマークの説明のバランスを取ることができます。 視覚化されていないディメンションとは、データ ソース内に存在するが、現在ビューでは使用されていないディメンションを指します。このタイプの説明は、合計、カウント、平均に使用されます。 非視覚化ディメンションのモデルは、説明する列の分類値に従ってマークを分割してから、ソースのビジュアライゼーションに含まれるすべてのデータ ポイントが含まれた値を使用してモデルを構築し、作成されます。行ごとに、モデルが各マークを形成する個々のコンポーネントの復元を試みます。分析では、視覚化されていないディメンションの値が不明なモデルを使用した場合と比べて、視覚化されていないディメンションに対応するコンポーネントをモデル化して合計すると、モデルがマークをより適切に予測するかどうかを示します。 集計ディメンションの説明では、マークの値が条件を指定せずにどの程度詳しく説明されているかを調べます。次に、潜在的な説明となる各列の値にモデルが条件を付けます。説明の列の分布に条件を付けることによって、より優れた予測が得られます。 |
|
関連するメジャー |
この説明は、視覚化されていないメジャーの観点から、視覚化されたディメンション全体で平均を集計してマークをモデル化します。視覚化されていないディメンションとは、データ ソース内に存在するが、ビューでは現在使用していないディメンションを指します。 関連するメジャーの説明によって、視覚化されていないメジャーとターゲット メジャーの間の線形関係または二次関係が明らかになります。 |
| 既定で除外されるフィールド | 除外の理由 |
|---|---|
|
データ ソースに 1,000 を超えるメジャーがあるときの、すべてのビジュアライズされていないメジャー。 データ ソースに 1,000 を超えるディメンションがあるときの、すべてのビジュアライズされていないディメンション。 |
1,000 個を超えるビジュアライズされていないメジャーやディメンションの説明を計算すると、計算に時間がかかり、場合によっては数分かかることがあります。これらのフィールドは初期分析では規定により除外されますが、さらに分析するためにそれらを含めるよう選択することができます。 このような場合は、「データの説明を見る」で複数のフィールドを考慮するかどうかを確認するアラートが表示されることがあります。詳細を表示するには、アラートのリンクをクリックします。[すべて説明] をクリック して、フィールドをさらに含めて分析を実行します。 |
| ジオメトリ、緯度、または経度を使用するフィールド | ジオメトリ、緯度、経度だけでは説明にはなりえません。緯度や経度を説明として呼び出す説明は、偽の相関関係によるものであり、確実な説明ではない可能性が高いです。 |
| 濃度の高いディメンション (500 人を超えるメンバーを持つディメンション) |
高濃度のディメンションは、計算に時間がかかります。ディメンションに 500 個を超える一意の値が含まれる場合は、分析対象として見なされません。 |
| グループ、ビン、またはセット | 現在サポートされていません。 |
| 表計算 | 表計算がビューとは異なる詳細レベルにある場合は、表計算を分析することはできません。 |
| 平均化できないビジュアライズされていないメジャー | 平均化できないビジュアライズされていないメジャーには、計算式に集計が含まれる計算フィールドであるメジャーが含まれます (シートに追加すると AGG() フィールドとして表示されます)。 |
| 非連続メジャーと連続ディメンション | 現在サポートされていません。 |
| 非表示のフィールド | 利用できません。 |
| エラーのある計算フィールド | 分析する値がありません。 |
|
この説明では以下を示します。
探索オプションを以下に示します。
さらなる分析のための手順を以下に示します。
|
この例では、463 時間というレンタル時間の 1 つの極値が、予測よりも高い 613 時間という総レンタル時間に影響しています。 この高い値の理由としては、誰かが自転車を返却したときにドッキングするのを忘れた可能性が考えられます。このような場合は、作成者は将来の分析のためにこの値を除外することをお勧めします。
|
|
違いを視覚化するこのセクションでは次のことを示しています。
探索オプションを以下に示します。
さらなる分析のための手順を以下に示します。
|
この例では、483 という極値を除外すると、分析されたマークは、ビュー内の他のマークと比較してとくに高くないことがわかります。他のマークが目立つようになりました。自転車のレンタル時間が他のいくつかの場所で長く、作成者はその理由を確認しようとして、他のマークを調べたいと考えるでしょう。 |
|
この説明では以下を示します。
探索オプションを以下に示します。
さらなる分析のための手順を以下に示します。
|
この例では、ターゲット メジャーの Null 値の割合が青色の円で示されています。 |
|
この説明では以下を示します。
探索オプションを以下に示します。
さらなる分析のための手順を以下に示します。
|
この例では、元のビジュアライゼーションのディメンションである乗車月ごとに、走行距離のレコード数が一覧表示されています。8 月は総走行距離の値が最も高くなっています。 8 月に走行距離の値が最も高くなっているのは、8 月には多くの人が乗車したからか、それとも一部の人が長く走行したからかを確認することができます。 |
|
この説明では以下を示します。
探索オプションを以下に示します。
さらなる分析のための手順を以下に示します。
|
この例では、8 月の平均走行距離は、ほかの月と比べて大幅に高くも低くもありません。これは、8 月は乗車時間が長い人がいたからではなく、乗車回数が多かったため、8 月の総走行距離が長かったことを示しています。 |
この説明では以下を示します。
探索オプションを以下に示します。
さらなる分析のための手順を以下に示します。
|
この例では、統計分析により、多くの乗車がバック湾の駅周辺から行われていることが明らかになりました。「駅周辺」は視覚化されていないディメンションであり、ビジュアライゼーションの参照元データの走行距離と何らかの関係があることがわかります。 |
この説明では以下を示します。
探索オプションを以下に示します。
さらなる分析のための手順を以下に示します。
|
この例では、統計分析により、全体的な乗車のマークと比較して、サウス駅と MIT からの乗車が多く、チャールズ サークル駅とケンダル駅からの乗車が少ないことが明らかになりました。 「駅名」は視覚化されていないディメンションであり、ビジュアライゼーションの参照元データの走行距離と何らかの関係があることがわかります。 |
この説明では以下を示します。
探索オプションを以下に示します。
さらなる分析のための手順を以下に示します。
|
この例では、走行距離が長い理由の 1 つとして、平均合計レンタル時間が長いことが考えられます。 |
この説明では以下を示します。
探索オプションを以下に示します。
さらなる分析のための手順を以下に示します。
|
この例では、高い割合のレコードが曇りの天気に関連付けられています。データはボストンでのレンタサイクルに関するものであり、分析されたマークは 8 月の走行距離であるため、通常、天気は暖かくて湿度が高いと推測できます。暑さを避けるために、曇りの日には自転車がより頻繁に借りられたかもしれません。8 月は曇りの日が多かった可能性もあります。 |
| モード | アクセスできるユーザー |
|---|---|
|
表示モード |
Tableau の Viewer、Explorer、Creator ([Run Explain Data (「データの説明を見る」を実行)] パーミッション機能を持つ) は、「データの説明を見る」の説明を表示モードで実行および探索できます。 |
|
編集モード
|
Tableau の Creator は、Tableau Desktop、Tableau Cloud、Tableau Server でビューを編集するときに「データの説明を見る」を実行できます。[Run Explain Data (「データの説明を見る」を実行)] パーミッション機能と編集権限を持つ Explorer は、Tableau Cloud または Tableau Server でワークブックを編集するときに「データの説明を見る」を実行できます。 Creator と 編集権限を持つ Explorer は、新しいワークシートを開いてさらに分析することができます。 また、「データの説明を見る」の設定を使用して、「データの説明を見る」を使用できるユーザーと表示内容を制御することもできます。 |
|
「データの説明を見る」を使用する |
ワークブックの作成とアクセスの制御 |
| カテゴリ | 製品名 | 売上 |
| 家具 | フロア ランプ | $96.00 |
| 「データの説明を見る」は、以下を使用するビューでは実行できません。 |
|
|
「データの説明を見る」は、以下を選択した場合は実行できません。 |
|
| 「データの説明を見る」は、以下の説明に使用されるメジャーでは実行できません。 |
|
|
「データの説明を見る」は、以下の場合にディメンションの説明を提供できません。 |
|
| レコード数 |
取得までの時間 |
|---|---|
|
100,000 |
1.7 分 |
|
250,000 |
4 分 |
|
500,000 |
8.5 分 |
| Library (ライブラリ) | LibraryID | Consortium Member (コンソーシアム メンバー) | Private (プライベート) | Librarians (ライブラリアン) | Library Technicians (ライブラリ技術者) | Library Assistants (ライブラリ アシスタント) |
|
Idle Hour Library (アイドル状態のライブラリ) |
L-IHL | はい | いいえ | 53 | 61 | 16 |
|
The Bibliophile’s Shelves (愛書家の棚) |
L-BS | はい | はい | 4 | 3 | 0 |
|
Armchair Athanaeum (アームチェア室) |
L-AA | いいえ | はい | 6 | 0 | 0 |
| Old Friend Library (オールド フレンド ライブラリ) | L-OFL | はい | いいえ | 3 | 5 | 17 |
| Bide Awhile (待機) | L-BA | はい | いいえ | 9 | 20 | 6 |
| IndieUnBound | L-IUB | はい | いいえ | 7 | 2 | 47 |
|
Page Station Book Exchange (ページ ステーション ブック エクスチェンジ) |
L-PS | いいえ | はい | 3 | 1 | 4 |
|
Actian Matrix* Alibaba AnalyticDB for MySQL‡ Alibaba Data Lake Analytics‡ Alibaba MaxCompute‡ Amazon Athena‡ Amazon Aurora for MySQL‡ Amazon EMR Hadoop Hive‡ Amazon Redshift‡ Apache Drill‡ Aster Database* Azure Data Lake Storage Gen2‡ Box‡ Cloudera Hadoop‡ Databricks‡ Datorama by Salesforce‡ Denodo‡ Dremio by Dremio‡ Dropbox‡ Esri コネクタ‡ Exasol‡ |
Google BigQuery**‡ Google BigQuery JDBC**‡ Google Cloud SQL‡ Google ドライブ‡ Impala‡ Kognito* Kyvos‡ Hortonworks Hadoop Hive IBM BigInsights IBM DB2‡ IBM PDA (Netezza)* Kyvos‡ MariaDB‡ MarkLogic* Microsoft Azure SQL データベース‡ Microsoft Azure Synapse Analytics‡ Microsoft SQL Server‡ MonetDB* MongoDB BI Connector‡ MySQL‡ |
OData‡ OneDrive‡ Oracle‡ Pivotal Greenplum Database‡ PostgreSQL‡ Progress OpenEdge* Presto‡ Qubole Presto‡ SAP HANA (仮想接続のみ)‡ SAP Sybase ASE* SAP Sybase IQ* Salesforce‡ SharePoint Lists‡ SingleStore (旧 MemSQL)‡ Snowflake‡ Spark SQL‡ Teradata***‡ Vertica‡ |
|
Alibaba AnalyticsDB for MySQL‡ Alibaba Data Lake Analytics‡ Amazon Athena‡ Amazon Aurora for MySQL‡ Amazon EMR Hadoop Hive‡ Amazon Redshift‡ Apache Drill‡ Azure Data Lake Storage Gen2‡ Azure Synapse Analytics (SQL Server 互換) Box‡ Cloudera Hadoop‡ Databricks‡ Datorama by Salesforce‡ Denodo‡ Dremio by Dremio‡ |
Dropbox*‡ Esri コネクタ‡ Exasol‡ Google BigQuery*‡ Google Cloud SQL (MySQL 互換)‡§ Google ドライブ‡ Hortonworks Hadoop Hive Impala‡ Kyvos‡ MariaDB‡ Microsoft Azure SQL データベース‡ Microsoft Azure Synapse Analytics‡ Microsoft SQL Server‡ MongoDB BI Connector‡ MySQL‡ |
OData‡ OneDrive*‡ Oracle‡ Pivotal Greenplum Database‡ PostgreSQL‡ Presto‡ Qubole Presto‡ Salesforce‡ SAP HANA (仮想接続のみ)‡ SharePoint Lists‡ SingleStore (旧 MemSQL)‡ Snowflake‡ Spark SQL‡ Teradata**‡ Vertica‡ |
|
Google ドライブ OData |
| セクション | 説明 | 例 |
|---|---|---|
|
予測 予測はユース ケースの目標を反映したものです。 |
目標は、結果を最大限に高めるか、最小限に抑えるかのどちらかです。たとえば、目標には、配送時間を最小限に抑える、または、配送当たりの平均売上収益を最大化するなどがあります。 |
|
|
上位予測変数 予測結果に最も大きな影響を与える条件 (大きさの降順)。 |
条件は、フィールドに関連付けられたデータ値です。 予測変数は、1 つまたは 2 つの条件で構成されます。2 つの条件が表示されている場合、それらは条件の交差を表すために and によって結合されます。 緑 (上矢印) は、予測変数が予測結果を改善することを示します。 赤 (下矢印) は、予測変数が予測結果を悪化させることを示します。 |
|
|
改善方法 予測結果を改善するためにユーザーが実行できる推奨アクション。 |
改善点は、配送方法やサブスクライバーのメンバーシップ レベルなど、ユーザーが制御できると思われる要因に関連付けられます。 |
|
| 要件 | 説明 |
|---|---|
|
Salesforce のライセンス |
次のいずれかのライセンス:
これらのライセンスの利用には追加料金が発生します。 |
|
Salesforce のユーザー アカウント |
Einstein Discovery にアクセスするように構成されたアカウントの場合。 Einstein Discovery in Tableau のライセンスを使用する場合は、ユーザー アカウントに Connect API を介して Einstein Discovery の推奨事項を表示するシステム パーミッションを割り当てる必要があります。 Tableau CRM Plus のライセンスと Einstein Predictions のライセンスのいずれかを使用する場合:
ユーザアカウントを構成するには、Salesforce ヘルプの「Einstein Discovery の設定」を参照してください。 |
|
管理者設定 |
Salesforce 管理者は、次の操作を行う必要があります。 |
| 要件 | 説明 |
|---|---|
|
Tableau のライセンスとパーミッション |
Einstein Discovery のダッシュボードの拡張機能を構成する作成者には、Creator または Explorer のライセンスと、ワークブックの編集と保存を行えるパーミッションが必要です。 Einstein Discovery のダッシュボードの拡張機能で予測を利用するには、Creator、Explorer、Viewer は Salesforce 組織アカウントにサインインする必要があります。 |
|
Tableau のユーザー アカウント |
Tableau Cloud および Tableau Server では、Salesforce ユーザー アカウントのログイン情報を Tableau ユーザー アカウントと共に保存できます。 |
|
管理者設定 |
Tableau Server 管理者は、Tableau サーバーを OAuth 用に構成する必要があります (Tableau から予測へのアクセスを有効にします)。詳細については、Tableau Server ヘルプの「Einstein Discovery 統合の構成」を参照してください。 パブリッシュされた表計算でユーザーが予測を確認できるようにするには、Tableau Server 管理者はサイトの分析拡張機能を有効にする必要があります。詳細については、Tableau Server ヘルプの「分析拡張機能を使用した接続の構成」を参照してください。 Tableau Server 構成の詳細については、「Einstein Discovery 統合の構成 (Tableau Server)」を参照してください。 Tableau Cloud 構成の詳細については、「Einstein Discovery 統合の構成 (Tableau Cloud)」を参照してください。 |
| 名前 | 式 |
| 初回購入日 | {FIXED [Customer Name] : MIN([Order Date])} |
| 初回の購入以来の日数 | DATETRUNC('day', [Order Date])-DATETRUNC('day', [First Purchase Date]) |
| bq-fetch-tasks | HTTP を使用してデータをフェッチするときに使用する、並列バックグラウンド タスクの数。既定は 10 です。 |
| bq-large-fetch-rows |
スプール クエリの各バッチでフェッチされる行の数。既定は 50000 です。 |
| bq-fetch-rows | 非スプール クエリの各バッチでフェッチされる行の数。既定は 10000 です。 |
| bq-response-rows | 非スプールおよび非一括クエリで返される行の数。既定は 10000 です。 |
| CAP_BIGQUERY_FORCE_SPOOL_JOB | すべてのクエリで一時テーブル アプローチの使用を強制します。既定値は「no」です。この属性をオンに切り替えるには値を「yes」に変更します。 |
|
請求 請求支払 貸方票 保証金 |
予測 請求書 仕分記入 支払 発注 |
発注書 払い戻しレシート 売上レシート ベンダー クレジット |
| たとえば、JSON ファイルのスニペットは次のとおりです。 | JSON ファイルはこれらのスキーマ レベルを生成します。 |
|
|
| レコード数 |
取得までの時間 |
|---|---|
|
1,000 |
4.5 秒 |
|
10,000 |
45 秒 |
|
100,000 |
8 分 |
|
1,000,000 |
75 分 |
| SQL_ODBC_INTERFACE_CONFORMANCE | 現在使用されていません。 |
| SQL_SQL_CONFORMANCE | 整数ビットマスク。データ ソースが SQL 標準を遵守するレベルを、次のように定義します: 「1」はエントリー レベル SQL-92 準拠、「2」は FIPS 127-2 トランジショナル、「4」は中間、「8」は完全準拠。 |
| SQL_CATALOG_USAGE | 整数ビットマスク。カタログ識別子を使用することができる SQL ステートメントを定義します。 |
| SQL_SCHEMA_USAGE | 整数ビットマスク。スキーマ識別子を使用することができる SQL ステートメントを定義します。 |
| SQL_AGGREGATE_FUNCTIONS | 整数ビットマスク。サポートされている標準的な SQL 集計形式を定義します。 |
| SQL_NUMERIC_FUNCTIONS | 整数ビットマスク。サポートされている SQL スカラー数値関数を定義します。 |
| SQL_STRING_FUNCTIONS | 整数ビットマスク。サポートされている SQL スカラー文字列関数を定義します。 |
| SQL_TIMEDATE_FUNCTIONS | 整数ビットマスク。サポートされている SQL スカラー日付 / 時刻関数を定義します。 |
| SQL_TIMEDATE_ADD_INTERVALS | 整数ビットマスク。TIMESTAMPADD スカラー関数でサポートされている日付 / 時刻間隔を定義します。 |
| SQL_TIMEDATE_DIFF_INTERVALS | 整数ビットマスク。TIMESTAMPDIFF スカラー関数でサポートされている日付 / 時刻間隔を定義します。 |
| SQL_DATETIME_LITERALS | 整数ビットマスク。DATE / TIME 制限および INTERVAL を表現するのにサポートされている SQL-92 リテラルを定義します。 |
| SQL_SYSTEM_FUNCTIONS | 整数ビットマスク。次の特殊な SQL システム スカラー関数のサポートを定義します: IFNULL、DBNAME、および USERNAME。 |
| SQL_SQL92_VALUE_EXPRESSIONS | 整数ビットマスク。テスト値および操作値をサポートしている論理関数を定義します: CASE、CAST、および NULLIF。 |
| SQL_SQL92_NUMERIC_VALUE_FUNCTIONS | 整数ビットマスク。次を含む非数値データから数値を生成することができる関数を定義します: EXTRACT (日付 / 時刻部分抽出)、CHAR_LENGTH, CHARACTER_LENGTH、および POSITION(.. IN ..)。 |
| SQL_SQL92_STRING_FUNCTIONS | 整数ビットマスク。サポートされている文字列操作関数を定義します。 |
| SQL_SQL92_DATETIME_FUNCTIONS | 整数ビットマスク。現在の日付、時刻、またはタイムスタンプの決定をサポートしている日付 / 時刻操作関数を定義します。 |
| SQL_OJ_CAPABILITIES | 整数ビットマスク。サポートされている外部結合の型を定義します。 |
| SQL_SQL92_RELATIONAL_JOIN_OPERATORS | 整数ビットマスク。サポートされている JOIN 操作の型を定義します。例: INNER、OUTER。 |
| SQL_SQL92_PREDICATES | 整数ビットマスク。値の論理テストをサポートしている述語を定義します。例: IS NULL, LIKE, IN. |
| SQL_CONVERT_FUNCTIONS | 整数ビットマスク。1 つのデータ型から別のデータ型への CAST または CONVERT をサポートしている ODBC スカラー関数を定義します。 |
| SQL_CONVERT_TINYINT | 整数ビットマスク。ODBC スカラー関数 CONVERT を使用してこの名前付きの型を変換することができる他のデータ型を判別します。 |
| SQL_CONVERT_SMALLINT | 整数ビットマスク。上記と同じ。 |
| SQL_CONVERT_INTEGER | 整数ビットマスク。上記と同じ。 |
| SQL_CONVERT_BIGINT | 整数ビットマスク。上記と同じ。 |
| SQL_CONVERT_REAL | 整数ビットマスク。上記と同じ。 |
| SQL_CONVERT_FLOAT | 整数ビットマスク。上記と同じ。 |
| SQL_CONVERT_DOUBLE | 整数ビットマスク。上記と同じ。 |
| SQL_CONVERT_CHAR | 整数ビットマスク。上記と同じ。 |
| SQL_CONVERT_VARCHAR | 整数ビットマスク。上記と同じ。 |
| SQL_CONVERT_LONGVARCHAR | 整数ビットマスク。上記と同じ。 |
| SQL_CONVERT_DECIMAL | 整数ビットマスク。上記と同じ。 |
| SQL_CONVERT_NUMERIC | 整数ビットマスク。上記と同じ。 |
| SQL_CONVERT_BIT | 整数ビットマスク。上記と同じ。 |
| SQL_CONVERT_GUID | 整数ビットマスク。上記と同じ。 |
| SQL_CONVERT_BINARY | 整数ビットマスク。上記と同じ。 |
| SQL_CONVERT_VARBINARY | 整数ビットマスク。上記と同じ。 |
| SQL_CONVERT_LONGVARBINARY | 整数ビットマスク。上記と同じ。 |
| SQL_CONVERT_DATE | 整数ビットマスク。上記と同じ。 |
| SQL_CONVERT_TIME | 整数ビットマスク。上記と同じ。 |
| SQL_CONVERT_TIMESTAMP | 整数ビットマスク。上記と同じ。 |
| SQL_CONVERT_INTERVAL_DAY_TIME | 整数ビットマスク。上記と同じ。 |
| SQL_CURSOR_COMMIT_BEHAVIOR | 短整数値。データ ソースのコミット時に準備されたステートメントがクローズされる場合は、"0" です。 |
| SQL_MAX_IDENTIFIER_LEN | 整数値。識別子で使用できる最大文字数を定義します。Tableau は、文字列の終端文字として 1 文字分の余白を残しています。 |
| SQL_TXN_CAPABLE | 短整数値。データソースがトランザクションをサポートしていない場合は、"0" です。 |
| SQL_QUOTED_IDENTIFIER_CASE | 整数ビットマスク。 |
| SQL_COLUMN_ALIAS | ブール値。"データ ソースが SELECT 句に挙げられている列の別名の使用をサポートしている場合、「Y」になります。 |
| SQL_IDENTIFIER_QUOTE_CHAR | 文字列値。引用する識別子として使用できる文字を示します。接続カスタマイズは XML ドキュメントであるため、すべてのエンティティは正しくエンコードする必要があります。たとえば、二重引用符は「"」になります。また、この文字は識別子前後では開きかっこおよび閉じかっことして機能するため、識別子を囲うために「[]」が必要なデータ ソースではサポートされていない場合があります。 |
| SQL_CATALOG_NAME_SEPARATOR | 文字値。識別子をカタログ、スキーマ、または表名で修飾する場合、識別子間に使用する区切り文字を示します。一般的なピリオドです。 |
| SQL_SPECIAL_CHARACTERS | 文字列値。識別子文字列で許可されている特殊文字を示します。 |
| SQL_CATALOG_TERM | 文字列値。この ODBC データ ソースの Tableau 接続ダイアログに表示される、データベース カタログの説明用語です。 |
| SQL_SCHEMA_TERM | 文字列値。この ODBC データ ソースの Tableau 接続ダイアログに表示される、データベース スキーマの説明用語です。 |
| SQL_TABLE_TERM | 文字列値。この ODBC データ ソースの Tableau 接続ダイアログに表示される、データベース表の説明用語です。 |
| SQL_DRIVER_NAME | 文字列値。データベース ODBC ドライバーの名前です。 |
| SQL_DRIVER_VER | 文字列値。ODBC ドライバーのバージョン番号です。 |
| SQL_DRIVER_ODBC_VER | 文字列値。ドライバーがサポートしている ODBC API のバージョンです。 |
| SQL_ODBC_VER | 文字列値。Windows ODBC ドライバー マネージャーがサポートしている ODBC のバージョンです。カスタマイズする必要はありません。 |
| SQL_DBMS_NAME | 文字列値。データベース ベンダーの名前です。 |
| SQL_DBMS_VER | 文字列値。データベース システムのバージョンです。 |
| SQL_SERVER_NAME | 文字列値。データベース サーバーの名前付きネットワーク アドレスです。 |
| SQL_USER_NAME | 文字列値。現在認証されているユーザーの名前です。 |
| レコード数 |
取得までの時間 |
|---|---|
|
50,662 レコード |
3 分 17 秒 |
|
95,214 行 |
6 分 14 秒 |
|
194,679 行 |
12 分 55 秒 |
|
共有メンバーを含める ダイエット飲料が "Diet Drinks (ダイエット飲料)" 階層とそれぞれのドリンク階層の両方に表示されます。 |
共有メンバーを含めない ダイエット飲料がそれぞれのドリンク階層に一度だけ表示されます。 |
|
|
|
|
|
| ライブ接続 | 抽出接続 |
|
|
| 別名を非表示にした状態 | 別名を表示した状態 |
|
|
| レコード数 |
取得までの時間 |
|---|---|
|
1,000 |
11 秒 |
|
10,000 |
2 分 |
|
100,000 |
18 分 |
|
Snowflake では、既定のアイデンティティ プロバイダー (IdP) として、アクセス トークンを提供しアイデンティティを認証する Okta が使用されます。OAuth およびシングル サインオン (SSO) の機能を使用するには、Snowflake と Okta で設定を構成する必要があります。 Okta では、Okta を OAuth 認証サーバーとして定義し、Snowflake を OAuth リソースとして識別します。Snowflake のヘルプ トピック「Snowflake 用の ID プロバイダーの設定」の手順に従います。 |
|
|
|
| 場所 | Hyperforce 地域 | ポッド (ポッド名) | Hyperforce に移行後の IP アドレスと範囲
(または、「Hyperforce 地域」を https://ip-ranges.salesforce.com/ip-ranges.json で検索します) |
|
|---|---|---|---|---|
| アジア太平洋 |
オーストラリア |
ap-southeast-2 |
prod-apsoutheast-a |
141.163.192.0/23 |
| インド | ap-south-2 | prod-in-a | 141.163.216.0/24 | |
|
インドネシア |
ap-southeast-3 |
prod-apsoutheast-c |
141.163.212.0/24 |
|
|
日本 |
ap-northeast-1 |
prod-apnortheast-a |
141.163.208.0/23 |
|
|
シンガポール |
ap-southeast-1 |
prod-apsoutheast-b |
141.163.196.0/23 |
|
| 韓国 | ap-northeast-2 | prod-kr-a | 141.163.200.0/23 | |
| カナダ |
ケベック |
ca-central-1 |
prod-ca-a |
155.226.152.0/23 |
| ヨーロッパ | ドイツ | eu-central-1 |
dub01 (DUB01) |
145.224.208.0/23 |
|
eu-west-1a (EW1A) |
||||
| スイス | eu-central-2 | prod-ch-a | 145.224.198.0/24 | |
| UK |
eu-west-2 |
prod-uk-a |
145.224.200.0/23 |
|
| 米国 - 西部 | オレゴン | us-west-2 |
10ax (10AX) |
155.226.128.0/21 |
|
10ay (10AY) |
||||
|
10az (10AZ) |
||||
|
uw2b (UW2B) |
||||
|
prod-uswest-c |
||||
| 米国 - 東部 | バージニア | us-east-1 |
prod-useast-a |
155.226.144.0/22 |
|
prod-useast-b |
||||
|
us-east-1 (useast-1) |
||||
|
prod-useast-c |
||||
| 場所 | Hyperforce 地域 | ポッド (ポッド名) | Hyperforce へ移行前の IP アドレス | |
|---|---|---|---|---|
| アジア太平洋 |
オーストラリア |
ap-southeast-2 |
prod-apsoutheast-a |
3.25.37.32/28 |
|
日本 |
ap-northeast-1 |
prod-apnortheast-a |
18.176.203.96/28 |
|
| カナダ |
ケベック |
ca-central-1 |
prod-ca-a |
3.98.24.208/28 |
| ヨーロッパ |
ドイツ 注: Hyperforce へ移行前はアイルランド地域でした。 |
eu-central-1 |
dub01 (DUB01) |
34.246.74.86 52.215.158.213 |
|
eu-west-1a (EW1A) |
34.246.62.141 34.246.62.203 |
|||
| UK |
eu-west-2 |
prod-uk-a |
18.134.84.240/28 |
|
| 米国 - 西部 | オレゴン | us-west-2 |
10ax (10AX) |
34.208.207.197 52.39.159.250 |
|
10ay (10AY) |
34.218.129.202 52.40.235.24 |
|||
|
10az (10AZ) |
34.218.83.207 52.37.252.60 |
|||
|
us-west-2b (UW2B) |
34.214.85.34 34.214.85.244 |
|||
| 米国 - 東部 | バージニア | us-east-1 |
prod-useast-a |
3.219.176.16/28 |
|
prod-useast-b |
3.219.176.16/28 |
|||
|
us-east-1 (useast-1) |
50.17.26.34 52.206.162.101 |
|||
| 場所 | Hyperforce 地域 | ポッド (ポッド名) | IP アドレスと範囲 /VPCE ID | |
|---|---|---|---|---|
| アジア太平洋 |
オーストラリア |
ap-southeast-2 |
prod-apsoutheast-a |
141.163.192.0/23 |
| インド | ap-south-2 | prod-in-a |
141.163.216.0/24 vpce-02e14aeeeccOa2eef |
|
|
インドネシア |
ap-southeast-3 |
prod-apsoutheast-c |
141.163.212.0/24 |
|
|
日本 |
ap-northeast-1 |
prod-apnortheast-a |
141.163.208.0/23 |
|
|
シンガポール |
ap-southeast-1 |
prod-apsoutheast-b |
141.163.196.0/23 |
|
| 韓国 | ap-northeast-2 | prod-kr-a |
141.163.200.0/23 vpce-053ebbbe86f5411ca |
|
| カナダ |
ケベック |
ca-central-1 |
prod-ca-a |
155.226.152.0/23 |
| ヨーロッパ | ドイツ | eu-central-1 |
dub01 (DUB01) |
145.224.208.0/23 vpce-091ff41bc3686e6e8 |
|
eu-west-1a (EW1A) |
||||
| スイス | eu-central-2 | prod-ch-a |
145.224.198.0/24 vpce-0fbf9d552ffbb6be2 |
|
| UK |
eu-west-2 |
prod-uk-a |
145.224.200.0/23 |
|
| 米国 - 西部 | オレゴン | us-west-2 |
10ax (10AX) |
155.226.128.0/21 vpce-090a7c76e361d5013 |
|
10ay (10AY) |
||||
|
10az (10AZ) |
||||
|
uw2b (UW2B) |
||||
|
prod-uswest-c |
||||
| 米国 - 東部 | バージニア | us-east-1 |
prod-useast-a |
155.226.144.0/22 vpce-0ea40e596e16259d1 |
|
prod-useast-b |
||||
|
us-east-1 (useast-1) |
||||
|
prod-useast-c |
||||
| 機能と性能 | Tableau Desktop Public Edition | Tableau Desktop Free Edition | Tableau Desktop Professional Edition |
| プライバシーとセキュリティ |
|
|
|
| ビジュアライゼーションのローカルへの保存 |
|
|
|
| 自動回復 |
|
|
|
| 他の公開サイトにビジュアライゼーションをパブリッシュまたは埋め込む |
* Tableau Public にパブリッシュした後に利用できる埋め込みオプション |
|
|
| ビジュアライゼーションを Tableau Public にパブリッシュ |
|
|
|
| Tableau Cloud または Tableau Server にビジュアライゼーションをパブリッシュする |
|
|
|
| パッケージ化されたワークブックを他のユーザーと共有する |
|
|
|
| ライブ データの更新 | データの更新に制限がある (Google Drive のみ。)データは 24 時間ごとに自動的に更新されます。) |
|
|
| データ ソース | データ ソースの選択肢に制限がある (Google ドライブ、JSON ファイル、Microsoft Excel 2007 以降、OData、PDF、空間ファイル、統計ファイル、テキスト ファイル) |
* Tableau Cloud または Tableau Server 上でパブリッシュされたデータ ソースはサポートされていません |
|
| データ ソース行 |
1500 万行 |
無制限 |
無制限 |
| クラウドストレージ |
Tableau Public 上で 10GB |
|
Tableau Cloud と Tableau Server (該当する場合) |
| ローカルストレージ |
|
|
|
| 視覚キュー | 説明 |
![]() |
ワークブックがリレーショナル データ ソースまたはファイルに直接接続されます。 |
![]() |
ワークブックが、元のデータを参照している抽出に接続されます。 |
![]() |
ワークブックがキューブ (多次元) データ ソースに接続されます。Tableau では、Windows のみでキューブ データ ソースをサポートしています。 |
|
ブックは Excel テーブル、サブテーブル、または名前付き範囲に接続されます。 |
|
ワークブックが Tableau Server にパブリッシュされたデータ ソースに接続されます。 |
| 視覚キュー | フィールドの説明 |
![]() |
テキスト値または文字列値。 |
![]() |
数値。 |
![]() |
日付値。 |
|
日付値と時刻値。 |
![]() |
ブール値 (true または false)。 |
|
|
地理的データ。このアイコンは、フィールドに地理的な役割が割り当てられていることも示します。これらのフィールドは、マップ ビューを作成する際に使用します。Tableau のマップおよび地理的データの分析を参照してください。 |
|
|
カスタム ジオコーディング ファイルからの地理的データ。Tableau が認識しない場所をジオコーディングし、マップ上にプロットするを参照してください。 |
|
|
イメーの役割に設定された URL。Web 画像をワークシートに動的に追加するを参照してください。 |
![]() |
データ ソースによって定義された計算。 |
|
ユーザー定義セット。セットの作成を参照してください。 |
|
サーバーの名前付きセット。 |
|
アクションの結果として自動的に作成されたセット。アクションを参照してください。 |
|
パブリッシュされたコンテンツ向けのユーザー フィルター。データ行レベルでのアクセスの制限を参照してください。 |
|
数値ビン。連続メジャーから連続の bin を作成するを参照してください。 |
|
グループ。データのグループ化によりデータエラーの修正またはディメンション メンバーを組み合わせるを参照してください。 |
|
|
クラスター グループ。データ内のクラスターを見つけるを参照してください。 |
![]() |
リレーショナル階層。階層の作成を参照してください。 |
|
多次元階層内のレベル。5 を超えるレベルは、数値なしで表示されます。 |
![]() |
1 つ以上のフィールドが含まれるフォルダーです。フォルダーは、[データ] ペインのフィールドを整理するのに使用されます。データ ペインの整理を参照してください。 |
|
キューブ (多次元) データ ソースの属性。Tableau では、Windows のみでキューブ データ ソースをサポートしています。 |
|
キューブ (多次元) データ ソースの変動属性。 |
|
|
このフィールドは、データ ブレンド用のアクティブ リンクです。データのブレンドを参照してください。 |
|
|
このフィールドは、データ ブレンドに使用される可能性のあるリンクです。データのブレンドを参照してください。 |
|
|
このフィールドは関連なしです。マルチファクト関係データ モデルについてを参照してください。 |
|
|
フィールドはつなぎ合わせフィールドです。マルチファクト関係データ モデルについてを参照してください。 |
|
|
フィールドは非表示です。クリックするとフィールドが再表示されます。フィールドの表示または非表示を参照してください。 |
| 視覚キュー | 説明 |
|
シェルフの青色のフィールドは不連続フィールドを示します。ほとんどの場合、シェルフにディメンションを追加すると青色のフィールドで表示されます。青色のフィールドは不連続フィールドで、有限数の値を含みます。青色のフィールドをシェルフに追加すると、ヘッダーが作成されます。詳細については、ヘッダーを参照してください。 |
|
シェルフの緑色のフィールドは連続フィールドを示します。ほとんどの場合、シェルフにメジャーを追加すると緑色のフィールドで表示さえれます。緑色のフィールドは連続フィールドで、有限数の値を含みます。緑色のフィールドをシェルフに追加すると、軸が作成されます。詳細については、軸を参照してください。 |
|
|
並べ替えアイコンは、計算による並べ替え順序または手動の並べ替え順序が適用されるフィールドであることを示します。視覚化内でのデータの並べ替えを参照してください。 |
|
シグマ アイコンは、スライス フィルターが多次元 (キューブ) データ ソースにあることを示します。スライス フィルターの作成を参照してください。 |
|
ベン図形アイコンはセットを示します。セットの作成を参照してください。 |
|
関連のないアイコンは、フィールドが Viz 内の少なくとも 1 つの他のフィールドと関連がないことを示します。フィールド レベルの関連性指標を参照してください。 |
|
関連ありアイコンは、ディメンションが関連のないフィールドをつなぎ合わせていることを示します。フィールド レベルの関連性指標を参照してください。 |
|
斜体で表示されるフィールド名は、アクションによってフィルターが生成および制御されたことを示します。 |
|
[フィルター] シェルフにある灰色のフィールドはコンテキスト フィルターを示します。コンテキスト フィルターの使用を参照してください。 |
|
デルタ アイコンはフィールドが表計算であることを示します。表計算での値の変換を参照してください。 |
|
プラス記号とマイナス記号は、フィールドが、ドリル ダウンまたはロール アップできる階層の一部である場合に表示されます。 |
|
矢印アイコンは、予測がフィールドで表示されていることを示します。このアイコンは、実際の値と予測値を区別するのに使用する自動フィールドである [予測インジケーター] フィールドでも使用されます。予測を参照してください。 |
|
オレンジ色のチェック マークが付いたデータ ソース シリンダーは、フィールドがセカンダリ データ ソースからのものであることを示します。データのブレンドを参照してください。 |
|
フィルターが、特定のワークシートに割り当てられます。 |
|
フィルターが、同じデータ ソースを持つすべてのワークシートに割り当てられます。 |
|
フィールドにビュー内の 1 つ以上の別のフィールドとの互換性がありません。 |
| 視覚キュー | 説明 |
|
フィールドは [マーク] カードの [色] に適用されます。 |
|
フィールドは [マーク] カードの [サイズ] に適用されます。 |
|
フィールドは [マーク] カードの [ラベル] に適用されます。 |
|
フィールドは [マーク] カードの [形状] に適用されます。 |
|
フィールドは [マーク] カードの [詳細] に適用されます。 |
|
フィールドは [マーク] カードの [ツールヒント] に適用されます。 |
|
フィールドは [マーク] カードの [パス] に適用されます。[パス] は、[マーク] ドロップダウン メニューから線または多角形のマーク タイプを選択した場合にのみ利用できます。 |
| 視覚キュー | 説明 |
![]() |
シートはワークシートです。 |
![]() |
シートはダッシュボードです。 |
| 視覚キュー | 説明 |
| [フィールド名] | オレンジ色のテキスト。フィールドはディメンション、メジャー、またはセットです。 |
| [パラメーター].[パラメーター名] |
紫色のテキスト。フィールドはパラメーターです。 パラメーターが別のフィールドと同じ名前を持つ場合、Tableau ではあいまいさを避けるためにプレフィックス [パラメーター] が追加されます。 |
| [データ ソース].[フィールド名] | オレンジ色のテキスト。フィールドはセカンダリ データ ソースからのものです。データ ソース名がプレフィックスとして追加されます。 |
| 青() | 青いテキスト。計算関数。 |
| CAP_CREATE_TEMP_TABLES | Tableau が特定の複雑なクエリや最適化されたクエリに必要な一時テーブルを作成することができる場合、「yes」に設定します。CAP_SELECT_INTO も参照してください。 |
| CAP_CONNECT_STORED_PROCEDURE | ストアド プロシージャへの接続に対応することを許可する場合は、「yes」に設定します。 |
| CAP_FAST_METADATA | スキーマが小規模から中規模の場合は、「yes」に設定します。この機能は、Tableau が接続直後にすべてのオブジェクトを列挙するかどうかを制御します。値を「yes」に設定するとこの機能が有効になり、新規接続の作成時のパフォーマンスが改善されます。この機能を無効にすると、すべてのオブジェクトを取得する代わりに、特定のスキーマやテーブルを検索できます。空の文字列を使用すると、すべてのオブジェクトを検索できます。この機能は、9.0 以降で使用できます。 |
| CAP_ISOLATION_LEVEL_READ_COMMITTED | データ ソースで対応している場合、強制的にトランザクション分離レベルを "Read Committed" にするには、「yes」に設定します。4 つのトランザクション分離レベルのうち、1 つのみを「yes」に設定します。次も参照してください: CAP_SET_ISOLATION_LEVEL_VIA_SQL。 |
| CAP_ISOLATION_LEVEL_READ_UNCOMMITTED | データ ソースで対応している場合、強制的にトランザクション分離レベルを "Read Uncommitted" にするには、「yes」に設定します。4 つのトランザクション分離レベルのうち、1 つのみを「yes」に設定します。この機能はロック競合を減らすことにより速度を向上させる可能性がありますが、クエリ結果のデータが部分的または一貫性のない状態になる可能性があります。次も参照してください: CAP_SET_ISOLATION_LEVEL_VIA_SQL。 |
| CAP_ISOLATION_LEVEL_REPEATABLE_READS | データ ソースで対応している場合、強制的にトランザクション分離レベルを "Repeatable Reads" にするには、「yes」に設定します。4 つのトランザクション分離レベルのうち、1 つのみを「yes」に設定します。次も参照してください: CAP_SET_ISOLATION_LEVEL_VIA_SQL。 |
| CAP_ISOLATION_LEVEL_SERIALIZABLE | データ ソースで対応している場合、強制的にトランザクション分離レベルを "Serializable" にするには、「yes」に設定します。4 つのトランザクション分離レベルのうち、1 つのみを「yes」に設定します。これは非常に標準的な設定で、パフォーマンスは低下しますが、安定性は向上する可能性があります。次も参照してください: CAP_SET_ISOLATION_LEVEL_VIA_SQL。 |
| CAP_JDBC_BIND_DETECT_ALIAS_CASE_FOLDING | Tableau で、予想されるフィールド名ではなく、大文字や小文字のみを使用する結果セットのフィールド名を報告する JDBC データ ソースを検出し、それから復元を許可するには、「yes」に設定します。 |
| CAP_JDBC_EXPORT_DATA_BATCH | JDBC 一括操作をデータの挿入に使用するのを無効するには、「no」に設定します。 |
| CAP_JDBC_METADATA_GET_INDEX_INFO | インデックス情報の読み取りを無効にするには、「no」に設定します。 |
| CAP_JDBC_METADATA_READ_FOREIGNKEYS | 外部キー メタデータの読み取りを無効にするには、「no」に設定します。 |
| CAP_JDBC_METADATA_READ_PRIMARYKEYS | プライマリ キー メタデータの読み取りを無効にするには、「no」に設定します。 |
| CAP_JDBC_METADATA_USE_RESULTSET_FOR_TABLE | 選択 * クエリの結果セットから列のメタデータを取得するには、「yes」に設定します。Tableau 2020.4 以降で使用できます。 |
| CAP_JDBC_QUERY_ASYNC | 別のスレッドでクエリを実行するには、「yes」に設定します。 |
| CAP_JDBC_QUERY_CANCEL | ドライバーがクエリをキャンセルできる場合は、「yes」に設定します。 |
| CAP_JDBC_QUERY_DISABLE_AUTO_COMMIT | クエリの実行時に既定の自動コミット モードを無効にするには、「yes」に設定します。Tableau 2020.4 以降で使用できます。 |
| CAP_JDBC_QUERY_FORCE_PREPARE | 実行前に常にクエリを準備するには、「yes」に設定します。Tableau 2020.4 以降で使用できます。 |
| CAP_JDBC_SUPPRESS_EMPTY_CATALOG_NAME | 欠落しているカタログを無視するには、「yes」に設定します。 |
| CAP_JDBC_SUPPRESS_ENUMERATE_DATABASES | データベースの列挙を無効にするには、「yes」に設定します。 |
| CAP_JDBC_SUPPRESS_ENUMERATE_SCHEMAS | スキーマの列挙を無効にするには、「yes」に設定します。 |
| CAP_JDBC_METADATA_SUPPRESS_PREPARED_QUERY | CAP_JDBC_METADATA_USE_RESULTSET_FOR_TABLE が有効になっている場合は、この機能を「yes」に設定して、テーブル メタデータの読み取りに使用されるクエリの準備を無効にします。where-false 句でラップされたクエリを実行します。 |
| CAP_JDBC_USE_ADAPTIVE_FETCH_SIZE | ResultSet メタデータを使用して最適な取得サイズを決定するには、「yes」に設定します。正しく動作するためには、CAP_JDBC_QUERY_FORCE_PREPARE を有効にする必要がある場合があります。Tableau 2020.4 以降で使用できます。 |
| CAP_MULTIPLE_CONNECTIONS_FROM_SAME_IP | Tableau がデータベースへの 1 つを超えるアクティブな接続を作成するのを防ぐには、「no」に設定します。これは標準的な設定で、パフォーマンスは下がりますが、安定性は高まる可能性があります。 |
| CAP_QUERY_BOOLEXPR_TO_INTEXPR | Tableau で、任意のブール式を整数値にし、結果セットに含める必要がある場合は、「yes」に設定します。 |
| CAP_QUERY_FROM_REQUIRES_ALIAS | FROM 句で、特定のテーブルに別名を提供する必要がある場合は、「yes」に設定します。 |
| CAP_QUERY_GROUP_ALLOW_DUPLICATES | SQL クエリで GROUP BY 句に重複する式を含めることができない場合は、「no」に設定します (一般的ではありません)。 |
| CAP_QUERY_GROUP_BY_ALIAS | 集計のある SQL クエリで、SELECT 一覧の対応する別名よりグループ化列を参照することができる場合は、「yes」に設定します。例:GROUP BY "none_ShipCountry_nk"。 |
| CAP_QUERY_GROUP_BY_DEGREE | 集計のある SQL クエリで、各列の位置よりグループ化列を参照することができる場合は、「yes」に設定します。例:GROUP BY 2, 5。CAP_QUERY_SORT_BY_DEGREE も参照してください。 |
| CAP_QUERY_HAVING_REQUIRES_GROUP_BY | Tableau で、HAVING 句はあるもののグループ化列のない任意のクエリで人工グループ化フィールドを使用する必要がある場合、「yes」に設定します。 |
| CAP_QUERY_HAVING_UNSUPPORTED | HAVING の SQL 構文に対応していない場合、「yes」に設定します。Tableau では、サブクエリを使用してこれを回避することができる場合があります。CAP_QUERY_SUBQUERIES も参照してください。 |
| CAP_QUERY_INCLUDE_GROUP_BY_COLUMNS_IN_SELECT | すべての GROUP BY 式が SELECT 式一覧にも表示されるよう要求するには、「yes」に設定します。 |
| CAP_QUERY_JOIN_ACROSS_SCHEMAS | SQL クエリが、異なるスキーマに位置するテーブルの結合を表すことができる場合、「yes」に設定します。 |
| CAP_QUERY_JOIN_ASSUME_CONSTRAINED | データベース テーブルに FK-PK 関係がない場合でも内部結合をカリングするには、「yes」に設定します。 |
| CAP_QUERY_JOIN_PUSH_DOWN_CONDITION_EXPRESSIONS | 結合を書き換えて ON 句の条件を単純化してシンプルな識別子の比較にするには、「yes」に設定します。 |
| CAP_QUERY_JOIN_REQUIRES_SCOPE | 正しい評価順にするために、SQL クエリがかっこ内のそれぞれの結合句を詳細に調べる必要がある場合、「yes」に設定します。 |
| CAP_QUERY_JOIN_REQUIRES_SUBQUERY | サブクエリで構成される 2 つを超えるテーブルを含む結合式を強制するには、「yes」に設定します。 |
| CAP_QUERY_NULL_REQUIRES_CAST | データ ソースですべての NULL リテラルが 1 つの明示的なデータ型であることが要求される場合、「yes」に設定します。 |
| CAP_QUERY_SELECT_ALIASES_SORTED | Tableau で、SELECT 式 (別名ごとに並べ替え) に対して決定的な命令を出し、Tableau 視覚化でクエリ結果と各フィールドを正しく一致させる必要がある場合、「yes」に設定します。これは、クエリ結果を含むメタデータが返されるときに SELECT 式の別名を保存しないデータ ソースの場合にのみ要求されます。 |
| CAP_QUERY_SORT_BY_DEGREE | SQL クエリが、各列の順序位置に基づいて並べ替え列を参照することができる場合は、「yes」に設定します。例:ORDER BY 2, 5。CAP_QUERY_GROUP_BY_DEGREE も参照してください。 |
| CAP_QUERY_SUBQUERIES | データ ソースがサブクエリに対応している場合、「yes」に設定します。 |
| CAP_QUERY_SUBQUERIES_WITH_TOP | データ ソースがサブクエリ内の TOP や LIMIT 行制限句に対応している場合、「yes」に設定します。 |
| CAP_QUERY_SUBQUERY_DATASOURCE_CONTEXT | サブクエリでフィルターされたクエリ コンテキストを使用してデータ ソース フィルターを実装するには、「yes」に設定します。この機能は、Tableau 8.0 から Tableau 9.3 でのみ使用できます。 |
| CAP_QUERY_SUBQUERY_QUERY_CONTEXT | Tableau で、一時テーブルとローカルでキャッシュした結果ではなく、コンテキスト フィルターのサブクエリを強制的に使用するには、「yes」に設定します。 |
| CAP_QUERY_TOP_N | データ ソースが任意の形式の行制限句に対応している場合、「yes」に設定します。対応している正確な形式は、次のとおりです。 |
| CAP_QUERY_TOPSTYLE_LIMIT | データ ソースが行制限句として LIMIT を使用する場合、「yes」に設定します。 |
| CAP_QUERY_TOPSTYLE_ROWNUM | データ ソースが行制限句として、ROWNUM に関して Oracle スタイルのフィルターに対応している場合、「yes」に設定します。 |
| CAP_QUERY_TOPSTYLE_TOP | データ ソースが行制限句として TOP を使用する場合、「yes」に設定します。 |
| CAP_QUERY_USE_QUERY_FUSION | Tableau が複数の個々のクエリを 1 つのクエリにまとめるのを回避するには、「no」に設定します。パフォーマンスを調整する必要がある場合、またはデータベースが大量のクエリを処理できない場合は、この機能をオフにします。この機能は既定では有効で、Tableau 9.0 以降の Tableau データ抽出を除くすべてのデータ ソースで使用できます。Tableau 9.0.6 から、Tableau データ抽出でこの機能に対応しています。 |
| CAP_SELECT_INTO | Tableau が別のクエリの結果セットのフライに関するテーブルを作成することができる場合、「yes」に設定します。CAP_CREATE_TEMP_TABLES も参照してください。 |
| CAP_SELECT_TOP_INTO | Tableau がクエリの結果セットからテーブルを作成するときに TOP や LIMIT 行制限句を使用できる場合は、「yes」に設定します。 |
| CAP_SET_ISOLATION_LEVEL_VIA_SQL | Tableau で、SQL クエリを使用しているデータ ソースのトランザクション分離レベルを強制的に設定するには、「yes」に設定します。4 つの CAP_ISOLATION_LEVEL 機能のいずれかが「yes」に設定されている場合、CAP_SET_ISOLATION_LEVEL_VIA_SQL を「yes」に設定する必要があります。 |
| CAP_STORED_PROCEDURE_PREFER_TEMP_TABLE | 一時テーブルを使用して、ストアド プロシージャ結果セットに対するリモート クエリに対応するには、「yes」に設定します。 |
| CAP_STORED_PROCEDURE_REPAIR_TEMP_TABLE_STRINGS | メタデータで幅が示されない場合や正数以外の幅が示される場合に実際の文字列の幅を計算するには、「yes」に設定します。 |
| CAP_STORED_PROCEDURE_TEMP_TABLE_FROM_BUFFER | 一時テーブルにバッファされた結果セットをそのまま設定するには、「yes」に設定します。 |
| CAP_STORED_PROCEDURE_TEMP_TABLE_FROM_NEW_PROTOCOL | この操作で作成された別のプロトコルから一時テーブルにデータを設定するには、「yes」に設定します。 |
| CAP_SUPPRESS_DISCOVERY_QUERIES | Tableau で、対応しているさまざまな句の SQL 構文を検出するのを防ぐには、「yes」に設定します。 |
| CAP_SUPPRESS_DISPLAY_LIMITATIONS | このデータ ソースの制限に関するすべての警告を非表示にするには、「yes」に設定します。 |
| パラメーター | 値 | 説明 | 例 |
|---|---|---|---|
| src (必須) |
文字列 | Tableau Server または Tableau Cloud でのメトリクスの URL。 | https://mycompany/#/metrics/1
|
|
link-target (HTML) linkTarget (JavaScript) (オプション) |
文字列 | メトリクスをクリックした場合にビューアーが誘導される URL。ターゲットが指定されていない場合、埋め込みメトリクスはソース URL にリンクされます。 | http://example.com
|
| 操作内容 | キーストローク |
|---|---|
| フォーカスを前に移動します | 上 |
| フォーカスを次に移動します | 下 |
| (単一列) フォーカスを前に移動します。(複数列) フォーカスを左へ移動します。 | 左 |
| (単一列) フォーカスを次に移動します。(複数列) フォーカスを右へ移動します。 | 右 |
| フォーカスを最初の項目に移動します | ホーム |
| フォーカスを最後の項目に移動します | End |
| 項目の選択を切り替えます | スペースバー |
|
ハイライトのオンとオフを切り替えます 注: これは [選択したアイテムをハイライト] に相当するキーボードです。 |
Enter |
|
項目の選択をすべてクリアします 注: 凡例項目のテキストを高いコントラストで表示するには、凡例項目を個別に選択し、ハイライトのオンとオフを切り替えます。 |
Esc |
| 操作内容 | キーストローク |
|---|---|
|
ドロップダウン リストが閉じている場合: フォーカスを前の項目に移動して値にコミットします。 ドロップダウン リストが開いている場合: フォーカスを前の項目に移動して値にコミットします。値にコミットしません。 |
上 |
|
ドロップダウン リストが閉じている場合: フォーカスを次の項目に移動して値にコミットします。 ドロップダウン リストが開いている場合: フォーカスを次の項目に移動して値にコミットします。値にコミットしません。 |
下 |
|
ドロップダウン リストが閉じている場合: ドメイン リストを開くか閉じます。 ドロップダウン リストが開いている場合: フォーカスのある項目の選択をコミットします。 |
スペースバー |
| ドロップダウン リストが開いている場合: 選択を行わずにドメイン リストを閉じます。 | Esc |
| 操作内容 | キーストローク |
|---|---|
| フォーカスをビジュアライゼーション (viz) に移動します | ダッシュボードまたはワークブック内で、Enter キーを押します |
|
viz にフォーカスを置いて、[データの表示] ウィンドウを開きます 注: ご利用のスクリーン リーダーによっては、複数の修飾キー (Shift、Ctrl、Alt、Cmd) を組み合わせて Enter キーを押す必要がある場合があります。使用しているスクリーン リーダーのドキュメントを参照してください。 |
Shift+Enter |
| フォーカスをデータ グリッド内の任意のセルに移動します | 矢印キー |
| グリッド内のセルを操作する | 矢印キーを使用してセルに移動します。Enter キーを押すと、セル内の要素にフォーカスが当てられます。次に、Enter キーや Space キーなどのキーボード ナビゲーションを使用して要素を操作します。ナビゲーション モードに戻るには、Esc キーを押します。 |
| 列を移動します | データ グリッド内で矢印キーを使用して、フォーカスを目的の列のセルに移動します。Enter キーを押し、下矢印キーを使用して [左に移動] または [右に移動] を選択し、Enter キーを押します。 |
| 列で並べ替えます | データ グリッド内で矢印キーを使用して、フォーカスを目的の列のセルに移動します。Enter キーを押し、下矢印キーを使用して [昇順で並べ替え] または [降順で並べ替え] を選択し、Enter キーを押します。 |
| 列を削除します | データ グリッド内で矢印キーを使用して、フォーカスを目的の列のセルに移動します。Enter キーを押し、下矢印キーを使用して [削除] を選択し、Enter キーを押します。 |
| フォーカスを別のデータ テーブルに移動します | Tab キーを押して、フォーカスを [サマリー] タブに移動します。下矢印キーを使用して、フォーカスを [タブ] ペイン内の目的のデータ テーブルに移動します。 |
| 行数を編集します | Tab キーを押して、フォーカスを [行数] フィールドに移動します。目的の行番号を入力して、Enter キーを押します。 |
| 別名を表示または非表示にします | Tab キーを押して、フォーカスを [設定] ボタンに移動します。別名を表示するには Enter キーを押し、別名を非表示にするには Enter キーをもう一度押します。 |
| フィールドを追加または削除します | Tab キーを押して、フォーカスを [フィールドの表示] ボタンに移動します。Enter キーを押して、データ ソースのフィールドのリストを表示します。矢印キーを使用して、フォーカスを各フィールド名に移動します。Enter キーを押して、不要なフィールドをデータ グリッドから削除します。フィールドをデータ グリッドに追加し直すには、目的のフィールドで Enter キーを押して、フィールドをもう一度選択します。 |
| [データの表示] ウィンドウに表示されているデータをダウンロードします | Tab キーを押して、フォーカスを [ダウンロード] ボタンに移動し、Enter キーを押します。カスタマイズされた表示データを含む CSV ファイルがブラウザーでダウンロードされます。 |
| [データの表示] ウィンドウを閉じます | Windows: ALT + F4 Mac OS: Cmd+W |
| 操作内容 | キーストローク |
|---|---|
| フォーカスをビジュアライゼーション (viz) に移動します | ダッシュボードまたはワークブック内で、Enter キーを押します |
| viz に焦点を合わせて、左、上、右、または下のヘッダーに移動します | 矢印キー |
| ヘッダーに移動します | Enter |
|
ヘッダーまたはネストされたヘッダー内を移動します |
矢印キー |
| ヘッダーの強調表示のオンとオフを切り替えます | スペースバー |
| ヘッダーから戻ります | Esc |
| 製品名 | 製品画像 URL | 製品売上高 |
| フラット | https://img.example.com/flats.png | 12,118 |
| ハイヒール | https://img.example.com/highheels.png | 15,865 |
| ランニング シューズ | https://img.example.com/runningshoes.png | 14,200 |
| ウェッジ | https://img.example.com/wedges.png | 8,665 |
| ポイントする | 選択する | メニュー |
|
|
|
| アクセシビリティが低い - コントラストが低い | アクセシビリティが高い - コントラストが高い |
|
|
| アクセシビリティが低い - マークが多すぎる | アクセシビリティが高い - 集計されたビュー |
|---|---|
|
|
| アクセシビリティが低い - マークが多すぎる | アクセシビリティが高い - 集計およびグループ化されたビュー |
|---|---|
|
|
| アクセシビリティが低い - 不要なマーク | アクセシビリティが高い - 不要なマークが削除されている |
|---|---|
|
|
| アクセシビリティが容易でない | アクセシビリティが高い - 色弱パレットと形状 |
|---|---|
|
|
| アクセシビリティが低い - マークが多すぎる | アクセシビリティが高い - ビュー内のマークが少ない |
|---|---|
|
|
| 簡単に理解できない - マークが多すぎる | アクセシビリティが高い - 集計されたビュー |
|---|---|
|
|
|
|
| 簡単に理解できない - テキストが少なすぎる | アクセシビリティが高い - 説明文を補足してコンテキストを提供する |
|---|---|
|
|
|
|
| 簡単に理解できない - テキストが少なすぎる | アクセシビリティが高い - 説明文を追加 |
|---|---|
|
|
|
|
| 簡単に理解できない - 色のみでマークを区別 | アクセシビリティが高い - 色と形状でマークを区別 |
|---|---|
|
|
|
|
|
編集を開始するには、既存のフィールドをダブルクリックします。 |
|
| 空のシェルフまたはシェルフの空の部分をダブルクリックしても、新しい計算を作成できます。 |
|
| 入力して式を更新するか、[データ] ペインまたはビュー内の別の場所から新しいフィールドを式にドラッグします。 |
|
|
Enter キーまたは Tab キーを押すか、式の外側をクリックすると、式がコミットされ、計算が終了し、ビューが更新されます。 式をコミットし、計算を閉じずにビューを更新するには、Ctrl + Enter (Mac では Command + Enter) を押します。 |
|