# tableau Tableau Reader (reader) - Full Documentation [Skip to main content](#main-content) # Colour Legend The colour legend can either be categorical or quantitative. A categorical legend represents discrete categories such as customer names and regions while a quantitative legend represents a range of numeric values such as sales and profit.

Categorical Legend

Quantitative Legend

#### To edit a categorical colour legend: 1. Right-click (Control-click on Mac) the legend and select Edit Colours. 2. Select a data item in the list on the left, and then select a new colour in the palette on the right. 3. Click OK. Note: You can select a different Colour Palette from the drop-down list in the upper right corner of the Edit Colour dialog box. #### To edit a quantitative colour legend: 1. Right-click (Control-click on Mac) the legend and select Edit Colours. 2. Click the colour indicator next to the colour ramp and select a new colour in the spectrum. 3. You can also specify one or more of the following options: - Stepped Colour – groups the values into uniform bins each given a unique colour. - Reversed – switches the order of the colours in the range. - Use Full Colour Range – starting and ending numbers in the range are assigned full intensity (only available when using a diverging colour palette). 4. Optionally use the Advanced options to define starting, centre and ending values for the colour range. 5. When finished, click OK. Note: You can select a different Colour Palette from the drop-down list at the top of the Edit Colour dialog box. [Skip to main content](#main-content) # Creating a PDF File You can print one or more views to a PDF document. You do not need to have Adobe Acrobat installed on your computer. #### To publish to PDF: 1. If you want to specify which elements are printed to the PDF file, and how they're laid out, select File > Page Setup. For more information, see [Printing Worksheets](https://help.tableau.com/current/reader/desktop/en-gb/print.htm). 2. Select File > Print to PDF. 3. In the Print to PDF dialog box, select the print range: - Entire Workbook – publishes all the sheets in the workbook. - Active Sheet – publishes only the sheet currently displayed in the workbook. - Selected Sheets - publishes the selected sheets. ![](/tableau/current/en-gb/reader/desktop/en-gb/Img/rpdf3.png) 4. Select a paper size and orientation. If you select unspecified, the paper size will be as large as necessary to show the entire view on a single page. 5. Optionally select View PDF File After Printing if you want to automatically open the PDF when you are done printing. This option is only available if you have Adobe Acrobat Reader or Adobe Acrobat installed on your computer. 6. Optionally select Show Selections if you want to include selected marks and highlighting in the PDF. 7. Click OK and select where you want to save the PDF. Then click Save. 8. Optionally specify the [Page Setup](https://help.tableau.com/current/reader/desktop/en-gb/print.htm#psetup) for each sheet in the workbook before publishing to PDF. [Skip to main content](#main-content) # Exporting Data or Views You can export the data from a workbook or export an image that represents a view, to other applications for presentations and documents. ## Exporting Data You can either copy a selection of data from a view to use in another application or you can export all the data from the worksheet to an Access database. #### To copy data to the Clipboard: 1. Select the data in the view that you want to copy. 2. Right-click (Control-click on Mac) the selection and select Copy > Data. 3. Open another application such as MS Word or MS Excel and select Edit > Paste. Note: You can also copy the data as a cross-tab for use in Microsoft Excel. Select Copy > Crosstab on the context menu. ![](/tableau/current/en-gb/reader/desktop/en-gb/Img/data1.png) #### To export data to Microsoft Access: 1. Select Worksheet > Export > Data. ![](/tableau/current/en-gb/reader/desktop/en-gb/Img/data2.png) 2. Enter a location and name for the Access database, and then click Save. 3. In the Export Data to Access dialog box, specify a database name and what data to export, and then click OK. ## Exporting a view as an image You can either copy the view for use in another application or you can export the view as an image file. #### To copy the view to the Clipboard: 1. Select Worksheet > Copy > Image. 2. In the Copy Image dialog box, select the contents you want to include and the legend layout if the view contains a legend. ![](/tableau/current/en-gb/reader/desktop/en-gb/Img/image3.png) 3. Click Copy. 4. Open another application such as MS Word or MS Excel and select Edit > Paste. Note: In some applications you can select Paste Special and specify a format for the image. #### To export a view to an image file: 1. Select Worksheet > Export > Image. ![](/tableau/current/en-gb/reader/desktop/en-gb/Img/image4.png) 2. In the Export Image dialog box, select the contents to include and the legend layout if the view contains a legend, and then click Save. 3. When finished, click Save. 4. In the Save Image dialog box, navigate to where you want to save the image file and type a file name into the text box. Select a file format from the Save as type drop-down list. When finished, click Save. [Skip to main content](#main-content) # Filtering Data Use filtering to select a subset of the data in the view to focus on that data or to exclude data from the view. ## Filtering using marks or headers You can click a mark to select the data represented by just that mark, use your cursor to select a set of marks or click on a header to select a section of data. When you do, the data for the marks or header is highlighted and other data is dimmed. To see all the data again, click anywhere outside the marks. ### Keeping or excluding data You can remove selected data altogether, or you can keep just selected data and remove all the other data in a view. #### To keep or exclude data: 1. Select the marks or headers for that data that you want to keep or exclude. 2. Right-click (Control-click on Mac) the mark or header, and then click Keep Only or Exclude. ## Using filter cards Filters are cards on the worksheet that display a range of data. If the author of the workbook has included a filter card, you can include and exclude data in the view using the card. For categorical data fields, filters display as a list of tick boxes or radio buttons for each member of the field. For example, a filter for a Date field might list the following members: 2011, 2012, 2013, 2014. ![](/tableau/current/en-gb/reader/desktop/en-gb/Img/rfilter1_157x125.png) To select data in the filter, select the members you want to include. The author of the workbook can also set the filter to exclude values, which means the selected members will be filtered from the view and the rest are included. This mode is useful when you usually want to show most members and exclude just a few. For measures (numerical data), filters are displayed as a slider. Slide the handles left and right to define the range of values you want to include in the view. For example, you could use a filter for the Sales measure to only include values between $50,000 and $85,000. ![](/tableau/current/en-gb/reader/desktop/en-gb/Img/rfilter2_156x72.png) To specify exact lower and upper values, click one of the numbers on the filter and enter a new value. ## Resetting filters You can reset the filters along with other changes you've made by either clicking the Undo button or reverting the workbook to its last saved state. For more information about how to revert a workbook, see [Reverting Workbooks](https://help.tableau.com/current/reader/desktop/en-gb/revert.htm). [Skip to main content](#main-content) # Interacting with Views A workbook's author might have added features to the workbook that let you interact with views. If a workbook includes the features, you can interact with views in the following ways: - Filter: Lets you visually isolate subsets of the data. - Sort: Lets you change the order in which the data is displayed in a view. - Actions: Lets you select a mark in one view to highlight related data in another view. - Page Playback: Lets you flip through individual pages in a view. - Legends: Change the colour palette that is applied to the data in the view. ## Other articles in this section [Skip to main content](#main-content) # Opening Workbooks In Tableau Reader, you can open packaged workbooks that were created using Tableau Desktop or Tableau Server. Packaged workbooks, saved with a .twbx file extension, contain the workbook along with a copy of any local file data sources and background images. The workbook is no longer linked to the original data sources and images. Packaged workbooks only connect to local file data sources such as Excel, Access, data extracts and text files.

To open a Tableau Reader file do one of the following:

  • Click Browse for File on the Start page and navigate to the location of the workbook using the Open dialog box.

    Home page for Tableau Reader.

    Note: This button only appears if you have no other recently opened workbooks in the pane.

  • Select File > Open and navigate to the location of the packaged workbook using the Open dialog box.

  • Double-click on any packaged workbook file.

  • Drag any packaged workbook file onto the Reader desktop icon or onto the running application.

  • Click the Open a workbook link and select a workbook to open.

    Note: This link only appears after you have previously opened at least one workbook.

When a workbook opens, the worksheets and dashboards are shown as tabs along the bottom of the window. ![](/tableau/current/en-gb/reader/desktop/en-gb/Img/rsheet_navigation.png) Note: If the workbook connects to a Microsoft Office 2007 data source (Excel or Access), you need to also have Microsoft Office 2007 installed on your computer. You can also ask the author of the workbook to save the data source to a version that is compatible with your software. [Skip to main content](#main-content) # Printing Worksheets Specify page setup options and print one or more worksheets. ## Page Setup The Page Setup is a collection of options for how the worksheet will look when it is printed. For example, you can select whether to include legends and the page orientation. Each worksheet can be assigned different page setup options. Open the page setup dialog box by selecting File > Page Setup. ![](/tableau/current/en-gb/reader/desktop/en-gb/Img/print1.png) Navigate through the following categories of settings:
General

Select the parts of the worksheet that you want to show when you print. In addition, specify how to handle headers and page breaks. If the view contains Pages, you can select whether to print the current page or all pages.

Layout

Specify legend layout, page margins and centering.

Print Scaling

Fit the view to a certain size and change the page orientation.

## Print After specifying [Page Setup](#psetup) options, you can print by selecting File > Print. In the Print dialog box, select a printer, specify a print range and select the number of copies you want to print. ![](/tableau/current/en-gb/reader/desktop/en-gb/Img/print2.png) [Skip to main content](#main-content) # Publishing and Exporting Share the views and data in a workbook as well as include them in presentations and documents. You can Print the PDF, Export to Another Application or Print one or more worksheets. ## Other articles in this section [Skip to main content](#main-content) # Reader Layout When you open a workbook, it opens in the Reader window where you can view and interact with the data. A workbook can contain a single sheet, or view. It can also include a dashboard, which is a view that combines several worksheets in a single place so that you can compare and monitor a variety of data at one time. ![](/tableau/current/en-gb/reader/desktop/en-gb/Img/layout1.png)\` ## Navigating through your workbook Tableau gives you several options to navigate through your workbook. If the workbook contains multiple sheets, each sheet or dashboard displayed in the workbook are shown as tabs along the bottom of the window. To switch between the sheets, click a tab. If there are too many sheets to show all of the tabs at once, you can scroll through the tabs using the controls on the left. ![](/tableau/current/en-gb/reader/desktop/en-gb/Img/layout4.png) To view all the sheets or dashboards in a workbook at one time, use the filmstrip or sheet sorter view. The filmstrip view shows each sheet as a thumbnail image along the bottom of the workbook. To toggle between showing tabs and the filmstrip view, click the button on the bottom right of the Reader window. Select the thumbnail image to open the sheet that you want to view. ![](/tableau/current/en-gb/reader/desktop/en-gb/Img/layout7.png) The sheet sorter view shows all sheets in a workbook as thumbnail images in a single pane,. To open the sheet sorter, click the button on the bottom right of the Reader window. Select the thumbnail image to open the sheet that you want to view. ![](/tableau/current/en-gb/reader/desktop/en-gb/Img/layout9.png) ## Using the toolbar and menus Use the toolbar and menus to interact with views. For example, use the navigation tools to zoom in and pan around a view or click one of the Sort buttons to quickly sort the data in a table. The toolbar contains the following controls (from left to right): ## ![](/tableau/current/en-gb/reader/desktop/en-gb/Img/layout3.png) - Tableau icon: Click to navigate to the start page. - Undo – Click to reverse the last action that you took on the sheet or dashboard. For example, if you changed the filters on a view, click the Undo button to reset the view to it's last state. - Redo – Click to repeat the last action that you reversed on the sheet or dashboard when you clicked the Undo button. - Pause Auto Updates\- Click to pause the auto update feature. When this feature is enabled, Tableau automatically updates the worksheet or dashboard based on changes that you make with the filters. If you do not want to automatically update the view, you can click this button to disable the feature. - Run Update – Click to manually update and refresh a view with the most current settings when automatic updates have been paused. - Sort Ascending – Click to sort data fields in ascending order. - Sort Descending – Click to sort data fields in descending order. - Fit Control\- Select from options in the drop-down list to adjust the size of the view in relation to the application window. - Fix Axes – Click to switch between a locked axis that only shows a specific range of values and a dynamic axis that shows the range of values based on the minimum and maximum values in the view. - Presentation Mode – Click to show the view only and hide the toolbar and menu. Press Esc or click the Presentation button in the lower right corner of the screen to return to the standard view mode. [Skip to main content](#main-content) # Reverting Workbooks You may want to undo all of the changes you've made to a workbook and just start back at how it was when you opened it. Rather than clicking through your history using the Undo ![An arrow pointing left.](/tableau/current/en-gb/reader/desktop/en-gb/Img/undo.png) button, you can revert the workbook to its saved state. #### To revert a workbook: 1. Select File > Revert to Saved. 2. Click Revert in the warning dialog box. [Skip to main content](#main-content) # Setting a Preferred Language You can set Tableau to display the user interface (menus, messages, etc.) in one of the supported languages. The language you select is your User Interface (UI) Language. By default, when you install Tableau, the language is set to an automatic setting that recognises your Windows Locale and uses the appropriate language if it is supported. If you are using an unsupported language, the application will default to English. #### To change language: 1. Select Help > Choose Language. 2. Restart Tableau Reader. **Note**: A workbook author can set the language (locale) for a workbook, which determines how numbers, dates, map tiles and so on are displayed. In that case, the language setting in the workbook takes precedence over the language that you've set for Tableau Reader. [Skip to main content](#main-content) # Shape Legend The shape legend can only represent categorical data, that is discrete categories such as products and regions. The marks are separated into different shapes. With Reader you can't edit the shapes used in the view. ![](/tableau/current/en-gb/reader/desktop/en-gb/Img/shape1_162x91.png) [Skip to main content](#main-content) # Size Legend The size legend can either be categorical or quantitative. A categorical legend represents discrete categories such as region and order priority while a quantitative legend represents a range of numeric values such as delivery time or profit.

Categorical Legend

Quantitative Legend

[Skip to main content](#main-content) # Sorting Data In Reader you can sort items in a table based on a measure used in the view. Sorting gives you control over the order that dimension members are listed in a table and can often reveal relationships between fields. #### To sort items in a table: 1. Select the items you want to sort. 2. Click one of the sort buttons ![](/tableau/current/en-gb/reader/desktop/en-gb/Img/quick_sort1_59x27.png) on the toolbar. **Note:** The tool tips for the sort buttons tell you how the table is going to be sorted. For example, click the Sort Ascending button to reorder the bars in the chart from lowest sales to highest sales, as shown below. ![](/tableau/current/en-gb/reader/desktop/en-gb/Img/rsort2_684x465.png) You can also sort items by dragging the field labels in a column. In the example below, Regular Espresso is dragged to move below Mint. The new location is indicated by the black line. ![A sorted column.](/tableau/current/en-gb/reader/desktop/en-gb/Img/sortcolumn.png) You can also manually sort items in the view using the Legend. To manually sort items do the following steps: 1. In the Legend, right-click anywhere in the white space and select Sort from the context menu. 2. In the Sort dialog, in the Manual section, select items that you want to reorder and then use the Up and Down buttons to move items in the list. ![Sort dialog box with the Manual sort option selected.](/tableau/current/en-gb/reader/desktop/en-gb/Img/ManualSort.png) ## Resetting sort order You can reset how a table is sorted by either clicking the Undo button or by reverting the workbook to its saved state. For more information about how to revert a workbook, see [Reverting Workbooks](https://help.tableau.com/current/reader/desktop/en-gb/revert.htm). [Skip to main content](#main-content) # Tableau Reader Help Use Tableau Reader to open and interact with packaged workbooks with extracted data sources that have been created in Tableau Desktop. A packaged workbook contains a copy of the data source that the workbook references, so that you don't need to have access to the source data to see and interact with the views. With Tableau Reader, you can: - Open and interact with Tableau workbooks - Present views as a slideshow - Export views or data - Print views - Publish views as PDF files [Skip to main content](#main-content) # Useful Tableau Terms The following table describes some of the common terms that are used in the Reader help.

Cross-tab

Another name for a text table or a table of numbers.

Dashboard

A collection of views shown in a single location where you can compare and monitor a variety of data simultaneously.

Data source

The underlying data that Tableau Reader is connected to. You can't change the data source in Tableau Reader.

Filter

A control on a view that limits the data shown in a view. For example, a filter on Region that only includes the West.

Marks

A visual representation of one or more rows in a data source. Mark types can be bar, line, square and so on.

Packaged workbook

A type of workbook created in either Tableau Desktop or Tableau Server. These files contain both the workbook as well as copies of the referenced local file data sources and background images.

Pane

The row and columns areas in a view.

RepositoryA folder located in your My Documents folder that stores workbooks.

View

The visual representation of your data in a worksheet or dashboard.

Workbook

A collection of one or more worksheets and dashboards.

Worksheet

A single view of data. Each worksheet can be connected to a single data source.

[Skip to main content](#main-content) # Using Actions to Access Linked Data Some views might contain _actions_, which relate information in one view with other views or link to external information. Actions add context to the data and can connect the analytical results to web pages, files and other worksheets. For example, a view that shows the home sales in a specific neighbourhood might contain links to census data for the neighbourhood, to a satellite image of the house and to another worksheet showing similar houses in the area. There are three kinds of actions that you might see in Reader : - Filter Actions – A filter action uses a selection in one view to filter the data shown in another view. - Highlight Actions i A highlight action uses a selection in one view to highlight related data in another view. - URL Actions. – A URL action points to a web page, file, or other web resource. An action can be set up to run simply by hovering over a mark, selecting a mark or right-clicking a mark and selecting a menu option. Note: Hyperlinks are not always visible for every worksheet and mark. Because hyperlinks are mapped to specific fields in the data source, links are only available for the worksheets that use the mapped fields and for marks that contain the necessary parameters. For example, the view below shows a URL link from a map view in Reader to a satellite image of a specific location. ![](/tableau/current/en-gb/reader/desktop/en-gb/Img/links3_522x470.png) [Skip to main content](#main-content) # Using Legends Tableau Reader uses colour, size and shape to encode the view with additional information. For example, the marks can be broken into multiple colours to represent different regions and shapes to represent different products. Then those same marks could be assigned different sizes to represent the profit margin. Each type of encoding has a legend. You can edit these legends to use different [colours](https://help.tableau.com/current/reader/desktop/en-gb/colors.htm). ## Other articles in this section [Skip to main content](#main-content) # Using Page Playback A view can be broken down into a series of pages so you can better analyse how a specific field affects the rest of the data in a view. For example, pages are commonly used to show change over time, with each page representing a year, month or other specific date. The Pages card controls allow you to flip through the pages automatically or jump to a specific page. ![](/tableau/current/en-gb/reader/desktop/en-gb/Img/rpages_shelf1_159x123.png) #### To advance through pages, do one of the following: - To view pages as a slideshow, click the Play button ![](/tableau/current/en-gb/reader/desktop/en-gb/Img/play_65x32.png) at the bottom of the Pages card. - To move manually through the pages, click the forward and back buttons on either side of the drop-down list, or use the slider. - To jump to a specific page, select the page from the list. To change the speed of playback, use the speed control in the bottom right corner of the Pages card. To leave the marks from the previous page as you move through the pages, select Show history. [Skip to main content](#main-content) # Using Presentation Mode As you interact with your view, you might want to share your findings with others using Presentation Mode. When you use this mode, Tableau hides the toolbar and menu and shows only the view, similar to presenting a slide show. To turn presentation mode on or off, click the Presentation Mode ![Display presentation icon.](/tableau/current/en-gb/reader/desktop/en-gb/Img/pres_mode.png) button on the toolbar or select Window > Presentation Mode. **Note:** If you want to hide individual sheets, contact the workbook author. The following table describes the different controls that are available when you are in presentation mode. These controls are displayed in the bottom right corner of the screen.
Filmstrip icon.Show Filmstrip – shows the sheets as thumbnails at the bottom of the workspace.
Show tabs icon.Show Tabs – shows the sheet tabs at the bottom of the workspace.
Left and right arrow triangles. Previous/Next Sheet – advances forward or backward through the sheets in a workbook.
Capture icon.Enter/Exit Full Screen – switches between expanding the workbook to fill the entire screen and showing it in a window.
Display presentation icon.Exit Presentation Mode – returns the workbook to showing the entire workspace including the menus, toolbar and the Data pane.