---
schema_version: "1"
id: ea57fb0e4cc4c2afaa78a9e52337e526b1c2aec683147b853f07c0995195519b
title: Setting Up the Product Designer
collection: admin
version: current
locale: en-us
portal_url: https://docs.salesforce.com/admin/current/en-us/ind/264-0-0/comms_setting_up_the_vlocity_product_designer.md
canonical_url: https://help.salesforce.com/s/articleView?id=ind.comms_setting_up_the_vlocity_product_designer.htm&release=264.0.0&type=5
source_site: help.salesforce.com
content_type: documentation
content_hash: 51a8709664aafb5adc92136ce2d56036b69048b71cf2a6094f8d5d5be87a4a75
description: Perform the following steps to ensure the Product Designer displays the correct page layout and compact layout.
products:
  - Communications
  - Media
  - Energy and Utilities
release: "264"
---
# Setting Up the Product Designer

Perform the following steps to ensure the Product Designer displays the correct page layout and compact layout.

1. Set up the Product Designer Lightning App:
    
    - From Setup, enter App Manager in the **Quick Find** box.
    - Click App Manager. The Lightning Experience App Manager page appears.
        
        ![Lightning Experience App Manager page](https://sf-zdocs-cdn-prod.zoominsoftware.com/tdta-ind-comms_media_energy_managed-264-0-0-production-enus/ff4079f6-a384-475c-b863-578bbbb0ef9b/resources-product/images/vdp_lex_appmgr.png)
    - Scroll down and click Vlocity Product Designer . If you do not see Vlocity Product Designer , but instead see Vlocity Product Console , then continue with the following steps.
    - Click the arrow on the right, then click Edit. The App Details and Branding page appears.
    - If the name is Vlocity Product Console :
        
        - In the App Name field, update the Label to Vlocity Product Designer .
        - In the **Description** field, type Manage Product Configuration.
        - Click Save.
    - From the left panel, click User Profiles.
    - Ensure that your Administrator profile is active under the **Selected Profiles** list.
    - Click Save.
    - Click Back to return to the Lightning Experience App Manager.
2. Assign a Page Layout to the profile and record type:
    
    - Go to **Setup** → **Object Manager** → **Product** → **Page Layouts** → **Page Layout Assignment**.
    - Click Edit Assignment.
    - Assign the Product Console Layout to System Admin or other profiles for the Product and other record types.
    - Click Save.
3. Repeat the previous step to assign page layouts for:
    
    <table class="slds-table slds-table_bordered slds-max-medium-table_stacked slds-m-bottom_small ">
            <colgroup>
              <col>
              <col>
            </colgroup>
            <thead class="slds-text-title_caps ">
              <tr class="">
                <th scope="col" class="slds-cell-wrap" style="vertical-align:top;" id="d350112e213">
                  <p style="margin-bottom:0;">Label (from Object Manager)</p>
                </th>
                <th scope="col" class="slds-cell-wrap" style="vertical-align:top;" id="d350112e219">
                  <p style="margin-bottom:0;">Lightning Record Pages to select</p>
                </th>
              </tr>
            </thead>
            <tbody>
              <tr class="">
                <td data-label="Label (from Object Manager)" class="slds-cell-wrap" style="vertical-align:top;" headers="d350112e213 ">
                  <p style="margin-bottom:0;">Catalog</p>
                </td>

                <td data-label="Lightning Record Pages to select" class="slds-cell-wrap" style="vertical-align:top;" headers="d350112e219 ">
                  <p style="margin-bottom:0;">Catalog Layout (Vlocity)</p>
                </td>

              </tr>
              <tr class="">
                <td data-label="Label (from Object Manager)" class="slds-cell-wrap" style="vertical-align:top;" headers="d350112e213 ">
                  <p style="margin-bottom:0;">Project</p>
                </td>

                <td data-label="Lightning Record Pages to select" class="slds-cell-wrap" style="vertical-align:top;" headers="d350112e219 ">
                  <p style="margin-bottom:0;">Project Layout</p>
                </td>

              </tr>
            </tbody>
          </table>
4. Set up the Compact Layouts (Highlights panel):
    
    - Click Setup.
    - Click Object Manager.
    - Click Product → Compact Layouts → Product Highlights.
    - Click Compact Layout Assignment.
    - Click Edit Assignment.
    - Assign the compact layout **Product Highlights** to the Product or other record types.
5. Assign the **Create New Product** and Generate Report buttons to the list view:
    
    - Go to Setup → Object Manager → Product → Search Layouts for Salesforce Classic → List View.
    - Click the associated drop-down for **List View** and click Edit. The Product List View page appears.
        
        ![Product List View page](https://sf-zdocs-cdn-prod.zoominsoftware.com/tdta-ind-comms_media_energy_managed-264-0-0-production-enus/ff4079f6-a384-475c-b863-578bbbb0ef9b/resources-product/images/upc_assignbutton.png)
    - Under **Standard Buttons**, uncheck New \[CreateNewProduct\].
    - Under Available Buttons, select **Create New Product** and **Generate Report** and add them to the Selected Buttons list.
    - Click Save.
6. Ensure you can see the **Delete** button on the **Highlights** panel of the Products page:
    
    - Go to Setup → Object Manager → Product → Page Layouts → Product Console Layout.
    - If you see **Override the predefined actions** link under **Salesforce Mobile and Lightning Experience Actions**, then click **Remove all the existing actions**.
    - In the layout panel at the top, click Mobile and Lightning Actions.
    - Drag and drop the following Quick Actions from **Mobile & Lightning Actions** onto the **Salesforce Mobile and Lightning Experience Actions** section.
        
        <table class="slds-table slds-table_bordered slds-max-medium-table_stacked slds-m-bottom_small ">
                <colgroup>
                  <col>
                  <col>
                  <col>
                  <col>
                </colgroup>
                <thead class="slds-text-title_caps ">
                  <tr class="">
                    <th scope="col" class="slds-cell-wrap" style="vertical-align:top;" id="d350112e445">
                      <p style="margin-bottom:0;">Object Name</p>
                    </th>
                    <th scope="col" class="slds-cell-wrap" style="vertical-align:top;" id="d350112e451">
                      <p style="margin-bottom:0;">Page Layout</p>
                    </th>
                    <th scope="col" class="slds-cell-wrap" style="vertical-align:top;" id="d350112e457">
                      <p style="margin-bottom:0;">Quick Action Label (Action Name)</p>
                    </th>
                    <th scope="col" class="slds-cell-wrap" style="vertical-align:top;" id="d350112e463">
                      <p style="margin-bottom:0;">Comment</p>
                    </th>
                  </tr>
                </thead>
                <tbody>
                  <tr class="">
                    <td data-label="Object Name" class="slds-cell-wrap" style="vertical-align:top;" headers="d350112e445 ">
                      <p style="margin-bottom:0;">Product</p>
                    </td>

                    <td data-label="Page Layout" class="slds-cell-wrap" style="vertical-align:top;" headers="d350112e451 ">
                      <p style="margin-bottom:0;">Product Console Layout</p>
                    </td>

                    <td data-label="Quick Action Label (Action Name)" class="slds-cell-wrap" style="vertical-align:top;" headers="d350112e457 ">
                      <p>Delete (Product2.Product_Delete)</p>
                      <p style="margin-bottom:0;">Generate All
                        References (Product2.ProductDetailsReport)</p>
                    </td>

                    <td data-label="Comment" class="slds-cell-wrap" style="vertical-align:top;" headers="d350112e463 ">&nbsp;</td>

                  </tr>
                  <tr class="">
                    <td data-label="Object Name" class="slds-cell-wrap" style="vertical-align:top;" headers="d350112e445 ">&nbsp;</td>

                    <td data-label="Page Layout" class="slds-cell-wrap" style="vertical-align:top;" headers="d350112e451 ">&nbsp;</td>

                    <td data-label="Quick Action Label (Action Name)" class="slds-cell-wrap" style="vertical-align:top;" headers="d350112e457 ">
                      <p>New Version (Product2.New_Version)</p>
                      <p>Release
                        Product (Product2.Product_Release)</p>
                      <p style="margin-bottom:0;">Version History
                        (Product2.Version_History)</p>
                    </td>

                    <td data-label="Comment" class="slds-cell-wrap" style="vertical-align:top;" headers="d350112e463 ">
                      <p style="margin-bottom:0;">Add these Versioning-related buttons to the layout when
                        the Versioning
                        feature is enabled. These buttons do not need to be
                        exposed in non-versioning orgs.</p>
                    </td>

                  </tr>
                </tbody>
              </table>
    - Click Save.
7. Define Folder Setup (required for attachments to work):
    
    - Switch to Classic view if you are in Lightning experience.
    - Click + to open the All Tabs page.
    - Click the Documents tab.
    - In the Document Folders section, click Create New Folder. The New Document Folder page appears.
    - In the Document Folder Label field, type ProductConsole (no spaces).
    - From the **Public Folder Access** dropdown, select Read/Write.
    - Click Save.
    - Switch back to Lightning mode.
8. The following tabs should appear in the Vlocity Product Designer. If you don't see these tabs, perform the next steps.
    
    - Catalogs
    - Offer Migration Plans
    - Products
    - Project
    - Vlocity Attributes
    - Vlocity Attribute Categories
    - Vlocity Object & Object Types
    - Vlocity Picklists
    - Vocity String Translations
    - Product Relationships
9. Click Setup.
10. In the Quick Find field, type tabs.
11. Under **Custom Object Tabs**, click New.
12. Select the tab in question, for example, Vlocity Object or Object Type. The New Custom Object Tab appears.
13. Select a tab style.
14. Click Next.
15. For **Apply one tab visibility to all profiles**, select Default on.
16. Click Next. The Tabs page appears.
17. Click the associated checkbox for Product Console.
18. Click Save.
19. Click Setup.
20. In the **Quick Find** field, type App Manager.
21. From the search results, click App Manager. The Setup page for Lightning Experience App Manager appears.
22. On the row for the Vlocity Product Designer , click the arrow and select Edit. The Vlocity Product Designer app page appears.
23. From the **App Settings** panel, click Navigation Items.
24. Under the **Available Items** list, click the name of the tab, for example, Vlocity Object and Object types, then click the right arrow to add it to the **Selected Items** list.
25. Click Save. It may take a few moments for your changes to appear.
26. Repeat the above steps for the Vlocity Object and Object Types tab, Project tab, or any other tabs that do not appear.